Evaluar una fórmula anidada paso a paso

A veces, es difícil comprender cómo calcula el resultado final una fórmula anidada es difícil porque hay varios cálculos intermedios y pruebas lógicas. Pero, mediante el cuadro de diálogo Evaluar fórmula, puede ver las distintas partes de la fórmula anidada evaluadas en el orden en el que se calcula la fórmula. Por ejemplo, la fórmula = si (promedio (F2: F5) >50, suma (G2: G5), 0) es más fácil de entender cuando puede ver los siguientes resultados intermedios:

Pasos que aparecen en el cuadro de diálogo

Descripción

=SI(PROMEDIO(F2:F5)>50;SUMA(G2:G5);0)

La fórmula anidada se muestra al principio. Las funciones PROMEDIO y SUMA se anidan dentro de la función SI.

=SI(40>50,SUMA(G2:G5),0)

El rango de celdas F2:F5 contiene los valores 55, 35, 45 y 25, etc., así el resultado de la función PROMEDIO(F2:F5) es 40.

=SI(Falso,SUMA(G2:G5),0)

40 no es mayor que 50, por lo que la expresión en el primer argumento de la función si (el argumento prueba_lógica) es falsa.

0

La función SI devuelve el valor del tercer argumento (el argumento valor_si_falso). La función suma no se evalúa porque es el segundo argumento para la función si (argumento valor_si_verdadero) y solo se devuelve cuando la expresión es verdadera.

  1. Una vez más, seleccione la celda a la que desea dar formato. Solo se puede evaluar una celda a la vez.

  2. En el grupo Auditoría de fórmulas de la pestaña Fórmulas, haga clic en Evaluar fórmula.

    Grupo Auditoría de fórmulas en la ficha Fórmulas

  3. Haga clic en Evaluar para examinar el valor de la referencia subrayada. El resultado de la evaluación se muestra en cursiva.

    Si la parte subrayada de la fórmula es una referencia a otra fórmula, haga clic en Paso a paso para entrar para mostrar la otra fórmula en el cuadro Evaluación. Haga clic en Paso a paso para salir para volver a la celda y fórmula anteriores.

    Nota: El botón Paso a paso para entrar no está disponible la segunda vez que la referencia aparece en la fórmula o si la fórmula hace referencia a una celda de otro libro.

  4. Continúe hasta que se haya evaluado cada parte de la fórmula.

  5. Para volver a ver la evaluación, haga clic en Reiniciar.

    Para finalizar la evaluación, haga clic en Cerrar.

    Notas: 

    • Algunas de las partes de las fórmulas que usan las funciones si y elegir no se evalúan y #N/A se muestra en el cuadro evaluación .

    • Si una referencia está en blanco, se mostrará un valor cero (0) en el cuadro Evaluación.

    • Es posible que las fórmulas con referencias circulares no se evalúen como se espera. Si se desean referencias circulares, se puede Habilitar el cálculo iterativo.

    • Las siguientes funciones se vuelven a calcular cada vez que cambia la hoja de cálculo y pueden hacer que la herramienta evaluar fórmula dé resultados diferentes de los que aparecen en la celda: aleatorio, DESREF, celda, indirecto, ahora, hoy, aleatorio, info e sumar.Si (en algunos escenarios).

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Vea también

Cómo evitar la ruptura de las fórmulas

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×