Evaluar una fórmula anidada paso a paso

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

A veces, es difícil comprender cómo se calcula el resultado final una anidadas fórmula porque hay diversos cálculos intermedios y pruebas lógicas. Sin embargo, mediante el cuadro de diálogo Evaluar fórmula, puede ver las distintas partes de una fórmula anidada en el orden en que se calcula la fórmula. Por ejemplo, la fórmula =IF(AVERAGE(F2:F5) > 50,SUM(G2:G5),0) es más fácil de entender cuando se pueden ver los siguientes resultados intermedios:

Pasos que aparecen en el cuadro de diálogo

Descripción

=SI(PROMEDIO(F2:F5)>50;SUMA(G2:G5);0)

La fórmula anidada se muestra al principio. Las funciones PROMEDIO y SUMA se anidan dentro de la función SI.

=SI(40>50,SUMA(G2:G5),0)

El rango de celdas F2: F5 contiene los valores 55, 35, 45 y 25 y, por lo que el resultado de la función AVERAGE(F2:F5) es 40.

=SI(Falso,SUMA(G2:G5),0)

40 no es mayor que 50, por lo que la expresión en el primer argumento de la función si (el argumento prueba_lógica) es falsa.

0

La función si devuelve el valor del tercer argumento (el argumento valor_si_falso). La función suma no se evalúa porque es el segundo argumento de la función si (argumento valor_si_verdadero) y se devuelve solo cuando la expresión es true.

  1. Una vez más, seleccione la celda a la que desea dar formato. Solo se puede evaluar una celda a la vez.

  2. En el grupo Auditoría de fórmulas de la pestaña Fórmulas, haga clic en Evaluar fórmula.

    Grupo Auditoría de fórmulas en la ficha Fórmulas

  3. Haga clic en Evaluar para examinar el valor de la referencia subrayada. El resultado de la evaluación se muestra en cursiva.

    Si la parte subrayada de la fórmula es una referencia a otra fórmula, haga clic en Paso a paso para entrar para mostrar la otra fórmula en el cuadro Evaluación. Haga clic en Paso a paso para salir para volver a la celda y fórmula anteriores.

    Nota: El botón Paso a paso para entrar no está disponible la segunda vez que la referencia aparece en la fórmula o si la fórmula hace referencia a una celda de otro libro.

  4. Continúe hasta que se haya evaluado cada parte de la fórmula.

  5. Para volver a ver la evaluación, haga clic en Reiniciar.

    Para finalizar la evaluación, haga clic en Cerrar.

    Notas: 

    • Algunas partes de las fórmulas que utilizan el concepto si y elegir funciones no se evalúan y #N/A se muestra en el cuadro evaluación.

    • Si una referencia está en blanco, un valor de cero (0) se muestra en el cuadro Evaluación.

    • No se pueden evaluar fórmulas con referencias circulares según lo esperado. Si las referencias circulares se lo desea, puede Habilitar cálculo iterativo.

    • Las siguientes funciones se actualizan cada vez que los cambios de la hoja de cálculo y puede provocar la herramienta Evaluar fórmula dé resultados diferentes de lo que aparece en la celda: aleatorio, DESREF, celda, indirecto, ahora, hoy, aleatorio.entre, información y sumar.Si (en algunos escenarios).

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×