Esquematizar (agrupar) datos en una hoja de cálculo

Si tiene una lista de datos que desea agrupar y resumir, puede crear un esquema de hasta ocho niveles, uno para cada grupo. Cada nivel interno, que está representado por un número superior de símbolos del esquema, muestra datos de detalle del nivel externo anterior, representado por un número inferior de símbolos de esquema. Use un esquema para mostrar rápidamente filas o columnas de resumen, o bien para mostrar los datos de detalle de cada grupo. Puede crear un esquema de filas (como se ilustra en el ejemplo siguiente), un esquema de columnas o un esquema de filas y columnas.

Lista de esquema
Se muestra una fila de datos de ventas agrupados por regiones geográficas y meses con varias filas de resumen y detalles.

1.  Para mostrar filas para un nivel, haga clic en los símbolos de esquema uno dos tres adecuados.

2.  El nivel 1 contiene las ventas totales de todas las filas de detalle.

3.  El nivel 2 contiene las ventas totales para cada mes en cada región.

4.  El nivel 3 contiene las filas de detalle — en este caso, las filas 11 a 13.

5.  Para expandir o contraer datos en el esquema, haga clic en los símbolos de esquema más y menos .

¿Qué desea hacer?

Crear un esquema de filas

Crear un esquema de columnas

Mostrar u ocultar datos de esquemas

Personalizar un esquema con estilos

Copiar datos esquematizados

Ocultar o quitar un esquema

Crear un informe de resumen con un gráfico

Crear un esquema de filas

  1. Asegúrese de que cada columna de los datos a los que desea aplicar un esquema tiene un rótulo en la primera fila, contiene datos similares en cada columna y el rango no tiene filas ni columnas en blanco.

  2. Asegúrese de que las filas de detalle también tengan una fila de resumen: un subtotal. Siga uno de los procedimientos siguientes:

    Insertar filas de resumen utilizando el comando Subtotal   

    • Use el comando Subtotal que inserta la función SUBTOTAL inmediatamente debajo o encima de cada grupo de filas de detalle y crea automáticamente el esquema. Para más información sobre la función SUBTOTAL, vea Función SUBTOTAL.

      Insertar sus propias filas de resumen   

    • Inserte sus propias filas de resumen, con las fórmulas, inmediatamente encima o debajo de cada grupo de filas de detalle. Por ejemplo, debajo (o encima) de las filas de datos de ventas de marzo y abril, use SUMA (función SUMA) para obtener el subtotal de las ventas para esos meses. En la tabla que aparece más adelante en este tema se muestra un ejemplo.

  3. Especifique si las filas de resumen están encima o debajo de las filas de detalle. En el grupo Esquema de la pestaña Datos, haga clic en el selector de cuadro de diálogo Esquema.
    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

  4. Si las filas de resumen están encima de las filas de detalle, desactive la casilla Filas resumen debajo del detalle. Si no lo están, deje la casilla tal cual.

  5. Aplique un esquema a los datos. Siga uno de los procedimientos siguientes:

    Aplicar un esquema a los datos automáticamente

    1. En caso necesario, seleccione una celda del rango de celdas del que desea crear un esquema.

    2. En el grupo Esquema de la pestaña Datos, haga clic en la flecha de Agrupar y, a continuación, haga clic en Autoesquema.

      Haga clic en la flecha situada debajo de Grupo y en Esquema automático

    Aplicar un esquema a los datos manualmente

    Importante: Cuando agrupe manualmente niveles de esquema, es mejor tener todos los datos mostrados para evitar agrupar las filas incorrectamente.

    1. Aplique un esquema al grupo externo.

      Cómo aplicar un esquema al grupo externo

      1. Seleccione todas las filas de resumen subordinadas y sus filas de detalle relacionadas.

        Por ejemplo, en los datos siguientes, la fila 6 contiene el subtotal para las filas 2 a 5, y la fila 10 contiene el subtotal para las filas 7 a 9, y la fila 11 contiene el total general. Para agrupar todos los datos de detalle para la fila 11, seleccione las filas 2 a 10.

         

        A

        B

        C

        1

        Región

        Mes

        Ventas

        2

        Este

        Marzo

        9647 €

        3

        Este

        Marzo

        4101 €

        4

        Este

        Marzo

        7115 €

        5

        Este

        Marzo

        2957 €

        6

        Este

        Total de marzo

        23 820 €

        7

        Este

        Abril

        4257 €

        8

        Este

        Abril

        1829 €

        9

        Este

        Abril

        6550 €

        10

        Este

        Total de abril

        12 636 €

        11

        Total del este

        36 456 €

        Importante: No incluya la columna resumida (fila 11) en la selección.

      2. En el grupo Esquema de la pestaña Datos, haga clic en Agrupar, en Filas y, a continuación, en Aceptar.

        Haga clic en Filas y en Aceptar

        Los símbolos del esquema aparecen en la pantalla al lado del grupo.

    2. Opcionalmente, aplique un esquema a un grupo interno anidado: las filas de detalle de una sección determinada de los datos.

      Cómo aplicar un esquema a grupos internos anidados (grupos de filas detalladas)

      1. Para grupo interno anidado, seleccione las filas de detalle adyacentes a la fila que contiene la fila de resumen.

        En el ejemplo siguiente, para agrupar las filas 2 a 5, que tienen una fila resumen 6, seleccione las filas 2 a 5. Para agrupar las filas 7 a 9, que tiene una fila resumen 10, seleccione las filas 7 a 9.

         

        A

        B

        C

        1

        Región

        Mes

        Ventas

        2

        Este

        Marzo

        9647 €

        3

        Este

        Marzo

        4101 €

        4

        Este

        Marzo

        7115 €

        5

        Este

        Marzo

        2957 €

        6

        Este

        Total de marzo

        23 820 €

        7

        Este

        Abril

        4257 €

        8

        Este

        Abril

        1829 €

        9

        Este

        Abril

        6550 €

        10

        Este

        Total de abril

        12 636 €

        11

        Total del este

        36 456 €

        Importante: No incluya la fila de resumen de la selección.

      2. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

        Haga clic en Agrupar en la pestaña Datos

        Los símbolos del esquema aparecen en la pantalla al lado del grupo.

      3. Siga seleccionando y agrupando filas internas hasta que haya creado todos los niveles que desee en el esquema.

      4. Si desea desagrupar filas, selecciónelas y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

        También puede desagrupar secciones del esquema sin quitarlo todo. Mantenga presionada la tecla Mayús mientras hace clic en cuadro Signo o en cuadro Signo - del grupo y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

        Importante: Si desagrupa un esquema mientras los datos de detalle están ocultos, las filas de detalle permanecen ocultas. Para mostrar los datos, desplácese por los números de fila visibles adyacentes a las filas ocultas. En el grupo Celdas de la pestaña Inicio, haga clic en Formato, elija Ocultar y mostrar y, a continuación, haga clic en Mostrar filas.

Principio de página

Crear un esquema de columnas

  1. Asegúrese de que cada fila de los datos a los que desea aplicar un esquema tiene una etiqueta en la primera fila, contiene datos similares en cada columna y el rango no tiene filas ni columnas en blanco.

  2. Inserte sus propias columnas resumidas con fórmulas inmediatamente a la derecha o a la izquierda de cada grupo de columnas de detalle. La tabla mostrada en el paso 4 siguiente le muestra un ejemplo.

    Nota: Para trazar esquemas de los datos por columnas, debe tener columnas de resumen que contengan fórmulas que hagan referencias a las celdas de cada una de las columnas de detalle para dicho grupo.

  3. Especifique si la ubicación de la columna de resumen está a la derecha o a la izquierda de las columnas de detalle. En el grupo Esquema de la pestaña Datos, haga clic en el selector de cuadro de diálogo Esquema.

    Cómo especificar la ubicación de la columna de resumen

    1. En el grupo Esquema de la pestaña Datos, haga clic en el selector de cuadro de diálogo Esquema.

      En el grupo Esquema, haga clic en el selector de cuadro de diálogo

    2. Para especificar una columna de resumen a la izquierda de la columna de detalles, desactive la casilla de verificación Columnas resumen a la derecha del detalle. Para especificar una columna de resumen a la derecha de la columna de detalles, active la casilla de verificación Columnas resumen a la derecha del detalle.

    3. Haga clic en Aceptar.

  4. Para aplicar un esquema a los datos, siga uno de estos procedimientos:

    Aplicar un esquema a los datos automáticamente

    1. En caso necesario, seleccione una celda del rango.

    2. En el grupo Esquema de la pestaña Datos, haga clic en la flecha de Agrupar y en Autoesquema.

    Aplicar un esquema a los datos manualmente

    Importante: Cuando agrupe manualmente niveles de esquema, es mejor tener todos los datos mostrados para evitar agrupar las columnas incorrectamente.

    1. Aplique un esquema al grupo externo.

      Cómo aplicar un esquema al grupo externo (todas las columnas excepto el total general)

      1. Seleccione todas las columnas de resumen subordinadas, así como sus datos de detalle relacionados.

        En el ejemplo siguiente, la columna E contiene los subtotales para las columnas B a D, y la columna I contiene los subtotales para las columnas F a H, y la columna J contiene los totales generales. Para agrupar todos los datos de detalle para la columna J, seleccione las columnas B a I.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Regn

        Ene

        Feb

        Mar

        T1

        Abr

        May

        Jun

        T2

        M1

        2

        Este

        371

        504

        880

        1755

        186

        653

        229

        1068

        2823

        3

        Oeste

        192

        185

        143

        520

        773

        419

        365

        1557

        2077

        4

        Norte

        447

        469

        429

        1345

        579

        180

        367

        1126

        2471

        5

        Sur

        281

        511

        410

        1202

        124

        750

        200

        1074

        2276

        Importante: No incluya en la selección la columna resumen J (los totales generales) para dicho grupo.

      2. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

        Haga clic en Agrupar en la pestaña Datos

        Los símbolos del esquema aparecen en la pantalla al lado del grupo.

    2. De manera opcional, aplique un esquema a un grupo interno anidado (grupos individuales de columnas detalladas).

      Cómo aplicar un esquema al grupo interno anidado (grupos de columnas detalladas)

      1. Para grupo interno anidado, seleccione las columnas de detalle adyacentes a la columna que contiene la fila de resumen.

        En el ejemplo siguiente, para agrupar las columnas B a D, que tiene una columna resumida E, seleccione las columnas B a D. Para agrupar columnas F a H, que tiene una fila de resumen I, seleccione las columnas F a H.

         

        A

        B

        C

        D

        E

        F

        G

        H

        I

        J

        1

        Regn

        Ene

        Feb

        Mar

        T1

        Abr

        May

        Jun

        T2

        M1

        2

        Este

        371

        504

        880

        1755

        186

        653

        229

        1068

        2823

        3

        Oeste

        192

        185

        143

        520

        773

        419

        365

        1557

        2077

        4

        Norte

        447

        469

        429

        1345

        579

        180

        367

        1126

        2471

        5

        Sur

        281

        511

        410

        1202

        124

        750

        200

        1074

        2276

        Importante:  No incluya en la selección la columna resumida para dicho grupo.

      2. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

        Haga clic en Agrupar en la pestaña Datos

        Los símbolos del esquema aparecen en la pantalla al lado del grupo.

  5. Siga seleccionando y agrupando columnas internas hasta que haya creado todos los niveles que desee en el esquema.

  6. Si desea desagrupar columnas, selecciónelas y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

En la pestaña Datos, haga clic en Desagrupar

También puede desagrupar secciones del esquema sin quitarlo todo. Mantenga presionada la tecla Mayús mientras hace clic en cuadro Signo o en cuadro Signo - del grupo y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

Si desagrupa un esquema mientras los datos de detalle están ocultos, las columnas de detalle permanecen ocultas. Para mostrar los datos, desplácese por las letras de columna visibles adyacentes a las columnas ocultas. En el grupo Celdas de la pestaña Inicio, haga clic en Formato, elija Ocultar y mostrar y, después, haga clic en Mostrar columnas.

Principio de página

Mostrar u ocultar datos de esquemas

  1. Si no ve los símbolos de esquema uno dos tres , más y menos , haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y seleccione Opciones de Excel (Excel 2007), o bien, haga clic en la pestaña Archivo (otras versiones) y, a continuación, en Opciones. Después, haga clic en la categoría Avanzadas, a continuación, en la sección Mostrar opciones para esta hoja, seleccione la hoja de cálculo y active la casilla Mostrar símbolos de esquema si se aplica un esquema.

  2. Haga clic en Aceptar.

  3. Siga uno o varios de estos procedimientos:

    Mostrar u ocultar los datos de detalle de un grupo   

    • Para mostrar los datos de detalle de un grupo, haga clic en más del grupo.

    • Para ocultar los datos de detalle de un grupo, haga clic en menos del grupo.

      Expandir o contraer todo el esquema hasta un nivel determinado   

    • En los símbolos de esquema uno dos tres , haga clic en el número del nivel que desee. Los datos de detalle de los niveles inferiores se ocultan.

      Por ejemplo, si un esquema tiene cuatro niveles, puede ocultar el cuarto y mostrar los restantes haciendo clic en tres .

      Mostrar u ocultar todos los datos de detalle del esquema   

    • Para mostrar todos los datos de detalle, haga clic en el nivel más bajo de los símbolos de esquema uno dos tres . Por ejemplo, si existen tres niveles, haga clic en tres .

    • Para ocultar todos los datos de detalle, haga clic en uno .

Principio de página

Personalizar un esquema con estilos

En el caso de las filas del esquema, Microsoft Excel usa estilos como NivelFila_1 y NivelFila_2. Con respecto a las columnas del esquema, Excel usa estilos como NivelCol_1 y NivelCol_2. Estos estilos emplean la negrita, la cursiva y otros formatos de texto para diferenciar las filas o columnas de resumen en los datos. Si se cambia la forma en que están definidos estos estilos, se pueden aplicar distintos formatos de texto y celda para personalizar el aspecto del esquema. Puede aplicar un estilo a un esquema al crear el esquema o después de crearlo.

Realice uno o varios de los siguientes procedimientos:

Aplicar un estilo automáticamente a una columna o fila resumen   

  1. En el grupo Esquema de la pestaña Datos, haga clic en el selector de cuadro de diálogo Esquema.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

  2. Active la casilla de verificación Estilos automáticos.

Aplicar un estilo a una columna o fila resumen existente   

  1. Seleccione las celdas a las que desee aplicar estilos de esquema.

  2. En el grupo Esquema de la pestaña Datos, haga clic en el selector de cuadro de diálogo Esquema.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

  3. Active la casilla de verificación Estilos automáticos.

  4. Haga clic en Aplicar estilos.

Asimismo, puede usar los formatos automáticos para dar formato a los datos esquematizados.

Principio de página

Copiar datos esquematizados

  1. Si no ve los símbolos de esquema uno dos tres , más y menos , haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y seleccione Opciones de Excel (Excel 2007), o bien, en la pestaña Archivo (otras versiones), haga clic en Opciones. Después, haga clic en la categoría Avanzadas, a continuación, en la sección Mostrar opciones para esta hoja, seleccione la hoja de cálculo y active la casilla Mostrar símbolos de esquema si se aplica un esquema.

  2. Utilice los símbolos de esquema uno dos tres , menos y más para ocultar los datos de detalle que no desee copiar.

    Para obtener más información, vea la sección Mostrar u ocultar datos de esquemas.

  3. Seleccione el rango de filas de resumen.

  4. En la pestaña Inicio, en el grupo Modificar, haga clic en Buscar y seleccionar y, a continuación, haga clic en Ir a.

    Haga clic en Buscar & Seleccionar y, después, haga clic en Ir a

  5. Haga clic en Ir a Especial.

  6. Haga clic en Solo celdas visibles.

  7. Haga clic en Aceptar y, a continuación, copie los datos.

Principio de página

Ocultar o quitar un esquema

Nota: No se eliminan los datos al ocultar o quitar un esquema.

Ocultar un esquema

  • (Excel 2007) Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y seleccione Opciones de Excel, o bien, en la pestaña Archivo (otras versiones), haga clic en Opciones. Después, haga clic en la categoría Avanzadas, a continuación, en la sección Mostrar opciones para esta hoja, seleccione la hoja de cálculo que contiene el esquema que desea ocultar y desactive la casilla Mostrar símbolos de esquema si se aplica un esquema.

Quitar un esquema

  1. Haga clic en la hoja de cálculo.

  2. En el grupo Esquema de la pestaña Datos, haga clic en Desagrupar y en Borrar esquema.

    Haga clic en Desagrupar y en Borrar esquema

    Importante: Si quita un esquema mientras los datos de detalle están ocultos, las columnas o filas de detalle permanecen ocultas. Para mostrar los datos, desplácese por los números de fila o letras de columna visibles adyacentes a las columnas o filas ocultas. En el grupo Celdas de la pestaña Inicio, haga clic en Formato, elija Ocultar y mostrar y, a continuación, haga clic en Mostrar filas o en Mostrar columnas.

Principio de página

Crear un informe de resumen con un gráfico

Supongamos que desea crear un informe resumido de los datos que solo muestra los totales acompañados de un gráfico de dichos totales. En general, puede hacer lo siguiente:

  1. Crear un informe de resumen

    1. Aplicar un esquema a los datos.

      Para obtener más información, vea las secciones, Crear un esquema de filas o Crear un esquema de columnas.

    2. Oculte el detalle haciendo clic en los símbolos de esquema uno dos tres , más y menos para mostrar solo los totales como se muestra en el siguiente ejemplo de un esquema de fila:

      Lista esquematizada que muestra solo las filas de totales

    3. Para obtener más información, vea la sección Mostrar u ocultar datos de esquemas.

  2. Representar en un gráfico el informe de resumen

    1. Seleccione los datos de resumen que desea representar.

      Por ejemplo, para representar únicamente los totales de Buchanan y Davolio, pero no los totales generales, seleccione las celdas A1 a C11, como se muestra en el ejemplo anterior.

    2. Cree el gráfico. Por ejemplo, en el grupo Gráficos de la pestaña Insertar, haga clic en Gráficos recomendados o bien seleccione otro tipo de gráfico.

      Por ejemplo, si crea el gráfico con el Asistente para gráficos, tendrá un aspecto similar al del siguiente ejemplo.

      Gráfico creado a partir de datos de subtotales

      Si muestra u oculta los detalles de la lista esquematizada de datos, el gráfico también se actualiza para mostrar u ocultar los datos.

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×