Enviar los datos del formulario en un mensaje de correo electrónico

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede agregar a la plantilla de formulario una conexión de envío de datos secundaria que permita a los usuarios enviar los datos del formulario en un mensaje de correo electrónico. Puede usar valores estáticos, valores basados en los datos del formulario o una fórmula para especificar las direcciones de correo electrónico a las que se envía el formulario, la línea de asunto del mensaje y el nombre del formulario. También puede especificar si desea que el formulario aparezca en el cuerpo del mensaje de correo electrónico o como datos adjuntos del mensaje.

Si configura la plantilla de formulario para incluir el formulario como datos adjuntos del mensaje de correo electrónico, también puede adjuntar la plantilla de formulario al mensaje. Al incluir el formulario y la plantilla de formulario como datos adjuntos del mensaje de correo electrónico, puede ayudar a asegurarse de que los destinatarios del mensaje pueden abrir el formulario en Microsoft Office InfoPath, incluso si no tienen la plantilla de formulario almacenada en caché en sus equipos. Para que los destinatarios puedan abrir los datos adjuntos, deben tener InfoPath instalado en sus equipos.

Cuando los usuarios envían los datos del formulario en un mensaje de correo electrónico, InfoPath crea un mensaje con los datos del formulario y lo envía a los destinatarios de correo especificados al crear la conexión de datos. Si los usuarios que reciben los formularios completados utilizan Microsoft Office Outlook 2007, pueden agregar una carpeta a su Bandeja de entrada para contener todos los formularios de InfoPath que reciban y configurarla para mostrar los datos de los formularios en columnas en Outlook.

Después de agregar la conexión de envío de datos, debe configurar la plantilla de formulario para permitir que los usuarios envíen los datos del formulario. Como resultado, cuando los usuarios abren el formulario, InfoPath agrega automáticamente un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo. También se pueden personalizar las opciones de envío de la plantilla de formulario de las siguientes maneras.

  • Cambiar el texto que aparece en el botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Cambiar el método abreviado de teclado del botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Crear mensajes personalizados para mostrar a los usuarios cuando envíen los formularios

  • Especificar si el formulario debe quedar abierto, se debe cerrar o se debe abrir otro formulario en blanco después de enviarlo

Principio de página

Agregar una conexión de envío de datos

  1. En el menú Herramientas, haga clic en Opciones de envío.

  2. En el cuadro de diálogo Opciones de envío, seleccione la casilla de verificación Permitir a los usuarios enviar este formulario.

  3. Haga clic en Enviar datos del formulario a un único destino y, después, en la lista, haga clic en Correo electrónico.

  4. Haga clic en Agregar.

  5. En el Asistente para la conexión de datos, en los cuadros correspondientes, escriba las direcciones de correo electrónico de los destinatarios, el asunto que desee que aparezca en el mensaje y el texto de introducción que desee. Cuando termine, haga clic en Siguiente.

    Sugerencia: También puede especificar un campo o utilizar una fórmula para crear el valor de cada cuadro, excepto para el cuadro Introducción.

    Cómo

    1. Haga clic en Insertar fórmula Botón de fórmula .

    2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

      • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

      • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

        Sugerencia: Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

      • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

    Operación

    Símbolo

    Sumar

    +

    Restar

    -

    Multiplicar

    *

    Dividir

    /

    • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

    • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

      Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

  6. En la siguiente página del asistente, siga uno de estos procedimientos:

    1. Para mostrar el formulario en el cuerpo del mensaje de correo electrónico, haga clic en Enviar únicamente la vista activa del formulario sin datos adjuntos.

    2. Para enviar los datos del formulario como datos adjuntos del mensaje de correo electrónico, haga clic en Enviar los datos del formulario como datos adjuntos, active la casilla de verificación Adjuntar la plantilla de formulario para asegurar que los usuarios puedan abrir el formulario y, después, escriba un nombre para el formulario en el cuadro Nombre de datos adjuntos. También puede especificar un campo o utilizar una fórmula para asegurarse de que el nombre de cada formulario es único.

      Cómo

      1. Haga clic en Insertar fórmula Botón de fórmula .

      2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

        • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

        • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

          Sugerencia: Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

        • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

      Operación

      Símbolo

      Sumar

      +

      Restar

      -

      Multiplicar

      *

      Dividir

      /

      • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

      • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

        Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

      Nota: Los usuarios que reciban los datos del formulario como datos adjuntos en un mensaje de correo electrónico deben tener InfoPath instalado en sus equipos para abrir los datos adjuntos.

  7. Haga clic en Siguiente.

  8. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba un nombre descriptivo para esta conexión de datos de envío.

  9. Compruebe que la información es correcta en la sección Resumen y, después, haga clic en Finalizar.

    1. Para cambiar el nombre del botón Enviar que aparece en la barra de herramientas estándar y el comando Enviar que aparece en el menú archivo cuando los usuarios rellenan el formulario, escriba el nuevo nombre en el cuadro de título en el cuadro de diálogo Opciones de envío.

      Sugerencia: Si desea asignar un método abreviado de teclado a este botón y el comando, escriba una y comercial (&) antes del carácter que desea utilizar como un método abreviado de teclado. Por ejemplo, para asignar ALT+B como método abreviado de teclado para el botón Enviar y el comando, escriba Su & bmit.

  10. Si no desea que los usuarios utilicen un comando Enviar o el botón Enviar en la barra de herramientas estándar cuando rellenen el formulario, desactive la casilla de verificación Mostrar el elemento de menú Enviar y el botón Enviar.

    1. De forma predeterminada, cuando los usuarios envían un formulario, InfoPath mantiene el formulario abierto y muestra un mensaje para indicar si el formulario se envió correctamente. Para cambiar este comportamiento predeterminado, haga clic en Avanzadas y, a continuación, siga uno de estos procedimientos:

      • Para cerrar el formulario o crear un nuevo formulario en blanco después de que el usuario envía un formulario completado, haga clic en la opción que desee en la lista después de enviar.

      • Para crear un mensaje personalizado para indicar si el formulario se envió correctamente, seleccione la casilla de verificación usar mensajes personalizados y, a continuación, escriba los mensajes en los cuadros de éxito y de error.

        Sugerencia: Use un mensaje en el cuadro de error para informar a los usuarios qué hacer si no puede enviar el formulario. Por ejemplo, puede sugerir que los usuarios, guarde el formulario y ponerse en contacto para obtener más instrucciones.

      • Si no desea mostrar un mensaje cuando el usuario envía un formulario, desactive la casilla de verificación Mostrar mensajes de error y éxito.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×