Enviar los datos del formulario a varias ubicaciones

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede diseñar la plantilla de formulario de forma que los usuarios puedan enviar los datos del formulario a varias ubicaciones cuando hagan clic en el botón Enviar.

En este artículo

Información general

Paso 1: Agregar las conexiones de datos de envío

Paso 2: Configure la plantilla de formulario para permitir el envío

Introducción

Para permitir que los usuarios envíen los datos del formulario a varias ubicaciones, debe agregar una conexión de datos secundaria a la plantilla de formulario que envía los datos para cada una de las ubicaciones donde desee que los usuarios envíen el formulario. Después de agregar todas las conexiones de envío de datos, debe configurar la plantilla para permitir que los usuarios envíen los datos del formulario a varias ubicaciones mediante una regla. Como resultado, Microsoft Office InfoPath agrega un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo cuando los usuarios rellenan el formulario. InfoPath envía los datos del formulario a las conexiones de datos secundarias en el orden en que se enumeran en la regla. No puede configurar la regla para usar todas las conexiones de envío de datos al mismo tiempo.

Al configurar la plantilla de formulario para permitir que los usuarios envíen los datos del formulario, también puede personalizar las opciones de envío de las siguientes maneras:

  • Cambiar el texto que aparece en el botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Cambiar el método abreviado de teclado del botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Crear mensajes personalizados para mostrar a los usuarios cuando envíen los formularios

  • Especificar si el formulario debe quedar abierto, se debe cerrar o se debe abrir otro formulario en blanco después de enviarlo

Volver al principio

Paso 1: Agregar las conexiones de envío de datos

Para configurar la plantilla de formulario para permitir que los usuarios envíen los formularios completados a varias ubicaciones, debe agregar las conexiones de envío de datos necesarias a la plantilla de formulario. Puede agregar conexiones de datos a las siguientes ubicaciones:

  • Un servicio Web

  • Una biblioteca de documentos de un servidor que ejecute Microsoft Windows SharePoint Services

  • En un mensaje de correo electrónico

    Nota: Para poder enviar los datos del formulario en un mensaje de correo electrónico, los usuarios deben tener Microsoft Office Outlook instalado en su equipo.

En los siguientes procedimientos se explica cómo agregar conexiones de envío de datos a estas ubicaciones.

Agregar una conexión de datos que envíe los datos a un servicio Web

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el Asistente para conexiones de datos, haga clic en Crear una nueva conexión para, haga clic en Enviar datos y, a continuación, haga clic en Siguiente.

  4. En la siguiente página del asistente, haga clic en A un servicio Web y, a continuación, haga clic en Siguiente.

  5. En la siguiente página del asistente, escriba la ubicación del servicio Web al que los usuarios enviarán los formularios y, después, haga clic en Siguiente.

    Si desea buscar un servicio Web en un servidor UDDI (Universal Description, Discovery, and Integration), haga clic en Buscar en UDDI, especifique el servidor UDDI en el que desee buscar, especifique si desea buscar por proveedor o por los servicios que se proporcionan, escriba una palabra clave de búsqueda y, después, haga clic en Buscar. Los servicios Web que coincidan con la palabra de búsqueda aparecerán en la lista Resultado de la búsqueda.

  6. En la siguiente página del asistente, en la lista Seleccione una operación, haga clic en la operación del servicio Web que recibirá los datos del formulario y, después, haga clic en Siguiente.

  7. En la siguiente página del asistente, siga uno de estos procedimientos:

    Enviar los datos de un campo o grupo

    1. En la lista Parámetros, haga clic en un parámetro del servicio Web que recibirá los datos del formulario.

    2. En Opciones de parámetros, haga clic en Campo o grupo.

    3. Haga clic en Modificar Imagen del botón .

    4. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el campo o grupo cuyos datos desee enviar y, después, haga clic en Aceptar.

    5. En el cuadro Incluir, haga clic en Únicamente texto y elementos secundarios para enviar sólo el contenido y los elementos secundarios del campo o grupo, o haga clic en Subárbol XML, incluyendo elemento seleccionado para enviar el contenido y el grupo o campo seleccionado.

    Enviar todos los datos del formulario

    1. Haga clic en Formulario completo (documento XML, incluidas las instrucciones para su proceso).

    Enviar los datos como una cadena

    1. Active la casilla de verificación Enviar datos en forma de cadena.

      Generalmente, esta casilla de verificación se activa para enviar datos firmados digitalmente. Para la mayoría de los casos, debe desactivarse.

  8. Haga clic en Siguiente.

  9. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba un nombre descriptivo para esta conexión de datos de envío.

  10. Compruebe que la información es correcta en la sección Resumen y, después, haga clic en Finalizar.

Agregar una conexión de datos que envíe datos a una biblioteca de documentos

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el Asistente para conexiones de datos, haga clic en Crear una nueva conexión para, haga clic en Enviar datos y, a continuación, haga clic en Siguiente.

  4. En la siguiente página del asistente, haga clic en A una biblioteca de documentos en un sitio de SharePoint y, después, haga clic en Siguiente.

  5. En la siguiente página del asistente, en el cuadro Biblioteca de documentos, escriba la ubicación de la biblioteca de documentos de SharePoint.

  6. En el cuadro Nombre de archivo, escriba un nombre que se utilizará para identificar el formulario en la biblioteca de documentos. También puede usar una fórmula para asegurarse de que el nombre de cada formulario es único.

    Cómo

    1. Haga clic en Insertar fórmula Botón de fórmula .

    2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

      • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

      • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

        Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

      • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

    Operación

    Símbolo

    Sumar

    +

    Restar

    -

    Multiplicar

    *

    Dividir

    /

    • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

    • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

      Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

  7. Para sobrescribir formularios existentes con el mismo nombre en la biblioteca de documentos, active la casilla de verificación Permitir sobrescribir si existe el archivo.

  8. Haga clic en Siguiente.

  9. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba un nombre descriptivo para esta conexión de datos de envío.

  10. Compruebe que la información es correcta en la sección Resumen y, después, haga clic en Finalizar.

Agregar una conexión de datos que envíe los datos en un mensaje de correo electrónico

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el Asistente para conexiones de datos, haga clic en Crear una nueva conexión para, haga clic en Enviar datos y, a continuación, haga clic en Siguiente.

  4. En la página siguiente del asistente, haga clic en Como mensaje de correo electrónico y, a continuación, haga clic en Siguiente.

  5. En la siguiente página del asistente, escriba las direcciones de correo electrónico de los destinatarios del mensaje, el asunto que desee que aparezca en el mensaje y el texto de introducción que desee en los cuadros correspondientes. Después, haga clic en Siguiente. También puede usar una fórmula en cada cuadro, excepto en el cuadro Introducción.

    Cómo

    1. Haga clic en Insertar fórmula Botón de fórmula .

    2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

      • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

      • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

        Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

      • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

    Operación

    Símbolo

    Sumar

    +

    Restar

    -

    Multiplicar

    *

    Dividir

    /

    • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

    • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

      Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

  6. En la siguiente página del asistente, siga uno de estos procedimientos:

    1. Para mostrar el formulario en el cuerpo del mensaje de correo electrónico, haga clic en Enviar únicamente la vista activa del formulario sin datos adjuntos.

    2. Para enviar los datos del formulario como datos adjuntos al mensaje de correo electrónico, haga clic en enviar los datos del formulario como datos adjuntos, active la casilla de verificación adjuntar la plantilla de formulario para asegurar que los usuarios puedan abrir el formulario y, a continuación, escriba un nombre para el formulario en el cuadro Nombre de archivo adjunto. También puede especificar un campo o utilizar una fórmula para asegurarse de que cada nombre del formulario es único. Esta opción está disponible únicamente si está configurada para determinar automáticamente el nivel de seguridad de la plantilla de formulario o está configurada para el nivel de seguridad restringido o de plena confianza.

      Cómo

      1. Haga clic en Insertar fórmula Botón de fórmula .

      2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

        • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

        • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

          Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

        • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

      Operación

      Símbolo

      Sumar

      +

      Restar

      -

      Multiplicar

      *

      Dividir

      /

      • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

      • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

        Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

      Los destinatarios de correo electrónico de los datos del formulario que se envían como datos adjuntos deberán tener InfoPath instalado en sus equipos para poder abrir los datos adjuntos.

  7. Haga clic en Siguiente.

  8. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba un nombre descriptivo para esta conexión de datos de envío.

  9. Compruebe que la información es correcta en la sección Resumen y, después, haga clic en Finalizar.

Volver al principio

Paso 2: Configurar la plantilla de formulario para permitir el envío

Después de agregar las conexiones de datos secundarias que sean necesarias a la plantilla de formulario, debe configurar la plantilla para permitir que los usuarios envíen los datos del formulario. Al hacerlo, InfoPath agrega un comando Enviar al menú Archivo y un botón Enviar a la barra de herramientas Estándar cuando los usuarios rellenan el formulario. Después, puede configurar la acción que se producirá cuando el usuario haga clic en el botón Enviar. En este caso, agregará una regla que envía los datos del formulario a cada conexión de envío de datos cuando el usuario hace clic en el comando Enviar del menú Archivo o el botón Enviar de la barra de herramientas Estándar.

En el mismo cuadro de diálogo, puede configurar las opciones de envío.

  1. En el menú Herramientas, haga clic en Opciones de envío.

  2. En el cuadro de diálogo Opciones de envío, seleccione la casilla de verificación Permitir a los usuarios enviar este formulario.

    Al activar esta casilla de verificación, InfoPath agrega un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo cuando los usuarios rellenan el formulario.

  3. Haga clic en Realizar una acción personalizada utilizando reglas y, después, haga clic en Reglas.

  4. En el cuadro de diálogo Reglas para enviar formularios, haga clic en Agregar.

  5. Haga clic en Agregar acción.

  6. En el cuadro Acción, haga clic en Enviar usando una conexión de datos, haga clic en la conexión de datos que desee usar para esta acción de envío en la lista Conexión de datos y, después, haga clic en Aceptar.

  7. Repita los pasos 5 y 6 para cada conexión de envío de datos que ha agregado a la plantilla de formulario.

  8. Después de agregar condiciones para todas las conexiones de envío de datos de la plantilla de formulario, haga clic en Aceptar dos veces.

    1. Para cambiar el nombre del botón Enviar que aparece en la barra de herramientas estándar y el comando Enviar que aparece en el menú archivo cuando los usuarios rellenan el formulario, escriba el nuevo nombre en el cuadro de título en el cuadro de diálogo Opciones de envío.

      Si desea asignar un método abreviado de teclado a este botón y el comando, escriba una y comercial (&) antes del carácter que desea utilizar como un método abreviado de teclado. Por ejemplo, para asignar ALT+B como método abreviado de teclado para el botón Enviar y el comando, escriba Su & bmit.

  9. Para impedir que los usuarios utilicen el comando Enviar o el botón Enviar de la barra de herramientas Estándar cuando rellenen el formulario, desactive la casilla de verificación Mostrar el elemento de menú Enviar y el botón de la barra de herramientas Enviar.

    1. De forma predeterminada, cuando los usuarios envían un formulario, InfoPath mantiene el formulario abierto y muestra un mensaje para indicar si el formulario se envió correctamente. Para cambiar este comportamiento predeterminado, haga clic en Avanzadas y, a continuación, siga uno de estos procedimientos:

      • Para cerrar el formulario o crear un nuevo formulario en blanco después de que el usuario envía un formulario completado, haga clic en la opción que desee en la lista después de enviar.

      • Para crear un mensaje personalizado para indicar si el formulario se envió correctamente, seleccione la casilla de verificación usar mensajes personalizados y, a continuación, escriba los mensajes en los cuadros de éxito y de error.

        Use un mensaje en el cuadro de error para informar a los usuarios qué hacer si no puede enviar el formulario. Por ejemplo, puede sugerir que los usuarios, guarde el formulario y ponerse en contacto para obtener más instrucciones.

      • Si no desea mostrar un mensaje cuando el usuario envía un formulario, desactive la casilla de verificación Mostrar mensajes de error y éxito.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×