Enviar los datos del formulario a una biblioteca de documentos

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede almacenar y organizar todos los formularios de los usuarios en una biblioteca de documentos de un servidor que ejecute Microsoft Windows SharePoint Services. En la biblioteca de documentos, los usuarios pueden rellenar formularios basados en la plantilla de formulario, exportar datos de formularios completados a Microsoft Office Excel 2003 o Microsoft Office Excel 2007, o combinar los datos de varios formularios en uno solo.

Para permitir que los usuarios envíen formularios basados en la plantilla de formulario a una biblioteca de documentos, puede agregar una conexión de datos secundaria a la plantilla de formulario que envía los datos. Después de agregar la conexión de envío de datos, puede configurar la plantilla para permitir que los usuarios envíen los datos del formulario a la biblioteca de documentos. Al hacerlo, Microsoft Office InfoPath agrega un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo en el formulario. También puede personalizar las opciones de envío de la plantilla de formulario de las siguientes maneras:

  • Cambiar el texto que aparece en el botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Cambiar el método abreviado de teclado del botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo.

  • Crear mensajes personalizados para mostrar a los usuarios cuando envíen los formularios

  • Especificar si el formulario debe quedar abierto, se debe cerrar o se debe abrir otro formulario en blanco después de enviarlo

Agregar una conexión de envío de datos

  1. En el menú Herramientas, haga clic en Opciones de envío.

  2. En el cuadro de diálogo Opciones de envío, seleccione la casilla de verificación Permitir a los usuarios enviar este formulario.

  3. Haga clic en Enviar datos del formulario a un único destino y, después, haga clic en Biblioteca de documentos de SharePoint en la lista.

  4. Haga clic en Agregar.

  5. En el Asistente para la conexión de datos, en el cuadro Biblioteca de documentos, escriba la ubicación de la biblioteca de documentos de SharePoint.

  6. En el cuadro Nombre de archivo, escriba un nombre que se utilizará para identificar el formulario en la biblioteca de documentos.

    Sugerencia: También puede usar una fórmula para asegurarse de que el nombre de cada formulario es único.

    Cómo

    1. Haga clic en Insertar fórmula Botón de fórmula .

    2. En el cuadro de diálogo Insertar fórmula, siga uno de estos procedimientos:

      • Para usar un campo en la fórmula, haga clic en Insertar campo o grupo, haga clic en el campo que desee usar en el cuadro de diálogo Seleccionar un campo o grupo y, después, haga clic en Aceptar.

      • Para usar una función en la fórmula, haga clic en Insertar función, seleccione la función que desee usar en el cuadro de diálogo Insertar función y, después, haga clic en Aceptar.

        Sugerencia: Si la función requiere parámetros, seleccione la función en el cuadro de diálogo Insertar función, haga clic en Aceptar y, a continuación, en el cuadro Fórmula del cuadro de diálogo Insertar fórmula, haga doble clic en la función que agregó y haga clic en un campo o grupo. Encontrará vínculos para obtener más información acerca de las funciones en la sección Vea también.

      • Para insertar un valor u operador matemático en la fórmula, escriba el valor o el símbolo de la operación matemática en el cuadro Fórmula.

    Operación

    Símbolo

    Sumar

    +

    Restar

    -

    Multiplicar

    *

    Dividir

    /

    • Nota: Si la fórmula utiliza el operador de división (/), asegúrese de que hay un espacio delante y detrás del operador. Si el operador de división no tiene un espacio delante y otro detrás, InfoPath puede interpretar "/" como un separador de pasos de ubicación de XPath en lugar de un operador de división.

    • Para comprobar que la fórmula tiene una sintaxis correcta, en el cuadro de diálogo Insertar fórmula, haga clic en Comprobar fórmula.

      Encontrará vínculos para obtener más información acerca de las fórmulas en la sección Vea también.

  7. Para sobrescribir formularios existentes con el mismo nombre en la biblioteca de documentos, active la casilla de verificación Permitir sobrescribir si existe el archivo.

  8. Haga clic en Siguiente.

  9. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba un nombre descriptivo para esta conexión de datos de envío.

  10. Compruebe que la información es correcta en la sección Resumen y, después, haga clic en Finalizar.

    1. Para cambiar el nombre del botón Enviar que aparece en la barra de herramientas estándar y el comando Enviar que aparece en el menú archivo cuando los usuarios rellenan el formulario, escriba el nuevo nombre en el cuadro de título en el cuadro de diálogo Opciones de envío.

      Sugerencia: Si desea asignar un método abreviado de teclado a este botón y el comando, escriba una y comercial (&) antes del carácter que desea utilizar como un método abreviado de teclado. Por ejemplo, para asignar ALT+B como método abreviado de teclado para el botón Enviar y el comando, escriba Su & bmit.

  11. Si no desea que los usuarios utilicen un comando Enviar o el botón Enviar en la barra de herramientas estándar cuando rellenen el formulario, desactive la casilla de verificación Mostrar el elemento de menú Enviar y el botón Enviar.

    1. De forma predeterminada, cuando los usuarios envían un formulario, InfoPath mantiene el formulario abierto y muestra un mensaje para indicar si el formulario se envió correctamente. Para cambiar este comportamiento predeterminado, haga clic en Avanzadas y, a continuación, siga uno de estos procedimientos:

      1. Para cerrar el formulario o crear un nuevo formulario en blanco después de que el usuario envía un formulario completado, haga clic en la opción que desee en la lista después de enviar.

      2. Para crear un mensaje personalizado para indicar si el formulario se envió correctamente, seleccione la casilla de verificación usar mensajes personalizados y, a continuación, escriba los mensajes en los cuadros de éxito y de error.

        Sugerencia: Use un mensaje en el cuadro de error para informar a los usuarios qué hacer si no puede enviar el formulario. Por ejemplo, puede sugerir que los usuarios, guarde el formulario y ponerse en contacto para obtener más instrucciones.

      3. Si no desea mostrar un mensaje cuando el usuario envía un formulario, desactive la casilla de verificación Mostrar mensajes de error y éxito.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×