Enviar datos de formulario a una base de datos de Microsoft Access

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

En este artículo:

Información general

Paso 1: Habilitar la conexión de envío de datos

Paso 2: Configurar las opciones de envío

Información general

Al diseñar una plantilla de formulario de Microsoft Office InfoPath que se basa en una base de datos de Microsoft Office Access (.mdb) o Microsoft Office Access 2007 (.accdb), el Asistente para la conexión de datos crea una conexión de datos de envío a la base de datos si se cumplen las condiciones siguientes.

  • La plantilla de formulario está diseñada de manera que los usuarios deben rellenarla mediante InfoPath. Si el formulario se rellena con un explorador Web, el formulario no puede enviar los datos directamente a una base de datos. Para configurar una plantilla de formulario compatible con el explorador para enviar datos a una base de datos, utilice una conexión de datos que envía los datos a un servicio Web que funciona con la base de datos.

  • La tabla de base de datos principal que se utiliza en la conexión de datos principal contiene una clave principal, delimitación única o índice único.

  • Cualquier otra tabla de base de datos que se utilice con esta conexión de datos principal posee una relación simple y jerárquica con la tabla de base de datos principal.

  • La base de datos no contiene campos que puedan almacenar un tipo de datos binarios de gran tamaño, como imágenes, objetos OLE, archivos adjuntos, el tipo de datos Memo de Office Access o el tipo de datos de texto SQL.

Si la base de datos cumple estos requisitos, InfoPath crea la conexión de datos de envío y agrega un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo del formulario.

Nota: Las conexiones de datos secundarias no pueden enviar los datos a una base de datos. Si desea utilizar una conexión de datos de envío a una base de datos como una conexión de datos secundaria, identifique un servicio Web que funcione con la base de datos y después agregue una conexión de datos de envío a ese servicio Web.

Después de habilitar la conexión de datos de envío, puede personalizar las opciones de envío para su plantilla de formulario de las maneras siguientes.

  • Cambiar el texto que aparece en el botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo. .

  • Cambiar los accesos directos para el botón Enviar de la barra de herramientas Estándar y el comando Enviar del menú Archivo. .

  • Crear mensajes personalizados para mostrar a los usuarios cuando envíen los formularios

  • Especificar si el formulario debe quedar abierto, se debe cerrar o se debe abrir otro formulario en blanco después de enviarlo

Principio de página

Paso 1: Habilitar la conexión de envío de datos

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en la conexión de datos principal y, después, haga clic en Modificar.

  3. En el Asistente para la conexión de datos, haga clic en Siguiente.

  4. En la siguiente página del asistente, active la casilla de verificación Habilitar el envío para esta conexión y, después, haga clic en Finalizar.

Principio de página

Paso 2: configurar las opciones de envío

Una vez habilitada la conexión de datos de envío, InfoPath agrega un botón Enviar a la barra de herramientas Estándar y un comando Enviar al menú Archivo. InfoPath también configura los formularios basados en esta plantilla de formulario para mostrar un mensaje a los usuarios después de que éstos envíen sus formularios rellenos. Este mensaje aparece si el formulario se envió correctamente. De manera predeterminada, InfoPath mantiene abierto el formulario después de que se haya enviado. Para cambiar el texto que aparece en el botón Enviar, así como el comportamiento que se da después de que los usuarios envíen sus formularios, haga lo siguiente:

  1. En el menú Herramientas, haga clic en Opciones de envío.

    1. Para cambiar el nombre del botón Enviar que aparece en la barra de herramientas estándar y el comando Enviar que aparece en el menú archivo cuando los usuarios rellenan el formulario, escriba el nuevo nombre en el cuadro de título en el cuadro de diálogo Opciones de envío.

      Sugerencia: Si desea asignar un método abreviado de teclado a este botón y el comando, escriba una y comercial (&) antes del carácter que desea utilizar como un método abreviado de teclado. Por ejemplo, para asignar ALT+B como método abreviado de teclado para el botón Enviar y el comando, escriba Su & bmit.

  2. Si no desea que los usuarios utilicen un comando Enviar o el botón Enviar en la barra de herramientas estándar cuando rellenen el formulario, desactive la casilla de verificación Mostrar el elemento de menú Enviar y el botón Enviar.

    1. De forma predeterminada, cuando los usuarios envían un formulario, InfoPath mantiene el formulario abierto y muestra un mensaje para indicar si el formulario se envió correctamente. Para cambiar este comportamiento predeterminado, haga clic en Avanzadas y, a continuación, siga uno de estos procedimientos:

      • Para cerrar el formulario o crear un nuevo formulario en blanco después de que el usuario envía un formulario completado, haga clic en la opción que desee en la lista después de enviar.

      • Para crear un mensaje personalizado para indicar si el formulario se envió correctamente, seleccione la casilla de verificación usar mensajes personalizados y, a continuación, escriba los mensajes en los cuadros de éxito y de error.

        Sugerencia: Use un mensaje en el cuadro de error para informar a los usuarios qué hacer si no puede enviar el formulario. Por ejemplo, puede sugerir que los usuarios, guarde el formulario y ponerse en contacto para obtener más instrucciones.

      • Si no desea mostrar un mensaje cuando el usuario envía un formulario, desactive la casilla de verificación Mostrar mensajes de error y éxito.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×