Ejemplos de fórmulas comunes

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede utilizar los ejemplos siguientes en las columnas calculadas de una lista o biblioteca. Los ejemplos que no incluyen referencias a columnas se pueden utilizar para especificar el valor predeterminado de una columna.

En este artículo

Fórmulas condicionales

Fórmulas de fecha y hora

Fórmulas matemáticas

Fórmulas de texto

Fórmulas condicionales

Puede usar las fórmulas siguientes para probar la condición de una instrucción y devolver un valor Sí o No, para probar un valor alternativo como Correcto o Incorrecto, o para devolver un espacio en blanco o un guión para representar un valor nulo.

Comprobar si un número es mayor o menor que otro

Use la función SI para realizar esta comparación.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

15000

9000

=[Columna1]>[Columna2]

¿Es Columna1 mayor que Columna2? (Sí)

15000

9000

=SI([Columna1]<=[Columna2], "Correcto", "Incorrecto")

¿Es Columna1 menor o igual que Columna2? (Incorrecto)

Devolver un valor lógico después de comparar el contenido de las columnas

Para obtener un resultado que sea un valor lógico (Sí o No), use las funciones Y, O y NO.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado posible)

15

9

8

=Y([Columna1]>[Columna2], [Columna1]<[Columna3])

¿Es 15 mayor que 9 y menor que 8? (No)

15

9

8

=O([Columna1]>[Columna2], [Columna1]<[Columna3])

¿Es 15 mayor que 9 o menor que 8? (Sí)

15

9

8

=NO([Columna1]+[Columna2]=24)

¿Es 15 más 9 diferente de 24? (No)

Para obtener un resultado que sea otro cálculo o un valor distinto de Sí o No, use las funciones SI, Y y O.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado posible)

15

9

8

=SI([Columna1]=15, "Correcto", "Incorrecto")

Si el valor de Columna1 es igual a 15, devolver "Correcto". (Correcto)

15

9

8

=SI(Y([Columna1]>[Columna2], [Columna1]<[Columna3]), "Correcto", "Incorrecto")

Si 15 es mayor que 9 y menor que 8, devolver "Correcto". (Incorrecto)

15

9

8

=SI(O([Columna1]>[Columna2], [Columna1]<[Columna3]), "Correcto", "Incorrecto")

Si 15 es mayor que 9 o menor que 8, devolver "Correcto". (Correcto)

Mostrar ceros como espacios en blanco o guiones

Para mostrar un cero, realice un cálculo sencillo. Para mostrar un espacio en blanco o un guión, use la función SI.

C olumna1

Columna2

Fórmula

Descripción (resultado posible)

10

10

=[Columna1]-[Columna2]

Segundo número restado del primero (0)

15

9

=SI([Columna1]-[Columna2],"-",[Columna1]-[Columna2])

Devuelve un guión cuando el valor es cero (-)

Ocultar valores de error en columnas

Para mostrar un guión, #N/A o ND en lugar de un valor de error, use la función ESERROR.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

10

0

=[Columna1]/[Columna2]

Da como resultado un error (#DIV/0)

10

0

=SI(ESERROR([Columna1]/[Columna2]),"ND",[Columna1]/[Columna2])

Devuelve ND cuando el valor es un error

10

0

=SI(ESERROR([Columna1]/[Columna2]),"-",[Columna1]/[Columna2])

Devuelve un guión cuando el valor es un error

Volver al principio

Fórmulas de fecha y hora

Puede usar las fórmulas siguientes para realizar cálculos que se basen en la fecha y la hora, como agregar un número de días, meses o años a una fecha, calcular la diferencia entre dos fechas y convertir la hora a un valor decimal.

Agregar fechas

Para agregar un número de días a una fecha, use el operador de suma (+).

Nota: Cuando trate las fechas, el tipo devuelto de la columna calculada debe establecerse en Fecha y hora.

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

3

=[Columna1]+[Columna2]

Agrega 3 días a 6/9/2007 (6/12/2007)

12/10/2008

54

=[Columna1]+[Columna2]

Agrega 54 días a 12/10/2008 (2/2/2009)

Para agregar un número de meses a una fecha, use las funciones FECHA, AÑO, MES y DIA.

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

3

=FECHA(AÑO([Columna1]),MES([Columna1])+[Columna2],DIA([Columna1]))

Agrega 3 meses a 6/9/2007 (9/9/2007)

12/10/2008

25

=FECHA(AÑO([Columna1]),MES([Columna1])+[Columna2],DIA([Columna1]))

Agregar 25 meses a 12/10/2008 (1/10/2011)

Para agregar un número de años a una fecha, use las funciones FECHA, AÑO, MES y DIA.

Columna1

Columna2

Fórmula

Descripción (resultado)

9/6/2007

3

=FECHA(AÑO([Columna1])+[Columna2],MES([Columna1]),DIA([Columna1]))

Agrega 3 años a 6/9/2007 (6/9/2010)

12/10/2008

25

=FECHA(AÑO([Columna1])+[Columna2],MES([Columna1]),DIA([Columna1]))

Agrega 25 años a 12/10/2008 (12/10/2033)

Para agregar una combinación de días, meses y años a una fecha, use las funciones FECHA, AÑO, MES y DIA.

Columna1

Fórmula

Descripción (resultado)

6/9/2007

=FECHA(AÑO([Columna1])+3,MES([Columna1])+1,DIA([Columna1])+5)

Agregar 3 años, 1 mes y 5 días a 6/9/2007 (7/14/2010)

12/10/2008

=FECHA(AÑO([Columna1])+1,MES([Columna1])+7,DIA([Columna1])+5)

Agregar 1 año, 7 meses y 5 días a 12/10/2008 (7/15/2010)

Calcular la diferencia entre dos fechas

Use la función SIFECHA para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"d")

Devuelve el número de días entre las dos fechas (1626)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"am")

Devuelve el número de meses entre las fechas, pasando por alto la parte correspondiente al año (5)

01-Ene-1995

15-Jun-1999

=SIFECHA([Columna1], [Columna2],"ad")

Devuelve el número de días entre las fechas, pasando por alto la parte correspondiente al año (165)

Calcular la diferencia entre dos horas

Para presentar el resultado en el formato de hora estándar (horas:minutos:segundos), use el operador de resta (-) y la función TEXTO. Para que este método funcione, las horas no deben ser mayores de 24 y los minutos y segundos no deben superar el valor 60.

Columna1

Columna2

Fórmula

Descripción (resultado)

06/09/2007 10:35 a.m.

06/09/2007 3:30 p.m.

=TEXTO([Columna2]-[Columna1],"h")

Horas entre dos (4)

06/09/2007 10:35 a.m.

06/09/2007 3:30 p.m.

=TEXTO([Columna2]-[Columna1],"h:mm")

Horas y minutos entre dos (4:55)

06/09/2007 10:35 a.m.

06/09/2007 3:30 p.m.

=TEXTO([Columna2]-[Columna1],"h:mm:ss")

Horas, minutos y segundos entre dos (4:55:00)

Para presentar el resultado en un total que se base en una unidad horaria, use la función ENTERO, o las funciones HORA, MINUTO o SEGUNDO.

Columna1

Columna2

Fórmula

Descripción (resultado)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=ENTERO(([Columna2]-[Columna1])*24)

Total de horas entre dos (28)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=ENTERO(([Columna2]-[Columna1])*1440)

Total de minutos entre dos (1735)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=ENTERO(([Columna2]-[Columna1])*86400)

Total de segundos entre dos (104100)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=HORA([Columna2]-[Columna1])

Horas entre dos, cuando la diferencia no supera 24 (4)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=MINUTO([Columna2]-[Columna1])

Minutos entre dos, cuando la diferencia no supera 60 (55)

06/09/2007 10:35 a.m.

06/10/2007 3:30 p.m.

=SEGUNDO([Columna2]-[Columna1])

Segundos entre dos, cuando la diferencia no supera 60 (0)

Convertir horas

Para convertir las horas del formato de hora estándar a un número decimal, use la función ENTERO.

Columna1

Fórmula

Descripción (resultado)

10:35 a.m.

=([Columna1]-ENTERO([Columna1]))*24

Número de horas desde 12:00 a.m. (10,583333)

12:15 p.m.

=([Columna1]-ENTERO([Columna1]))*24

Número de horas desde 12:00 a.m. (12,25)

Para convertir las horas de un número decimal al formato de hora estándar (horas:minutos:segundos), use el operador de división y la función TEXTO.

Columna1

Fórmula

Descripción (resultado)

23:58

=TEXTO(Columna1/24, "hh:mm:ss")

Horas, minutos y segundos desde las 12:00 a.m. (00:59:55)

2:06

=TEXTO(Columna1/24, "h:mm")

Horas y minutos desde las 12:00 a.m. (0:05)

Insertar fechas julianas

Una fecha juliana hace referencia a un formato de fecha que es una combinación del año actual y del número de días desde el comienzo del año. Por ejemplo, 1 de enero de 2007 se representa como 2007001 y 31 de diciembre de 2007 se representa como 2007365. Este formato no se basa en el calendario juliano.

Para convertir una fecha en fecha juliana, use las funciones TEXTO y FECHANUMERO.

Columna1

Fórmula

Descripción (resultado)

6/23/2007

=TEXTO([Columna1],"aa")&TEXTO(([Columna1]-FECHANUMERO("1/1/"& TEXTO([Columna1],"aa"))+1),"000")

Fecha en formato juliano, con el año de dos dígitos (07174)

6/23/2007

=TEXTO([Columna1],"aaaa")&TEXTO(([Columna1]-FECHANUMERO("1/1/"&TEXTO([Columna1],"aa"))+1),"000")

Fecha en formato juliano, con el año de cuatro dígitos (2007174)

Para convertir una fecha en la fecha juliana que se usa en astronomía, use la constante 2415018.50. Esta fórmula sólo funciona para las fechas después de 3/1/1901 y si va a usar el sistema de fechas 1900.

Columna1

Fórmula

Descripción (resultado)

6/23/2007

=[Columna1]+2415018.50

Fecha en formato juliano, que se usa en astronomía (2454274,50)

Mostrar las fechas con el día de la semana

Para convertir las fechas en el texto del día de la semana, use las funciones TEXTO y DIASEM.

Columna1

Fórmula

Descripción (resultado posible)

19-Feb-2007

=TEXTO(DIASEM([Columna1]), "dddd")

Calcula el día de la semana correspondiente a la fecha y devuelve el nombre completo del día (lunes)

3-Ene-2008

=TEXTO(DIASEM([Columna1]), "ddd")

Calcula el día de la semana correspondiente a la fecha y devuelve el nombre abreviado del día (Jue.)

Volver al principio

Fórmulas matemáticas

Puede usar las fórmulas siguientes para realizar diversos cálculos matemáticos, como sumar, restar, multiplicar y dividir números, calcular el promedio o la mediana de números, redondear un número y contar valores.

Sumar números

Para sumar los números de dos o más columnas en una fila, use el operador de suma (+) o la función SUMA.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

6

5

4

=[Columna1]+[Columna2]+[Columna3]

Suma los valores de las tres primeras columnas (15)

6

5

4

=SUMA([Columna1],[Columna2],[Columna3])

Suma los valores de las tres primeras columnas (15)

6

5

4

=SUMA(SI([Columna1]>[Columna2], [Columna1]-[Columna2], 10), [Columna3])

Si Columna1 es mayor que Columna2, suma la diferencia y Columna3. Si no, suma 10 y Columna3 (5)

Restar números

Para resta los números de dos o más columnas en una fila, use el operador de suma (+) o la función SUMA.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

15000

9000

-8000

=[Columna1]-[Columna2]

Resta 9000 de 15000 (6000)

15000

9000

-8000

=SUMA([Columna1], [Columna2], [Columna3])

Suma los números de las tres primeras columnas e incluye valores negativos (16000)

Ejemplo 5: Calcular la diferencia entre dos números y mostrarla como porcentaje

Use los operadores de resta (-) y división (/), y la función ABS.

Columna1

Columna2

Fórmula

Descripción (resultado)

2342

2500

=([Columna2]-[Columna1])/ABS([Columna1])

Cambio de porcentaje (6,75% o 0,06746)

Multiplicar números

Para multiplicar los números de dos o más columnas en una fila, use el operador de multiplicación (*) o la función PRODUCTO.

Columna1

Columna2

Fórmula

Descripción (resultado)

5

2

=[Columna1]*[Columna2]

Multiplica los números de las primeras dos columnas (10)

5

2

=PRODUCTO([Columna1], [Columna2])

Multiplica los números de las primeras dos columnas (10)

5

2

=PRODUCTO([Columna1],[Columna2],2)

Multiplica los números de las dos primeras columnas y el número 2 (20)

Dividir números

Para dividir los números de dos o más columnas en una fila, use el operador de división (/).

Columna1

Columna2

Fórmula

Descripción (resultado)

15000

12

=[Columna1]/[Columna2]

Divide 15000 por 12 (1250)

15000

12

=([Columna1]+10000)/[Columna2]

Suma 15000 y 10000, y después divide el total entre 12 (2083)

Calcular el promedio de números

El promedio también se conoce como media. Para calcular el promedio de los números de dos o más columnas en una fila, use la función PROMEDIO.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

6

5

4

=PROMEDIO([Columna1], [Columna2],[Columna3])

Promedio de los números de las tres primeras columnas (5)

6

5

4

=PROMEDIO(SI([Columna1]>[Columna2], [Columna1]-[Columna2], 10), [Columna3])

Si Columna1 es mayor que Columna2, calcular el promedio de la diferencia y Columna3. Si no, calcular el promedio del valor 10 y Columna3 (2,5)

Calcular la mediana de números

La mediana es el valor central en un intervalo ordenado de números. Use la función MEDIANA para calcular la mediana de un grupo de números.

A

B

C

C

E

F

Fórmula

Descripción (resultado)

10

7

9

27

0

4

=MEDIANA(A, B, C, D, E, F)

Mediana de los números de las primeras 6 columnas (8)

Calcular el número menor o mayor en un rango

Para calcular el número menor o mayor de dos o más columnas en una fila, use las funciones MIN y MAX.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

10

7

9

=MIN([Columna1], [Columna2], [Columna3])

Número menor (7)

10

7

9

=MAX([Columna1], [Columna2], [Columna3])

Número mayor (10)

Contar valores

Para contar valores numéricos, use la función CONTAR.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

Manzana

12/12/2007

=CONTAR([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas que contienen valores numéricos. Excluye la fecha y la hora, el texto y los valores nulos (0)

$12

#¡DIV/0!

1.01

=CONTAR([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas que contienen valores numéricos, pero excluye los valores de error y los valores lógicos (2)

Ejemplo 1: Aumentar o disminuir un número según un porcentaje

Use el operador de porcentaje (%) para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

23

3%

=[Columna1]*(1+5%)

Incrementa el número de Columna1 un 5% (24.15)

23

3%

=[Columna1]*(1+[Columna2])

Incrementa el número de Columna1 en el valor de porcentaje de Columna2: 3% (23,69)

23

3%

=[Columna1]*(1-[Columna2])

Reduce el número de Columna1 en el valor de porcentaje de Columna2: 3% (22,31)

Elevar un número a una potencia

Use el operador exponencial (^) o la función POTENCIA para realizar este cálculo.

Columna1

Columna2

Fórmula

Descripción (resultado)

5

2

=[Columna1]^[Columna2]

Calcula cinco al cuadrado (25)

5

3

=POTENCIA([Columna1], [Columna2])

Calcula cinco al cubo (125)

Redondear un número

Para redondear un número, use la función REDONDEAR.MAS, REDONDEA.IMPAR o REDONDEA.PAR.

Columna1

Fórmula

Descripción (resultado)

20.3

=REDONDEAR.MAS([Columna1],0)

Redondea 20.3 hacia arriba, al número entero más cercano (21)

-5.9

=REDONDEAR.MAS([Columna1],0)

Redondea -5.9 hacia arriba, al número entero más cercano (-5)

12.5493

=REDONDEAR.MAS([Columna1],2)

Redondea 12.5493 hacia arriba, a la centena más cercana, con dos lugares decimales (12.55)

20.3

=REDONDEA.PAR([Columna1])

Redondea 20.3 hacia arriba, al número par más cercano (22)

20.3

=REDONDEA.IMPAR([Columna1])

Redondea 20.3 hacia arriba, al número impar más cercano (21)

Para redondear hacia abajo un número, use la función REDONDEAR.MENOS.

Columna1

Fórmula

Descripción (resultado)

20.3

=REDONDEAR.MENOS([Columna1],0)

Redondea 20.3 hacia abajo al número entero más cercano (20)

-5.9

=REDONDEAR.MENOS([Columna1],0)

Redondea -5.9 hacia abajo al número entero más cercano (-6)

12.5493

=REDONDEAR.MENOS([Columna1],2)

Redondea 12.5493 a la centena más cercana, con dos lugares decimales (12.54)

Para redondear al número o fracción más cercanos, use la función REDONDEAR.

Columna1

Fórmula

Descripción (resultado)

20.3

=REDONDEAR([Columna1],0)

Redondea 20.3 hacia abajo, ya que la parte fraccionaria es menor que 0.5 (20)

5,9

=REDONDEAR([Columna1],0)

Redondea 5.9 hacia arriba, ya que la parte fraccionaria es mayor que 0.5 (6)

-5.9

=REDONDEAR([Columna1],0)

Redondea -5.9 hacia abajo, ya que la parte fraccionaria es menor que 0.5 (-6)

1.25

=REDONDEAR([Columna1], 1)

Redondea el número a la decena más cercana (un lugar decimal). Dado que la parte que se va a redondear es 0.05 o superior, el número se redondea hacia arriba (resultado: 1.3)

30.452

=REDONDEAR([Columna1], 2)

Redondea el número a la centena más cercana (dos lugares decimales). Dado que la parte que se va a redondear, 0.002, es menor que 0.005, el número se redondea hacia arriba (resultado: 30.45)

Para redondear un número al dígito significativo por encima de 0, use las funciones REDONDEAR, REDONDEAR.MAS, REDONDEAR.MENOS, ENTERO y LARGO.

Columna1

Fórmula

Descripción (resultado)

5492820

=REDONDEAR([Columna1],3-LARGO(ENTERO([Columna1])))

Redondea el número a 3 dígitos significativos (5490000)

22230

=REDONDEAR.MENOS([Columna1],3-LARGO(ENTERO([Columna1])))

Redondea el número hacia abajo a 3 dígitos significativos (22200)

5492820

=REDONDEAR.MAS([Columna1], 5-LARGO(ENTERO([Columna1])))

Redondea el número hacia arriba a 5 dígitos significativos (5492900)

Volver al principio

Fórmulas de texto

Puede usar las fórmulas siguientes para tratar texto, por ejemplo, para combinar o concatenar los valores de varias columnas, comparar el contenido de las columnas, quitar caracteres o espacios, y repetir caracteres.

Cambiar entre mayúsculas y minúsculas

Para cambiar las mayúsculas o minúsculas del texto, use la función MAYUSC.

Columna1

Fórmula

Descripción (resultado)

ana Trujillo

=MAYUSC([Columna1])

Cambia el texto a mayúsculas (ANA TRUJILLO)

ana Trujillo

=MINUSC([Columna1])

Cambia el texto a minúsculas (ana trujillo)

ana Trujillo

=NOMBREPROPIO([Columna1])

Cambia las primeras letras del texto a mayúsculas (Ana Trujillo)

Combinar nombres y apellidos

Para combinar el nombre y los apellidos, use el operador "y" comercial (&) o la función CONCATENAR.

Columna1

Columna2

Fórmula

Descripción (resultado)

Carlos

Carvallo

=[Columna1]&[Columna2]

Combina las dos cadenas (CarlosCarvallo)

Carlos

Carvallo

=[Columna1]&" "&[Columna2]

Combina las dos cadenas, separadas por un espacio (Carlos Carvallo)

Carlos

Carvallo

=[Columna2]&", "&[Columna1]

Combina las dos cadenas, separadas por una coma y un espacio (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENAR([Columna2], ",", [Columna1])

Combina las dos cadenas, separadas por una coma (Carvallo,Carlos)

Combinar texto y números de distintas columnas

Para combinar el texto y los números, use la función CONCATENAR, el operador "y" comercial (&) o la función TEXTO y el operador "y" comercial.

Columna1

Columna2

Fórmula

Descripción (resultado)

Yang

28

=[Columna1]&" vendió "&[Columna2]&" unidades."

Combina el contenido anterior en una frase (Yang vendió 28 unidades.)

Dubois

40%

=[Columna1]&" vendió el "&TEXTO([Columna2],"0%")&" del total de ventas."

Combina el contenido anterior en una frase (Dubois vendió el 40% del total de ventas.)

Nota: La función TEXTO anexa el valor con formato de Columna2 en lugar del valor subyacente, que es .4.

Yang

28

=CONCATENAR([Columna1]," vendió ",[Columna2]," unidades.")

Combina el contenido anterior en una frase (Yang vendió 28 unidades.)

Combinar texto con una fecha u hora

Para combinar el texto con una fecha u hora, use la función TEXTO y el operador "y" comercial (&).

Columna1

Columna2

Fórmula

Descripción (resultado)

Fecha de facturación

5-Jun-2007

="Fecha de la declaración: "&TEXTO([Columna2], "d-mmm-aaaa")

Combina el texto con una fecha (Fecha de la declaración: 5-Jun-2007)

Fecha de facturación

5-Jun-2007

=[Columna1]&" "&TEXTO([Columna2], "mmm-dd-aaaa")

Combina el texto y la fecha de columnas diferentes en una columna (Fecha de facturación Jun-05-2007)

Comparar el contenido de las columnas

Para comparar una columna con otra o una lista de valores, use las funciones IGUAL y O.

Columna1

Columna2

Fórmula

Descripción (resultado posible)

BD122

BD123

=IGUAL([Columna1],[Columna2])

Compara el contenido de las dos primeras columnas (No)

BD122

BD123

=IGUAL([Columna1], "BD122")

Compara el contenido de Columna1 y de la cadena "BD122" (Sí)

Comprobar si un valor de la columna o una parte del mismo coincide con un texto específico

Para comprobar si el valor de una columna o una parte concuerda con texto concreto, use las funciones SI, ENCONTRAR, HALLAR o ESNUMERO.

Columna1

Fórmula

Descripción (resultado posible)

Trujillo

=SI([Columna1]="Trujillo", "Correcto", "Incorrecto")

Comprueba si Columna1 es Trujillo (Correcto)

Trujillo

=SI(ESNUMERO(ENCONTRAR("t",[Columna1])), "Correcto", "Incorrecto")

Comprueba si Columna1 contiene la letra t (Correcto)

BD123

=ESNUMERO(ENCONTRAR("BD",[Columna1]))

Comprueba si Columna1 contiene BD (Sí)

Contar columnas no vacías

Para contar las columnas que no están en blanco, use la función CONTARA.

Columna1

Columna2

Columna3

Fórmula

Descripción (resultado)

Ventas

19

=CONTARA([Columna1], [Columna2])

Cuenta el número de columnas que no están en blanco (2)

Ventas

19

=CONTARA([Columna1], [Columna2], [Columna3])

Cuenta el número de columnas que no están en blanco (2)

Quitar caracteres de un texto

Para quitar caracteres del texto, use las funciones LARGO, IZQUIERDA y DERECHA.

Columna1

Fórmula

Descripción (resultado)

Vitamina A

=IZQUIERDA([Columna1],LARGO([Columna1])-2)

Devuelve 8 (10-2) caracteres, comenzando por la izquierda (Vitamina)

Vitamina B1

=DERECHA([Columna1], LARGO([Columna1])-9)

Devuelve 2 (11-9) caracteres, comenzando por la derecha (B1)

Eliminar los espacios del principio y el final de una columna

Para quitar los espacios de una columna, use la función ESPACIOS.

Columna1

Fórmula

Descripción (resultado)

¡Hola por ahí!

=ESPACIOS([Columna1])

Quita los espacios del principio y el final (¡Hola por ahí!)

Repetir un carácter en una columna

Para repetir un carácter de una columna, use la función REPETIR.

Fórmula

Descripción (resultado)

=REPETIR(".",3)

Repite un punto 3 veces (...)

=REPETIR("-",10)

Repite un guión 10 veces (----------)

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×