Documentar e imprimir el diseño de la base de datos

Documentar e imprimir el diseño de la base de datos

Microsoft Access le ayuda a preparar la documentación impresa del diseño de su base de datos, que podrá usar para planear y consultar sin conexión. En concreto, con Access puede imprimir las relaciones entre tablas como se muestran en la ventana Relaciones y las características de diseño de objetos de base de datos, como las propiedades de objeto.

Nota: La ventana Relaciones no está disponible en una base de datos o aplicación web.

¿Qué desea hacer?

Preparar la ventana Relaciones para imprimir

Imprimir la ventana Relaciones

Imprimir las características de diseño de los objetos de base de datos con el documentador de base de datos

Preparar la ventana Relaciones para imprimir

La ventana Relaciones es una ventana en la que puede ver, crear y editar relaciones entre tablas y consultas. Según el modo en que la configure, la ventana Relaciones no siempre muestra todas las relaciones en la base de datos. Debe decidir qué relaciones desea documentar, y preparar la ventana Relaciones en consecuencia, antes de imprimir las relaciones entre tablas. Se pueden mostrar u ocultar las tablas en la ventana Relaciones y se puede reorganizar su diseño.

Mostrar u ocultar una tabla en la ventana Relaciones

  1. En la pestaña Herramientas de base de datos, haga clic en Relaciones.

  2. Siga uno de estos procedimientos:

    • Para mostrar una tabla, en la pestaña Diseño del grupo Relaciones, haga clic en Mostrar tabla y, luego, en el cuadro de diálogo Mostrar tabla, agregue la tabla que desee.

    • Para ocultar una tabla, en la ventana Relaciones haga clic en la tabla que desea ocultar y, a continuación, presione la tecla SUPR.

  3. Presione CTRL+G para guardar los cambios.

Reorganizar las tablas en la ventana Relaciones

  1. Para reorganizar las tablas, arrástrelas a las posiciones que desee en la ventana Relaciones.

  2. Presione CTRL+G para guardar los cambios.

Imprimir la ventana Relaciones

Puede crear un informe en el que se muestren las relaciones en su base de datos tal y como aparecen en la ventana Relaciones. Este informe tiene el nombre predeterminado Relaciones de nombre de la base de datos. De forma predeterminada, el encabezado del informe contiene el nombre y la fecha en que se creó el informe.

Nota: La vista previa de impresión no ofrece una buena forma de editar el informe de relación. Debe asegurarse de que la ventana Relaciones se vea de la manera deseada antes de generar el informe.

  1. Abra la base de datos de Access que tiene las relaciones que desea imprimir.

  2. En la pestaña Herramientas de base de datos, haga clic en Relaciones.

  3. En la pestaña Diseño, en el grupo Herramientas, haga clic en Informe de relación.

    Se abrirá en modo de vista previa un informe que muestra la ventana Relaciones.

  4. Para ajustar el modo en que se imprimirá el informe, use los comandos de la pestaña Vista previa de impresión.

  5. En la pestaña Vista previa de impresión, en el grupo Imprimir, haga clic en Imprimir.

Imprimir las características de diseño de los objetos de la base de datos

Puede usar el Documentador de base de datos para imprimir las características de diseño de los objetos de base de datos.

  1. Abra la base de datos que quiera documentar.

  2. En la pestaña Herramientas de base de datos, en el grupo Analizar, haga clic en Documentador de base de datos.

  3. En el cuadro de diálogo Documentador, haga clic en la pestaña que representa el tipo de objeto de base de datos que desea documentar. Para crear un informe de todos los objetos de una base de datos, haga clic en la pestaña Todo tipo de objetos.

  4. Seleccione uno o varios de los objetos que se muestran. Para seleccionarlos todos, haga clic en Seleccionar todo.

  5. Haga clic en Aceptar.

    El Documentador de base de datos crea un informe con datos detallados de cada objeto seleccionado y lo abre en Vista previa de impresión. Por ejemplo, si ejecuta el Documentador de base de datos en un formulario de entrada de datos, el informe que cree detallará las propiedades del formulario como un todo, las propiedades de cada una de las secciones del formulario y las propiedades de todos los botones, etiquetas, cuadros de texto y otros controles del formulario, además de todos los módulos de código y permisos de usuario que estén asociados al formulario.

  6. En la pestaña Vista previa de impresión, en el grupo Imprimir, haga clic en Imprimir.

Volver al principio

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×