Dividir una base de datos de Access

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Considere la posibilidad de dividir una base de datos que compartan varias personas a través de una red. Si lo hace, puede mejorar el rendimiento de la base de datos y reducir el riesgo de que se dañe el archivo de base de datos.

Una vez que haya dividido la base de datos, puede optar entre mover la base de datos back-end o usar una base de datos back-end diferente. Puede usar el Administrador de tablas vinculadas para modificar la base de datos back-end que use.

Notas: 

  • Dividir una base de datos no es lo mismo que archivarla. En este tema no se explica cómo archivar datos. Los datos se archivan regularmente moviendo registros antiguos a una base de datos diferente, bien porque el archivo de base de datos aumente rápidamente de tamaño hasta el máximo permitido para el archivo, bien porque quiera reducir el tamaño del archivo de base de datos y mantener los datos bien organizados por un período de tiempo. En algunas circunstancias, es posible archivar datos dividiendo una base de datos. Para obtener más información, vea el artículo en línea Archivar datos de Access.

  • Si divide una base de datos web, las tablas web que contenga se moverán a la base de datos back-end y no estarán accesibles desde la base de datos front-end resultante.

En este artículo

Información general

Antes de empezar

Dividir la base de datos

Distribuir la base de datos front-end

Cambiar la base de datos back-end que va a usar

Información general

Cuando una base de datos se divide, esta se reorganiza en dos archivos: una base de datos back-end que contiene las tablas de datos y una base de datos front-end que contiene el resto de objetos de la base de datos, como consultas, formularios e informes. Cada usuario interactúa con los datos usando una copia local de la base de datos front-end.

Las bases de datos se dividen con el asistente Divisor de base de datos. Una vez dividida, deberá distribuir la base de datos front-end a los usuarios.

Precaución:  Para proteger sus datos si la base de datos tiene varios usuarios finales, se recomienda que no se comparten copias de una base de datos que contiene vínculos a listas de SharePoint. Si crea un vínculo a una tabla que se muestra una lista de SharePoint, crea una posibilidad de que cualquier usuario malintencionado cambiar el destino del vínculo y posiblemente modificar permisos en el sitio de SharePoint como la información de conexión para las tablas vinculadas está cifrada.

Ventajas de dividir una base de datos

Dividir una base de datos reporta las siguientes ventajas:

  • Mejor rendimiento    El rendimiento de la base de datos suele mejorar notablemente, ya que únicamente se envían los datos a través de la red. En una base de datos compartida que no está dividida, no solo se envían los datos a través de la red, sino también los propios objetos de base de datos (tablas, consultas, informes, macros y módulos).  

  • Mayor disponibilidad    Como solo se envían datos a través de la red, las transacciones de la base de datos (como modificar registros) son más rápidas y, por tanto, los datos están más tiempo disponibles para poder modificarlos.

  • Seguridad mejorada    Si la base de datos back-end que se guarda en un equipo que usa el sistema de archivos NTFS, puede usar las características de seguridad NTFS para ayudar a proteger los datos. Debido a los usuarios acceso a la base de datos back-end mediante tablas vinculadas, es menos probable que algún intruso obtenga acceso no autorizado a los datos mediante robo de la base de datos front-end o que se identifica como un usuario no autorizado. Si no está seguro de qué sistema de archivos usa el servidor de archivos, pida al administrador del sistema. Si tiene privilegios de administrador en el servidor de archivos, puede ejecutar el comando msinfo32 para determinar el sistema de archivos usted mismo.

    ¿Cómo se usa msinfo32 para comprobar el sistema de archivos?

    1. Haga clic en el botón Inicio y, después, en Ejecutar.

    2. En el cuadro de diálogo Ejecutar, escriba msinfo32 y, después, haga clic en Aceptar.

    3. En Resumen del sistema, haga clic en el signo más situado junto a Componentes.

    4. En Componentes, haga clic en el signo más situado junto a Almacenamiento y luego haga clic en Unidades. El cuadro de diálogo muestra información sobre las unidades disponibles en el panel de la derecha.

  • Mayor confiabilidad    Si la base de datos se cierra inesperadamente debido a un problema, el único archivo dañado es, por lo general, la copia de la base de datos front-end que el usuario tenía abierta. Como el usuario tiene acceso únicamente a los datos de la base de datos back-end mediante tablas vinculadas, hay muchas menos probabilidades de que el archivo de la base de datos back-end resulte dañado.

  • Entorno de desarrollo flexible    Puesto que cada usuario trabaja con una copia local de la base de datos front-end, cada uno de ellos puede generar consultas, formularios, informes y otros objetos de base de datos de forma independiente y sin que los demás usuarios resulten afectados. De modo similar, es posible desarrollar y distribuir una nueva versión de la base de datos front-end sin interrumpir el acceso a los datos almacenados en la base de datos back-end.

Principio de página

Antes de empezar

Antes de dividir una base de datos, tenga en cuenta lo siguiente:

  • Debe hacer siempre una copia de seguridad de la base de datos antes de dividirla. Si divide una base de datos y después decide que no era eso lo que quería, puede restaurar el original a partir de la copia de seguridad.

  • La división de una base de datos puede ser un proceso largo. Deberá notificar a los usuarios para que no usen la base de datos mientras se divide; si alguno lo hace, los cambios no se reflejarán en la base de datos back-end.

    Sugerencia: Si un usuario cambia los datos mientras divide la base de datos, puede importar los nuevos datos a la base de datos back-end cuando termine de dividirla.

  • Aunque la división de una base de datos constituye una forma de compartir datos, todos los que usen la base de datos deben tener una versión de Microsoft Office Access que sea compatible con el formato de archivo de la base de datos back-end. Por ejemplo, si el archivo de base de datos back-end usa el formato de archivo .accdb, los usuarios no podrán acceder a los datos a través de Access 2003.

  • Desea usar un formato de archivo anterior de Access para la base de datos back-end si usa características que ya no son compatibles. Por ejemplo, si usa páginas de acceso a datos (DAP); aún puede usarlas si la base de datos back-end está en un formato de archivo que admita DAP. A continuación, puede usar el nuevo formato de archivo con la base de datos front-end para que los usuarios tengan acceso a las ventajas del nuevo formato. Tenga en cuenta que no puede cambiar los datos en una página de acceso a datos mediante Access 2010 o posterior.

Principio de página

Dividir la base de datos

  1. Haga una copia de la base de datos que desea dividir en el equipo. Empiece por el archivo de base de datos almacenado en la unidad de disco duro local, no en el recurso compartido de red. Si el archivo de base de datos se comparte actualmente desde la unidad de disco duro local, puede dejarla donde está.

  2. Abra la copia de la base de datos que se encuentra en la unidad de disco duro local.

  3. En la ficha Herramientas de base de datos, en el grupo Mover datos, haga clic en Base de datos de Access. Se inicia el asistente Divisor de base de datos.

  4. Haga clic en Dividir base de datos.

  5. En el cuadro de diálogo Crear una base de datos back-end, escriba un nombre, un tipo de archivo y una ubicación para el archivo de base de datos back-end.

    Notas: 

    • Considere la posibilidad de usar el nombre propuesto por Access: se conserva el nombre de archivo original y, además, pone de manifiesto que la base de datos es una base de datos back-end al insertar _be en el nombre, justo delante de la extensión de nombre de archivo.

    • No cambie el tipo de archivo a no ser que algunos usuarios vayan a usar una versión anterior de Access para acceder a los datos.

    • Puede especificar la ruta de acceso a la ubicación de red en el cuadro Nombre de archivo, delante del nombre de archivo. Por ejemplo, si la ubicación de red de la base de datos back-end es \\servidor1\recursoCompartido1\ y el nombre de archivo de la base de datos back-end es MiBD_be.accdb, puede escribir \\servidor1\recursoCompartido1\MiBD_be.accdb en el cuadro Nombre de archivo.

    • La ubicación que elija debe estar disponible para todos aquellos que vayan a usar la base de datos. Como las asignaciones de unidades pueden cambiar, deberá especificar la ruta de acceso UNC de la ubicación en lugar de una letra de unidad asignada.

  6. Cuando el asistente finaliza, muestra un mensaje de confirmación.

La base de datos ya está dividida. La base de datos front-end es el archivo con el que inició el proceso (la copia de la base de datos compartida original) y la base de datos back-end se encuentra en la ubicación de red que especificó en el paso 5 de este procedimiento.

Restringir los cambios en el diseño de la base de datos front-end

Para limitar los cambios en la base de datos front-end que distribuya, puede guardarla como un archivo binario compilado (archivo .accde). Un archivo binario compilado es un archivo de aplicación de base de datos que se ha guardado con todo el código de Visual Basic Access (VBA) compilado. No queda nada de código fuente VBA en un archivo de este tipo. Los usuarios no pueden cambiar el diseño de los objetos en un archivo .accde.

  1. Abra el archivo de base de datos front-end (archivo .accdb) que quiera guardar como un archivo binario compilado (.accde).

  2. Haga clic en Archivo > Guardar como > Crear ACCDE > Guardar como.

    Si usa Access 2007, en la ficha Herramientas de base de datos, en el grupo Herramientas de base de datos, haga clic en Crear ACCDE.

  3. En el cuadro de diálogo Guardar como, vaya a la carpeta donde desea guardar el archivo, escriba un nombre para el archivo en el cuadro Nombre de archivo y, a continuación, haga clic en Guardar.

Principio de página

Distribuir la base de datos front-end

Después de dividir la base de datos, hay que distribuir la base de datos front-end a los usuarios para que puedan empezar a usarla.

Precaución:  Para proteger sus datos si la base de datos tiene varios usuarios finales, se recomienda que no se comparten copias de una base de datos que contiene vínculos a listas de SharePoint. Si crea un vínculo a una tabla que se muestra una lista de SharePoint, crea una posibilidad de que cualquier usuario malintencionado cambiar el destino del vínculo y posiblemente modificar permisos en el sitio de SharePoint como la información de conexión para las tablas vinculadas está cifrada.

Realice uno de los siguientes procedimientos:

  • Envíe un mensaje de correo electrónico a los usuarios de la base de datos front-end y adjunte el archivo de base de datos front-end en el mensaje. Incluya instrucciones que ayuden a los usuarios a empezar a usar la base de datos front-end inmediatamente.

  • Guarde el archivo de base de datos front-end en una ubicación de red a la que tengan acceso todos los usuarios de la base de datos y, tras ello, envíeles un mensaje de correo electrónico en el que se especifique la ubicación de red junto con otras instrucciones que puedan ser necesarias para acceder a la base de datos.

  • Distribuya el archivo de base de datos front-end en un medio extraíble, como un CD-ROM o un dispositivo USB. Si instala el archivo personalmente, puede probarlo para confirmar que funciona. Si los usuarios deben instalar el archivo, debe incluir un documento en el que se explique lo que deben hacer para instalar el archivo y la persona con la que deben ponerse en contacto si surge algún problema.

Principio de página

Cambiar la base de datos back-end que va a usar

Puede mover la base de datos back-end o usar una distinta mediante el Administrador de tablas vinculadas.

Si desea mover la base de datos back-end, cópiela primero en la nueva ubicación y, después, haga lo siguiente:

  1. En el grupo Herramientas de base de datos de la pestaña Herramientas de base de datos, haga clic en Administrador de tablas vinculadas.

    Si usa Access 2007, en la ficha Herramientas de base de datos, en el grupo Herramientas de base de datos, haga clic en Administrador de tablas vinculadas.

  2. En el Administrador de tablas vinculadas, seleccione las tablas que haya en la base de datos back-end actual.

    Sugerencia: Si no ha establecido vínculos a otras bases de datos, haga clic en Seleccionar todo.

  3. Active la casilla Preguntar siempre por la nueva ubicación y haga clic en Aceptar.

  4. Vaya a la nueva base de datos back-end y selecciónela.

Principio de página

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×