Definir el origen de registros de un informe

Definir el origen de registros de un informe

Para elegir el origen de los datos de un informe, abra el informe en la vista Presentación y presione Alt + Entrar para abrir la hoja de propiedades. Haga clic en el cuadro que hay justo debajo de la pestaña de objeto del informe para seleccionar todo el informe y, tras ello, en la pestaña Datos de la hoja de propiedades, haga clic en Origen del registro para seleccionar la propiedad. Después puede definir el origen del registro escogiendo un elemento de la lista o haciendo clic en el botón Generar Imagen del botón para abrir la vista de diseño de la consulta, donde podrá crear el origen del registro como del mismo modo que una consulta.

El origen del registro de un informe determina los campos de la base de datos que se pueden mostrar en el informe. En una base de datos relacional, los datos relacionados suelen estar dispersos entre varias tablas; así, por ejemplo, la información sobre los clientes se almacena en una tabla y la relativa a los pedidos, en otra. Los informes constituyen un modo muy flexible de “volver a ensamblar” los datos y mostrarlos exactamente del modo deseado. Además, se pueden optimizar para imprimirlos. Para más información sobre los orígenes de registro de los informes, lea el resto del artículo. Para obtener información general sobre los informes, vea el artículo Introducción a los informes en Access.

Nota: Este artículo no se hace extensivo a las aplicaciones de Access, el tipo de base de datos que se diseña con Access y se publica en línea. Vea Crear una aplicación de Access para más información.

En este artículo

Tipos de orígenes de registro diferentes

Tabla

Consulta con nombre

Consulta incrustada

Modo en que las herramientas de informe crean orígenes del registro

Trabajar con orígenes del registro

Convertir un origen del registro en una consulta incrustada

Método 1: Hacer clic en el botón Generar

Método 2: Agregar un campo de una tabla relacionada mediante la lista de campos

Método 3: Copiar y pegar SQL de una consulta con nombre

Método 4: Copiar y pegar SQL de otro formulario o informe

Modificar una consulta incrustada

Guardar una consulta incrustada como una consulta con nombre

Tipos de orígenes de registro diferentes

Tabla

Si todos los campos que necesita se encuentran en una sola tabla, puede usarla como origen del registro del informe. Pero, si están repartidos en dos o más tablas, necesitará cerciorarse de que las tablas se pueden combinar lógicamente según un valor común y, después, crear una consulta con nombre o una consulta incrustada para que haga de origen del registro.

Consulta con nombre

Una consulta con nombre (que suele llamarse, sencillamente, consulta) es una consulta que se ha guardado como un objeto de base de datos. Una consulta con nombre se puede usar como origen del registro de varios formularios o informes. No obstante, los cambios de diseño que haga en ella afectarán a todos los formularios e informes que la usen como origen del registro. Es más, es relativamente fácil eliminar este tipo de consultas, lo cual inutilizaría cualquier formulario o informe que la use.

Consulta incrustada

Una consulta incrustada es una consulta que se almacena en la propiedad Origen del registro de otro objeto. Dado que una consulta incrustada no es un objeto independiente, es menos probable que inutilice un informe si la elimina o modifica por error. Recomendamos crear este tipo de consulta si quiere que la consulta esté dedicada exclusivamente al informe (dicho de otro modo, no quiere compartirla con otros objetos).

Las consultas incrustadas se crean de forma predeterminada al usar las herramientas Diseño de informe, Informe en blanco o Etiquetas, en las que nos detendremos en la siguiente sección. Las consultas incrustadas también se crean mediante el Asistente para informes, siempre y cuando se seleccionen datos de más de una tabla para el informe. Si solo los selecciona de una tabla, el asistente enlaza el informe directamente a ella.

Puede crear una consulta incrustada también si copia la instrucción SQL de una consulta con nombre abierta en la vista SQL y la pega en la propiedad Origen del registro de un informe. Para abrir una consulta con nombre en la vista SQL:

  1. Haga clic con el botón secundario en la consulta en el panel de navegación y, después, haga clic en Vista Diseño.

  2. En el grupo Resultados de la pestaña Diseño, haga clic en Ver y, después, en Vista SQL.

Volver al principio

Modo en que las herramientas de informe crean orígenes del registro

Para crear un informe en Access, hay que hacer clic en una de las herramientas del grupo Informes de la pestaña Crear. Según cómo use las herramientas, cada una de ellas creará uno de los tres tipos de origen del registro descritos en la sección anterior.

En la siguiente tabla se describe lo que hace cada herramienta de informe y qué tipos de origen del registro se crea de manera predeterminada.

Herramienta

Descripción

Tipo de origen del registro predeterminado

Informe

Crea un informe sencillo y tabular que contiene todos los campos en el origen de datos.

Tabla o consulta con nombre, que debe seleccionar en el panel de navegación antes de hacer clic en la herramienta.

Diseño de informe

Abre un informe en blanco en la vista Diseño, al que se pueden agregar exclusivamente los campos y controles que quiera.

Consulta incrustada, si arrastra campos del panel de tareas Lista de campos al informe. También puede seleccionar una tabla o consulta con nombre en la lista desplegable Origen del registro de la hoja de propiedades.

Informe en blanco

Abre un informe en blanco en la vista Presentación y muestra el panel de tareas Lista de campos. Al arrastrar campos de la Lista de campos al informe, Access crea una consulta incrustada y la almacena en la propiedad Origen del registro del informe.

Consulta incrustada, si arrastra campos del panel de tareas Lista de campos al informe. También puede seleccionar una tabla o consulta con nombre en la lista desplegable Origen del registro de la hoja de propiedades.

Asistente para informes

Muestra un asistente de varios pasos que permite especificar campos, niveles de ordenación y agrupación, así como opciones de diseño. Este asistente crea un informe en función de las selecciones realizadas.

Consulta incrustada, si selecciona campos de más de una tabla. Si solo los selecciona de una tabla, Access la usará como el origen del registro.

Etiquetas

Muestra un asistente que permite seleccionar tamaños de etiqueta personalizados o estándar, así como los campos que se van a mostrar y la forma en que se van a almacenar. Este asistente crea una etiqueta en función de las selecciones realizadas.

Tabla o consulta con nombre, que debe seleccionar antes de hacer clic en la herramienta.

Nota: Las herramientas Diseño de informe, Asistente para informes y Etiquetas crean informes de “cliente”, que no son compatibles con las bases de datos web. Para más información sobre las bases de datos web, vea el artículo sobre cómo modificar o publicar un sitio de base de datos web en SharePoint.

Volver al principio

Trabajar con orígenes del registro

Convertir un origen del registro en una consulta incrustada

Cualquier informe que esté enlazado a una tabla o consulta con nombre se puede modificar para enlazarlo a una consulta incrustada. Tal y como hemos dicho antes, esto hace que la base de datos sea más fácil de mantener, ya que los informes son más autónomos, menos dependientes de otros objetos. Según cuál sea el tipo de origen del registro actual, use uno de los siguientes métodos para convertirlo en una consulta incrustada:

Método 1: Hacer clic en el botón Generar

Si la propiedad Origen del registro es un nombre de tabla, puede hacer clic en el botón General del cuadro de dicha propiedad para crear rápidamente una consulta incrustada.

  1. En el panel de navegación, haga clic con el botón secundario en el informe que quiera modificar y, después, haga clic en Vista Presentación.

  2. Haga clic con el botón secundario en cualquier parte del informe y haga clic en Propiedades del informe.

  3. En la pestaña Todo, haga clic en el cuadro de la propiedad Origen del registro y, después, haga clic en el botón Generar Imagen del botón .

  4. Access preguntará si quiere crear una consulta basada en la tabla. Haga clic en para continuar.

    Access abre el Generador de consultas y agrega la tabla que había en principio en la propiedad Origen del registro.

  5. Agregue campos a la cuadrícula de la consulta; para ello, haga doble clic en cada nombre de campo que quiera ver en el informe. Deberá hacer esto con cada uno de los campos que quiera agregar.

  6. Para agregar campos de consultas o tablas relacionadas:

    1. En el grupo Configuración de consultas de la pestaña Diseño, haga clic en Mostrar tabla.

    2. En el cuadro de diálogo Mostrar tabla, seleccione la tabla o consulta que quiera agregar y haga clic en Agregar.

    3. Haga clic en Finalizar para cerrar el cuadrode diálogo.

    4. Asegúrese de que las tablas y consultas que agregue se combinan de forma lógica. Por ejemplo, el campo Id. de la tabla Clientes probablemente tenga una línea de combinación que lo conecte al campo Id. de cliente de la tabla Pedidos. Puede crear líneas de combinación arrastrando un nombre de campo de una tabla o consulta al nombre de campo de otra tabla o consulta.

      Para más información sobre cómo crear consultas, vea el artículo Introducción a las consultas.

    5. Agregue campos a la cuadrícula de la consulta; para ello, haga doble clic en cada nombre de campo que quiera ver en el informe. Deberá hacer esto con cada uno de los campos que quiera agregar.

  7. Para comprobar la consulta:

    1. En el grupo Resultados de la pestaña Diseño, haga clic en Ver y, después, en Vista Hoja de datos.

    2. Para volver a la vista Diseño, en el grupo Resultados de la pestaña Diseño, haga clic en Ver y, después, en Vista Diseño.

  8. Cuando la consulta devuelva los datos que quiera incluir en el informe, haga clic en Cerrar en el grupo Cerrar de la pestaña Diseño.

  9. Haga clic en para guardar los cambios realizados en la instrucción SQL y actualizar la propiedad.

Nota: Si la nueva consulta no contiene todos los campos que se usaron en el informe, Access le pedirá que indique un valor de parámetro por cada campo que falte. Puede eliminar la referencia al campo en el informe, o bien usar el procedimiento descrito en Modificar una consulta incrustada para agregar a la consulta los campos que falten.

Método 2: Agregar un campo de una tabla relacionada mediante la lista de campos

  1. En el panel de navegación, haga clic con el botón secundario en el informe que quiera modificar y, después, haga clic en Vista Presentación.

  2. Si no se muestra el panel de tareas Lista de campos, en el grupo Herramientas de la pestaña Diseño, haga clic en Agregar campos existentes.

  3. Si Mostrar todas las tablas aparece en la parte superior de la lista de campos, haga clic en él para ver los campos de las tablas relacionadas y de otras tablas.

  4. En Campos disponibles en tablas relacionadas, expanda una tabla y arrastre uno de sus campos al informe.

    Access cambia el origen del registro por una consulta incrustada que contiene el campo agregado. Puede seguir agregando campos de este modo o modificar la consulta incrustada realizando el procedimiento de descrito en Modificar una consulta incrustada.

Método 3: Copiar y pegar SQL de una consulta con nombre

  1. En el panel de navegación, haga clic con el botón secundario en la consulta que contiene la instrucción SQL que quiera copiar y, después, haga clic en Vista Diseño.

  2. En el grupo Vistas de la pestaña Inicio, haga clic en Vista y, después, en Vista SQL.

  3. Copie el texto en el panel SQL y cierre la consulta sin guardar los cambios.

  4. En el panel de navegación, haga clic con el botón secundario en el informe al que quiera agregar la consulta incrustada y, después, haga clic en Vista Presentación.

  5. Si no se muestra la hoja de propiedades, presione F4.

  6. En la pestaña Todo, seleccione el texto que haya en la propiedad Origen del registro y presione CTRL+V para pegar la instrucción SQL en el cuadro de la propiedad.

Nota: Si la nueva consulta no contiene todos los campos que se usaron en el informe, Access le pedirá que indique un valor de parámetro por cada campo que falte. Puede eliminar la referencia al campo en el informe, o bien usar el procedimiento descrito en Modificar una consulta incrustada para agregar a la consulta los campos que falten.

Método 4: Copiar y pegar SQL de otro formulario o informe

Puede copiar una consulta incrustada directamente desde la propiedad Origen del registro de un objeto a otro. Así, si hay otro formulario o informe que contiene una consulta incrustada que devuelve los datos deseados, será fácil reutilizarla en el informe en el que esté trabajando.

  1. En el panel de navegación, haga clic con el botón secundario en el formulario o informe que contiene la instrucción SQL incrustada que quiera copiar y, después, haga clic en Vista Presentación.

  2. Haga clic con el botón secundario en cualquier parte del formulario o informe y, después, haga clic en Propiedades del formulario o Propiedades del informe.

  3. En la pestaña Todo, seleccione todo el texto de la instrucción SQL en el cuadro de la propiedad Origen del registro y presione CTRL+C para copiarla.

  4. Cierre el formulario o informe sin guardar los cambios.

  5. En el panel de navegación, haga clic con el botón secundario en el informe al que quiera agregar la consulta incrustada y, después, haga clic en Vista Presentación.

  6. Haga clic con el botón secundario en cualquier parte del informe y haga clic en Propiedades del informe.

  7. En la pestaña Todo, seleccione el texto que haya en la propiedad Origen del registro y presione CTRL+V para pegar la instrucción SQL en el cuadro de la propiedad.

Nota: Si la nueva consulta no contiene todos los campos que se usaron en el informe, Access le pedirá que indique un valor de parámetro por cada campo que falte. Puede eliminar la referencia al campo en el informe, o bien usar el siguiente procedimiento (Modificar una consulta incrustada) para agregar a la consulta los campos que falten.

Modificar una consulta incrustada

A medida que la base de datos va aumentando, es posible que necesite modificar el origen del registro de un informe (por ejemplo, para agregarle más campos). Use este procedimiento para abrir el origen del registro en el Generador de consultas:

  1. En el panel de navegación, haga clic con el botón secundario en el informe que contiene la consulta incrustada que quiera modificar y, después, haga clic en Vista Presentación.

  2. Haga clic con el botón secundario en cualquier parte del informe y haga clic en Propiedades del informe.

  3. En la pestaña Todo, haga clic en el cuadro de la propiedad Origen del registro y, después, haga clic en el botón Generar Imagen del botón .

    Access abre la consulta en el Generador de consultas.

  4. Modifique la consulta como crea necesario y, después, haga clic en Cerrar en el grupo Cerrar de la pestaña Diseño.

  5. Haga clic en para guardar los cambios y actualizar la propiedad.

    Access cierra el Generador de consultas. Todos los cambios que efectúe en el Generador de consultas se reflejará en la instrucción SQL de la propiedad Origen del registro.

Para más información sobre cómo crear consultas, consulte el artículo Introducción a las consultas.

Guardar una consulta incrustada como una consulta con nombre

Puede darse cuenta de que la consulta incrustada que actúa como origen del registro de un informe podría servir también para otros fines. En tal caso, se puede guardar como una consulta con nombre y, así, pasar a estar disponible para que otros objetos puedan usarla.

  1. En el panel de navegación, haga clic con el botón secundario en el informe que contiene la consulta incrustada y, después, haga clic en Vista Presentación.

  2. Haga clic con el botón secundario en cualquier parte del informe y haga clic en Propiedades del informe.

  3. En la pestaña Todo, haga clic en el cuadro de la propiedad Origen del registro y, después, haga clic en el botón Generar Imagen del botón .

    Access abre la consulta en el Generador de consultas.

  4. En el grupo Cerrar de la pestaña Diseño, haga clic en Guardar como.

  5. En el cuadro de diálogo Guardar como, escriba un nombre de consulta en el cuadro de arriba y, después, haga clic en Aceptar.

    Access guarda la consulta como una consulta con nombre en el panel de navegación.

  1. Haga clic en Cerrar en el grupo Cerrar de la pestaña Diseño.

    Access preguntará si quiere guardar los cambios realizados en la consulta incrustada, aun cuando no haya hecho ninguno. La mayoría de las veces bastará con hacer clic en No para cerrar el Generador de consultas pero, si hizo cambios que quiere ver reflejados en la consulta incrustada del informe, haga clic en .

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×