Crear una relación

Crear una relación

Una relación le ayuda a combinar datos de dos tablas diferentes. En una base de datos de escritorio de Access, puede crear una relación en la ventana relaciones. Crear una relación en una aplicación web de Access es un proceso diferente, como se explica más adelante en crear una relación en una aplicación web de Access.

Contenido

Crear una relación en una base de datos de escritorio de Access

Crear una relación en una aplicación web de Access

Crear una relación en una base de datos de escritorio de Access

  1. En la pestaña Herramientas de base de datos, en el grupo Relaciones, haga clic en Relaciones.

    Comando Relaciones de la pestaña Herramientas de base de datos

  2. Si aún no definió ninguna relación, aparece automáticamente el cuadro de diálogo Mostrar tabla. Si no aparece, en la pestaña Diseño, en el grupo Relaciones, haga clic en Mostrar tabla.

    En el cuadro de diálogo Mostrar tabla se muestran todas las tablas y las consultas de la base de datos. Para ver únicamente las tablas, haga clic en Tablas.

  3. Seleccione una o varias tablas y luego haga clic en Agregar. Cuando termine de agregar tablas, haga clic en Cerrar.

  4. Arrastre un campo (normalmente, la clave principal) de una tabla al campo común (clave externa) de la otra tabla. Para arrastrar varios campos, presione la tecla Ctrl, haga clic en cada uno de los campos y luego arrástrelos.

    Aparece el cuadro de diálogo Modificar relaciones.

    Cuadro de diálogo Modificar relaciones

  5. Compruebe que los nombres de campo que se muestran sean de los campos comunes de la relación. Si un nombre de campo es incorrecto, haga clic en él y seleccione el campo apropiado en la lista.

  6. Para exigir la integridad referencial para esta relación, active la casilla Exigir integridad referencial.

  7. Haga clic en Crear.

  8. Cuando haya terminado en la ventana Relaciones, haga clic en Guardar para guardar los cambios de diseño de la relación.

Access dibuja una línea de relación entre las dos tablas. Si activó la casilla Exigir integridad referencial, la línea aparece más gruesa en los extremos. Además, solo si activó la casilla Exigir integridad referencial, aparece el número 1 en la parte gruesa de un extremo de la línea de relación y el símbolo de infinito () en la parte gruesa del otro extremo de la línea.

Notas: 

  • Para crear una relación uno a uno    Ambos campos comunes (por lo general, los campos de clave principal y clave externa) deben tener un índice único. Esto significa que la propiedad Indexado de estos campos debe estar establecida en Sí (Sin duplicados). Si ambos campos tienen un índice único, Access crea una relación uno a uno.

  • Para crear una relación uno a varios    El campo de un lado (por lo general, la clave principal) de la relación debe tener un índice único. Esto significa que la propiedad Indexado de este campo debe estar establecida en Sí (Sin duplicados). El campo ubicado en el lado varios de la relación no debe tener un índice único. Puede tener un índice, pero debe permitir los duplicados. Esto significa que la propiedad Indexado de este campo debe estar establecida en No o Sí (Con duplicados). Cuando un campo tiene un índice único y el otro no, Access crea una relación uno a varios.

Crear una relación en una aplicación web de Access

La ventana Relaciones no está disponible en una aplicación web de Access. En lugar de crear una relación en una aplicación web de Access, cree un campo de búsqueda que obtiene los valores de un campo relacionado de otra tabla. Por ejemplo, supongamos que tiene una tabla de empleados y desea agregar una búsqueda a una tabla de regiones, por lo que puede mostrar qué cada empleado trabaja en la región.

Nota:  El campo que la búsqueda usará como fuente para los valores ya debe existir antes de crear un campo de búsqueda.

Le mostramos cómo crear un campo de búsqueda en una aplicación web de Access:

  1. Abra la tabla donde desea crear un nuevo campo de búsqueda haciendo doble clic en el panel de navegación. (Sugerencia: necesita haga clic en Inicio > Panel de navegación para ver las tablas disponibles.)

    En el ejemplo anterior, haga clic en la tabla Employees .

  2. Haga clic en la columna Nombre de campo justo debajo del último campo de la tabla y escriba un nombre para el nuevo campo de búsqueda.

    En el ejemplo, escriba región como el nombre del campo.

  3. En la columna Tipo de datos, haga clic en la flecha y seleccione Buscar.

    Configuración del tipo de datos Búsqueda para un campo de búsqueda

    Se inicia el Asistente para búsquedas.

  4. En la primera página del Asistente para búsquedas, seleccione Deseo que el campo de búsqueda obtenga los valores de otra tabla o consulta. Aparecerán más opciones en el cuadro de diálogo.

  5. Seleccione el nombre de la tabla o consulta que debe proporcionar los valores de la búsqueda.

    En el ejemplo, seleccione tabla: regiones.

    Opciones para elegir en Asistente para búsquedas

    (Nombres de las tablas en la imagen se corresponden con el ejemplo que usaremos.)

  6. Después de seleccionar la tabla, utilice la lista qué valor desea mostrar en la búsqueda para seleccionar el campo que desea utilizar como un valor de visualización para el campo de búsqueda. De forma predeterminada, Access selecciona el primer campo de texto que puede encontrar en la tabla seleccionada.

    En el ejemplo, ¿deje el campo seleccionado, título, como el valor de visualización.

  7. Use la lista Desea ordenar los elementos en la búsqueda para establecer la ordenación, si lo desea.

  8. En lo que debe ocurrir cuando un registro de la tabla "Regiones" se elimina, establezca el tipo de relación que desea entre las dos tablas y si desea exigir integridad referencial. (El nombre de la tabla en esta pregunta varía según la tabla seleccionada en el paso 5).

    El Asistente para búsquedas valores predeterminados para impedir que elimine si hay son los registros correspondientes en la tabla "Empleados", ya que es la opción más segura en la mayoría de los casos. En el ejemplo, esta opción significa que no se puede eliminar un valor de la tabla de regiones si esa región se utiliza en los registros de la tabla Employees. Por lo tanto, si los registros de empleados usan una región, como "Oeste" e intenta eliminar "Oeste" de la tabla de regiones, Access impedirá eliminarlo. En este caso, debe restablecer todos los registros de empleados con ese valor a algo más, para poder eliminar "Oeste" de la tabla de regiones. La última opción puede trabajar en este ejemplo, ya le permitirá eliminar "Oeste" de la tabla de regiones. El valor de la región se eliminará automáticamente de los registros de empleados que se establecieron en "Oeste", deje el valor en blanco. Si elige la segunda opción Eliminar todos los registros de empleados de la tabla de empleados que tengan la región establecida en "Oeste". Que denomina una eliminación en cascada y eliminaría mucho más datos que desee en el ejemplo. Tenga cuidado al elegir esta opción.

Para obtener más información sobre los pormenores de las relaciones, vea el artículo crear, modificar o eliminar una relación.

¿Solo quiere conocer conceptos básicos para modificar o eliminar relaciones? Vea estos artículos:

Notas: 

  • Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

  • Para su referencia, puede encontrar la versión en inglés de este artículo aquí. Todos los miembros de la comunidad de Microsoft pueden mejorar este artículo mediante el marco de colaboración en traducciones (CTF). Simplemente, mueva el puntero sobre cualquier frase del artículo y, a continuación, haga clic en "MEJORAR TRADUCCIÓN" en el widget CTF. Haga clic aquí para obtener más información acerca de CTF. Con el uso de CTF, el usuario acepta nuestras Condiciones del servicio.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×