Crear una referencia externa (enlace) a un rango de celdas de otro libro

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede hacer referencia al contenido de las celdas de otro libro mediante la creación de una referencia externa. Una referencia externa (también denominada vínculo) es una referencia a una celda o rango en una hoja de cálculo en otro libro de Excel o una referencia a un nombre definido en otro libro. Puede hacer referencia al rango específico de celdas, un nombre definido para el rango de celdas, o definir un nombre para la referencia externa.

¿Qué desea hacer?

Obtenga más información sobre referencias externas

Crear una referencia externa entre celdas de libros distintos

Crear una referencia externa a un nombre definido en otro libro

Definir un nombre que contiene una referencia externa a las celdas de otro libro

Obtenga más información sobre referencias externas

Aunque las referencias externas se parecen a las referencias de celdas, existen diferencias importantes. Las referencias externas se usan al trabajar con cantidades grandes de datos o fórmulas complejas que se encuentran extendidas por varios libros. Se crean de modo distinto y aparecen de manera distinta en una celda o en la barra de fórmulas.

Dónde pueden utilizarse eficazmente las referencias externas

Las referencias externas son especialmente útiles cuando no resulta práctico mantener juntos en el mismo libro los modelos de hoja de cálculo grandes.

  • Combinar datos de varios libros    Puede vincular libros de varios usuarios o departamentos e integrar los datos pertinentes en un libro de resumen. De este modo, cuando se cambian los libros de origen, no tendrá que cambiar manualmente el libro de resumen.

  • Crear distintas presentaciones de los datos    Pueden insertarse todos los datos en uno o más libros de origen y, a continuación, crear un libro de informe que sólo contenga las referencias externas a los datos pertinentes.

  • Simplificar modelos grandes y complejos    Al dividir un modelo complicado en una serie de libros interdependientes, podrá trabajar en el modelo sin necesidad de abrir todas las hojas relacionadas con él. Los libros de menor tamaño son más fáciles de modificar, no necesitan mucha memoria y se pueden abrir, guardar y calcular con más rapidez.

Métodos para crear referencias externas

Si usa una referencia de celda para crear una referencia externa, a continuación, puede aplicar también fórmulas a la información. Al cambiar entre los distintos tipos de referencia de celda, también puede controlar las celdas que están vinculadas a si mueve la referencia externa. Por ejemplo, si usa una referencia relativa, al mover la referencia externa, la celda o celdas que vínculos cambian para reflejar su nueva posición en la hoja de cálculo.

Cuando se crea una referencia externa de un libro a otro libro, debe usar un nombre para hacer referencia a las celdas que desea vincular. Puede crear una referencia externa utilizando un nombre que ya está definido, o puede definir el nombre cuando se crea la referencia externa. Mediante un nombre, es más fácil de recordar el contenido de las celdas que desea vincular. Referencias externas que utilizan nombres definidos no cambian cuando se mueven, ya que un nombre hace referencia a una celda específica o un rango de celdas. Si desea una referencia externa que usa un nombre definido para cambiar al moverlo, puede cambiar el nombre que se usa en la referencia externa o puede cambiar las celdas que hace referencia el nombre.

Aspecto de una referencia externa a otro libro

Las fórmulas con referencias externas a otros libros se muestran de dos maneras, según el libro de origen, el que proporciona datos a la fórmula, se encuentre abierto o cerrado.

Cuando el libro de origen está abierto, la referencia externa incluye el nombre del libro entre corchetes ([ ]), seguido del nombre de la hoja de cálculo, un signo de exclamación (!) y las celdas de las que depende la fórmula. Por ejemplo, la siguiente fórmula suma las celdas C10:C25 del libro Presupuesto.xls.

Referencia externa

=SUMA([Presupuesto.xlsx]Anual!C10:C25)

Si el libro de origen está cerrado, la referencia externa incluye toda la ruta de acceso.

Referencia externa

=SUMA('C:\Informes\[Presupuesto.xlsx]Anual'!C10:C25)

Nota: Si el nombre de la otra hoja de cálculo o del otro libro contiene caracteres no alfabéticos, se deberá poner el nombre (o la ruta de acceso) entre comillas sencillas.

Las fórmulas vinculadas con un nombre definido en otro libro usan e nombre del libro seguido de un signo de exclamación (!) y el nombre. Por ejemplo, la siguiente fórmula suma las celdas del rango Ventas del libro Presupuesto.xlsx.

Referencia externa

=SUMA(Presupuesto.xlsx!Ventas)

Principio de página

Crear una referencia externa entre celdas de libros distintos

  1. Abra el libro que contendrá la referencia externa (el libro de destino) y el libro que contiene los datos con los que desea establecer el vínculo (el libro de origen).

  2. En el libro de origen, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido.

  3. Seleccione la celda o las celdas en las que desea crear la referencia externa.

  4. Escriba = (signo de igual). Si desea ejecutar cálculos o funciones en el valor de la referencia externa, escriba el operador o la función que debe preceder a la referencia externa.

  5. Cambie al libro de origen y, a continuación, haga clic en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.

  6. Seleccione la celda o las celdas con las que desee establecer el vínculo.

  7. Vuelva al libro de destino y observe que Excel agrega la referencia al libro de origen y a las celdas que seleccionó en el paso anterior.

  8. También puede modificar o cambiar la fórmula en la hoja de cálculo de destino.

  9. Presione CTRL+MAYÚS+ENTRAR.

Principio de página

Crear una referencia externa a un nombre definido en otro libro

  1. Abra el libro que contendrá la referencia externa (el libro de destino) y el libro que contiene los datos con los que desea establecer el vínculo (el libro de origen).

  2. En el libro de origen, haga clic en Guardar Imagen del botón en la barra de herramientas de acceso rápido.

  3. Seleccione la celda o las celdas en las que desea crear la referencia externa.

  4. Escriba signo igual (=). Si desea ejecutar cálculos o funciones en el valor de la referencia externa, escriba el operador o función que debe preceder la referencia externa.

  5. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y después en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.

    El grupo Ventana en la pestaña Vista

  6. Presione F3 y, a continuación, seleccione el nombre con el que desea establecer el vínculo.

Principio de página

Definir un nombre que contiene una referencia externa a las celdas de otro libro

  1. Abra el libro de destino y el libro de origen.

  2. En el libro de destino, en la ficha Fórmulas, en el grupo Nombres definidos, haga clic en Definir nombre.

    Imagen de la cinta de Excel

  3. En el cuadro de diálogo Nombre nuevo, en el cuadro Nombre, escriba un nombre para el rango.

  4. Borre el contenido del cuadro Se refiere a y mantenga el cursor dentro del cuadro.

    Si el nombre contiene una fórmula, escriba la fórmula y, a continuación, coloque el cursor donde desea que la referencia externa. Por ejemplo, escriba = suma()y, a continuación, sitúe el cursor entre los paréntesis.

  5. En la ficha Vista, en el grupo Ventana, haga clic en Cambiar ventanas, en el libro de origen y después en la hoja de cálculo que contiene las celdas con las que desea establecer el vínculo.

    El grupo Ventana en la pestaña Vista

  6. Seleccione la celda o el rango de celdas con las que desea establecer el vínculo.

  7. En el cuadro de diálogo Nombre nuevo, haga clic en Aceptar.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×