Crear una consulta de creación de tabla

En este artículo se explica cómo crear y ejecutar una consulta de creación de tabla. Este tipo de consulta se usa cuando hay que copiar datos a una tabla o almacenarlos.

Para cambiar o actualizar parte de los datos de un conjunto existente de registros, como uno o varios campos, puede usar una consulta de actualización. Para más información, consulte el artículo Crear una consulta de actualización.

Si necesita agregar registros (filas) a una tabla existente, use una consulta de datos anexados. Para más información sobre las consultas de datos anexados, consulte el artículo Crear una consulta de datos anexados.

¿Qué desea hacer?

Las consultas de creación de tabla

Crear una consulta de creación de tabla

Más información sobre los criterios y las expresiones de consulta

Evitar que el modo deshabilitado bloquee una consulta

Las consultas de creación de tabla

Una consulta de creación de tabla recupera datos de una o varias tablas y, a continuación, carga el conjunto de resultados en una nueva tabla. Esa nueva tabla puede residir en la base de datos abierta o puede crearse en otra base de datos.

Normalmente, las consultas de creación de tabla se crean cuando hay que copiar o archivar datos. Por ejemplo, supongamos que tiene una tabla (o tablas) de los datos de ventas pasos y que usa esos datos en informes. Las cifras de ventas no pueden cambiar porque las transacciones tienen al menos un día de antigüedad y la ejecución continuada de una consulta para recuperar los datos puede tardar un tiempo, en especial si se ejecuta una consulta compleja en un almacén de datos de gran tamaño. Cargar los datos en una tabla independiente y usar esa tabla como origen de datos puede reducir la carga de trabajo y proporcionar un archivo de datos útil. Durante el proceso, recuerde que los datos en la nueva tabla son estrictamente una instantánea; no tienen ninguna relación o conexión con su tabla o tablas de origen.

El proceso de creación de una consulta de creación de tabla se compone de los siguientes pasos:

  • Habilite la base de datos si no está firmada o si no reside en una ubicación de confianza. En caso contrario, no podrá ejecutar consultas de acción (consultas de datos anexados, consultas de actualización y consultas de creación de tabla).

  • En la vista Diseño de la consulta, cree una consulta de selección y, a continuación, modifique esa consulta hasta que devuelva los registros que desee. Puede seleccionar datos de más de una tabla y, en términos reales, puede desnormalizar los datos. Por ejemplo, puede incluir los datos de cliente, transportista y proveedor en una sola tabla, lo cual no se hace en una base de datos de producción con tablas correctamente normalizadas. Asimismo, puede usar criterios en la consulta para personalizar o restringir más el conjunto de resultados.

    Para más información sobre normalización de datos, consulte el artículo Conceptos básicos del diseño de una base de datos.

  • Convierta la consulta de selección en una consulta de creación de tabla, elija una ubicación para la nueva tabla y, a continuación, ejecute la consulta para crear la tabla.

No hay que confundir una consulta de creación de tabla con una consulta de actualización o de datos anexados. Puede usar una consulta de actualización cuando necesite agregar o cambiar los datos de campos individuales. Use una consulta de datos anexados cuando necesite agregar registros (filas) a un conjunto de registros existente en una tabla existente.

Para más información sobre las consultas de actualización, consulte el artículo Crear una consulta de actualización. Para más información sobre las consultas de datos anexados, consulte el artículo Crear una consulta de datos anexados.

Principio de página

Crear una consulta de creación de tabla

Para crear una consulta de creación de tabla, cree primero una consulta de selección y, a continuación, conviértala en una consulta de creación de tabla. La consulta de selección puede usar campos calculados y expresiones para ayudar a devolver los datos que necesite. En los siguientes pasos se explica cómo crear y convertir la consulta. Si ya tiene una consulta de selección que se ajuste a sus necesidades, vaya a los pasos descritos para convertir la consulta de selección y ejecutar la consulta de creación de tabla.

Habilitar la base de datos

Nota: Siga estos pasos solo cuando la base de datos no resida en una ubicación de confianza o no está firmada. Access muestra la barra de mensajes cada vez que abra una base de datos que no sea de confianza o que esté sin firmar.

  1. En la barra de mensajes, haga clic en Opciones.

  2. En el cuadro de diálogo Opciones de seguridad de Microsoft Office, haga clic en Habilitar este contenido y después en Aceptar.

Si no ve la barra de mensajes

  • En la pestaña Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

Crear la consulta de selección

Nota: Si ya dispone de una consulta de selección que genere los datos que necesite, vaya a los siguientes pasos.

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

Imagen de la cinta de opciones de Access

  1. En el cuadro de diálogo Mostrar tabla, haga doble clic en las tablas de las que desee recuperar datos. Cada tabla aparece como una ventana en la sección superior del diseñador de consultas. Haga clic en Cerrar cuando termine de agregar tablas.

  2. En cada tabla, haga doble clic en los campos que desee usar en la consulta. Cada campo aparece en una celda en blanco de la fila Campo de la cuadrícula de diseño. Esta figura muestra la cuadrícula de diseño con varios campos de tabla agregados.

    Consulta con tres campos en la cuadrícula de diseño

  3. De manera opcional, agregue expresiones a la fila Campo.

  4. De manera opcional, agregue criterios a la fila Criterios de la cuadrícula de diseño.

  5. Haga clic en Ejecutar Imagen del botón para ejecutar la consulta y mostrar los resultados en una hoja de datos.

  6. De manera opcional, cambie los campos, expresiones o criterios y vuelva a ejecutar la consulta hasta que devuelva los datos que desee incluir en la nueva tabla.

Convertir la consulta de selección

  1. Abra la consulta de selección en la vista Diseño, o bien, cambie a la vista Diseño. Access permite hacerlo de varias maneras:

    • Si la consulta está abierta en una hoja de datos, haga clic con el botón secundario del mouse en la ficha de documentos de la consulta y haga clic en Vista Diseño.

    • Si la consulta está cerrada, en el panel de exploración, haga clic con el botón secundario del mouse en la consulta y haga clic Vista Diseño en el menú contextual.

  2. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Crear tabla.

    Aparecerá el cuadro de diálogo Crear tabla.

  3. En el cuadro Nombre de la tabla, escriba el nombre de la nueva tabla.

    o bien

    Haga clic en la flecha desplegable y seleccione un nombre de tabla existente.

  4. Siga uno de estos pasos:

    • Colocar la nueva tabla en la base de datos activa    

      1. Si aún no está seleccionada la opción Base de datos activa, haga clic en ella y, a continuación, haga clic en Aceptar.

      2. Haga clic en Ejecutar Imagen del botón y después pulse para confirmar la operación.

        Nota: Si está reemplazando una tabla existente, Access elimina primero esa tabla y le pide que confirme su eliminación. Haga clic en y, a continuación, haga de nuevo clic en para crear la nueva tabla.

    • Colocar la nueva tabla en otra base de datos    

      1. Haga clic en Otra base de datos.

      2. En el cuadro Nombre de archivo, escriba la ubicación y el nombre de archivo de la otra base de datos.

        o bien

        Haga clic en Examinar, use el cuadro de diálogo Crear tabla para buscar la otra base de datos y, a continuación, haga clic en Aceptar.

      3. Haga clic en Aceptar para cerrar el primer cuadro de diálogo Crear tabla.

      4. Haga clic en Ejecutar Imagen del botón y después pulse para confirmar la operación.

        Nota: Si está reemplazando una tabla existente, Access elimina primero esa tabla y le pide que confirme su eliminación. Haga clic en y, a continuación, haga de nuevo clic en para crear la nueva tabla.

Principio de página

Obtener más información sobre los criterios y las expresiones de consulta

En este artículo se hace referencia a criterios y expresiones de consulta. Un criterio de consulta es una regla que identifica los registros que el usuario desea incluir en una consulta. Los criterios de consulta se usan cuando no se desea ver todos los registros en un conjunto determinado de datos. Por ejemplo, el criterio >25 Y <50 devuelve valores mayores que 25 y menores que 50. El criterio "Chicago" O "París" O "Moscú" devuelve únicamente los registros correspondientes a esas ciudades.

Para más información sobre cómo usar los criterios, consulte el artículo Ejemplos de criterios de consulta.

Una expresión es una combinación de operadores matemáticos o lógicos, constantes, funciones y nombres de campos, controles y propiedades que se evalúan como un solo valor. Una expresión se usa cuando se requieren datos que no residen directamente en una tabla. Por ejemplo, la expresión [PrecioUnidad]*[Cantidad]] multiplica el valor del campo PrecioUnidad por el valor del campo Cantidad. Las expresiones se pueden usar de formas muy diversas. El proceso de creación y el uso de las expresiones pueden llegar a ser bastante complejos.

Para más información sobre cómo crear y usar las expresiones, consulte el artículo Crear una expresión.

Principio de página

Evitar que el modo deshabilitado bloquee una consulta

De forma predeterminada, si abre una base de datos que no reside en una ubicación de confianza, o bien, si ha elegido no confiar en la base de datos, Access impide la ejecución de todas las consultas de acción: de datos anexados, de actualización, eliminación o creación de tablas.

Si intenta ejecutar una consulta de acción y parece que no sucede nada, compruebe si en la barra de estado de Access aparece el siguiente mensaje:

El modo deshabilitado ha bloqueado la acción o el evento

Si ve ese mensaje, siga este procedimiento:

Habilitar contenido bloqueado

  • En la barra de mensajes, haga clic en Opciones.

    Aparecerá el cuadro de diálogo Opciones de seguridad de Microsoft Office.

  • Haga clic en Habilitar este contenido y, a continuación, en Aceptar.

  • Ejecute la consulta otra vez.

Si no ve la barra de mensajes

  • Haga clic en la pestaña Herramientas de base de datos y, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

Para obtener más información sobre el modo deshabilitado y la seguridad de Access, consulte el artículo Proteger una base de datos de Access 2007.

Principio de página

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×