Crear un modelo de base de datos (también denominado diagrama Relación de entidades)

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Con la plantilla Diagrama de modelo de base de datos, puede crear un nuevo modelo o aplicar ingeniería inversa a una base de datos existente en un modelo utilizando el relacionales o conceptos de modelado relacional de objetos. Use la Galería de símbolos relación de entidades a bases de datos de modelo que se basan en SQL92 y estándares anteriores. Use la Galería de símbolos relacional de objetos, que contiene formas adicionales para trabajar con tipos de bases de datos de modelo que se basan en SQL99 y estándares posteriores.

Mostrar un ejemplo

Este artículo describe cómo crear un modelo de base de datos y qué puede hacer con el modelo después de crearlo. Para el inicio rápido, en el menú archivo, elija nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

No se pueden encontrar las características del modelo de base de datos

Más probable es que la edición de Microsoft Office Visio no incluye las características que está buscando. Para averiguar qué edición de Visio tiene, haga clic en Acerca de Microsoft Office Visio, en el menú Ayuda. Es el nombre de la edición en la línea superior del texto en el cuadro de diálogo.

  • Los estándares de Microsoft Office Visio no incluyen la plantilla Diagrama de modelo de base de datos.

  • Microsoft Office Visio Professional admite las características de ingeniería inversa de la plantilla Diagrama de modelo de base de datos (es decir, utilizar una base de datos existente para crear un modelo en Visio), pero no admite la ingeniería directa (es decir, utilizar un modelo de base de datos de Visio para generar código SQL).

  • Puede encontrar el conjunto completo de base de datos de características de modelado, incluyendo ingeniería inversa y directa en Enterprise de Visio. Enterprise de Visio está incluida en MSDN Premium Subscription, disponible con Visual Studio Professional y ediciones de Visual Studio Team System basado en roles.

  1. Para iniciar su diagrama de modelo de base de datos, siga uno de los procedimientos siguientes:

    Crear un nuevo diagrama de modelo de base de datos desde el principio

    Si no dispone de una base de datos que desee usar como punto de partida, puede empezar con un modelo de base de datos en blanco y agregar sus propias tablas y relaciones.

    1. En el menú Archivo, elija Nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    2. En el menú Base de datos, elija Opciones y, a continuación, Documento.

    3. En el cuadro de diálogo Opciones de documento de base de datos, seleccione el juego de símbolos que desee utiliza, así como las opciones de tabla y de relaciones adicionales y haga clic en Aceptar.

    Usar una base de datos existente como punto de partida

    Si cuenta con una base de datos que desee modelar para que pueda comprenderla mejor o usarla como punto de partida para un nuevo modelo, puede utilizar el Asistente para ingeniería inversa con el fin de extraer el esquema, o estructura, de la base de datos y crear un nuevo modelo.

    Nota: Antes de iniciar el asistente:

    1. Si inversa antes de iniciar al Asistente de ingeniería un libro de Microsoft Office Excel, debe abrir el libro y el nombre del grupo (o rango) de celdas que contiene los encabezados de columna. Si desea usar más de una hoja de cálculo, asigne un nombre al grupo de celdas de la columna en cada hoja de cálculo. Estos rangos se tratan como tablas en el asistente. Para obtener más información sobre cómo asignar un nombre a un rango de celdas, vea el tema de Microsoft Office Excel titulado Definir rangos con nombre referencias de celda o de ayuda.

    2. Para obtener el mejor resultado, configure el controlador predeterminado para la base de datos de destino a la que desee aplicar ingeniería inversa antes de ejecutar el Asistente para ingeniería inversa. Esta medida garantiza que el asistente asigne correctamente los tipos de datos nativos y que todos los códigos extraídos por él se muestren correctamente en la ventana Código.

    3. En el menú Archivo, elija Nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    4. En el menú Base de datos, haga clic en Ingeniería inversa.

    5. En la primera pantalla del Asistente para ingeniería inversa, puede realizar las siguientes acciones:

      1. Seleccione el controlador de bases de datos de Microsoft Office Visio correspondiente a su sistema de administración de bases de datos (DBMS). Si aún no ha asociado el controlador de la base de datos de Visio con un origen de datos ODBC en concreto, haga clic en Configurar.

        Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa, elija el controlador ODBC genérico.

      2. Seleccione el origen de datos de la base de datos que esté actualizando. Si no ha creado ya un origen de datos para la base de datos existente, haga clic en nuevo para hacerlo ahora.

        Cuando se crea un nuevo origen, su nombre se agrega a la lista de Orígenes de datos.

      3. Cuando la configuración sea correcta, haga clic en Siguiente.

    6. Siga las instrucciones de todos los cuadros de diálogo específicos del controlador.

      Por ejemplo, en el cuadro de diálogo Conectar origen de datos, escriba un nombre de usuario y una contraseña y haga clic en Aceptar. Si el origen de datos no está protegido con contraseña, haga clic en Aceptar.

      Nota: Si usa el controlador ODBC genérico, puede que reciba un mensaje de error que indique que la información de ingeniería inversa quizá no esté completa. En la mayoría de los casos, no representa un problema, haga clic en Aceptar y continúe con los pasos del asistente. 

    7. Active las casillas de verificación del tipo de información que desee extraer y, a continuación, haga clic en Siguiente.

      Nota: Puede que algunos elementos no estén disponibles (aparecen atenuados), ya que no todos los sistemas de administración de bases de datos admiten todos los tipos de elementos que puede extraer el asistente.

    8. Seleccione las casillas de verificación de las tablas (y vistas, si procede) que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

      Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa y no ve nada en esta lista, es probable que necesite un nombre al rango de celdas que contiene los encabezados de columna en la hoja de cálculo.

    9. Si seleccionó la casilla de verificación Procedimientos almacenados en el paso 5, seleccione los procedimientos que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

    10. Indique si desea que se agreguen automáticamente los elementos de ingeniería inversa a la página actual.

      Nota: Puede elegir que el asistente cree automáticamente el dibujo, además a los elementos de ingeniería inversos en la ventana tablas y vistas de lista. Si decide no tiene el dibujo creado automáticamente, puede arrastrar los elementos desde la ventana tablas y vistas hasta la página de dibujo para ensamblar manualmente el modelo de base de datos.

    11. Revise sus selecciones para asegurarse de extraer la información deseada y, a continuación, haga clic en Finalizar.

      El asistente extrae la información seleccionada y muestra información acerca del proceso de extracción en la ventana Resultados.

    Importar y perfeccionar un modelo existente

    Si dispone de un modelo de VisioModeler o PLATINUM ERwin, quizá pueda importarlo para crear un diagrama de modelo de base de datos con el fin de crear un diagrama de modelo de base de datos de Visio. Esta funcionalidad se limita sólo a VisioModeler 2.0 o a archivos de modelos de diccionarios (.imd) anteriores y a archivos .erx de PLATINUM ERwin 2.6, 3.0 y 3.52.

    1. En el menú Archivo, elija Nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    2. En el menú Base de datos, elija Importar y haga clic en Importar <tipo de modelo>.

    3. Escriba la ruta de acceso y el nombre de archivo del modelo que desee importar o haga clic en el botón Examinar para buscar el archivo del modelo y, a continuación, haga clic en Abrir.

    4. En el cuadro de diálogo Importar, haga clic en Aceptar.

      Visio importa el archivo y muestra el progreso en la ventana Resultados. Las tablas importadas se muestran en la ventana Tablas y vistas.

    5. En la ventana Tablas y vistas, seleccione las tablas que desee convertir en modelo y arrástrelas hasta la página de dibujo.

  2. Después de crear un diagrama de modelo de base de datos, comienza el trabajo de perfeccionamiento del diagrama. Puede agregar y personalizar tablas y vistas, crear relaciones y personalizar columnas y tipos de datos.

    Tablas

    Use la forma Entidad para crear una tabla en el diagrama.

    1. Desde la galería de símbolos Relación de entidades o Relacional de objetos, arrastre una forma Entidad hasta el dibujo.

    2. Haga doble clic en la forma para abrir la ventana Propiedades de la base de datos.

    3. En la sección Categorías, haga clic en Definición y escriba un nombre para la tabla.

    4. En categorías, haga clic en columnas, escriba un nombre y elija un tipo de datos.

    5. Active la casilla de verificación solicitado para las columnas que no tienen valores null.

    6. Active la casilla de verificación PK (clave principal) para las columnas que identifiquen exclusivamente cada una de las filas de la tabla de base de datos.

    7. En la sección Categorías, haga clic en Índices, Desencadenadores, Comprobar o Extendido para crear estos elementos opcionales.

    Columnas

    Use la ventana Propiedades de base de datos para agregar o cambiar propiedades de columnas, incluidos los tipos de datos y las claves principales.

    1. Haga doble clic en la tabla del diagrama.

    2. En la sección Categorías de la ventana Propiedades de la base de datos, haga clic en Columnas.

    3. Haga clic en el la primera celda Nombre físico vacía y escriba un nombre.

    4. Para cambiar el tipo de datos de una columna, haga clic en el campo Tipo de datos de la columna y, a continuación, seleccione un tipo de datos de la lista o escríbalo en la lista. Por ejemplo, puede escribir Decimal(8;2) o char(30).

    5. Para evitar que se usen valores nulos, active la casilla de verificación Solicitado.

    6. Para especificar que la columna es una clave principal, active la casilla de verificación PK.

    7. Para ver más propiedades de la columna, además de las que aparecen al hacer clic en la categoría Columnas, seleccione la columna y, a continuación, haga clic en Modificar.

    Relaciones

    Relaciones de usar claves principales y externas para permitir las bases de datos para que coincida con una fila en una tabla con una fila en una tabla relacionada. Puede mostrar las relaciones en el diagrama. Además, puede establecer cardinalidad (por ejemplo, uno a varios) y usar IDEF1X, relacional o Patas de gallo notación para mostrar la cardinalidad. No puede mostrar las relaciones de varios a varios con cualquiera de estas notaciones en la plantilla de diagrama de modelo de base de datos.

    1. Crear relaciones entre tablas:

      1. Asegúrese de que se ven las dos tablas en el diagrama. Si aplica ingeniería inversa al modelo a partir de una base de datos existente, puede que deba arrastrar una o las dos desde la ventana Tablas y vistas hasta la página de dibujo.

      2. Haga doble clic en la tabla que desee que sea la clave principal de la relación.

      3. En la sección Categorías de la ventana Propiedades de la base de datos, haga clic en Columnas.

      4. En la cuadrícula, haga clic en la columna que desea usar para identificar exclusivamente cada fila de la tabla y seleccione la casilla de verificación CP para establecerla como la clave principal.

      5. Desde la galería de símbolos Relacional de objetos o Relación de entidades, arrastre una forma Relación y colóquela en un espacio en blanco de la página.

      6. Conecte el extremo superior a la tabla con la tabla principal.

      7. Conecte el otro extremo a la tabla secundaria.

        Si la segunda tabla aún no contiene ninguna columna con el mismo nombre que la clave principal, Modeler la agrega a la segunda tabla como clave externa.

        Nota: Si desaparecen las líneas de relación, en el menú de la base de datos, elija Opciones y, a continuación, haga clic en documento. En la ficha relaciones, en Mostrar, active la casilla de verificación de las relaciones.

    2. Establecer la cardinalidad de la relación:

      1. Haga doble clic en la relación.

      2. En la sección Categorías de la ventana Propiedades de la base de datos, haga clic en Diversas.

      3. En cardinalidad, elija la que mejor se adapte a la relación. Relaciones uno a varios, la mejor opción es cero o más o uno o más. Relaciones uno a uno, la mejor opción es cero a uno o exactamente uno.

  3. Para perfeccionar aún más el diagrama (por ejemplo, creando índices, cláusulas de comprobación y desencadenadores), siga uno de estos procedimientos:

    Crear índices

    Los índices mejoran el rendimiento, o la velocidad, de la base de datos al ejecutar una consulta.

    1. Abra el diagrama de modelo de base de datos.

    2. Haga doble clic en la tabla a la que desee agregar un índice y en la ventana Propiedades de base de datos, en la lista Categorías, haga clic en Índices.

    3. Haga clic en Nuevo.

    4. En el cuadro de diálogo Crear índice, escriba un nombre para el índice y, a continuación, haga clic en Aceptar.

    5. En la lista Tipo de índice, seleccione una opción para crear un índice único o no único.

    6. En la lista Columnas disponibles, seleccione el nombre de todas las columnas que desee incluir en dicho índice y, después, haga clic en Agregar >.

    7. En la lista Columnas indizadas, active la casilla de verificación Asc para crear un índice con criterio de ordenación ascendente o desactívela para que sea descendente.

      Se actualiza el diagrama de modelo de base de datos.

    Crear vistas

    Puede pensar en una vista como si fuese una consulta guardada. Las vistas son especialmente útiles si debe obtener acceso repetidamente a la misma información desde varias tablas o si desea exponer los datos a los usuarios sin que puedan cambiar las tablas reales.

    Desde la galería de símbolos Relación de entidades o Relacional de objetos, arrastre una forma Vista hasta la página de dibujo.

    Establecer propiedades extendidas de tablas y vistas

    Dependiendo de su sistema de administración de la base de datos (DBMS), es posible que pueda establecer propiedades extendidas para tablas o vistas para determinar dónde se almacenan.

    Haga doble clic en la tabla o vista cuyas propiedades extendidas desea establecer y en la ventana Propiedades de base de datos, en la lista Categorías, haga clic en Extendido.

    Crear cláusulas de comprobación

    Use las cláusulas de comprobación para asegurarse de que los datos se especifican en una columna dentro de un intervalo de valores concreto. Por ejemplo, puede crear una cláusula de comprobación que requiera los datos de una columna denominada "Edad" cuyo valor sobrepase 65.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En la sección Categorías, haga clic en Columnas y, a continuación, haga clic en la columna a la que desee agregar una cláusula de comprobación.

    3. Haga clic en Editar.

    4. En la ficha Comprobar del cuadro de diálogo Propiedades de columna, especifique las restricciones que desee. Para obtener más información sobre las opciones, vea Cuadros de diálogo Propiedades de columna y Propiedades de campo (ficha Comprobar).

      La cláusula de comprobación se agrega a la ventana de códigos en Código local.

    Crear procedimientos almacenados y funciones definidas por el usuario

    Usar procedimientos almacenados y funciones definidas por el usuario para crear paquetes de código que puede volver a usar para realizar las mismas acciones repetidamente. La principal diferencia entre los dos es que una función definida por el usuario devuelve un valor, mientras que el procedimiento almacenado ejecuta el código sin devolver un valor.

    1. En el menú Base de datos, elija Ver y, a continuación, haga clic en Código para abrir la ventana del mismo nombre.

    2. Haga clic en Código global y, a continuación en Nuevo.

    3. En la ficha Propiedades del Editor de código, haga clic en el tipo de código que desee crear y escriba un nombre para el código.

    4. En la ficha Cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

    Crear desencadenadores

    Los desencadenadores provocan la ejecución del código SQL especificado en el desencadenador cuando se produce un evento en concreto en la base de datos.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de la base de datos.

    2. En la sección Categorías, haga clic en Desencadenadores y después en Agregar.

    3. En la ficha Propiedades, escriba un nombre para el desencadenador.

    4. En la ficha Cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

      El desencadenador se agrega a la ventana de códigos en Código local.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!