Crear un modelo de base de datos (también denominado diagrama Relación de entidades)

Crear un modelo de base de datos (también denominado diagrama Relación de entidades)

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Con la plantilla Diagrama de modelo de base de datos, puede crear un nuevo modelo o aplicar ingeniería inversa a una base de datos existente en un modelo utilizando el relacionales o conceptos de modelado relacional de objetos. Use la Galería de símbolos relación de entidades a bases de datos de modelo que se basan en SQL92 y estándares anteriores. Use la Galería de símbolos relacional de objetos, que contiene formas adicionales para trabajar con tipos de bases de datos de modelo que se basan en SQL99 y estándares posteriores.

Ejemplo de modelo de base de datos

Con la plantilla Diagrama de modelo de base de datos, puede crear un nuevo modelo o aplicar ingeniería inversa a una base de datos existente en un modelo utilizando el relacionales o conceptos de modelado relacional de objetos. Use la Galería de símbolos relación de entidades a bases de datos de modelo que se basan en SQL92 y estándares anteriores. Use la Galería de símbolos relacional de objetos, que contiene formas adicionales para trabajar con tipos de bases de datos de modelo que se basan en SQL99 y estándares posteriores.

Este artículo describe cómo crear un modelo de base de datos y qué puede hacer con el modelo después de crearlo.

¿No encuentra la base de datos de características de modelo?

No todas las ediciones de Microsoft Visio tiene la característica de modelo de base de datos. Si no puede encontrar las características descritas en los procedimientos descritos en este artículo, probablemente tendrá una edición de Visio que no incluye.

  • Microsoft Visio Standard no incluye la plantilla Diagrama de modelo de base de datos.

  • Ediciones de Microsoft Visio Professional y Premium son compatibles con las características de ingeniería inversas de la plantilla de diagrama de modelo de base de datos (que es, usando una base de datos existente para crear un modelo en Visio), pero no admite la ingeniería directa (es decir, utilizar un de Visio modelo base de datos para generar código SQL).

  1. Para iniciar el diagrama de modelo de base de datos, siga uno de estos procedimientos:

    Crear un nuevo diagrama de modelo desde cero

    Si no tiene una base de datos existente que desee usar como punto de partida, puede empezar con un modelo de base de datos en blanco y agregar sus propias tablas y relaciones.

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en nuevo, haga clic en Software y base de datos y, a continuación, haga doble clic en Diagrama de modelo de base de datos.

    3. En la pestaña de la base de datos, en el grupo Administrar, haga clic en Opciones de presentación.

    4. En el cuadro de diálogo Opciones de documento de base de datos, seleccione el conjunto de símbolos que desea usar y otras opciones de tabla y relación y, a continuación, haga clic en Aceptar.

    Usar una base de datos existente como punto de partida

    Si tiene una base de datos que desee modelar para que puedan comprender mejor o usarla como punto de partida para un nuevo modelo, puede usar al Asistente para ingeniería inversa para extraer el esquema o la estructura de la base de datos y crear un nuevo modelo.

    Antes de iniciar al asistente:

    1. Si inversa antes de iniciar al Asistente de ingeniería un libro de Microsoft Excel, debe abrir el libro y el nombre del grupo (o rango) de celdas que contiene los encabezados de columna. Si desea usar más de una hoja de cálculo, asigne un nombre al grupo de celdas de la columna en cada hoja de cálculo. Estos rangos se tratan como tablas en el asistente. Para obtener más información sobre cómo asignar un nombre a un rango de celdas, vea el tema de la Ayuda de Excel titulado Definir rangos con nombre referencias de celda o.

    2. Para obtener los mejores resultados, configure el controlador predeterminado para la base de datos de destino que desea aplicar ingeniería inversa antes de ejecutar al Asistente para ingeniería inversa. Este paso asegura que el asistente asigna los tipos de datos nativos correctamente y que todo el código que extrae el asistente se muestre correctamente en la ventana de código.

    3. Haga clic en la pestaña Archivo.

    4. Haga clic en nuevo, haga clic en Software y base de datos y, a continuación, haga doble clic en Diagrama de modelo de base de datos.

    5. En la pestaña de la base de datos, en el grupo de modelos, haga clic en Ingeniería inversa.

    6. En la primera pantalla del Asistente de ingeniería inversa, haga lo siguiente:

      1. Seleccione el controlador de base de datos para su sistema de administración de la base de datos (DBMS). Si aún no ha asociado el controlador de base de datos de Visio con un origen de datos ODBC concreto, haga clic en configuración.

        Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa, elija el controlador ODBC genérico.

      2. Seleccione el origen de datos de la base de datos que esté actualizando. Si no ha creado ya un origen de datos para la base de datos existente, haga clic en nuevo para hacerlo ahora.

        Cuando se crea un nuevo origen, su nombre se agrega a la lista de Orígenes de datos.

      3. Cuando esté satisfecho con la configuración, haga clic en siguiente.

    7. Siga las instrucciones de los cuadros de diálogo específico del controlador.

      Por ejemplo, en el cuadro de diálogo Conectar origen de datos, escriba el nombre de usuario y contraseña y, a continuación, haga clic en Aceptar.

      Nota: Si utiliza el controlador ODBC genérico, puede recibir un mensaje de error que indica que la información de ingeniería inversa puede estar incompleta. En la mayoría de los casos, no es un problema, simplemente haga clic en Aceptar y continuar con el asistente.

    8. Seleccione las casillas de verificación para el tipo de información que desea extraer y, a continuación, haga clic en siguiente.

      Nota: Algunos elementos no estén disponibles (aparece atenuada) porque no todos los sistemas de administración de base de datos admiten todos los tipos de elementos que puede extraer el asistente.

    9. Seleccione las casillas de verificación de las tablas (y vistas, si procede) que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

      Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa y no ve nada en esta lista, es probable que necesite un nombre al rango de celdas que contiene los encabezados de columna en la hoja de cálculo.

    10. Si seleccionó la casilla de verificación Procedimientos almacenados, seleccione los procedimientos que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

    11. Seleccione si desea que los elementos de ingeniería inversos que se agregará automáticamente a la página actual.

      Nota: Puede elegir que el asistente cree automáticamente el dibujo, además a los elementos de ingeniería inversos en la ventana tablas y vistas de lista. Si decide no tiene el dibujo creado automáticamente, puede arrastrar los elementos desde la ventana tablas y vistas hasta la página de dibujo para ensamblar manualmente el modelo de base de datos.

    12. Revise sus selecciones para asegurarse de extraer la información que desee y, a continuación, haga clic en Finalizar.

      El asistente extrae la información seleccionada y muestra notas sobre el proceso de extracción en la ventana de resultados.

    Importar y refinar un modelo existente

    Si tiene un modelo de VisioModeler o PLATINUM ERwin existente, es posible que pueda importar para crear un diagrama de modelo de base de datos de Visio. Esta funcionalidad se limita a solo VisioModeler 2.0 o posterior diccionario (.imd) y archivos del modelo archivos .erx de PLATINUM ERwin 2.6, 3.0 y 3.52.

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en nuevo, haga clic en Software y base de datos y, a continuación, haga doble clic en Diagrama de modelo de base de datos.

    3. En la pestaña de la base de datos, en el grupo de modelos, haga clic en Importar y, a continuación, haga clic en el tipo de modelo.

    4. Escriba la ruta de acceso y nombre de archivo para el modelo que desea importar, o haga clic en el botón Examinar para buscar el archivo del modelo y, a continuación, haga clic en Abrir.

    5. En el cuadro de diálogo Importar, haga clic en Aceptar.

      Visio importa el archivo y mostrará su progreso en la ventana de resultados. Las tablas importadas se muestran en la ventana tablas y vistas.

    6. En la ventana tablas y vistas, seleccione las tablas que desee convertir en modelo y, a continuación, arrástrelos hasta la página de dibujo.

  2. Después de crear un diagrama de modelo de base de datos, comienza el trabajo de perfeccionamiento del diagrama. Puede agregar y personalizar tablas y vistas, crear relaciones y personalizar columnas y tipos de datos.

    Tablas

    Use la forma entidad para crear una tabla en el diagrama.

    1. Desde la Galería de símbolos de la Relación de entidades o Relacional de objetos, arrastre una forma entidad hasta el dibujo.

    2. Haga doble clic en la forma para abrir la ventana Propiedades de base de datos.

    3. En categorías, haga clic en definición y escriba un nombre para la tabla.

    4. En categorías, haga clic en columnas, escriba un nombre y elija un tipo de datos.

    5. Active la casilla de verificación solicitado para las columnas que no tienen valores null.

    6. Seleccione la casilla de verificación CP (clave principal) para las columnas que identifiquen exclusivamente cada fila de la tabla de base de datos.

    7. En categorías, haga clic en índices, desencadenadores, Comprobar o extendido para crear estos elementos opcionales.

    Columnas

    Use la ventana Propiedades de base de datos para agregar o cambiar propiedades de columnas, incluidos los tipos de datos y las claves principales.

    1. Haga doble clic en la tabla en el diagrama.

    2. En la ventana Propiedades de base de datos, en categorías, haga clic en columnas.

    3. Haga clic en la primera celda Nombre físico vacía y escriba un nombre.

    4. Para cambiar el tipo de datos de una columna, haga clic en el campo Tipo de datos de la columna y seleccione un tipo de datos de la lista o escribir en la lista. Por ejemplo, puede escribir decimal(8,2) o char (30).

    5. Para evitar que los valores nulos, active la casilla de verificación solicitado .

    6. Para especificar que la columna es una clave principal, seleccione la casilla de verificación de la clave principal.

    7. Para ver más propiedades de columna además de las que aparecen al hacer clic en la categoría columnas, seleccione la columna y, a continuación, haga clic en Editar.

    Relaciones

    Relaciones de usar claves principales y externas para permitir las bases de datos para que coincida con una fila en una tabla con una fila en una tabla relacionada. Puede mostrar las relaciones en el diagrama. Además, puede establecer cardinalidad (por ejemplo, uno a varios) y usar IDEF1X, relacional o Patas de gallo notación para mostrar la cardinalidad. No puede mostrar las relaciones de varios a varios con cualquiera de estas notaciones en la plantilla de diagrama de modelo de base de datos.

    1. Crear una relación entre tablas:

      1. Asegúrese de que están visibles en el diagrama de ambas tablas. Si aplica ingeniería inversa del modelo de base de datos existente, debe arrastrar uno o ambos desde la ventana tablas y vistas a la página de dibujo.

      2. Haga doble clic en la tabla que desee para el lado de la clave principal de la relación.

      3. En la ventana Propiedades de base de datos, en categorías, haga clic en columnas.

      4. En la cuadrícula, haga clic en la columna que desea usar para identificar exclusivamente cada fila de la tabla y seleccione la casilla de verificación CP para establecerla como la clave principal.

      5. Desde la Galería de símbolos Relacional de objetos o Relación de entidades, arrastre una forma de relación y colóquela en un espacio en blanco en la página.

      6. Conecte el extremo superior a la tabla con la tabla principal.

      7. Conecte el otro extremo a la tabla secundaria.

        Si la segunda tabla ya no contiene una columna con el mismo nombre que la clave principal, el modelador lo agrega a la segunda tabla como clave externa.

        Nota: Si desaparecen las líneas de relación, en la pestaña de la base de datos, en el grupo Administrar, haga clic en Opciones de presentación. En la ficha relaciones, en Mostrar, active la casilla de verificación de las relaciones.

    2. Establecer cardinalidad de la relación:

      1. Haga doble clic en la relación.

      2. En la ventana Propiedades de base de datos, en categorías, haga clic en varios.

      3. En cardinalidad, elija la que mejor se adapte a la relación. Relaciones uno a varios, la mejor opción es cero o más o uno o más. Relaciones uno a uno, la mejor opción es cero a uno o exactamente uno.

  3. Para realizar otros ajustes al diagrama (por ejemplo, para crear índices, cláusulas de comprobación y desencadenadores) puede hacer lo siguiente:

    Crear índices

    Índices de mejoran el rendimiento o la velocidad de la base de datos cuando se ejecuta una consulta.

    1. Abra el diagrama de modelo de base de datos.

    2. Haga doble clic en la tabla a la que desea agregar un índice y, en la ventana Propiedades de base de datos, en la lista categorías, haga clic en índices.

    3. Haga clic en Nuevo.

    4. En el cuadro de diálogo Crear índice, escriba un nombre para el índice y, a continuación, haga clic en Aceptar.

    5. En la lista Tipo de índice, seleccione una opción para crear un índice único o no único.

    6. En la lista Columnas disponibles, seleccione el nombre de cada columna que desee incluir en dicho índice y, a continuación, haga clic en Agregar >.

    7. En la lista Columnas indizadas, active la casilla de verificación Asc para crear un índice en orden ascendente o desactive la casilla de verificación para crear un índice con un criterio de ordenación descendente.

      Se actualiza el diagrama de modelo de base de datos.

    Crear vistas

    Puede considerar que una vista como una consulta guardada. Las vistas son especialmente útiles si necesita obtener acceso repetidamente a la misma información de varias tablas o si desea exponer los datos a los usuarios sin que puedan cambiar las tablas reales.

    Desde la Galería de símbolos Relación de entidades o Relacional de objetos, arrastre una forma de Ver la página de dibujo.

    Establecer propiedades extendidas para tablas y vistas

    Dependiendo de su sistema de administración de la base de datos (DBMS), es posible que pueda establecer propiedades extendidas para tablas o vistas para determinar dónde se almacenan.

    Haga doble clic en la tabla o vista cuyas propiedades extendidas desea establecer y en la ventana Propiedades de base de datos, en la lista categorías, haga clic en extendido.

    Crear cláusulas de comprobación

    Utilice cláusulas de comprobación para asegurarse de que los datos que se especifican en una columna están dentro de un intervalo concreto de valores. Por ejemplo, puede crear una cláusula de comprobación que requiera los datos de una columna denominada "Edad" para que sea mayor 65.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de base de datos.

    2. En categorías, haga clic en columnas y, a continuación, haga clic en la columna que desea agregar una cláusula de comprobación.

    3. Haga clic en Editar.

    4. En la ficha Comprobar del cuadro de diálogo Propiedades de columna, especifique las restricciones que desee.

      La cláusula de comprobación se agrega a la ventana de código en código Local.

    Crear procedimientos almacenados y funciones definidas por el usuario

    Usar procedimientos almacenados y funciones definidas por el usuario para crear paquetes de código que puede volver a usar para realizar las mismas acciones repetidamente. La principal diferencia entre los dos es que una función definida por el usuario devuelve un valor, mientras que el procedimiento almacenado ejecuta el código sin devolver un valor.

    1. En la pestaña de la base de datos, en el grupo Mostrar u ocultar, active la casilla de verificación de código para abrir la ventana de código.

    2. Haga clic en Código Global y, a continuación, haga clic en nuevo.

    3. En la pestaña Propiedades del Editor de código, haga clic en el tipo de código que desea crear y escriba un nombre para el código.

    4. En la ficha cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

    Crear desencadenadores

    Desencadenadores que el código SQL que especifique en el desencadenador para que se ejecute cuando se produce un evento determinado en la base de datos.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de base de datos.

    2. En categorías, haga clic en desencadenadores y, a continuación, haga clic en Agregar.

    3. En la pestaña Propiedades, escriba un nombre para el desencadenador.

    4. En la ficha cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

      El desencadenador se agrega a la ventana de código en código Local.

Este artículo describe cómo crear un modelo de base de datos y qué puede hacer con el modelo después de crearlo. Para el inicio rápido, en el menú archivo, elija nuevo, elija Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

¿No encuentra la base de datos de características de modelo?

Más probable es que la edición de Microsoft Office Visio no incluye las características que está buscando. Para averiguar qué edición de Visio tiene, haga clic en Acerca de Microsoft Office Visio, en el menú Ayuda. Es el nombre de la edición en la línea superior del texto en el cuadro de diálogo.

  • Microsoft Office Visio Standard no incluye la plantilla Diagrama de modelo de base de datos.

  • Microsoft Office Visio Professional admite las características de ingeniería inversa de la plantilla de diagrama de modelo de base de datos (que es, usando una base de datos existente para crear un modelo en Visio), pero no admite la ingeniería directa (es decir, utilizar una base de datos de Visio modelo para generar código SQL).

  • Puede encontrar el conjunto completo de base de datos de características de modelado, incluyendo ingeniería inversa y directa en Enterprise de Visio. Enterprise de Visio está incluida en MSDN Premium Subscription, disponible con Visual Studio Professional y ediciones de Visual Studio Team System basado en roles.

  1. Para iniciar el diagrama de modelo de base de datos, siga uno de estos procedimientos:

    Crear un nuevo diagrama de modelo desde cero

    Si no tiene una base de datos existente que desee usar como punto de partida, puede empezar con un modelo de base de datos en blanco y agregar sus propias tablas y relaciones.

    1. En el menú archivo, elija nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    2. En el menú de la base de datos, elija Opciones y, a continuación, haga clic en documento.

    3. En el cuadro de diálogo Opciones de documento de base de datos, seleccione el conjunto de símbolos que desea usar y otras opciones de tabla y relación y, a continuación, haga clic en Aceptar.

    Usar una base de datos existente como punto de partida

    Si tiene una base de datos que desee modelar para que puedan comprender mejor o usarla como punto de partida para un nuevo modelo, puede usar al Asistente para ingeniería inversa para extraer el esquema o la estructura de la base de datos y crear un nuevo modelo.

    Nota: Antes de iniciar al asistente:

    1. Si inversa antes de iniciar al Asistente de ingeniería un libro de Microsoft Office Excel, debe abrir el libro y el nombre del grupo (o rango) de celdas que contiene los encabezados de columna. Si desea usar más de una hoja de cálculo, asigne un nombre al grupo de celdas de la columna en cada hoja de cálculo. Estos rangos se tratan como tablas en el asistente. Para obtener más información sobre cómo asignar un nombre a un rango de celdas, vea el tema de Microsoft Office Excel titulado Definir rangos con nombre referencias de celda o de ayuda.

    2. Para obtener los mejores resultados, configure el controlador predeterminado para la base de datos de destino que desea aplicar ingeniería inversa antes de ejecutar al Asistente para ingeniería inversa. Este paso asegura que el asistente asigna los tipos de datos nativos correctamente y que todo el código que extrae el asistente se muestre correctamente en la ventana de código.

    3. En el menú archivo, elija nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    4. En el menú de la base de datos, haga clic en Ingeniería inversa.

    5. En la primera pantalla del Asistente de ingeniería inversa, haga lo siguiente:

      1. Seleccione el controlador de base de datos de Microsoft Office Visio para su sistema de administración de la base de datos (DBMS). Si aún no ha asociado el controlador de base de datos de Visio con un origen de datos ODBC concreto, haga clic en configuración.

        Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa, elija el controlador ODBC genérico.

      2. Seleccione el origen de datos de la base de datos que esté actualizando. Si no ha creado ya un origen de datos para la base de datos existente, haga clic en nuevo para hacerlo ahora.

        Cuando se crea un nuevo origen, su nombre se agrega a la lista de Orígenes de datos.

      3. Cuando esté satisfecho con la configuración, haga clic en siguiente.

    6. Siga las instrucciones de los cuadros de diálogo específico del controlador.

      Por ejemplo, en el cuadro de diálogo Conectar origen de datos, escriba un nombre de usuario y contraseña y, a continuación, haga clic en Aceptar. Si el origen de datos no está protegido con contraseña, haga clic en Aceptar.

      Nota: Si utiliza el controlador ODBC genérico, puede recibir un mensaje de error que indica que la información de ingeniería inversa puede estar incompleta. En la mayoría de los casos, no es un problema, simplemente haga clic en Aceptar y continuar con el asistente.

    7. Seleccione las casillas de verificación para el tipo de información que desea extraer y, a continuación, haga clic en siguiente.

      Nota: Algunos elementos no estén disponibles (aparece atenuada) porque no todos los sistemas de administración de base de datos admiten todos los tipos de elementos que puede extraer el asistente.

    8. Seleccione las casillas de verificación de las tablas (y vistas, si procede) que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

      Nota: Si aplica una hoja de cálculo de Excel de ingeniería inversa y no ve nada en esta lista, es probable que necesite un nombre al rango de celdas que contiene los encabezados de columna en la hoja de cálculo.

    9. Si seleccionó la casilla de verificación Procedimientos almacenados en el paso 5, seleccione los procedimientos que desea extraer o haga clic en Seleccionar todo para extraer todos y, a continuación, haga clic en siguiente.

    10. Seleccione si desea que los elementos de ingeniería inversos que se agregará automáticamente a la página actual.

      Nota: Puede elegir que el asistente cree automáticamente el dibujo, además a los elementos de ingeniería inversos en la ventana tablas y vistas de lista. Si decide no tiene el dibujo creado automáticamente, puede arrastrar los elementos desde la ventana tablas y vistas hasta la página de dibujo para ensamblar manualmente el modelo de base de datos.

    11. Revise sus selecciones para asegurarse de extraer la información que desee y, a continuación, haga clic en Finalizar.

      El asistente extrae la información seleccionada y muestra notas sobre el proceso de extracción en la ventana de resultados.

    Importar y refinar un modelo existente

    Si tiene un modelo de VisioModeler o PLATINUM ERwin existente, es posible que pueda importar para crear un diagrama de modelo de base de datos de Visio. Esta funcionalidad se limita a solo VisioModeler 2.0 o posterior diccionario (.imd) y archivos del modelo archivos .erx de PLATINUM ERwin 2.6, 3.0 y 3.52.

    1. En el menú archivo, elija nuevo, Software y base de datos y, a continuación, haga clic en Diagrama de modelo de base de datos.

    2. En el menú de la base de datos, elija Importar y, a continuación, haga clic en Importar < tipo de modelo >.

    3. Escriba la ruta de acceso y nombre de archivo para el modelo que desea importar, o haga clic en el botón Examinar para buscar el archivo del modelo y, a continuación, haga clic en Abrir.

    4. En el cuadro de diálogo Importar, haga clic en Aceptar.

      Visio importa el archivo y mostrará su progreso en la ventana de resultados. Las tablas importadas se muestran en la ventana tablas y vistas.

    5. En la ventana tablas y vistas, seleccione las tablas que desee convertir en modelo y, a continuación, arrástrelos hasta la página de dibujo.

  2. Después de crear un diagrama de modelo de base de datos, comienza el trabajo de perfeccionamiento del diagrama. Puede agregar y personalizar tablas y vistas, crear relaciones y personalizar columnas y tipos de datos.

    Tablas

    Use la forma entidad para crear una tabla en el diagrama.

    1. Desde la Galería de símbolos de la Relación de entidades o Relacional de objetos, arrastre una forma entidad hasta el dibujo.

    2. Haga doble clic en la forma para abrir la ventana Propiedades de base de datos.

    3. En categorías, haga clic en definición y escriba un nombre para la tabla.

    4. En categorías, haga clic en columnas, escriba un nombre y elija un tipo de datos.

    5. Active la casilla de verificación solicitado para las columnas que no tienen valores null.

    6. Seleccione la casilla de verificación CP (clave principal) para las columnas que identifiquen exclusivamente cada fila de la tabla de base de datos.

    7. En categorías, haga clic en índices, desencadenadores, Comprobar o extendido para crear estos elementos opcionales.

    Columnas

    Use la ventana Propiedades de base de datos para agregar o cambiar propiedades de columnas, incluidos los tipos de datos y las claves principales.

    1. Haga doble clic en la tabla en el diagrama.

    2. En la ventana Propiedades de base de datos, en categorías, haga clic en columnas.

    3. Haga clic en el primer vacío nombre físico de la celda y a continuación, escriba un nombre.

    4. Para cambiar el tipo de datos de una columna, haga clic en el campo Tipo de datos de la columna y seleccione un tipo de datos de la lista o escribir en la lista. Por ejemplo, puede escribir decimal(8,2) o char (30).

    5. Para evitar que los valores nulos, active la casilla de verificación solicitado .

    6. Para especificar que la columna es una clave principal, seleccione la casilla de verificación de la clave principal.

    7. Para ver más propiedades de columna además de las que aparecen al hacer clic en la categoría columnas, seleccione la columna y, a continuación, haga clic en Editar.

    Relaciones

    Relaciones de usar claves principales y externas para permitir las bases de datos para que coincida con una fila en una tabla con una fila en una tabla relacionada. Puede mostrar las relaciones en el diagrama. Además, puede establecer cardinalidad (por ejemplo, uno a varios) y usar IDEF1X, relacional o Patas de gallo notación para mostrar la cardinalidad. No puede mostrar las relaciones de varios a varios con cualquiera de estas notaciones en la plantilla de diagrama de modelo de base de datos.

    1. Crear una relación entre tablas:

      1. Asegúrese de que están visibles en el diagrama de ambas tablas. Si aplica ingeniería inversa del modelo de base de datos existente, debe arrastrar uno o ambos desde la ventana tablas y vistas a la página de dibujo.

      2. Haga doble clic en la tabla que desee para el lado de la clave principal de la relación.

      3. En la ventana Propiedades de base de datos, en categorías, haga clic en columnas.

      4. En la cuadrícula, haga clic en la columna que desea usar para identificar exclusivamente cada fila de la tabla y seleccione la casilla de verificación CP para establecerla como la clave principal.

      5. Desde la Galería de símbolos Relacional de objetos o Relación de entidades, arrastre una forma de relación y colóquela en un espacio en blanco en la página.

      6. Conecte el extremo superior a la tabla con la tabla principal.

      7. Conecte el otro extremo a la tabla secundaria.

        Si la segunda tabla ya no contiene una columna con el mismo nombre que la clave principal, el modelador lo agrega a la segunda tabla como clave externa.

        Nota: Si desaparecen las líneas de relación, en el menú de la base de datos, elija Opciones y, a continuación, haga clic en documento. En la ficha relaciones, en Mostrar, active la casilla de verificación de las relaciones.

    2. Establecer cardinalidad de la relación:

      1. Haga doble clic en la relación.

      2. En la ventana Propiedades de base de datos, en categorías, haga clic en varios.

      3. En cardinalidad, elija la que mejor se adapte a la relación. Relaciones uno a varios, la mejor opción es cero o más o uno o más. Relaciones uno a uno, la mejor opción es cero a uno o exactamente uno.

  3. Para realizar otros ajustes al diagrama (por ejemplo, para crear índices, cláusulas de comprobación y desencadenadores) puede hacer lo siguiente:

    Crear índices

    Índices de mejoran el rendimiento o la velocidad de la base de datos cuando se ejecuta una consulta.

    1. Abra el diagrama de modelo de base de datos.

    2. Haga doble clic en la tabla a la que desea agregar un índice y, en la ventana Propiedades de base de datos, en la lista categorías, haga clic en índices.

    3. Haga clic en Nuevo.

    4. En el cuadro de diálogo Crear índice, escriba un nombre para el índice y, a continuación, haga clic en Aceptar.

    5. En la lista Tipo de índice, seleccione una opción para crear un índice único o no único.

    6. En la lista Columnas disponibles, seleccione el nombre de cada columna que desee incluir en dicho índice y, a continuación, haga clic en Agregar >.

    7. En la lista Columnas indizadas, active la casilla de verificación Asc para crear un índice en orden ascendente o desactive la casilla de verificación para crear un índice con un criterio de ordenación descendente.

      Se actualiza el diagrama de modelo de base de datos.

    Crear vistas

    Puede considerar que una vista como una consulta guardada. Las vistas son especialmente útiles si necesita obtener acceso repetidamente a la misma información de varias tablas o si desea exponer los datos a los usuarios sin que puedan cambiar las tablas reales.

    Desde la Galería de símbolos Relación de entidades o Relacional de objetos, arrastre una forma de Ver la página de dibujo.

    Establecer propiedades extendidas para tablas y vistas

    Dependiendo de su sistema de administración de la base de datos (DBMS), es posible que pueda establecer propiedades extendidas para tablas o vistas para determinar dónde se almacenan.

    Haga doble clic en la tabla o vista cuyas propiedades extendidas desea establecer y en la ventana Propiedades de base de datos, en la lista categorías, haga clic en extendido.

    Crear cláusulas de comprobación

    Utilice cláusulas de comprobación para asegurarse de que los datos que se especifican en una columna están dentro de un intervalo concreto de valores. Por ejemplo, puede crear una cláusula de comprobación que requiera los datos de una columna denominada "Edad" para que sea mayor 65.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de base de datos.

    2. En categorías, haga clic en columnas y, a continuación, haga clic en la columna que desea agregar una cláusula de comprobación.

    3. Haga clic en Editar.

    4. En la ficha Comprobar del cuadro de diálogo Propiedades de columna, especifique las restricciones que desee. Para obtener más información sobre las opciones, consulte el cuadro de diálogo Propiedades de campo y columna (ficha Comprobar).

      La cláusula de comprobación se agregan a la ventana de código en código Local.

    Crear procedimientos almacenados y funciones definidas por el usuario

    Usar procedimientos almacenados y funciones definidas por el usuario para crear paquetes de código que puede volver a usar para realizar las mismas acciones repetidamente. La principal diferencia entre los dos es que una función definida por el usuario devuelve un valor, mientras que el procedimiento almacenado ejecuta el código sin devolver un valor.

    1. En el menú de la base de datos, elija Ver y, a continuación, haga clic en código para abrir la ventana de código.

    2. Haga clic en Código Global y, a continuación, haga clic en nuevo.

    3. En la pestaña Propiedades del Editor de código, haga clic en el tipo de código que desea crear y escriba un nombre para el código.

    4. En la ficha cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

    Crear desencadenadores

    Desencadenadores que el código SQL que especifique en el desencadenador para que se ejecute cuando se produce un evento determinado en la base de datos.

    1. Haga doble clic en la tabla para abrir la ventana Propiedades de base de datos.

    2. En categorías, haga clic en desencadenadores y, a continuación, haga clic en Agregar.

    3. En la pestaña Propiedades, escriba un nombre para el desencadenador.

    4. En la ficha cuerpo, escriba el código y, a continuación, haga clic en Aceptar.

      El desencadenador se agrega a la ventana de código en código Local.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×