Crear un informe agrupado o un informe de resumen

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Información puede resultar más fácil de entender cuando se divide en grupos. Por ejemplo, un informe que agrupe ventas por región puede resaltar tendencias que de lo contrario podrían ir problemas. Además, colocan los totales al final de cada grupo en el informe puede reemplazar una gran cantidad de interacción manual con una calculadora.

Microsoft Office Access 2007 facilita el trabajo con los informes agrupados. Puede crear un informe agrupado básico mediante el Asistente para informes, puede agregar agrupación y ordenación a un informe existente o puede revisar de agrupación y ordenación opciones que ya se ha definido.

En este artículo...

Comprender la agrupación, las secciones de informes y controles

Crear un nuevo informe agrupado mediante el Asistente para informes

Ajustar el informe

Agregar campos u otros controles a un informe existente

Agregar o modificar el agrupamiento y ordenación en un informe existente

Guardar, imprimir o enviar el informe

Notas

Comprender la agrupación, las secciones de informes y controles

Si es nuevo en los informes agrupados, resulta útil para tener cierta información general sobre agrupación y ordenación, así como los tipos de controles y secciones de informe diferente. Si siente cómodo con estos conceptos ya, puede omitir esta sección y vaya a la sección crear un nuevo informe agrupado mediante el Asistente para informes.

Agrupar y ordenar

Al imprimir un informe, normalmente desea organizar los registros en un orden determinado. Por ejemplo, si va a imprimir una lista de proveedores, que desee ordenar los registros alfabéticamente por nombre de compañía.

Para muchos de los informes, ordenar los registros no es suficiente. También puede dividirlos en grupos. Un grupo es un conjunto de registros, junto con cualquier información de introducción y resumen que se muestra con los registros, como un encabezado. Un grupo consta de un encabezado de grupo, anidado grupos (si los hay), registros de detalle y un pie de grupo.

Agrupación permite separar visualmente los grupos de registros y mostrar datos introductorios y de resumen de cada grupo. Por ejemplo, el siguiente informe de grupos de ventas por fecha de envío y calcula el importe total de ventas para cada día.

Informe agrupado con totales

1. la fecha presenta al grupo.

2 total resume el grupo.

Puede ver cómo funciona el agrupamiento comparando la lista de productos por informe de categoría (que se muestra en la siguiente ilustración) a la hoja de datos de la consulta subyacente, lista de productos. El informe y los productos de ordenación de la consulta por categoría, pero el informe también se imprime el nombre de cada categoría en una línea independiente al principio de cada grupo (en el encabezado de grupo) y el número de productos de cada categoría en una línea independiente al final de cada grupo (en el pie de grupo).

Informe Productos por categoría

1. el nombre de categoría aparece en cada fila de la hoja de datos.

2. el nombre de categoría aparece una vez para cada grupo en el informe, en el encabezado del grupo.

3. el total de la categoría aparece al final de cada grupo, en el pie de grupo.

4. los registros aparecen como un grupo grande de la hoja de datos.

5. los registros para cada categoría aparecen como una sección independiente en el informe, precedidos por un encabezado de grupo y seguido de un pie de grupo.

Puede agrupar en los campos y expresiones que ordenar por (hasta 10). Puede agrupar varias veces en el mismo campo o expresión. Al agrupar en más de un campo, Office Access 2007 anida los grupos según su nivel de grupo. El primer campo que agrupe es el nivel de grupo primero y más importante; el segundo campo en que agrupar es el siguiente nivel de grupo; y así sucesivamente. La ilustración siguiente muestra cómo Office Access 2007 anida los grupos.

Jerarquía de encabezados y pies

1. cada encabezado de grupo se corresponde con un pie de grupo.

Normalmente se utiliza un encabezado de grupo para mostrar los datos que identifica el grupo en una sección independiente al principio del grupo. Normalmente, se utiliza un pie de grupo para resumir los datos en el grupo en una sección independiente al final del grupo.

Volver al principio

Acerca de las secciones del informe

En Access, el diseño de un informe está dividido en secciones. Para crear informes útiles, debe comprender cómo funciona cada sección. Por ejemplo, la sección en la que eligió colocar un control calculado determina cómo Access calcula los resultados. La siguiente lista muestra un resumen de los tipos de sección y sus usos.

  • Encabezado del informe    Imprime una vez al principio del informe. Usar el encabezado del informe para la información que normalmente puede aparecer en una página de portada, como un logotipo o un título y una fecha. El encabezado del informe se imprime antes del encabezado de página. Cuando se coloca un control calculado en el encabezado del informe, el valor se calcula para todo el informe. Por ejemplo, si se coloca un control que usa la función suma en el encabezado del informe, calcula la suma de todo el informe.

  • Encabezado de página    Imprimir en la parte superior de cada página. Use un encabezado de página, por ejemplo, repetir el título del informe en cada página.

  • Encabezado de grupo    Imprime al principio de cada grupo de registros nuevo. Utilice el encabezado de grupo para imprimir el nombre del grupo. Por ejemplo, en un informe agrupado por producto, utilice el encabezado de grupo para imprimir el nombre del producto. Cuando se coloca un control calculado que utiliza la función suma en el encabezado de grupo, es la suma del grupo actual.

  • Detalle    Imprime una vez por cada fila del origen de registros. La sección de detalle es donde se colocan los controles que constituyen el cuerpo principal del informe.

  • Pie de grupo    Imprimir al final de cada grupo de registros. Use un pie de grupo para imprimir información de resumen para un grupo.

  • Pie de página    Imprime al final de cada página. Use un pie de página para imprimir números de página o información por página.

  • Pie del informe    Imprime una vez al final del informe. Use el pie del informe para los totales del informe de impresión u otra información de resumen de todo el informe.

    Nota: En la vista Diseño, el pie del informe aparece debajo del pie de página. Sin embargo, cuando se imprime el informe o se obtiene la vista previa, el pie del informe aparece encima del pie de página, justo después del último grupo pie de página o detalle línea en la página final.

Volver al principio

Acerca de los controles

Los controles son objetos que muestran datos, realizan acciones y le permiten ver y trabajar con información que enriquece la interfaz de usuario, como etiquetas e imágenes. Access admite tres tipos de controles: enlazado, independientes y calculados. La siguiente lista muestra un resumen de estos controles y sus usos.

  • Control dependiente    Un control cuyo origen de datos es un campo en una tabla o consulta. Use los controles dependientes para mostrar los valores de los campos de la base de datos. Los valores pueden ser texto, fechas, números, valores Sí/No, imágenes o gráficos. Un cuadro de texto es el tipo más común de control dependiente. Por ejemplo, un cuadro de texto en un formulario que muestre los apellidos de un empleado podría obtener esta información desde el campo Apellido de la tabla Employees.

  • Control independiente    Un control que no tiene un origen de datos. Use los controles independientes para mostrar información, líneas, rectángulos e imágenes. Por ejemplo, una etiqueta que muestra el título de un informe es un control independiente.

  • Control calculado    Un control cuyo origen de datos es una expresión en lugar de un campo. Especifique el valor que desee en el control definiendo una expresión como origen de datos para el control. Una expresión es una combinación de operadores (por ejemplo, = y + ), nombres de controles, nombres de campo, funciones que devuelven un único valor y valores constantes. Por ejemplo, la siguiente expresión calcula el precio de un artículo con un descuento del 25% multiplica el valor en el campo Precio unitario por un valor constante (. 75).

= [Unit Price] * .75

Una expresión puede usar los datos de un campo en la tabla o consulta subyacente o de un control en el informe.

Cuando se crea un informe, es probable más eficaz agregar y organizar todos los controles dependientes en primer lugar, especialmente si son la mayoría de los controles en el informe. A continuación, puede agregar los controles independientes y calculados que completen el diseño mediante las herramientas del grupo controles de la ficha Diseño.

Imagen de la cinta de Access

Enlaza un control a un campo identificando el campo desde la que obtiene sus datos el control. Puede crear un control que está enlazado al campo seleccionado arrastrando el campo desde el panel Lista de campos al informe. (El panel Lista de campos muestra los campos de la tabla o consulta subyacente. Para mostrar el panel Lista de campos, siga uno de estos procedimientos:

  • En la ficha Diseño, en el grupo Herramientas, haga clic en Agregar campos existentes. Imagen del botón

  • Presione ALT+F8.

Cuando haga doble clic en un campo o arrástrelo desde el panel Lista de campos al informe, crear un control dependiente.

Como alternativa, puede enlazar un campo a un control escribiendo el nombre del campo en el propio control o en el cuadro para el valor ControlSource en hoja de propiedades del control. La hoja de propiedades define las características del control, como su nombre, el origen de sus datos y su formato. Para mostrar la hoja de propiedades, presione F4.

Usar el panel Lista de campos es la mejor manera de crear un control dependiente por dos razones:

  • Un control dependiente lleva adjunta una etiqueta y la etiqueta toma el nombre del campo (o el título definido para el campo en la tabla o consulta subyacente) como título de forma predeterminada, para que no tenga que escribir manualmente el título.

  • Un control dependiente hereda muchos de los mismos valores del campo de la tabla o consulta (como las propiedades formato, LugaresDecimalesy máscara de entrada ) subyacente. Por lo tanto, puede asegurarse de que estas propiedades del campo se conservan las cada vez que cree un control que está enlazado a ese campo.

Si ya tiene un control independiente y desea enlazar a un campo, establezca la propiedad ControlSource del control en el nombre del campo.

Volver al principio

Crear un nuevo informe agrupado mediante el Asistente para informes

El Asistente para informes presenta una serie de preguntas y genera posteriormente un informe basándose en las respuestas. Entre esas preguntas figura la referente a los campos que desea utilizar para agrupar el informe. Una vez creado el informe, lo podrá utilizar tal cual o modificarlo según sus necesidades. Antes de iniciar el Asistente para informes, es preciso elegir un origen de datos.

Elegir un origen de registros

Un informe se compone de información extraída de una tabla o consulta y la información almacenada en el diseño de informe, como etiquetas, encabezados y gráficos. La tabla o consulta que proporciona los datos subyacentes es también conocida como origen de registros del informe. Antes de empezar a crear el informe, debe pensar la información que desea incluir. Entre los campos que elija deben ser los que desee agrupar o resumir. Si los campos que desea incluir todos se encuentran en una sola tabla, utilice dicha tabla como origen de registros. Si los campos se extraen de más de una tabla, desea usar una consulta como origen de registros. Esa consulta ya exista en la base de datos o debe crear una consulta específicamente para satisfacer las necesidades de su informe.

Para obtener más información sobre las consultas, siga los vínculos de la sección Vea también de este artículo.

Iniciar el Asistente para informes

  1. En la ficha crear, en el grupo informes, haga clic en Asistente para informes. Imagen del botón

    Access inicia el Asistente para informes.

    Selección de campo en el Asistente para informes

  2. Haga clic en la lista desplegable Tablas y consultas y elija la tabla o consulta que contenga los campos que desee incluir en el informe.

  3. Haga doble clic en los campos de la lista Campos disponibles para elegirlos.

    Access los mueve a la lista Campos seleccionados. Asimismo, puede hacer clic en los botones situados entre el cuadro Campos disponibles y el cuadro Campos seleccionados para agregar o quitar el campo seleccionado, o para agregar o quitar todos los campos.

  4. Si otra tabla o consulta contiene campos que también desea incluir en el informe, haga clic en la lista desplegable Tablas y consultas, elija la otra tabla o consulta y siga agregando campos.

  5. Haga clic en Siguiente cuando termine de agregar los campos.

Agrupar registros en el Asistente para informes

El agrupamiento permite organizar los registros por grupo, por ejemplo, por Región o por Vendedor. Los grupos se pueden anidar para poder identificar fácilmente las relaciones entre los grupos y buscar rápidamente la información necesaria. El agrupamiento también se puede utilizar para calcular información de resumen, como totales y porcentajes.

Cuando incluye más de una tabla en un informe, el asistente examina las relaciones entre las tablas y determina cómo puede presentar el usuario la información.

  1. En la página del Asistente para informes en la que se pregunta ¿Desea agregar algún nivel de agrupamiento?, haga clic en uno de los nombres de campo de la lista y, a continuación, haga clic en Siguiente.

  2. Para agregar niveles de agrupamiento, haga doble clic en cualquiera de los nombres de campo de la lista para agregarlo al informe.

    Asimismo, puede quitar un nivel de agrupamiento haciendo doble clic en el nivel en la página situada a la derecha del cuadro de diálogo. Use los botones de flecha para agregar y quitar niveles de agrupamiento, y ajuste la prioridad de un nivel de agrupamiento seleccionándolo y haciendo clic en los botones de prioridad. Access agrega cada nivel de agrupamiento y lo muestra anidado dentro de su nivel de agrupamiento primario.

    Agregar niveles de agrupamiento en el Asistente para informes

  3. Haga clic en Opciones de agrupamiento para mostrar el cuadro de diálogo Intervalos de agrupamiento.

    Agrupar intervalos en el Asistente para informes

  4. Si así lo quiere, elija para cada campo de nivel de grupo un intervalo de agrupamiento.

    El intervalo de agrupamiento permite personalizar cómo se agrupan los registros. En la ilustración anterior, los registros se agrupan en el campo FechaEnvío, que es una fecha y hora de datos tipo. El Asistente para informes ofrece opciones apropiadas para el tipo de campo en la lista de intervalos de agrupamiento. Por lo tanto, porque FechaEnvío es un tipo de fecha y hora, puede optar por agrupar por el valor real (Normal), año, trimestre, mes, semana, día, hora y minuto. Si el campo fuese un tipo de datos de texto, puede elegir agrupar todo el campo (Normal), o por los primeros caracteres de uno a cinco. Para un tipo de datos numéricos, puede elegir Agrupar por valor (Normal) o por intervalo en incrementos seleccionados.

    Tras seleccionar un intervalo de agrupamiento, haga clic en Aceptar.

  5. Haga clic en Siguiente para pasar a la siguiente página del asistente.

Ordenar y resumir registros

Puede ordenar los registros por un máximo de cuatro campos, ya sea en orden ascendente o descendente.

  1. Haga clic en la primera lista desplegable y elija el campo por el que desee ordenar.

    Puede hacer clic en el botón situado a la derecha de la lista para cambiar de orden ascendente a descendente, y viceversa (Ascendente es el valor predeterminado). De manera opcional, haga clic en la segunda, tercera y cuarta lista desplegable para elegir más campos de ordenación.

    Criterios de ordenación en el Asistente para informes

  2. Haga clic en Opciones de resumen si desea resumir alguno de los campos numéricos.

    Observe que el botón Opciones de resumen solo estará visible si hay uno o varios campos numéricos en la sección Detalle del informe. El asistente muestra los campos numéricos disponibles.

    Opciones de resumen en el Asistente para informes

  3. Active la casilla de verificación en Suma, Promedio, Mín o Máx que desee para incluir esos cálculos en el pie de grupo.

    Asimismo, puede optar por mostrar los detalles y el resumen o solo el resumen. En el último caso, se mostrarán los totales correspondiente a cada valor Fecha de envío (por ejemplo, si ha seleccionado la casilla de verificación de Suma), pero se omitirán los detalles de los pedidos. También puede optar por mostrar un porcentaje de los cálculos totales de las sumas.

  4. Haga clic en Aceptar.

  5. Siga las instrucciones en las páginas restantes del Asistente para informes. En la última página, puede editar el título del informe, que se mostrará en la primera página del informe. Además, Access guardará el informe con el título como nombre del documento. Puede modificar tanto el título como el nombre de documento posteriormente si es necesario.

  6. Haga clic en Finalizar. Access guarda automáticamente el informe y lo muestra en la Vista preliminar, donde se ve el informe tal y como quedará una vez impreso.

Puede utilizar los botones de desplazamiento situados en la parte inferior del Panel de vista previa para ver secuencialmente las páginas del informe o ir a cualquier página del informe. Haga clic en uno de los botones de desplazamiento o escriba el número de página que desee ver en el correspondiente cuadro y, a continuación, presione ENTRAR.

En la vista preliminar, puede acercar para ver detalles o alejar para ver cómo se colocación los datos en la página. Con el puntero del mouse sobre el informe, haga clic una vez. Para invertir el efecto del zoom, haga clic en nuevo. También puede usar el control de zoom en la barra de estado.

Volver al principio

Ajustar el informe

Es probable que el Asistente para informes no generarán los resultados exactos que está buscando en el informe. Por ejemplo, es podrán que desee agregar texto, ajuste los anchos de columna, agregar un logotipo, etcetera. Access proporciona dos vistas en el que puede realizar modificaciones en el informe: la vista Diseño y la vista Diseño. Se describen brevemente en esta sección.

Acerca de la vista de diseño

Vista presentación es la vista más fácil de usar para realizar cambios en el informe y proporciona la mayoría de las herramientas que necesita para ajustar con precisión el informe. Puede ajustar el ancho de columna, reorganizar las columnas y agregar o modificar los niveles de agrupación y totales. Puede incluir campos nuevos en el diseño del informe y configurar las propiedades para el informe y sus controles. La ventaja de vista de diseño es que puede ver los datos al hacer cambios en el formato del informe, para que pueda ver inmediatamente cómo afectan los cambios a la presentación de los datos.

Para abrir un informe en la vista Diseño, haga clic en el informe en el panel de navegación y, a continuación, haga clic en vista Diseño Imagen del botón .

Puede usar la hoja de propiedades para modificar las propiedades del informe y sus controles y secciones. Para mostrar la hoja de propiedades, presione F4.

Puede usar el panel Lista de campos para agregar campos de la tabla o consulta subyacente al diseño del informe. Para mostrar el panel Lista de campos:

  1. En la ficha formato, en el grupo controles, haga clic en Agregar campos existentes Imagen del botón .

    Sugerencia: Access 2010 incluye nuevas características de formato condicional que pueden mejorar la legibilidad de un informe.

Acerca de la vista Diseño

Si no puede realizar un cambio específico en el informe en la vista Diseño, pruebe la vista Diseño. La vista Diseño muestra la estructura subyacente del informe y proporciona que algunas diseñen más capacidades y herramientas de la vista Diseño. Por ejemplo, puede colocar una mayor variedad de controles en el informe, puede ajustar la alineación de los controles con más precisión y tiene la capacidad para establecer más propiedades que en la vista Diseño.

Para abrir un informe en la vista Diseño, haga clic en el informe en el panel de navegación, haga clic en Vista Diseño Imagen del botón .

Volver al principio

Agregar campos u otros controles a un informe existente

Cada campo, etiqueta, línea o imagen que ve en el informe se crea con algún tipo de control. El control usados con mayor frecuencia en un informe es el cuadro de texto. Esto es lo que normalmente se usa para mostrar los datos de origen de registros del informe. Puede crear cuadros de texto que ya están enlazados a campos del origen de registros agregando campos desde el panel Lista de campos, o puede agregarlos al informe mientras trabaja en la vista Diseño (pero, a continuación, debe "enlazarlos" a los campos del origen de registros usted mismo). La ventaja de diseño de la vista es que puede agregar muchos otros tipos de controles aparte de enlazado cuadros de texto, como rectángulos, saltos de página y gráficos. Esta sección describen dos métodos para agregar controles a un informe.

Agregar campos a un informe existente

Vista de diseño es la vista recomendada para agregar campos a un informe, pero también puede hacerse en la vista Diseño. Para agregar un campo, asegúrese de que se muestra el panel Lista de campos. El panel Lista de campos contiene una lista de todos los campos que están disponibles en el informe. Para mostrar el panel Lista de campos, presione ALT+F8.

Agregar campos desde el panel Lista de campos

  • Para agregar un solo campo, arrastre el campo desde el panel Lista de campos a la sección del informe donde desee que se muestre.

  • Para agregar varios campos a la vez, haga clic en el primer campo que desee y, a continuación, mantenga presionada la tecla CTRL y haga clic en cada campo adicional que desee. A continuación, arrastre los campos seleccionados hasta el informe.

Al colocar los campos, Access crea un control de cuadro de texto dependiente para cada campo y coloca automáticamente un control de etiqueta junto a cada campo.

Nota: 

  • Si agrega un campo de una tabla relacionada, Access agregará el nivel de agrupamiento adecuado para usted.

  • Si agrega un campo de otra tabla (no relacionada), Access muestra un cuadro de diálogo donde puede especificar cómo relacionar la tabla con el origen de datos existente para el informe.

Para ver las relaciones de tabla ya se han especificado para la base de datos, o para agregar nuevos:

  1. En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en relaciones. Imagen del botón

Para obtener más información, vea el artículo crear, modificar o eliminar una relación.

Agregar otros controles a un informe existente

Al agregar un campo desde el panel Lista de campos al informe, se crea automáticamente un control de cuadro de texto dependiente para el mismo. Cambiar a la vista Diseño y con las herramientas del grupo controles en la pestaña Diseño pueden agregar otros controles, como etiquetas, líneas e imágenes.

Imagen de la cinta de Access

Determinar el nombre de una herramienta

  • Coloque el puntero del mouse sobre la herramienta.

    Access muestra el nombre de la herramienta.

Crear un control mediante las herramientas del grupo controles

  • Haga clic en la herramienta para el tipo de control que desee agregar. Por ejemplo, para crear una casilla de verificación, haga clic en la herramienta de casilla de verificación Imagen del botón .

  • Haga clic en el diseño del informe donde desea colocar la esquina superior izquierda del control. Haga clic una vez para crear un control de tamaño predeterminado, o haga clic y arrastre en el informe para crear un control del tamaño que desee.

  • Si no coloca el control perfectamente al primer intento, puede mover mediante el procedimiento siguiente:

    • Haga clic en el control para seleccionarlo.

    • Sitúe el puntero sobre el control hasta que se convierta en una flecha de cuatro puntas Puntero de desplazamiento y, a continuación, arrastre el control a la ubicación deseada.

Este proceso crea un control "independiente". Si el control es el tipo que puede mostrar datos (un cuadro de texto o una casilla de verificación, por ejemplo), debe escribir un nombre de campo o una expresión en la propiedad Origen del Control del control que muestre los datos.

Mostrar la hoja de propiedades

  • Presione F4.

Nota: Una vez completado el nuevo informe, asegúrese de guardar el trabajo.

Volver al principio

Agregar o modificar el agrupamiento y la ordenación en un informe existente

Si ya tiene un informe y desea ordenarlo o agruparlo, o bien, desea modificar la ordenación o el agrupamiento existente del informe, esta sección le ayuda a hacerlo.

Agregar agrupamiento, ordenación y totales en la vista Diseño

Puede realizar sencillas de ordenación, agrupamiento y operaciones haciendo clic en los campos en la vista presentación y eligiendo la operación que desee en el menú contextual. Para cambiar a la vista Diseño, haga clic en el informe en el panel de navegación y, a continuación, haga clic en vista Diseño Imagen del botón .

Nota: Si bien en las instrucciones descritas en esta sección no se utiliza directamente el panel Agrupación, orden y total, se recomienda abrir el panel y observar cómo cambia mientras está trabajando. De este modo, comprenderá mejor lo que hace Access y, a medida que le resulte más fácil trabajar con el panel Agrupación, orden y total, podrá utilizarlo para aplicar más ajustes al informe. Para mostrar el panel Agrupación, orden y total:

  1. En la ficha formato, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

Ordenar por un solo campo

  • Haga clic en cualquier valor del campo que desea ordenar.

  • En el menú contextual, haga clic en la opción de ordenación que desee. Por ejemplo, para ordenar un campo de texto en orden ascendente, haga clic en Ordenar de A Z Imagen del botón . Para ordenar un campo numérico en orden descendente, haga clic en Ordenar de mayor a menor Imagen del botón .

Access ordena el informe de acuerdo según lo haya especificado. Si está abierto el panel Agrupación, orden y total, podrá ver que se ha agregado una nueva línea Ordenar por para el campo.

Ordenar por varios campos

Nota: Al aplicar la ordenación haciendo doble clic en un campo en la vista Diseño, solo puede ordenar un campo a la vez. Aplicar la ordenación a otro campo, quita la ordenación en el primer campo. Esto difiere el comportamiento de ordenación en los formularios, donde se pueden establecer varios criterios de ordenación haciendo clic en cada campo por separado y elegir el criterio de ordenación que desee. Para crear varios niveles de ordenación, vea la sección Agregar agrupamiento, ordenación y totales mediante el grupo, orden y Total panel.

Agrupar en un campo

  • Haga clic con el botón secundario en cualquier valor del campo en el que desee agrupar.

  • En el menú contextual, haga clic en Agrupar en Imagen del botón .

Access agrega el nivel de agrupamiento y crea un encabezado de grupo para ese nivel. Si está abierto el panel Agrupación, orden y total, podrá ver que se ha agregado una nueva línea Agrupar en para el campo.

Agregar un total a un campo

Esta opción permite calcular una suma, un promedio, una cuenta u otro agregado para un campo. Se agregará un total general al final del informe y se agregarán totales de grupo a todos los grupos del informe.

  • Haga clic con el botón secundario en cualquier valor del campo para el que desee calcular el total.

  • Haga clic en Total.

  • Haga clic en la operación que desea realizar: Suma, Promedio, Incluir registros (para contar todos los registros), Incluir valores (para contar solo los registros con un valor en este campo), Máx, Mín, Desviación estándar o Varianza.

Access agrega un control de cuadro de texto calculado al pie del informe, lo que crea un total general. Si el informe tiene niveles de agrupamiento, Access agrega pies de grupo (si aún no los hay) y coloca el total en cada pie.

Puede también agregar totales haciendo clic en el campo que desea calcular el total y, a continuación, en la ficha formato, en el grupo agrupación y totales, haga clic en totales Imagen del botón .

Agregar agrupamiento, ordenación y totales mediante el panel Agrupación, orden y total

El panel Agrupación, orden y total aporta la mayor flexibilidad cuando desea agregar o modificar las opciones de agrupamiento, criterios de ordenación o totales de un informe. Una vez más, la vista Presentación es la vista preferida para trabajar, ya que es mucho más fácil ver cómo afectan los cambios a la presentación de los datos.

Mostrar el panel Agrupación, orden y total

  • En la vista presentación:

    En la ficha formato, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

  • En la vista Diseño:

    En la ficha Diseño, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

Access muestra el panel agrupación, orden y Total.

Panel Agrupación, orden y total

Para agregar un nuevo nivel de ordenación o agrupamiento, haga clic en Agregar un grupo o Agregar un orden.

Se agrega una nueva línea al panel Agrupación, orden y total, y se muestra una lista de los campos disponibles.

Lista de campos en el panel Agrupación, orden y total

Puede hacer clic en uno de estos nombres de campo o puede hacer clic en expresión debajo de la lista de campos para escribir una expresión. Una vez que elija un campo o escriba una expresión, Access agrega el nivel de agrupación al informe. Si está en la vista presentación, la presentación cambia inmediatamente para mostrar la agrupación o criterio de ordenación.

Notas: 

  • Si ya se han definido varios niveles de ordenación o agrupamiento, es posible que tenga que desplazarse hacia abajo por el panel Agrupación, orden y total para poder ver los botonesAgregar un grupo y Agregar un orden.

  • Puede definir hasta 10 niveles de agrupamiento y ordenación en un informe.

Cambiar las opciones de agrupamiento

Cada nivel de ordenación o agrupamiento tiene varias opciones que se pueden establecer para obtener los resultados deseados.

Opciones de agrupamiento

  • Para mostrar todas las opciones de un nivel de agrupamiento u ordenación, haga clic en Más en el nivel que desee cambiar.

    Opciones de agrupamiento (expandido)

  • Para ocultar las opciones, haga clic en Menos.

Criterio de ordenación    Para cambiar el criterio de ordenación, haga clic en la lista desplegable de criterios de ordenación y, a continuación, haga clic en la opción que desee.

Intervalo del grupo    Este valor determina cómo se agrupan juntos los registros. Por ejemplo, puede agrupar por el primer carácter de un campo de texto de modo que se agrupen todas las entradas que comiencen por "A", todos los valores que comiencen por "B", y así sucesivamente. En el caso de un campo de fecha, puede agrupar por día, semana, mes, trimestre, o bien, puede especificar un intervalo personalizado.

Totales    Para agregar totales, haga clic en esta opción. Puede agregar totales en varios campos y agregar varios tipos de totales en el mismo campo.

Ventana emergente de totales

  • Haga clic en la flecha desplegable de Total de y seleccione el campo que desee resumir.

  • Haga clic en la flecha desplegable de Tipo y seleccione el tipo de cálculo que desee realizar.

  • Seleccione Mostrar total general para agregar un total general al final del informe (en el pie del informe).

  • Seleccione Mostrar totales de grupo como % de Total general para agregar un control al pie de grupo que calcula el porcentaje del total general de cada grupo.

  • Seleccione Mostrar en encabezado de grupo o Mostrar en pie de grupo para mostrar el total en el lugar deseado.

Una vez elegidas todas las opciones para un campo, puede repetir el proceso y resumir otro campo seleccionándolo en la lista desplegable Total de. De lo contrario, haga clic fuera de la ventana emergente Totales para cerrarla.

Título    Permite cambiar el título del campo que está resumiendo. Se utiliza para el encabezado de columna y las etiquetas de los campos de resumen en los encabezados y pies.

Para agregar o modificar el título:

  • Haga clic en el texto azul detrás de con título.

    Aparecerá el cuadro de diálogo Zoom.

  • Escriba el nuevo título en el cuadro de diálogo y haga clic en Aceptar.

Con/sin una sección de encabezado    Utilice esta opción para agregar o quitar la sección de encabezado que precede a cada grupo. Cuando agrega una sección de encabezado, Access mueve el campo de agrupamiento hasta el encabezado. Cuando quita una sección de encabezado que contiene controles que no sean el campo de agrupamiento, Access le pide que confirme si desea eliminar los controles.

Con/sin una sección de pie    Utilice esta opción para agregar o quitar la sección de pie que aparece después de cada grupo. Al quitar una sección de pie que contiene controles, Access le pide que confirme si desea eliminar los controles.

Mantener junto el grupo    Esta opción determina cómo se distribuyen los grupos en la página al imprimir el informe. Quizás desee mantener los grupos en una página para evitar lo máximo posible que haya que dar la vuelta a las páginas para poder ver los grupos en su totalidad. Sin embargo, esto suele aumentar la cantidad de papel necesario para imprimir el informe, ya que la mayoría de las páginas presentarán espacios en blanco en la parte inferior.

  • No mantener junto el grupo en una página    Utilice esta opción si no le importa que los grupos se dividan por los saltos de página. Por ejemplo, un grupo de 30 elementos puede tener 10 elementos en la parte inferior de una página y los 20 restantes en la parte superior de la siguiente página.

  • ¿Desea mantener todo el grupo en una página?     Esta opción ayuda a minimizar el número de saltos de página en un grupo. Si un grupo no cabe en el espacio restante de una página, Access deja ese espacio en blanco y coloca el grupo en la siguiente página. Es posible que los grupos de gran tamaño sigan abarcando varias páginas, pero esta opción minimiza en la medida de lo posible el número de saltos de página dentro del grupo.

  • Mantener el encabezado y el primer registro juntos en una página     En el caso de los grupos con encabezados de grupo, esta opción asegura que el encabezado de grupo no se imprimirá automáticamente en la parte inferior de una página. Si Access determina que no hay espacio suficiente para que se imprima al menos una fila de datos después del encabezado, el grupo se colocará en la siguiente página.

Cambiar la prioridad de los niveles de agrupamiento y ordenación

Para cambiar la prioridad de un nivel de agrupamiento o de ordenación, haga clic en el fila del panel Agrupación, orden y total y, a continuación, en la flecha arriba o flecha abajo a la derecha de la fila.

Eliminar niveles de agrupamiento y ordenación

Para eliminar un nivel de agrupamiento o de ordenación, haga clic en la fila que desea eliminar en el panel Agrupación, orden y total y presione SUPRIMIR o haga clic en el botón Eliminar a la derecha de la flecha. Al eliminar un nivel de agrupamiento, si el campo de agrupamiento estaba en el encabezado o pie de grupo, Access lo mueve a la sección Detalle del informe. Se eliminan todos los controles incluidos en el encabezado o pie de grupo.

Volver al principio

Crear un informe de resumen (sin detalles de registros)

Si desea mostrar sólo totales (es decir, sólo la información de las filas de encabezado y pie de página), en la ficha formato (o en la ficha Diseño en la vista Diseño), en el grupo agrupación y totales, haga clic en Ocultar detalles. Esto oculta los registros en el siguiente nivel inferior de agrupamiento, es el resultado de una presentación de manera más compacta los datos de resumen. Aunque los registros están ocultos, no se eliminan los controles en la sección oculta. Haga clic en Ocultar detalles para restaurar las filas de detalle en el informe.

Crear un efecto de agrupamiento sin encabezados

Puede lograr un efecto de agrupamiento en el informe sin el uso de encabezados. Quitar encabezados, crea un informe más compacto porque se utiliza menos espacio vertical por las líneas de encabezado.

El procedimiento general implica quitar el encabezado de cada grupo, que mueve cada campo de agrupamiento en la sección de detalles del informe. Para restaurar el efecto de agrupamiento visual, se establece la propiedad Ocultar duplicados de cada campo de agrupamiento en .

Ejemplo

Tenga en cuenta este informe agrupado que usa los encabezados de grupo:

Informe agrupado con encabezados de grupo

Como puede ver, cada nombre de compañía ocupa una línea completa, como sucede en cada Id.

En este ejemplo, va a modificar el informe para que tenga un aspecto similar a la siguiente ilustración:

Informe agrupado con encabezados de grupo quitados

  1. Abra el informe en la vista presentación haciendo clic con botón secundario en el panel de navegación y haga clic en Vista Diseño Imagen del botón .

  2. En la ficha formato, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

    Nota: Es conveniente empezar con el grupo de nivel inferior; en caso contrario, la presentación del informe le resulte confusa mientras está trabajando.

  3. Haga clic en el nivel de agrupamiento inferior en la lista y, a continuación, haga clic en más.

  4. En la lista desplegable de secciones de encabezado, seleccione sin una sección de encabezado.

    Cuando se quita un encabezado, Access conserva el cuadro de texto para el campo de agrupamiento moviéndolo a la sección de detalles. Sin embargo, puede que se elimine cualquier otro control en el encabezado del grupo. Access le avisa si todos los controles se van a eliminar como resultado de esta acción. Si hay controles en el encabezado del grupo que desea conservar, asegúrese de mover a otra sección del informe antes de realizar este paso. Debe cambiar a la vista Diseño para mover los controles a otras secciones.

    El informe resultante se muestra en la siguiente ilustración. Observe que el primer IdPedido está en la misma línea que el primer registro de detalle, en lugar de en su propia línea.

    Informe agrupado con encabezados de IdPedido quitados

    Desgraciadamente, el IdPedido se repite en cada línea de detalle y esto dificulta ver exactamente cuántos pedidos hay. En este momento, la configuración de propiedad de Ocultar duplicados del control de cuadro de texto es útil. Siga estos pasos para establecer esta propiedad:

    • Seleccione uno de los valores de repetición.

    • Si actualmente no se muestra la hoja de propiedades, presione F4 para mostrarla.

    • En la ficha formato de la hoja de propiedades, haga clic en la lista desplegable correspondiente a Ocultar duplicados y, a continuación, haga clic en .

      Los identificadores de pedido duplicados están ocultas. Tenga en cuenta que puede ver cuántos pedidos hay y cuántos productos hay por pedido.

      Informe agrupado con IdPedidos duplicados ocultos

  5. En este ejemplo se repita el paso 4 para el nivel de agrupación de nombre de la compañía. El informe final es similar a la siguiente ilustración:

    Informe agrupado con encabezados de grupo quitados

    El valor de nombre de la empresa está ahora en la misma línea que el primer registro de detalle y la propiedad Ocultar duplicados impide que el valor de nombre de compañía se repita en cada línea. Para un informe de tiempo que usa varios niveles de agrupamiento, esto puede dar lugar a un ahorro de papel significativa.

Volver al principio

Guardar, imprimir o enviar el informe

Después de guardar el diseño del informe, puede usarlo varias veces. El diseño del informe sea la misma, pero puede ver los datos actuales cada vez que se imprima el informe. Si cambian los informes que necesita, puede modificar el diseño de informe o crear un nuevo informe similar que se basa en el original.

Guardar el informe

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y luego en Guardar o presione CTRL+G Imagen del botón .

    Como alternativa, puede hacer clic en Guardar Imagen del botón en la Barra de herramientas de acceso rápido.

  2. Si el informe no tiene título, escriba un nombre en el cuadro Nombre del informe y, a continuación, haga clic en Aceptar.

Guardar el diseño de informe con un nombre nuevo

  1. Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Guardar como Imagen del botón .

  2. En el cuadro de diálogo Guardar como, escriba un nombre en el cuadro Guardar informe en, haga clic en el informe en el cuadro como y, a continuación, haga clic en Aceptar.

Imprimir el informe

Puede imprimir un informe desde la vista preliminar, la vista Diseño, la vista Diseño, la vista informe o desde el panel de navegación. Antes de imprimir, debería revisar configuración de página, como márgenes y la orientación de página. Access guarda la configuración de página con el informe, por lo que necesitará establecerlas solo una vez. Puede guardar la configuración más adelante, si cambian sus necesidades.

Cambiar la configuración de página

  1. Abra el informe en cualquier vista.

  2. En la ficha Diseño de página, en el grupo de la página, haga clic en una opción:

    • Tamaño Imagen del botón le permite seleccionar un número de tamaños de papel o escribir un tamaño de papel personalizado.

    • Vertical Imagen del botón orientar la página verticalmente.

    • Horizontal Imagen del botón orientar la página horizontalmente.

    • Márgenes Imagen del botón le permite seleccionar entre varios anchos de margen predefinidos, o puede hacer clic en Avanzadas para especificar anchos de margen personalizados mediante el cuadro de diálogo Configurar página.

    • Mostrar márgenes activa o desactiva la presentación de los márgenes y desactivar (solo en la vista Diseño).

    • Columnas muestra el cuadro de diálogo Configurar página. Escriba el número de columnas y el tamaño de la columna que desee y, a continuación, haga clic en Aceptar.

    • Imprimir sólo los datos anula la impresión de las etiquetas que haya en el informe. Solo los controles que se enlazan a los datos de la tabla o consulta que se va a imprimir. Esta característica puede ser útil para los informes que se imprimen ocasionalmente en formularios preimpresos. Puede suprimir la impresión de etiquetas en las situaciones y, a continuación, habilite la impresión de etiquetas al imprimir el informe en papel en blanco.

Nota: Para usar la configuración más detallada de la página, haga clic en el botón de Configuración de página en la esquina inferior derecha del grupo Diseño de página para mostrar el cuadro de diálogo Configurar página. Puede usar el cuadro de diálogo Configurar página para ajustar todas las opciones que están disponibles en la ficha Diseño de página así como para seleccionar una impresora específica para el informe.

Enviar el informe a una impresora

  1. Abra el informe en cualquier vista, o seleccione el informe en el panel de navegación.

  2. Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Imprimir. Botón Imprimir

  3. En el cuadro de diálogo Imprimir, especifique las opciones deseadas, como la impresora, el intervalo de impresión y el número de copias.

  4. Haga clic en Aceptar.

Volver al principio

Enviar el informe como mensaje de correo electrónico

Puede enviar el informe a los usuarios como mensaje de correo electrónico en lugar de imprimir una copia en papel.

  1. En el panel de navegación, haga clic en el informe para seleccionarlo, haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en correo electrónico Imagen del botón .

  2. En el cuadro de diálogo Enviar objeto como, haga clic en el formato de archivo que desea usar.

    Cuadro de diálogo Enviar objeto como

  3. Complete los cuadros de diálogo restantes.

  4. Cuando aparezca el programa de correo electrónico, escriba los detalles del mensaje y envíe el mensaje.

Volver al principio

Observaciones

Puede surgir un problema si tiene un informe en un archivo .accdb que ordena o grupos en un campo de búsqueda y desea importar este informe a un archivo .mdb y, a continuación, ábralo con una versión anterior de Access.

El método interno por el que los campos de búsqueda son ordenados y agrupados en archivos .accdb es incompatible con archivos .mdb. Si crea un informe en un .accdb archivo que usa agrupamiento u ordenación en un campo de búsqueda y, a continuación, exportar a un archivo .mdb (o utilice el comando Guardar como para guardar la base de datos como un archivo .mdb) y, a continuación, intente abrir el informe con una versión anterior de Access , el informe no se cargará.

Para revisar el informe para que pueda importarlo a un archivo .mdb y abrirlo en una versión anterior de Access, haga lo siguiente:

  1. En el archivo .accdb, cree una copia del informe.

  2. Abra la copia del informe en la vista Diseño.

  3. Si no se muestra el panel agrupación, orden y Total:

    1. En la ficha formato, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

  4. Eliminar todas las líneas en el panel agrupación, orden y Total haciendo clic en el botón Eliminar a la derecha de cada línea.

  5. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y luego en Guardar o presione CTRL+G Imagen del botón .

  6. Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Cerrar base de datos. Imagen del botón

  7. Haga clic en el Botón de Microsoft Office Imagen del botón de Microsoft Office y, a continuación, haga clic en Abrir. Imagen del botón

  8. Busque el archivo .mdb al que desea importar el informe y, a continuación, haga clic en Abrir.

  9. Importar la copia del informe en el archivo .mdb.

    ¿Cómo?

    1. En la pestaña Datos externos, en el grupo Importar, haga clic en Access. Imagen del botón

    2. Haga clic en Examinar.

    3. Vaya al archivo .accdb que contiene el informe y haga clic en Abrir.

    4. No está importando las tablas en este momento, por lo que no importa si elige importar o vincular a los datos de origen. Haga clic en Aceptar para continuar.

    5. En el cuadro de diálogo Importar objetos, haga clic en la pestaña informes.

    6. Haga clic en el informe que desea importar y, a continuación, haga clic en Aceptar.

    7. Si la operación de importación se realiza correctamente, Access le pregunta si desea guardar los pasos de importación para su uso posterior. Si desea guardar los pasos, active la casilla de verificación Guardar los pasos de importación, escriba la información solicitada y haga clic en Guardar importación. Si no desea guardar los pasos, haga clic en Cerrar.

      Access importa el informe y lo muestra en el panel de navegación.

  10. Abra el informe en la vista Diseño.

  11. Si no se muestra el panel Lista de campos:

    1. En la ficha formato, en el grupo controles, haga clic en Agregar campos existentes Imagen del botón .

  12. En el panel campos disponibles en tablas relacionadas, busque la tabla que contiene el campo que desee mostrar en el informe. Este campo contendrá los mismos valores que ve actualmente en el campo de búsqueda en el informe.

  13. Arrastre el campo al informe.

    Ahora tiene dos columnas que muestra la misma información.

  14. Haga clic en el campo para mostrar que acaba de agregar y haga clic en la opción de ordenación que desee usar.

  15. Eliminar el campo de visualización que acaba de agregar y ordenar.

  16. Si no se muestra el panel agrupación, orden y Total:

    1. En la ficha formato, en el grupo agrupación y totales, haga clic en Agrupar y ordenar. Imagen del botón

  17. Haga clic en Agregar un grupo.

  18. En la ventana emergente de Campo o expresión, haga clic en el nombre del campo de búsqueda en el informe.

El informe ahora está ordenado y agrupado tal y como era en el archivo ACCDB. Guarde y cierre el informe.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×