Crear un diagrama del visualizador de datos

¿Quiere crear automáticamente un diagrama de flujo de Visio detallado y refinado de un libro de Excel? Puede hacerlo con las plantillas del Visualizador de datos. Cada plantilla cuenta con un libro de Excel asociado que se usa para convertir datos del proceso en un diagrama de flujo de Visio. También puede obtener una plantilla de Excel personalizada, especificar asignaciones en el Asistente para plantillas y crear automáticamente el diagrama. Una vez que haya creado el diagrama de flujo, podrá agregar, editar o eliminar filas en Excel y, después, actualizar el diagrama de Visio. Incluso puede agregar columnas de datos adicionales en Excel que se convierten en datos de formas de Visio. El Visualizador de datos es compatible con Visio Pro para Office 365.

Información general del visualizador de datos

La posibilidad de usar las plantillas del Visualizador de datos solo está disponible con Visio Pro para Office 365 en el canal de publicación actual. Si no está seguro de qué versión de Visio usa, seleccione Archivo > Cuenta > Acerca de Visio. Vea Visio Pro para Office 365 para obtener más información sobre la versión de suscripción de Visio.

Si no ve las plantillas del Visualizador de datos o si tiene preguntas sobre cómo empezar a trabajar, visite la página Preguntas más frecuentes de Visualizador de datos.

Nota: Para utilizar esta característica, debe tener una suscripción a Office 365. Si es suscriptor de Office 365, asegúrese de tener instalada la versión más reciente de Office. Si es un profesional de TI que administra el proceso de actualización de Office 365, consulte la página de versiones de canal para obtener información sobre las actualizaciones que se proporcionan en cada canal.

En este artículo

Crear un diagrama del visualizador de datos

Antes de empezar

Recopile sus ideas y anótelas en un borrador en papel o en entradas de lápiz. Este borrador puede ayudarle a empezar el trabajo y a seguir los pasos de forma más sencilla.

Para crear un diagrama de visualizador de datos, puede trabajar al mismo tiempo en Excel y Visio. Puede que le resulte más fácil trabajar en dos ventanas en el dispositivo de Windows o en un entorno de varios monitores. Comparar visualmente los cambios realizados entre Excel y Visio le ayudará a confirmar que está haciendo lo que quiere hacer.

Fase 1: Elegir una plantilla de visualizador de datos

  1. Abra Visio, o bien seleccione Archivo > Nuevo si está editando un diagrama.

  2. Seleccione PLANTILLAS.

    El comando PLANTILLAS
  3. Seleccione Diagrama de flujo.

    El comando Diagrama de flujo
  4. Seleccione Diagrama de flujo básico: visualizador de datos o Diagrama de flujo de funciones cruzadas: visualizador de datos.

    Las plantillas de visualizador de datos

    Una plantilla de visualizador de datos tiene un icono de Excel en la esquina superior izquierda.

Para obtener más información sobre los diagramas de flujo y sus formas, consulte Crear un diagrama de flujo básico y Crear un diagrama de flujo de funciones cruzadas.

Fase 2: Crear un libro de Excel

  1. En la vista previa de la plantilla, seleccione Plantilla de datos de Excel.

    Seleccionar el vínculo de la plantilla de datos de Excel

    Tenga en cuenta que si desea usar las mismas plantillas de Excel de ejemplo usadas en este artículo para referencia, puede descargarlas desde los siguientes vínculos:

  2. Seleccione Archivo > Guardar, especifique el equipo, servidor de red o biblioteca de documentos de SharePoint, escriba un nombre de archivo y, después, pulse Guardar.

  3. Para agregar una nueva hoja de cálculo, en la parte inferior del libro, seleccione Hoja nueva Botón Nueva hoja .

  4. Crear una tabla de Excel Para obtener más información acerca del uso de las tablas de Excel, vea Descripción general de las tablas de Excel, Crear o eliminar una tabla de Excel, y Cambiar el tamaño de una tabla agregando o quitando filas y columnas.

  5. Agregar a la tabla filas y columnas que se utilizan para crear el diagrama de Visio. Hay requisitos específicos para los valores y encabezados de columna de tabla de Excel. Utilice la sección Cómo interactúan las columnas de Excel con los componentes de diagrama de flujo de Visio como guía visual.

Fase 3: Agregar datos de forma adicionales a la tabla de Excel (opcional)

  1. Examine la pestaña Mapa de proceso en la plantilla de Excel. Las columnas de la tabla de Excel están coloreadas de verde y azul. El color proporciona una pista visual sobre la diferencia entre las columnas.

    Las columnas azules se usan para crear el diagrama de flujo del diagrama de Visio. También se agregan todas las columnas como datos de formas.

  2. Para agregar datos de formas adicionales, agregue una o más columnas a la tabla de Excel.

    Las columnas verdes indican los datos de forma adicionales que puede agregar a cada forma. Puede agregar columnas adicionales a la tabla. De forma predeterminada, estos datos no están visibles en el diagrama, a menos que agregue gráficos de datos. Para ver los datos de formas del diagrama de Visio, seleccione Datos > Ventana de datos de formas. Para obtener más información acerca de los datos de formas y gráficos de datos, vea Agregar datos a formas y Gráficos de datos, una descripción general.

Fase 4: Crear un diagrama de Visio con el asistente

  1. Vuelva a Visio, en la vista previa de plantilla, seleccione la unidad de medida y, a continuación, seleccione Crear.

  2. En la primera página del asistente Crear diagramas a partir de datos, haga lo siguiente:

    1. En Qué diagrama desea crear a partir de datos, seleccione una plantilla: Diagrama de flujo básico, Diagrama de funciones cruzadas (horizontal) o Diagrama de funciones cruzadas (vertical).

    2. En Seleccione el libro de Excel, seleccione un libro en una lista de los libros utilizados recientemente o seleccione Examinar para localizar el libro que creó en la fase 2.

    3. En Seleccionar una tabla o un rango personalizado en el libro, seleccione la tabla que contiene los datos del proceso de Excel.

    4. Seleccione Finalizar. Esto acepta todos los valores predeterminados que Visio rellena para las demás páginas del asistente.

Como resultado, se crea automáticamente el diagrama dentro de un contenedor. Las páginas adicionales de Visio se agregan en función del tamaño del diagrama de flujo.

Fase 5: Guardar el diagrama de Visio

  • Seleccione Archivo > Guardar, busque una ubicación, escriba un nombre de archivo y, a continuación, seleccione Guardar.

Es una buena idea mantener los archivos de Excel y Visio en la misma ubicación porque funcionan codo con codo.

Fase 6: Actualizar el diagrama

Después de crear un diagrama con visualizador de datos, puede que desee realizar cambios en él. Puesto que existen dos componentes de visualizador de datos, un libro de Excel y un diagrama de Visio, debe mantener su diagrama sincronizado con los cambios en los datos de la tabla de Excel al actualizar desde Visio. Es importante comprender que el proceso de sincronización es una operación unidireccional. En primer lugar actualiza los datos en Excel y, a continuación, actualiza el diagrama de Visio. Si hay diferencias entre los datos en Excel y Visio al actualizar, los datos en Excel tienen prioridad.

  1. Realizar cambios en los datos en la tabla de Excel. Puede agregar, actualizar o eliminar filas.

  2. Guardar el libro de Excel.

  3. En Visio, seleccione el contenedor del diagrama y, a continuación, seleccione Datos > Actualizar.

Como resultado, los cambios realizados en el libro de Excel se mostrarán en el diagrama de Visio. Actualizar solo realiza cambios en las formas y en las conexiones dentro del contenedor. Conservar todas las líneas conectoras y formas del diagrama dentro del contenedor. Si agrega manualmente una forma al contenedor y, a continuación, actualiza el diagrama, se elimina esa forma. Los objetos en la página que se encuentren fuera del contenedor no se ven afectados. Se conservan los cambios de formato que se realizan a las formas o a los conectores en el contenedor. Para más información acerca de los contenedores, Clarificar la estructura de diagramas mediante contenedores y listas.

Fase 7: Personalizar la interacción entre la tabla de Excel y el diagrama de Visio (opcional)

Hay ocasiones en que puede desear personalizar la creación de los diagramas de visualizador de datos. Por ejemplo, es posible que desee usar diferentes formas para cumplir con los estándares de la organización o asignar nombres de columna diferentes en la tabla de Excel.

  1. Cuando seleccione Crear para iniciar el asistente Crear diagramas a partir de datos y, después, escriba los valores en la primera página (vea la fase 4), seleccione Siguiente o Volver para mostrar cada página del asistente.

  2. Seleccione Ayuda (?) para obtener más información sobre cómo personalizar cada opción en la página. Para obtener más información, vea Usar el asistente para crear diagramas a partir de datos.

Principio de página

Cómo interactúan las columnas de Excel con los componentes de diagrama de flujo de Visio

Use el siguiente tutorial de la imagen para comprender cómo se utiliza cada columna de Excel para crear el diagrama de flujo de Visio.

Id. de paso de proceso   un número que identifica cada forma del diagrama de flujo. Esta columna es obligatoria, y cada valor de la tabla de Excel debe ser único y no puede estar vacío. Este valor no aparece en el diagrama de flujo.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Id. de paso del proceso

Descripción del paso del proceso   El texto se agregará a cada forma del diagrama de flujo.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Descripción del paso del proceso

Id. del paso siguiente   El Id. del paso del proceso de la forma siguiente en la secuencia. Una forma de bifurcación tiene dos pasos siguientes y se representa con números separados por comas como 4,5. Puede tener más de dos pasos siguientes.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Id. del siguiente paso

Etiqueta de conector   Para formas de bifurcación, las etiquetas de conector se representan como texto separado por comas, como Sí, No. Sí se corresponde con 4 y No corresponde a 5 en el ejemplo.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Etiqueta de conector

Tipo de forma   El tipo de forma que desea representar en el diagrama de Visio, como Proceso o Decisión. Microsoft recomienda usar las listas desplegables para ayudar a validar las opciones.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Tipo de forma

Función y fase    La función (o calle) y la fase (o en escala de tiempo) que pertenece a cada forma. Esta columna solo se aplica a un diagrama de flujo de funciones cruzadas y es ignorado por un diagrama de flujo básico.

Interacción del mapa de proceso de Excel con el diagrama de flujo de Visio: Función y fase

Principio de página

Usar otras galerías de símbolos para crear un diagrama de visualizador de datos

Además de usar las plantillas de diagrama de flujo básico y de funciones cruzadas, puede usar las galerías de símbolos de otras plantillas cuando se crea un diagrama de visualizador de datos. Por ejemplo, hay otras galerías de símbolos orientados a procesos como Diagrama de auditoría, Básicas de BPMN o Diagrama de flujo para Seis Sigma. Pero puede agregar formas desde cualquier galería de símbolos, como Mis formas.

  1. Abra un diagrama de visualizador de datos que ya haya creado.

  2. Agregue una o más galerías de símbolos al panel Formas.

    Por ejemplo, haga clic en Más formas y, después, seleccione Negocios > Proceso de negocios > Formas para diagramas de auditoría.

    Plantillas adicionales en el panel Formas
  3. En la pestaña Datos, haga clic en Crear para iniciar el asistente Crear diagrama a partir de datos.

  4. Haga clic en Siguiente hasta que se muestre la página Elegir una forma adecuada para cada valor que aparece en la columna "Tipo de forma".

  5. En el lado derecho de la página, seleccione la galería de símbolos que quiera en la lista, como Formas para diagramas de auditoría.

    Plantillas adicionales agregadas a la página del asistente

Aplicar gráficos de datos al diagrama

Puede mejorar el diagrama agregando gráficos de datos, que le ayuda a visualizar datos de formas en el diagrama. En efecto, puede convertir el diagrama en un panel de proceso en el que los gráficos de datos muestren la información de indicador clave de rendimiento (KPI) mediante iconos de gráficos de datos basados en los datos de la forma.

  1. Abra el diagrama del visualizador de datos.

    Seleccione el contenedor para el que desea aplicar gráficos de datos.

  2. Seleccione Datos > Campos de gráficos de datos.

  3. Seleccione los campos de gráficos de datos que desee aplicar al diagrama.

    Los gráficos de datos se aplican a todo el diagrama. Para ocultar los gráficos de datos para determinadas formas, mantenga los valores de la columna de datos en blanco en el libro de Excel para esas filas.

  4. Si lo desea, puede establecer opciones adicionales en la pestaña Datos.

Aplicar gráficos de datos para el diagrama de visualizador de datos de Visio

Principio de página

Pasos siguientes

Estas son algunas tareas que podría desee hacer después de crear un diagrama de visualizador de datos.

  • Temas    Un tema de Visio es un conjunto de colores y efectos que se puede aplicar a un dibujo con un solo clic. Los temas son una manera rápida de proporcionar un aspecto profesional y de diseño a los dibujos. Para obtener más información, vea Aplicar un aspecto profesional a los dibujos con los temas.

  • Diseño    Visio cuenta con guías manuales y herramientas automáticas para garantizar que las formas del diagrama están bien alineadas y espaciadas. Esto ayuda a que el dibujo sea lo más claro posible y tenga un aspecto organizado. Para obtener más información, vea Alinear y colocar las formas en un diagrama.

  • Exportar    Exporte un diagrama de visualizador de datos y el libro de Excel asociado a un paquete de plantilla de Visio (.vtpx). Un paquete de plantilla de Visio guarda la configuración de diagrama, galerías de símbolos y datos para que otros usuarios puedan usarlos como punto de inicio rápido para crear su propio diagrama de visualizador de datos. Otros usuarios pueden instalar el paquete de plantilla en sus equipos. Para obtener más información, consulte Exportar e instalar un paquete de plantilla de visualizador de datos.

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×