Crear un diagrama de flujo básico

Crear un diagrama de flujo básico

Los diagramas de flujo son diagramas que muestran los diferentes pasos de un proceso. Son fáciles de crear y, dado que las formas son simples y visuales, también son fáciles de interpretar.

Nota   : También puede crear automáticamente un diagrama de flujo básico de los datos con un diagrama de Visualizador de datos en Visio Pro para Office 365. Para obtener más información, vea Crear un diagrama de visualizador de datos.

La plantilla de diagrama de flujo básico de Visio incluye formas que se pueden usar para mostrar numerosos tipos de procesos y resulta particularmente útil para mostrar procesos de negocio básicos, como el proceso de desarrollo de propuestas ilustrado en la siguiente figura.

Ejemplo de un diagrama de flujo que muestra un proceso de propuesta

Además de la plantilla de diagrama de flujo básico, Visio ofrece una variedad de plantillas para tipos de diagramas más específicos, como diagramas de flujo de datos, escalas de tiempo y modelado de software. Para obtener más información sobre las diferentes plantillas, vea ¿Cómo se puede saber para qué sirve cada plantilla de Visio?.

Crear un diagrama de flujo
  1. Inicie Visio.

  2. Haga clic en la categoría Diagrama de flujo.

  3. Haga doble clic en Diagrama de flujo básico.

  4. En cada paso del proceso que esté documentando, arrastre un forma de diagrama de flujo al dibujo.

  5. Conecte las formas del diagrama de flujo sosteniendo el puntero del mouse sobre la primera forma y, después, haciendo clic en la flecha pequeña que aparece señalando a la forma a la que desea conectar. Si la segunda forma no está justo enfrente de la primera forma, haga clic y mantenga presionada la flecha pequeña, arrástrela hasta la segunda forma y suelte el conector en el medio de la segunda forma.

  6. Para agregar texto a una forma o un conector, selecciónelos y, a continuación, escriba el texto. Cuando haya terminado de escribir, haga clic en una parte en blanco de la página.

  7. Para cambiar la dirección de la flecha de un conector, seleccione el conector y, en la pestaña Forma, en el grupo Estilos de forma, haga clic en Línea. Apunte a Flechas y, a continuación, seleccione la dirección de la flecha y el estilo que desee.

Arreglar la alineación y el espaciado

  1. Presione CTRL+A para seleccionarlo todo en la página del dibujo.

  2. En la pestaña Inicio, en el grupo Organizar, haga clic en Ubicación y, después, en Alineación y espaciado automático.

Si eso no funciona como desea, presione Ctrl+Z para deshacerlo y pruebe otra de las opciones bajo los botones de Alinear y Ubicación.

Ejemplo de un diagrama de flujo que muestra un proceso de propuesta

Qué representan las formas de diagrama de flujo

Al abrir la plantilla de diagrama de flujo básico, también se abre la galería de símbolos Formas para diagramas de flujo básicos. Cada forma de la galería de símbolos representa un paso diferente de un proceso. No obstante, no hay ningún significado estándar y universal para las formas; cada forma puede tener un significado acordado por las personas que crearán y leerán los diagramas de flujo. La mayor parte de los diagramas de flujo tienden a usar solo tres o cuatro formas, a menos que haya un motivo claro para usar más.

Dicho esto, las formas de Visio tienen nombres que sugieren sus usos más comunes. Aquí se muestran algunas de las formas más comunes:

  • Inicio o finalización    Use esta forma para el primer y último paso de un proceso.

    Forma Terminador

  • Proceso    Esta forma representa un paso típico del proceso. Es la forma más usada en casi todos los procesos.

    Forma Proceso

  • Decisión    Esta forma indica un punto en el que el resultado de una decisión indica el siguiente paso. Puede haber varios resultados, pero con frecuencia solo hay dos: sí y no.

    Forma Decisión

  • Subproceso    Use esta forma para un conjunto de pasos que se combinan para crear un subproceso que está definido en otro lugar, a menudo en otra página del mismo documento.

    Forma Proceso predefinido

  • Documento    Esta forma representa un paso que da como resultado un documento.

    Forma Documento

  • Datos    Esta forma indica que hay información que está entrando desde afuera en el proceso o saliendo de él. Esta forma también se puede usar para representar los materiales y a veces se denomina forma de entrada y salida.

    Forma Datos

  • Referencia en página    Este pequeño círculo indica que el paso siguiente (o anterior) se encuentra en otra parte del dibujo. Resulta particularmente útil para diagramas de flujo grandes en los que, de lo contrario, se debería usar un conector largo, que puede ser difícil de seguir.

    Forma Referencia en página

  • Referencia a otra página    Cuando se coloca esta forma en la página de dibujo, se abre un cuadro de diálogo en el que se puede crear un conjunto de hipervínculos entre dos páginas de un diagrama de flujo o entre una forma de subproceso y una página de diagrama de flujo independiente que muestra los pasos en dicho subproceso.

    Forma Referencia a otra página

Qué representan las formas de diagrama de flujo

Cuando abre la plantilla Diagrama de flujo básico, también se abre la galería de símbolos de Formas para diagramas de flujo básicos. Cada forma de la galería de símbolos representa un paso diferente del proceso.

Visio 2010 incluye muchas más galerías de símbolos especializadas y formas que puede usar en su diagrama de flujo. Para obtener información sobre cómo encontrar otras formas, vea Usar la ventana Formas para organizar y buscar formas.

  • Inicio o finalización    Use esta forma para el primer y último paso de un proceso.

    Forma Terminador

  • Proceso    Esta forma representa un paso del proceso.

    Forma Proceso

  • Subproceso    Use esta forma para un conjunto de pasos que se combinan para crear un subproceso que está definido en otro lugar, a menudo en otra página del mismo dibujo.

    Forma Proceso predefinido

  • Documento    Esta forma representa un paso que da como resultado un documento.

    Forma Documento

  • Datos    Esta forma indica que hay información que está entrando desde afuera en el proceso o saliendo de él. Esta forma también se puede usar para representar los materiales y a veces se denomina forma de entrada y salida.

    Forma Datos

  • Referencia en página    Este pequeño círculo indica que el paso siguiente (o anterior) se encuentra en otra parte del dibujo. Resulta particularmente útil para diagramas de flujo grandes en los que, de lo contrario, se debería usar un conector largo, que puede ser difícil de seguir.

    Forma Referencia en página

  • Referencia a otra página    Cuando se coloca esta forma en la página de dibujo, se abre un cuadro de diálogo en el que se puede crear un conjunto de hipervínculos entre dos páginas de un diagrama de flujo o entre una forma de subproceso y una página de diagrama de flujo independiente que muestra los pasos en dicho subproceso.

    Forma Referencia a otra página

Nota: ¿No puede encontrar la forma que necesita?     Para obtener información sobre cómo encontrar otras formas, vea Usar la ventana Formas para organizar y buscar formas.

Crear un diagrama de flujo
  1. Haga clic en la pestaña Archivo.

    ¿No ve la pestaña Archivo?

    Si no ve la pestaña Archivo, continúe con el paso siguiente del procedimiento.

  2. Haga clic en Nuevo y en Diagrama de flujo. A continuación, en Plantillas disponibles, haga clic en Diagrama de flujo básico.

  3. Haga clic en Crear.

  4. En cada paso del proceso que esté documentando, arrastre un forma de diagrama de flujo al dibujo.

    Nota: Vea la sección Qué representan las formas de diagrama de flujo para obtener información sobre las formas que puede usar en cada paso.

  5. Conecte las formas de diagrama flujo usando cualquiera de los métodos que se describen a continuación.

    Conectar dos formas juntas.

    1. En la pestaña Inicio, en el grupo Herramientas, haga clic en Conector.

    2. Arrastre desde un punto de conexión Imagen de punto de conexión: x azul en la primera forma hasta un punto de conexión en la segunda forma. Los extremos del conector se pondrán de color rojo cuando se conecten las formas.

      Diagrama de flujo con los extremos del conector de color rojo.

    Conectar una forma con varias desde un punto de conexión único.

    De manera predeterminada, los conectores se configuran como conectores de Ángulo recto, por lo que, si se conecta un solo punto de una forma a otras tres formas, se verá como muestra la figura siguiente.

    Forma conectada a otras tres formas con conectores de ángulo recto.

    Para que cada conector parta directamente desde el punto central de la primera forma hasta los puntos de cada una de las otras formas es necesario configurar los conectores como Conector recto, como se muestra en la figura siguiente.

    Diagrama de flujo con conectores rectos que parten desde un punto central.

    1. En la ficha Inicio, en el grupo Herramientas, haga clic en Conector.

    2. Para cada forma a la que desee conectarse, arrastre el mouse desde el mismo punto de conexión Imagen de punto de conexión: x azul en la primera forma hasta un punto de conexión en cada una de las otras formas.

    3. Haga clic con el botón secundario en cada conector y, a continuación, haga clic en Conector recto.

  6. Para volver a la edición normal, en la ficha Inicio, en el grupo Herramienta, haga clic en Herramienta Puntero.

  7. Para agregar texto a una forma o un conector, selecciónelos y, a continuación, escriba el texto. Cuando haya terminado de escribir, haga clic en una parte en blanco de la página.

  8. Para cambiar la dirección de la flecha de un conector, seleccione la conexión y, a continuación, en el grupo Forma, haga clic en la flecha situada a la derecha de Línea. Apunte a Flechas y, a continuación, seleccione la dirección de la flecha que desee.

Inicio de la página

Imprimir un diagrama de flujo grande

La manera más fácil de imprimir un diagrama de flujo más grande que el papel de la impresora es imprimirlo en varias hojas y, después, unirlas con cinta adhesiva.

Antes de empezar a imprimir, es importante que se asegure de que la página de dibujo, tal como aparece en Visio, contiene todo el diagrama de flujo. Las formas que sobresalen del borde de la página de dibujo de Visio no se imprimirán.

Para imprimir un diagrama de flujo grande, haga lo siguiente:

  1. Con el diagrama de flujo abierto, en la ficha Diseño, en el grupo Configurar página , haga clic en Tamaño y seleccione Ajustar al dibujo.

  2. Haga clic en la pestaña Archivo.

    ¿No ve la pestaña Archivo?

    Si no ve la pestaña Archivo, continúe con el paso siguiente del procedimiento.

  3. Haga clic en Imprimir y, a continuación, en Vista preliminar.

    En Vista preliminar, las líneas de puntos separan las diferentes páginas.
    Las líneas de puntos muestran cómo se imprimirá el dibujo en hojas separadas.
  4. Para imprimir el diagrama de flujo en varias hojas, haga lo siguiente:

    1. En Vista preliminar, en el grupo Imprimir, haga clic en Configurar página.

    2. En la ficha Configurar impresión, en el cuadro Papel de la impresora, seleccione el tamaño de papel que desee usar si aún no está seleccionado.

    3. Haga clic en Aceptar.

    4. En el grupo Vista previa, haga clic en Mosaico simple para ver cómo se imprimirá el dibujo en cada hoja. (Puede cambiar entre páginas haciendo clic en Mosaico siguiente o Mosaico anterior).

    5. Cuando esté satisfecho con el aspecto del dibujo, en el grupo Imprimir, haga clic en Imprimir.

    6. Después de imprimir el dibujo, puede recortar los márgenes, superponer las páginas y unirlas con cinta adhesiva.

  5. Para imprimir el diagrama de flujo en una sola hoja, haga lo siguiente:

    1. En Vista preliminar, en el grupo Imprimir, haga clic en Configurar página.

    2. En la ficha Configurar impresión, en el cuadro Papel de la impresora, seleccione el tamaño de papel que desee usar si aún no está seleccionado.

    3. En Zoom para imprimir, seleccione Ajustar a.

    4. A la derecha de Ajustar a, escriba un 1 en el cuadro situado junto a hoja(s) a lo ancho y, a continuación, escriba otro 1 en el cuadro situado junto a hojas a lo largo.

    5. Haga clic en Aceptar.

    6. En el grupo Imprimir, haga clic en Imprimir.

Qué representan las formas de diagrama de flujo

Cuando abre la plantilla Diagrama de flujo básico, también se abre la galería de símbolos de Formas para diagramas de flujo básicos. Cada forma de la galería de símbolos representa un paso diferente del proceso.

De todas las formas de la galería de símbolos de Formas para diagramas de flujo básicos, solo algunas se usan habitualmente. Esas formas usadas habitualmente se describen aquí. Para obtener más información sobre las formas menos usadas, abra el vínculo expansible (Formas de diagrama de flujo menos usadas) al final de esta sección.

  • Terminador    Use esta forma para el primer y último paso de un proceso.

    Forma Terminador

  • Proceso    Esta forma representa un paso del proceso.

    Forma Proceso

  • Proceso predefinido    Use esta forma para un conjunto de pasos que se combinan para crear un subproceso que está definido en otro lugar, a menudo en otra página del mismo dibujo.

    Forma Proceso predefinido

  • Decisión    Esta forma indica un punto en el que el resultado de una decisión indica el siguiente paso. Puede haber varios resultados, pero con frecuencia solo hay dos: sí y no.

    Forma Decisión

  • Documento    Esta forma representa un paso que da como resultado un documento.

    Forma Documento

  • Datos    Esta forma indica que hay información que está entrando desde afuera en el proceso o saliendo de él. Esta forma también se puede usar para representar los materiales y a veces se denomina forma de entrada y salida.

    Forma Datos

  • Formas de diagrama de flujo    Puede hacer clic con el botón derecho en esta multiforma para establecer cualquiera de las siguientes formas: Proceso, Decisión, Documento o Datos. Cualquier texto que escriba en la forma, o información que agregue a sus Datos de formas, se conserva con la forma.

    Este es el aspecto de la forma en la galería de símbolos:

    Formas de diagrama de flujo

    Esto es lo que ve cuando arrastra la forma a la página de dibujo y hace clic con el botón derecho en ella:

    Formas de diagrama de flujo con menú contextual

  • Datos almacenados    Use esta forma en un paso que tenga como resultado la información que se va a almacenar.

    Forma de datos almacenados

  • Referencia en página    Este pequeño círculo indica que el paso siguiente (o anterior) se encuentra en otra parte del dibujo. Resulta particularmente útil para diagramas de flujo grandes en los que, de lo contrario, se debería usar un conector largo, que puede ser difícil de seguir.

    Forma Referencia en página

  • Referencia a otra página    Cuando se coloca esta forma en la página de dibujo, se abre un cuadro de diálogo en el que se puede crear un conjunto de hipervínculos entre dos páginas de un diagrama de flujo o entre una forma de subproceso y una página de diagrama de flujo independiente que muestra los pasos en dicho subproceso.

    Forma Referencia a otra página

Formas de diagrama de flujo menos usadas

  • Conector dinámico    Este conector dibuja una ruta alrededor de las formas que encuentra.

    Forma de conector dinámico

  • Conector de línea curva    Este conector tiene una curvatura ajustable.

    Conector de línea curva

  • Cuadro alto auto.     Este es un cuadro de texto con borde que se ajusta para adaptarse a la cantidad de texto que escribe. Puede establecer el ancho arrastrando los lados de la forma. Aunque esta forma no representa un paso de un proceso, es una manera útil de agregar un cuadro de texto a su diagrama de flujo.

    Cuadro alto auto

  • Anotación     Este cuadro de texto entre corchetes se ajusta para adaptar la cantidad de texto que escriba. Puede establecer el ancho arrastrando los lados de la forma. Como la forma de cuadro alto auto., esta forma no representa un paso en un proceso. Use esta opción para agregar comentarios sobre las formas del diagrama de flujo.

    Forma Anotación

  • Entrada manual    Este es un paso en la que una persona proporciona información al proceso.

    Forma de entrada manual

  • Operación manual    Este es un paso que debe realizarse por una persona.

    Forma de operación manual

  • Almacenamiento interno    Esta forma representa información almacenada en un equipo.

    Forma Almacenamiento interno

  • Datos directos    Esta forma representa información almacenada de manera que se pueda acceder a cualquier registro único directamente. Esto representa cómo una unidad de disco duro almacena datos.

    Forma directa de datos

  • Datos secuenciales    Esta forma representa información almacenada en secuencia, como datos de AD en una cinta magnética. Cuando los datos se almacenan en secuencia, deben recuperarse en secuencia. Por ejemplo, para tener acceso al registro 7 primero tendrá que recorrer los registros 1 a 6.

    Forma de datos secuenciales

  • Cinta perforada o tarjeta    Esta forma representa una tarjeta física o una cinta perforada. Los sistemas de equipo anteriores usaban un sistema de tarjetas y cintas perforadas para almacenar y recuperar datos y para almacenar y ejecutar programas.

    Forma de tarjeta

  • Mostrar    Esta forma representa información que se muestra a una persona, normalmente en una pantalla de equipo.

    Mostrar forma

  • Preparación    Esta forma indica dónde se inicializan las variables en la preparación de un procedimiento.

    Forma de preparación

  • Modo paralelo    Esta forma muestra dónde pueden operar dos procesos diferentes de manera simultánea.

    Modo de modo paralelo

  • Límite de bucle    Esta forma marca el número máximo de veces que un bucle puede ejecutarse antes de que vaya al paso siguiente.

    Forma Límite de bucle

  • Transferencia de control    Esta forma indica un paso que se dirige a un paso que no es el siguiente paso típico cuando se cumplen determinadas condiciones.

    Forma Transferencia control

Crear un diagrama de flujo

  1. En el menú Archivo, señale Nuevo, Diagrama de flujo y, después, haga clic en Diagrama de flujo básico.

  2. En cada paso del proceso que esté documentando, arrastre un forma de diagrama de flujo al dibujo.

  3. Conecte las formas de diagrama flujo usando cualquiera de los métodos que se describen a continuación.

    Nota: Para obtener información sobre otras maneras de conectar formas, vea Agregar conectores entre formas en Visio.

    Conectar dos formas juntas.

    1. Haga clic en la herramienta Conector Imagen del botón en la barra de herramientas Estándar.

    2. Arrastre desde un punto de conexión Imagen de punto de conexión: x azul en la primera forma hasta un punto de conexión en la segunda forma. Los puntos de conexión del conector se pondrán de color rojo cuando se conecten las formas.

      Los extremos del conector son de color rojo cuando las formas están pegadas

    Conectar una forma con varias desde un punto de conexión único.

    De manera predeterminada, los conectores se configuran como conectores de Ángulo recto, por lo que, si se conecta un solo punto de una forma a otras tres formas, se verá como muestra la figura siguiente.

    Forma conectada a otras tres formas con conectores de ángulo recto.

    Para que cada conector parta directamente desde el punto central de la primera forma hasta los puntos de cada una de las otras formas es necesario configurar los conectores como Conector recto, como se muestra en la figura siguiente.

    Forma conectada a otras tres formas con conectores rectos.

    1. Haga clic en la herramienta Conector Imagen del botón en la barra de herramientas Estándar.

    2. Para cada forma a la que quiera conectarse, arrastre el mouse desde el mismo punto de conexión Imagen de punto de conexión: x azul en la primera forma hasta un punto de conexión en cada una de las otras formas.

    3. Haga clic con el botón derecho en cada conector y en Conector recto.

  4. Haga clic en la herramienta Puntero Botón del puntero de la barra de herramientas Estándar para volver a la edición normal.

  5. Para agregar texto a una forma o un conector, selecciónelos y, a continuación, escriba el texto. Cuando haya terminado de escribir, haga clic en una parte en blanco de la página.

  6. Para cambiar la dirección de la flecha del conector, seleccione la conexión y, después, en el menú Forma, señale Operaciones y haga clic en Invertir extremos.

Imprimir diagramas de flujo grandes

La manera más fácil de imprimir un diagrama de flujo más grande que el papel de la impresora es imprimirlo en varias hojas y, después, unirlas con cinta adhesiva.

En cambio, antes de empezar a imprimir, es importante que se asegure de que la página de dibujo, tal como aparece en Visio, contiene todo el diagrama de flujo. Las formas que sobresalen del borde de la página de dibujo de Visio no se imprimirán. Puede ver si la página de dibujo es lo suficientemente grande para el diagrama de flujo comprobando la vista previa en el cuadro de diálogo Configurar página (Menú Archivo, Configurar página, pestaña Configurar impresión).

Diagrama de flujo demasiado grande para la página de dibujo de Visio, junto a un diagrama de flujo que sí que se ajusta a dicha página

1. Un diagrama de flujo que lo suficientemente grande para la página de dibujo de Visio.

2. Un diagrama de flujo que se adapta a la página de dibujo de Visio.

Ajustar la página de dibujo de Visio al diagrama de flujo

  1. Con el diagrama de flujo abierto, en el menú Archivo, haga clic en Configurar página.

  2. Haga clic en la pestaña Tamaño de página.

  3. En Tamaño de página, haga clic en Ajustar al contenido del dibujo.

Para ver cómo se imprimirá el diagrama de flujo, mire la Vista preliminar, que se encuentra en el menú Archivo. La figura siguiente muestra un diagrama de flujo que se imprime en cuatro partes de tamaño de papel carta.

Vista previa de impresión de una gran diagrama de flujo que se imprimirá en 4 trozos de papel

Imprimir un diagrama de flujo grande en varias partes de papel

  1. En el menú Archivo, haga clic en Configurar página.

  2. En la pestaña Configurar impresión, en el cuadro Papel de la impresora, seleccione el tamaño de papel que quiere usar si aún no está seleccionado. No haga clic en Aceptar todavía.

  3. En la pestaña Tamaño de página, haga clic en Ajustar al contenido del dibujo. Ahora la vista previa muestra la diferencia entre la página nueva y el papel de la impresora.

  4. Haga clic en Aceptar.

  5. Para ver cómo se imprimirá el diagrama de flujo, haga clic en Vista preliminar en el menú Archivo.

    Nota: Si hay márgenes sombreados entre las páginas, estos marcan áreas que se imprimen en ambas partes del papel, de manera que cuando monte las partes no haya espacios en el diagrama de flujo.

  6. Después de imprimir el dibujo, puede recortar los márgenes, superponer las páginas y unirlas con cinta adhesiva.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×