Crear un cuadro de lista en cascada

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Cuadros de lista en cascada a los usuarios rellenar formularios más rápida y ayudar a garantizar que los usuarios introduzcan datos correctamente. En este artículo se describe cómo crear y rellenar los cuadros de lista en cascada con datos. En Microsoft Office InfoPath, puede rellenar una lista con los datos que usa los valores de formulario, los valores de un documento de lenguaje de marcado Extensible (XML) externo o valores de una base de datos de Microsoft Office Access.

En este artículo:

¿Qué es un cuadro de lista en cascada?

Paso 1: Insertar un cuadro de lista en cascada

Paso 2: Proporcionar los datos

¿Qué es un cuadro de lista en cascada?

Un cuadro de lista en cascada es un cuadro de lista con las opciones que cambian según el valor que un usuario selecciona en otro cuadro de lista. Por ejemplo, si un usuario hace clic en condimentos en el cuadro categorías que se muestra en la siguiente ilustración, el cuadro productos mostrará una lista de condimentos.

Ejemplo de cuadro de lista en cascada

Las siguientes secciones muestran cómo diseñar una plantilla de formulario con dos cuadros de lista, donde se filtra el segundo cuadro de lista según el valor que un usuario selecciona en el primer cuadro de lista. Cuando se cambia el valor en el primer cuadro de lista, el filtro se aplica automáticamente al segundo cuadro de lista, que cambia sus valores.

Consideraciones de compatibilidad

Filtros se pueden utilizar únicamente en las plantillas de formulario que están diseñadas para rellenarlo en InfoPath. Filtros no están disponibles en las plantillas de formulario compatibles con el explorador.

Principio de página

Paso 1: Insertar un cuadro de lista en cascada

Para crear un cuadro de lista en cascada, debe insertar dos cuadros de lista en la plantilla de formulario.

Nota: Al insertar un cuadro de lista en cascada en la plantilla de formulario, asegúrese de que los dos cuadros de lista no están en una sección de repetición o tabla de repetición.

  1. Si el panel Controles no es visible, haga clic en Más controles en el menú Insertar, o bien, presione ALT+I, C.

  2. En Insertar controles en el panel de tareas controles, haga clic en Cuadro de lista desplegable. Cuando un usuario rellena un formulario que se basa en la plantilla de formulario, la selección en este cuadro de lista desplegable determinará las opciones que están disponibles en el segundo cuadro de lista.

  3. Haga clic en el cuadro de lista. La plantilla de formulario debería contener un cuadro de lista desplegable y un cuadro de lista estándar.

    Cuadro de lista desplegable y cuadro de lista en un formulario

  4. Haga doble clic en el cuadro de lista desplegable que ha insertado en la plantilla de formulario en el paso 2.

  5. En el cuadro de diálogo Propiedades de cuadro de lista desplegable, haga clic en la pestaña datos.

  6. En el cuadro nombre de campo, escriba cuadroLista1y, a continuación, haga clic en Aceptar.

  7. Haga doble clic en el cuadro de lista que ha insertado en la plantilla de formulario en el paso 3.

  8. En el cuadro de diálogo Propiedades de cuadro de lista, haga clic en la pestaña datos.

  9. En el cuadro nombre de campo, escriba listBox2Cascadey, a continuación, haga clic en Aceptar.

Principio de página

Paso 2: Proporcionar los datos

Ahora que ha insertado los cuadros de lista en la plantilla de formulario, debe proporcionar los datos que se mostrarán. A continuación, debe aplicar una filtro para que las opciones en el segundo cuadro de lista se basan en la selección del usuario en el primer cuadro de lista.

En esta sección se explica cómo conectar los cuadros de lista a los datos mediante tres métodos comunes: agregar los datos en el formulario propiamente dicho; conectar el formulario a un documento XML existente que contiene los datos; o bien, conectando el formulario a una base de datos que contiene los datos. Para terminar de crear el cuadro de lista en cascada, haga clic en el método que desea usar en la lista siguiente.

Conectarse a datos en el formulario

Conectarse a un documento XML externo

Conectarse a una base de datos

Conectarse a datos en el formulario

En esta sección, aprenderá cómo llenar los cuadros de lista con los datos del formulario. Para ello, primero debe configurar campos en la plantilla de formulario para que pueda escribir los nombres de las categorías y un conjunto de productos para cada categoría.

Configurar los campos en la plantilla de formulario

  1. Si el panel de tareas Origen de datos no está visible, haga clic en Origen de datos en el menú Ver.

  2. En el panel de tareas Origen de datos, haga clic en el grupo misCampos y, a continuación, haga clic en Agregar.

  3. En el cuadro nombre, en el cuadro de diálogo Agregar campo o grupo, escriba CategoríasYProductos.

  4. En la lista tipo, haga clic en grupo.

  5. Active la casilla de verificación Repetir y, a continuación, haga clic en Aceptar.

  6. En el panel de tareas Origen de datos, haga clic en el grupo CategoríasYProductos.

  7. En el cuadro nombre, en el cuadro de diálogo Agregar campo o grupo, escriba categoríay, a continuación, haga clic en Aceptar. Este campo contiene los nombres de las categorías del primer cuadro de lista.

  8. Haga clic en el grupo CategoríasYProductos y, a continuación, haga clic en Agregar.

  9. En el cuadro nombre, en el cuadro de diálogo Agregar campo o grupo, escriba producto.

  10. Active la casilla de verificación Repetir y, a continuación, haga clic en Aceptar. Este campo contiene los nombres de los productos para el segundo cuadro de lista.

Dado que este cuadro de lista se rellena con datos del formulario, los datos deben agregarse al formulario. Para ello, debe crear valores predeterminados para los campos producto y categoría.

Sugerencia

También puede crear cuadros de lista que se muestran los valores que los usuarios escriban en el formulario de sí mismos. Para ello, asociar el cuadro de lista con los campos que se enlazan a los controles en el formulario. Cuando un usuario escribe valores en los controles, cambian las opciones en el cuadro de lista.

Crear valores predeterminados

  1. En el menú Herramientas, haga clic en Valores predeterminados.

  2. En el cuadro de diálogo Editar valores predeterminados, en el grupo CategoríasYProductos, seleccione el campo categoría (no desactive la casilla de verificación), y, a continuación, en el cuadro valor predeterminado, escriba Mariscos.

  3. Seleccione el campo producto (no desactive la casilla de verificación), y, a continuación, en el cuadro valor predeterminado, escriba cangrejo.

  4. Haga clic en el campo de producto y, a continuación, haga clic en Agregar otro producto anterior. Esto le permite agregar un segundo producto a mariscos como un valor predeterminado.

  5. Haga clic en la segunda instancia del campo producto (no desactive la casilla de verificación), y, a continuación, en el cuadro valor predeterminado, escriba Salmón.

  6. Haga clic en el grupo CategoríasYProductos y, a continuación, haga clic en Agregar otro elemento CategoríasYProductos debajo. Esto le permite agregar una segunda categoría como valor predeterminado.

  7. Use los pasos anteriores para especificar los valores predeterminados de la segunda instancia de los campos categoría y producto en lácteos, Cheddar y Batido de Chocolate, respectivamente.

  8. Haga clic en Aceptar.

Ahora que ha introducido los valores predeterminados para los campos producto y categoría, puede conectar el primer cuadro de lista a los datos que acaba de escribir.

Conectar el primer cuadro de lista a los datos

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista desplegable que insertó anteriormente.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista desplegable, las entradas del cuadro de lista, haga clic en Buscar valores en origen de datos del formulario.

  4. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  5. En el cuadro de diálogo Seleccionar un campo o grupo, en el grupo CategoríasYProductos, haga clic en el campo categoría y, a continuación, haga clic en Aceptar dos veces.

Ahora debe conectar el segundo cuadro de lista a los datos. Al realizar este conexión de datos, desea aplicar un filtro al segundo cuadro de lista. Este filtro rellenará el segundo cuadro de lista con los productos adecuados, en función de la categoría seleccionada en el primer cuadro de lista. El filtro compara los valores seleccionados en el primer cuadro de lista (campo cuadroLista1) con la lista de categorías guardada en el formulario (campo de categoría).

Conectar el segundo cuadro de lista a los datos

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista estándar que insertó anteriormente.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista, en las entradas del cuadro de lista, haga clic en Buscar valores en origen de datos del formulario.

  4. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  5. En el cuadro de diálogo Seleccionar un campo o grupo, en el grupo CategoríasYProductos, haga clic en el campo producto y, a continuación, haga clic en Filtrar datos.

  6. En el cuadro de diálogo Filtrar datos, haga clic en Agregar.

  7. En el cuadro de diálogo Especificar condiciones de filtro, haga clic en Seleccionar un campo o grupo en el primer cuadro.

  8. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en cuadroLista1 y, a continuación, haga clic en Aceptar.

  9. En el cuadro de diálogo Especificar condiciones de filtro, haga clic en Seleccionar un campo o grupo en el tercer cuadro.

  10. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el campo categoría y, a continuación, haga clic en Aceptar para cerrar todos los cuadros de diálogo Abrir.

Ahora que ha conectado el segundo cuadro de lista a los datos y ha aplicado el filtro, ya está listo para probar los cuadros de lista para asegurarse de que funcionan correctamente.

Comprobar los cuadros de lista

  1. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

  2. En el cuadro de lista desplegable, haga clic en Mariscos. El cuadro de lista estándar debe mostrar una línea en blanco, cangrejo y Salmón.

    Nota: La línea en blanco permite a los usuarios borrar su elección del cuadro de lista.

Si los cuadros de lista no funcionan correctamente, revise el filtro del segundo cuadro de lista para asegurarse de que se compara el campo cuadroLista1 con el campo categoría.

Principio de la sección

Conectarse a un documento XML externo

En esta sección, aprenderá a crear una conexión de datos a un documento XML que contiene los valores de producto y categoría. El documento XML será el origen de datos secundario. Para crear esta conexión de datos, debe crear el documento XML, asociar los cuadros de lista en la plantilla de formulario con el documento XML y, a continuación, aplicar un filtro al segundo cuadro de lista para que la lista de productos cambia de manera apropiada.

Para poder asociar el formulario con un origen de datos secundario, debe crear el documento XML.

Crear el documento XML

  1. Inicie el Bloc de notas u otro editor de texto.

  2. Copie y pegue los siguientes datos XML en el editor de texto:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Guarde el archivo en el equipo datosCuadroLista.XML.

Ahora que ha creado un documento XML, puede conectarse a la plantilla de formulario. Se creará un origen de datos secundario.

Conectar el documento XML a la plantilla de formulario

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el asistente para conexiones de datos, haga clic en Recibir datos y, a continuación, haga clic en Siguiente.

  4. En la siguiente página del asistente, haga clic en documento XML y, a continuación, haga clic en siguiente.

  5. En la siguiente página del asistente, haga clic en Examinar, seleccione el archivo datosCuadroLista.XML que guardó en el equipo y, a continuación, haga clic en Abrir.

  6. En la siguiente página del asistente, haga clic en incluir los datos como un archivo de recursos en la plantilla de formulario o un elemento de plantilla y, a continuación, haga clic en siguiente.

  7. En la siguiente página del asistente, en el cuadro Escriba un nombre para esta conexión de datos, escriba datosCuadroListaArchivoXML.

  8. Active la casilla de verificación recuperar datos automáticamente cuando se abre un formulario. Así se garantiza que los datos del cuadro de lista estará disponibles cada vez que se abre el formulario, en lugar de solicitar al usuario que consulta para él.

  9. Haga clic en Finalizar.

  10. En el cuadro de diálogo Conexiones de datos, haga clic en Cerrar.

Ahora está listo para conectar el primer cuadro de lista en la plantilla de formulario a los datos en el documento XML.

Conectar el primer cuadro de lista a los datos

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista desplegable que insertó anteriormente.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista desplegable, las entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  4. En el cuadro origen de datos, haga clic en datosCuadroListaArchivoXML.

  5. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  6. En el cuadro de diálogo Seleccionar un campo o grupo, en el grupo CategoríasYProductos, haga clic en el campo categorías.

    Nota: El fondo amarillo en el cuadro de diálogo Seleccionar un campo o grupo indica que está trabajando con un origen de datos secundario.

  7. Haga clic en Aceptar dos veces.

Ahora debe conectar el segundo cuadro de lista al documento XML. Al realizar esta conexión de datos, desea aplicar un filtro al segundo cuadro de lista. Este filtro rellenará el segundo cuadro de lista con los productos adecuados, en función de la categoría seleccionada en el primer cuadro de lista. El filtro compara los valores seleccionados en el primer cuadro de lista (campo cuadroLista1) con la lista de categorías guardada en el formulario (campo de categoría).

Conectar el segundo cuadro de lista a los datos

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista estándar que insertó anteriormente.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista, en las entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  4. En el cuadro origen de datos, haga clic en datosCuadroListaArchivoXML.

  5. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  6. En el cuadro de diálogo Seleccionar un campo o grupo, en el grupo CategoríasYProductos, expanda el grupo de productos y, a continuación, haga clic en el campo de producto.

  7. Haga clic en Filtrar datos.

  8. En el cuadro de diálogo Filtrar datos, haga clic en Agregar.

  9. En el cuadro de diálogo Especificar condiciones de filtro, haga clic en Seleccionar un campo o grupo en el primer cuadro.

  10. En el cuadro origen de datos, en el cuadro de diálogo Seleccionar un campo o grupo, haga clic en principal.

  11. Haga clic en cuadroLista1 y, a continuación, haga clic en Aceptar.

  12. En el cuadro de diálogo Especificar condiciones de filtro, haga clic en Seleccionar un campo o grupo en el tercer cuadro.

  13. En el cuadro origen de datos, en el cuadro de diálogo Seleccionar un campo o grupo, haga clic en datosCuadroListaArchivoXML (secundario) y, a continuación, haga clic en categorías.

  14. Haga clic en Aceptar para cerrar todos los cuadros de diálogo abiertos.

Ahora que ha conectado el segundo cuadro de lista al documento XML y ha aplicado el filtro, ya está listo para probar los cuadros de lista para asegurarse de que funcionan correctamente.

Comprobar los cuadros de lista

  1. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

  2. En el cuadro de lista desplegable, haga clic en Mariscos. El cuadro de lista estándar debe mostrar una línea en blanco, Cangrejo y Salmón.

    Nota: La línea en blanco permite a los usuarios borrar su elección del cuadro de lista.

Si los cuadros de lista no funcionan correctamente, revise el filtro del segundo cuadro de lista para asegurarse de que se compara el campo cuadroLista1 con el campo categoría.

Principio de la sección

Conectarse a una base de datos

En esta sección, aprenderá a crear una conexión de datos a dos tablas en una base de datos de Access. Para ello, asociar los cuadros de lista en la plantilla de formulario con la base de datos y, a continuación, aplicar un filtro al segundo cuadro de lista para que la lista que aparece en el segundo cuadro de lista, cambie de forma adecuada según el valor seleccionado en el primer cuadro de lista. Para este ejemplo, consideraremos que la base de datos de Access contiene dos tablas denominados categorías y productos y que las dos tablas están relacionadas entre sí por el campo IdCategoría, que se usa en cada tabla.

Tabla de categorías   

IdCategoría

CategoryName

1

Mariscos

2

Lácteos

Tabla de productos   

IdProducto

IdCategoría

NombreProducto

1

1

Cangrejo

2

1

Salmón

3

2

Chocolate leche

4

2

Cheddar

Conectar la plantilla de formulario con el origen de datos

En primer lugar, debe crear una conexión de datos entre la plantilla de formulario y las tablas de la base de datos. Puesto que sólo está visualizando los datos de la base de datos, en lugar de modificarlo directamente, la base de datos de Access será un origen de datos secundario para la plantilla de formulario.

  1. En el menú Herramientas, haga clic en Conexiones de datos.

  2. En el cuadro de diálogo Conexiones de datos, haga clic en Agregar.

  3. En el asistente para conexiones de datos, haga clic en Recibir datos y, a continuación, haga clic en Siguiente.

  4. En la siguiente página del asistente, haga clic en Base de datos (sólo de Microsoft SQL Server o Microsoft Office Access) y, a continuación, en Siguiente.

  5. En la siguiente página del asistente, haga clic en Seleccionar base de datos y a continuación, busque y haga doble clic en la base de datos de Access en el disco duro.

  6. En el cuadro de diálogo Seleccionar tabla, haga clic en la tabla que contiene los datos que desea mostrar en la primera lista (en este ejemplo, la tabla de categorías) y, a continuación, haga clic en Aceptar. Especifica la tabla como tabla principal para la conexión de datos.

  7. En el asistente, haga clic en Agregar tabla.

  8. En el cuadro de diálogo Agregar tabla o consulta, haga clic en la tabla que contiene los datos que desea mostrar en la segunda lista (en este ejemplo, la tabla productos) y, a continuación, haga clic en siguiente.

  9. En el cuadro de diálogo Modificar relación, asegúrese de que los campos de conexión son correctos. En este ejemplo, las tablas están relacionadas entre sí por el campo Id.

    Sugerencia: Si los campos de conexión son incorrectos, seleccione los campos y, a continuación, haga clic en Quitar relación. A continuación, haga clic en Agregar relación, seleccione los campos correctos y, a continuación, haga clic en Aceptar.

  10. Haga clic en Finalizar.

    Nota: En este ejemplo, la tabla de categorías tiene una relación de uno a varios con la tabla productos, lo que significa que por cada categoría puede haber varios productos. En una base de datos, normalmente se establezca usando campos de clave este tipo de relación. En este caso, el campo clave IdCategoría permite el acceso a asociar el conjunto correcto de productos con la categoría correspondiente.

  11. En el asistente, revise la estructura del origen de datos. Debería ver dos tablas conectadas entre sí: la tabla principal y la tabla secundaria. Para ver los campos individuales de la tabla, active la casilla de verificación Mostrar columnas de tabla. Una vez que haya terminado de revisar la estructura de datos, haga clic en siguiente.

  12. Desactive la casilla de verificación Almacenar una copia de los datos en la plantilla de formulario y, a continuación, haga clic en Siguiente.

  13. En el cuadro Escriba un nombre para esta conexión de datos, en la siguiente página del asistente, escriba un nombre para la conexión de datos.

  14. Active la casilla de verificación recuperar datos automáticamente cuando se abre un formulario.

  15. Haga clic en Finalizar y, a continuación, haga clic en Cerrar en el cuadro de diálogo Conexiones de datos.

Conectar el primer cuadro de lista a datos

Ahora que ha creado una conexión de datos al origen de datos secundario, puede conectar el primer cuadro de lista en la plantilla de formulario a las tablas de la base de datos.

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista desplegable que insertó anteriormente.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista desplegable, las entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  4. En el cuadro origen de datos, asegúrese de que está seleccionada la conexión de datos que creó.

  5. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  6. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el nombre de la tabla que contiene los datos que desea mostrar en la lista desplegable (en este ejemplo, d:Categories ) y, a continuación, haga clic en Aceptar.

    Nota: El fondo amarillo en el cuadro de diálogo Seleccionar un campo o grupo indica que está trabajando con un origen de datos secundario.

  7. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro valor.

  8. En el cuadro de diálogo Seleccionar un campo o grupo, asegúrese de que el campo conexión (en este ejemplo, : IdCategoría ) está seleccionado y, a continuación, haga clic en Aceptar. Este es el valor que se guardará cuando el usuario hace una selección en el cuadro de lista.

  9. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro nombre para mostrar.

  10. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el nombre del campo que desee que aparezca en la lista desplegable (en este ejemplo, : NombreCategoría ).

  11. Haga clic en Aceptar dos veces.

Conectar el segundo cuadro de lista a datos

Ahora debe conectar el segundo cuadro de lista a la base de datos. Al realizar esta conexión de datos, desea aplicar un filtro al segundo cuadro de lista. Este filtro rellenará el segundo cuadro de lista con los valores apropiados, según el valor que se ha seleccionado en el primer cuadro de lista.

  1. En la plantilla de formulario, haga doble clic en el cuadro de lista estándar.

  2. Haga clic en la ficha Datos.

  3. En el cuadro de diálogo Propiedades de cuadro de lista, en las entradas del cuadro de lista, haga clic en Buscar valores desde un origen de datos externos.

  4. En el cuadro origen de datos, asegúrese de que está seleccionada la conexión de datos que creó.

  5. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro Entradas.

  6. En el cuadro de diálogo Seleccionar un campo o grupo, expanda el grupo principal (en este ejemplo, d:Categories ) y, a continuación, haga clic en el grupo secundario que corresponde a la tabla que contiene los datos que desea que aparezca en el cuadro de lista en cascada (en este ejemplo, productos ).

  7. Haga clic en Filtrar datos.

  8. En el cuadro de diálogo Filtrar datos, haga clic en Agregar.

  9. En el cuadro de diálogo Especificar condiciones de filtro, en el primer cuadro, asegúrese de que está seleccionado el campo conexión de la tabla secundaria (en este ejemplo, productos ).

    Importante: Si los campos de conexión tienen el mismo nombre en ambas tablas, asegúrese de seleccionar correcto. Los campos de cada tabla se ordenan juntos en la lista. Por lo tanto, puede usar los nombres de campo adyacente para determinar cuál es la adecuada. En este ejemplo, seleccionamos el campo IdCategoría que aparece con los demás campos de la tabla productos.

  10. En el tercer cuadro, haga clic en Seleccione un campo o grupo.

  11. En el cuadro origen de datos, en el cuadro de diálogo Seleccionar un campo o grupo, haga clic en principal, haga clic en el campo cuadroLista1 y, a continuación, haga clic en Aceptar.

    Se ha configurado un filtro que compara los valores seleccionados en el cuadro de lista desplegable (campo cuadroLista1) con la lista de valores en el cuadro de lista estándar.

  12. Haga clic tres veces en Aceptar para volver al cuadro de diálogo Propiedades de cuadro de lista.

  13. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro valor.

  14. En el cuadro de diálogo Seleccionar un campo o grupo, seleccione el valor que desea guardar cuando el usuario hace una selección en el cuadro de lista. En este ejemplo, queremos guardar el campo IdProducto para su uso posterior. Por lo tanto, seleccionamos la : IdProducto agrupar y, a continuación, haga clic en Aceptar.

  15. Haga clic en Seleccionar XPath Imagen del botón junto al cuadro nombre para mostrar.

  16. En el cuadro de diálogo Seleccionar un campo o grupo, haga clic en el nombre del campo que desea mostrar en el cuadro de lista (en este ejemplo, : NombreProducto ).

  17. Haga clic en Aceptar dos veces.

Comprobar los cuadros de lista

Ahora que ha conectado el segundo cuadro de lista a la base de datos y ha aplicado el filtro, ya está listo para probar los cuadros de lista para asegurarse de que funcionan correctamente.

  1. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

  2. Seleccione un valor en el cuadro de lista desplegable. El cuadro de lista estándar debe mostrar los valores correspondientes de la tabla secundaria, dependiendo del campo de conexión que haya elegido.

Sugerencia: Si los cuadros de lista no funcionan correctamente, revise el filtro del segundo cuadro de lista para asegurarse de que se compara el campo cuadroLista1 con el campo IdCategoría.

Principio de la sección

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×