Crear o eliminar una macro

Para automatizar una tarea repetitiva, puede grabar rápidamente una macro en Microsoft Office Excel. También puede crear una macro utilizando el Editor de Visual Basic en Microsoft Visual Basic para escribir sus propios scripts de macro o para copiar toda o parte de una macro en una nueva macro. Una vez creada una macro, puede asignarla a un objeto (como un botón de la barra de herramientas, un gráfico o un control) para que pueda ejecutarla haciendo clic en ese objeto. Si ya no usa una macro, puede eliminarla.

¿Qué desea hacer?

Grabar una macro

Crear una macro mediante Microsoft Visual Basic

Copiar parte de una macro para crear otra

Asignar una macro a un objeto, gráfico o control

Eliminar una macro

Grabar una macro

Cuando graba una macro, la grabadora de macros graba todos los pasos necesarios para completar las acciones que desea que realice la macro. En los pasos grabados no se incluye el desplazamiento por la cinta de opciones.

Nota: La cinta de opciones es un componente de la interfaz de usuario de Microsoft Office Fluent.

  1. Si la pestaña Programador no está disponible, siga estos pasos para mostrarla:

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel.

    2. En la categoría Popular, en Opciones principales para trabajar con Excel, active la casilla de verificación Mostrar ficha Programador en la cinta de opciones y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota: Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros. Para más información sobre cómo cambiar la configuración, consulte Cambiar la configuración de seguridad de macros en Excel.

  3. En la ficha Programador, en el grupo Código, haga clic en Grabar macro.

  4. En el cuadro Nombre de la macro, escriba un nombre para la macro.

Nota: El primer carácter del nombre de la macro debe ser una letra. Los caracteres posteriores pueden ser letras, números o caracteres de subrayado. No pueden usarse espacios en un nombre de macro; puede utilizarse un carácter de subrayado para separar palabras. Si utiliza un nombre de macro que también es una referencia de celda, puede aparecer un mensaje de error indicando que el nombre de la macro no es válido.

  1. Para asignar una combinación de tecla de método abreviado con CTRL para ejecutar la macro, en el cuadro Tecla de método abreviado, escriba cualquier letra en mayúsculas o minúsculas que desee usar.

    Nota: La tecla de método abreviado invalidará cualquier tecla de método abreviado predeterminada equivalente de Excel mientras esté abierto el libro que contiene la macro. Para obtener una lista de teclas de método abreviado que utilicen la tecla CTRL y que ya están asignadas en Excel, vea Teclas de función y de método abreviado de Excel.

  2. En la lista Guardar macro en, seleccione el libro donde desea almacenar la macro.

    Sugerencia: Si desea que la macro esté disponible siempre que utilice Excel, seleccione Libro de macros personal. Cuando se selecciona Libro de macros personal, Excel crea un libro oculto de macros personal (Personal.xlsb), si aún no existe, y guarda la macro en este libro. En Windows Vista, este libro se guarda en la carpeta C:\Usuarios\nombre de usuario\AppData\Local\Microsoft\Excel\XLStart. En Microsoft Windows XP, este libro se guarda en la carpeta C:\Documents and Settings\nombre de usuario\Datos de programa\Microsoft\Excel\XLStart. Los libros almacenados en la carpeta XLStart se abren automáticamente al iniciar Excel. Si desea que se ejecute automáticamente una macro del libro de macros personal en otro libro, también debe guardar ese libro en la carpeta XLStart, de forma que ambos libros se abran cuando se inicie Excel.

  3. En el cuadro Descripción, escriba una descripción de la macro.

  4. Haga clic en Aceptar para iniciar la grabación.

  5. Realice las acciones que desee grabar.

  6. En la pestaña Programador, en el grupo Código, haga clic en Detener grabación Imagen del botón.

    Sugerencia: También puede hacer clic en Detener grabación Imagen del botón en el lado izquierdo de la barra de estado.

Inicio de la página

Crear una macro mediante Microsoft Visual Basic

  1. Si la pestaña Programador no está disponible, siga estos pasos para mostrarla:

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel.

    2. En la categoría Popular, en Opciones principales para trabajar con Excel, active la casilla de verificación Mostrar ficha Programador en la cinta de opciones y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota: Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros.

  3. En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

  4. De ser necesario, en el Editor de Visual Basic, en el menú Insertar, haga clic en Módulo.

    Nota: Se crean módulos automáticamente para todas las hojas del libro.

  5. En la ventana de código del módulo, escriba o copie el código de macro que desea utilizar.

  6. Para ejecutar la macro desde la ventana del módulo, presione F5.

  7. En el Editor de Visual Basic, en el menú Archivo, haga clic en Cerrar y volver a Microsoft Excel cuando termine de escribir la macro.

Inicio de la página

Copiar parte de una macro para crear otra

  1. Si la pestaña Programador no está disponible, siga estos pasos para mostrarla:

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel.

    2. En la categoría Popular, en Opciones principales para trabajar con Excel, active la casilla de verificación Mostrar ficha Programador en la cinta de opciones y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota: Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros.

  3. Abra el libro que contiene la macro que desee copiar.

  4. En el grupo Código de la pestaña Programador, haga clic en Macros.

  5. En el cuadro Nombre de la macro, haga clic en el nombre de la macro que desee copiar.

  6. Haga clic en Editar.

  7. En la ventana de código del Editor de Visual Basic, seleccione las líneas de la macro que desee copiar.

Sugerencia: Para copiar toda la macro, asegúrese de incluir las líneas Sub y End Sub en la selección.

  1. En el menú Edición haga clic en Copiar.

    Sugerencia: También puede hacer clic con el botón secundario y seleccionar Copiar, o puede presionar CTRL+C.

  2. En el cuadro Procedimiento de la ventana de código, haga clic en el módulo en el que desea colocar el código.

  3. En el menú Edición haga clic en Pegar.

    Sugerencia: También puede hacer clic con el botón secundario y seleccionar Pegar, o puede presionar CTRL+V.

Sugerencia: El archivo de libro de macros personal (Personal.xlsb) no se puede modificar porque es un libro oculto que siempre está abierto. Primero debe mostrarlo utilizando el comando Mostrar. También puede abrirlo en el Editor de Visual Basic presionando ALT+F11.

Inicio de la página

Asignar una macro a un objeto, gráfico o control

  1. En una hoja de cálculo, haga clic con el botón secundario en el objeto, gráfico o control al que desea asignar una macro existente y, a continuación, haga clic en Asignar macro.

  2. En el cuadro Nombre de la macro, haga clic en la macro que desea asignar.

Inicio de la página

Eliminar una macro

  1. Siga uno de los procedimientos siguientes:

    • Abra el libro que contiene la macro que desee eliminar.

    • Si la macro que quiere eliminar está almacenada en el Iibro de macros personal (Personal.xlsb) y este libro se encuentra oculto, proceda de la siguiente manera para mostrarlo:

      1. En la ficha Ver, en el grupo Ventana, haga clic en Mostrar.

      2. En Mostrar libro, haga clic en PERSONAL y después en Aceptar.

  2. Si la pestaña Programador no está disponible, siga estos pasos para mostrarla:

    1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, después, haga clic en Opciones de Excel.

    2. En la categoría Popular, en Opciones principales para trabajar con Excel, active la casilla de verificación Mostrar ficha Programador en la cinta de opciones y, a continuación, haga clic en Aceptar.

  3. En el grupo Código de la pestaña Programador, haga clic en Macros.

    El grupo Código en la pestaña Programador

  4. Seleccione el libro que contiene la macro que desea eliminar en la lista Macros en. Por ejemplo, haga clic en Este libro.

  5. En el cuadro Nombre de la macro, haga clic en el nombre de la macro que desee eliminar.

  6. Haga clic en Eliminar.

Inicio de la página

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!