Crear o eliminar una macro

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Para automatizar una tarea repetitiva, puede grabar rápidamente una macro en Microsoft Excel. También puede crear una macro mediante el Editor de Visual Basic en Microsoft Visual Basic para aplicaciones (VBA) para escribir su propio script de macro, o para copiar toda o parte de una macro en una nueva macro. Después de crear una macro, puede asignar a un objeto (por ejemplo, un botón de barra de herramientas, gráfico o control) para que se pueda ejecutar haciendo clic en el objeto. Si ya no usa una macro, puede eliminarla.

¿Qué desea hacer?

Grabar una macro

Crear una macro mediante VBA

Copiar parte de una macro para crear otra

Asignar una macro a un objeto, gráfico o control

Eliminar una macro

Grabar una macro

Cuando graba una macro, la grabadora de macros graba todos los pasos necesarios para completar las acciones que desea que realice la macro. En los pasos grabados no se incluye el desplazamiento por la cinta de opciones.

  1. Si la pestaña Programador no está disponible, haga lo siguiente para mostrarla:

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Opciones y, a continuación, haga clic en Personalizar cinta de opciones.

    3. En la categoría Personalizar cinta, en la lista Fichas principales, active la casilla Programador y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota    Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros.

      Para obtener más información acerca de cómo cambiar la configuración, vea el tema sobre cómo cambiar la configuración de seguridad de macros en Excel.

  3. En la ficha Programador, en el grupo Código, haga clic en Grabar macro.

  4. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Nota    El primer carácter del nombre de la macro debe ser una letra. Los caracteres siguientes pueden ser letras, números o caracteres de subrayado. No se pueden usar espacios en un nombre de macro; un carácter de subrayado funciona bien como separador de palabras. Si usa un nombre de macro que también es una referencia de celda, puede recibir un mensaje de error que el nombre de la macro no es válido.

  5. Para asignar una combinación de tecla de método abreviado con CTRL para ejecutar la macro, en el cuadro Tecla de método abreviado, escriba cualquier letra en mayúsculas o minúsculas que desee usar.

    Nota    La tecla de método abreviado invalidará a cualquier tecla de método abreviado predeterminada equivalente en Excel mientras esté abierto el libro que contiene la macro.

    Para obtener una lista de teclas de método abreviado que usen la tecla CTRL y que ya están asignadas en Excel, vea el tema sobre las teclas de función y de método abreviado de Excel.

  6. En la lista Guardar macro en, seleccione el libro donde desea almacenar la macro.

    Sugerencia    Si desea que una macro esté disponible siempre que utilice Excel, seleccione Libro de macros Personal. Cuando se selecciona Libro de macros Personal, Excel crea un libro oculto de macros personal (Personal.xlsb), si aún no existe y guarda la macro en este libro. En Windows Vista, este libro se guarda en la carpeta de name\AppData\Local\Microsoft\Excel\XLStart C:\Users\user. En Microsoft Windows XP, este libro se guarda en la carpeta C:\Documents and Settings\nombre de usuario\Application Data\Microsoft\Excel\XLStart. Libros en la carpeta XLStart se abren automáticamente cada vez que inicie Excel. Si desea que una macro en el libro de macros personal se ejecute automáticamente en otro libro, también debe guardar ese libro en la carpeta XLStart para que ambos libros se abren cuando se inicia Excel.

  7. Escriba una descripción de la macro en el cuadro Descripción.

  8. Haga clic en Aceptar para iniciar la grabación.

  9. Realice las acciones que desee grabar.

  10. En la ficha Programador, en el grupo Código, haga clic en Detener grabación Imagen del botón .

    Sugerencia    También puede hacer clic en Detener grabación Imagen del botón en el lado izquierdo de la barra de estado.

Parte superior de la página

Crear una macro mediante VBA

  1. Si la ficha Programador no está disponible, haga lo siguiente para mostrarla:

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Opciones y, a continuación, haga clic en Personalizar cinta de opciones.

    3. En la categoría Personalizar cinta, en la lista Fichas principales, active la casilla Programador y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota    Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros.

      Para obtener más información acerca de cómo cambiar la configuración, vea el tema sobre cómo cambiar la configuración de seguridad de macros en Excel.

  3. En la pestaña Programador, en el grupo Código, haga clic en Visual Basic.

  4. De ser necesario, en el Editor de Visual Basic, en el menú Insertar, haga clic en Módulo.

    Nota    Se crean módulos automáticamente para todas las hojas del libro.

  5. En la ventana de código del módulo, escriba o copie el código de macro que desea utilizar.

  6. Para ejecutar la macro desde la ventana del módulo, presione F5.

  7. En el Editor de Visual Basic, en el menú Archivo, haga clic en Cerrar y volver a Microsoft Excel cuando termine de escribir la macro.

Parte superior de la página

Copiar parte de una macro para crear otra

  1. Si la ficha Programador no está disponible, haga lo siguiente para mostrarla:

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Opciones y, a continuación, haga clic en Personalizar cinta de opciones.

    3. En la categoría Personalizar cinta, en la lista Fichas principales, active la casilla Programador y, a continuación, haga clic en Aceptar.

  2. Para establecer el nivel de seguridad de manera que estén habilitadas temporalmente todas las macros, haga lo siguiente:

    1. En la ficha Programador, en el grupo Código, haga clic en Seguridad de macros.

      El grupo Código en la pestaña Programador

    2. En Configuración de macros, haga clic en Habilitar todas las macros (no recomendado; puede ejecutarse código posiblemente peligroso) y, a continuación, haga clic en Aceptar.

      Nota    Para ayudar a evitar que se ejecute código potencialmente peligroso, recomendamos que vuelva a cualquiera de las configuraciones que deshabilitan todas las macros cuando termine de trabajar con las macros.

      Para obtener más información acerca de cómo cambiar la configuración, vea el tema sobre cómo cambiar la configuración de seguridad de macros en Excel.

  3. Abra el libro que contiene la macro que desee copiar.

  4. En la ficha Programador, en el grupo Código, haga clic en Macros.

  5. En el cuadro Nombre de la macro, haga clic en el nombre de la macro que desee copiar.

  6. Haga clic en Modificar.

  7. En la ventana de código del Editor de Visual Basic, seleccione las líneas de la macro que desee copiar.

    Sugerencia    Para copiar toda la macro, incluir las líneas Sub y End Sub en la selección.

  8. En el menú Edición, elija Copiar.

    Sugerencia    Puede también secundario y, a continuación, haga clic en Copiar, o puede presionar CTRL+C.

  9. En el cuadro Procedimiento de la ventana de código, haga clic en el módulo en el que desea colocar el código.

  10. En el menú Edición, elija Pegar.

    Sugerencia    Puede también secundario y, a continuación, haga clic en Pegar, o puede presionar CTRL+V.

Sugerencia    No puede editar el archivo de libro de macros Personal (Personal.xlsb) porque es un libro oculto que siempre está abierto. Primero debe mostrarlo utilizando el comando Mostrar. También puede abrir, en el Editor de Visual Basic presionando ALT+F11.

Parte superior de la página

Asignar una macro a un objeto, gráfico o control

  1. En una hoja de cálculo, haga clic con el botón secundario en el objeto, gráfico o control al que desea asignar una macro existente y, a continuación, haga clic en Asignar macro.

  2. En el cuadro Nombre de la macro, haga clic en la macro que desea asignar.

Parte superior de la página

Eliminar una macro

  1. Siga uno de los procedimientos siguientes:

    • Abra el libro que contiene la macro que desee eliminar.

    • Si la macro que quiere eliminar está almacenada en el Iibro de macros personal (Personal.xlsb) y este libro se encuentra oculto, proceda de la siguiente manera para mostrarlo:

      1. En la ficha Ver, en el grupo Ventana, haga clic en Mostrar.

      2. En Mostrar libro, haga clic en PERSONAL y después en Aceptar.

  2. Si la ficha Programador no está disponible, haga lo siguiente para mostrarla:

    1. Haga clic en la pestaña Archivo.

    2. Haga clic en Opciones y, a continuación, haga clic en Personalizar cinta de opciones.

    3. En la categoría Personalizar cinta, en la lista Fichas principales, active la casilla Programador y, a continuación, haga clic en Aceptar.

  3. En la ficha Programador, en el grupo Código, haga clic en Macros.

    El grupo Código en la pestaña Programador

  4. Seleccione el libro que contiene la macro que desea eliminar en la lista Macros en. Por ejemplo, haga clic en Este libro.

  5. En el cuadro Nombre de la macro, haga clic en el nombre de la macro que desee eliminar.

  6. Haga clic en Eliminar.

Parte superior de la página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!