Crear o ejecutar una macro

En Word, puede automatizar las tareas más usadas si crea y ejecuta macros. Una macro es una serie de comandos e instrucciones que se agrupan de forma conjunta como un mismo comando para completar una tarea automáticamente.

Para ahorrar tiempo en tareas que hace a menudo, encadene los pasos en una macro. Primero grabe la macro y luego ejecútela haciendo clic en un botón de la barra de herramientas de acceso rápido o pulsando una combinación de teclas (depende de cómo la haya configurado).

  1. Haga clic en Vista > Macros > Grabar macro.

    Comando Grabar macro

  2. Escriba un nombre para la macro.

    Cuadro del nombre de la macro

  3. Para usar esta macro en futuros documentos, asegúrese de que el cuadro Guardar macro en especifica Todos los documentos (Normal.dotm).

    Cuadro para elegir la ubicación donde guardar una macro

  4. Para que la macro se ejecute al hacer clic en un botón, elija Botón.

    Haga clic para asignar la macro a un botón

  5. Haga clic en la nueva macro (tendrá un nombre parecido a Normal.NuevasMacros.<nombre de la macro>), y luego en Agregar.

    La macro y el botón Agregar

  6. Haga clic en Modificar.

    Botón Modificar en el cuadro Personalizar la barra de herramientas de acceso rápido

  7. Elija una imagen para el botón, escriba el nombre que quiera y haga clic en Aceptar dos veces.

    Opciones de botones en el cuadro Modificar botón

  8. Ahora vamos a grabar los pasos. Haga clic en los comandos o presione las teclas de cada uno de los pasos de la tarea; Word graba cada acción que realice con el mouse o con el teclado.

    Nota: Utilice el teclado para seleccionar texto al grabar las macros, pues estas no graban las selecciones que se hagan con el mouse.

  9. Para detener la grabación, haga clic en Vista > Macros > Detener la grabación.

    Comando Detener grabación

El botón de la macro aparece en la Barra de herramientas de acceso rápido.

Botón de la macro en la Barra de herramientas de acceso rápido

Para ejecutar la macro, haga clic en el botón.

  1. Haga clic en Vista > Macros > Grabar macro.

    Comando Grabar macro

  2. Escriba un nombre para la macro.

    Cuadro del nombre de la macro

  3. Para usar esta macro en futuros documentos, asegúrese de que el cuadro Guardar macro en especifica Todos los documentos (Normal.dotm).

    Cuadro para elegir la ubicación donde guardar una macro

  4. Para ejecutar la macro al presionar un método abreviado de teclado, haga clic en Teclado.

    Haga clic para asignar la macro a un método abreviado de teclado

  5. Escriba una combinación de teclas en el cuadro Presione un nuevo método abreviado de teclado box.

  6. Compruebe que la combinación no esté asignada a otra función. En caso de que sí lo esté, trate de usar una combinación distinta.

  7. Para utilizar esta macro de método abreviado de teclado en futuros documentos, asegúrese de que el cuadro Guardar cambios en especifica Normal.dotm.

  8. Haga clic en Asignar.

  9. Ahora vamos a grabar los pasos. Haga clic en los comandos o presione las teclas de cada uno de los pasos de la tarea; Word graba cada acción que realice con el mouse o con el teclado.

    Nota: Utilice el teclado para seleccionar texto al grabar las macros, pues estas no graban las selecciones que se hagan con el mouse.

  10. Para detener la grabación, haga clic en Vista > Macros > Detener la grabación.

    Comando Detener grabación

Para ejecutar la macro, presione las teclas del método abreviado de teclado.

Para ejecutar una macro, haga clic en el botón o en la barra de herramientas de acceso rápido y presione el método abreviado de teclado. También puede hacerlo desde la lista de Macros.

  1. Haga clic en Vista > Macros > Ver macros.

    Comando Ver macros

  2. En la lista que se encuentra en la sección de Nombre de la macro, haga clic en la macro que desea ejecutar.

  3. Haga clic en Ejecutar.

Para hacer que la macro de un documento esté disponible en todos los futuros documentos, agréguela a la plantilla Normal.dotm.

  1. Abra el documento que contiene la macro.

  2. Haga clic en Vista > Macros > Ver macros.

    Comando Ver macros

  3. Haga clic en Organizador.

    Botón Organizador en el cuadro Ver macros

  4. Seleccione la macro que desea agregar a la plantilla Normal.dotm y haga clic en Copiar.

  1. Haga clic en Archivo > Opciones > Personalizar la cinta de opciones.

  2. En Comandos disponibles en, seleccione Macros.

  3. Haga clic en la macro que desee.

  4. En Personalizar la cinta de opciones, haga clic en la pestaña y el grupo personalizado donde desea agregar la macro.

Si no tiene ningún grupo personalizado, haga clic en Nuevo grupo y luego seleccione Cambiar nombre para ponerle un nombre.

  1. Haga clic en Agregar.

  2. Haga clic en Cambiar nombre para elegir una imagen para la macro y escribir el nombre que desee.

  3. Haga clic en Aceptar dos veces.

  1. En el grupo Código de la ficha Programador, haga clic en Macros.

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Nota: Si asigna a una nueva macro el mismo nombre que una macro integrada de Word, las nuevas acciones de macro reemplazarán a la macro integrada. Para ver una lista de las macros integradas, haga clic en Comandos de Word en la lista Macros en.

  3. En la lista Macros en, haga clic en la plantilla o documento donde quiera guardar la macro.

    Para que la macro esté disponible en todos los documentos, asegúrese de hacer clic en Normal.dotm.

  4. Haga clic en Crear para abrir el Editor de Visual Basic.

Después de abrir el Editor de Visual Basic, puede que quiera obtener más información sobre cómo trabajar con Visual Basic para Aplicaciones. Para obtener más información, haga clic en Ayuda de Microsoft Visual Basic en el menú Ayuda o presione F1.

Puede grabar una secuencia de acciones, o bien puede escribir una macro desde cero si escribe código de Visual Basic para Aplicaciones en el Editor de Visual Basic.

Nota: Para trabajar con macros en Office Word 2007 necesita mostrar la pestaña Desarrollador.

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, a continuación, en Opciones de Word.

  2. Haga clic en Popular.

  3. En Principales opciones para trabajar con Word, active la casilla Mostrar la pestaña Desarrollador en la cinta de opciones.

    Nota: La cinta de opciones es un componente de la interfaz de usuario de Microsoft Office Fluent.

  1. En el grupo Código de la ficha Programador, haga clic en Grabar macro.

    Grupo Código en la pestaña Desarrollador
  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Nota: Si asigna a una nueva macro el mismo nombre que una macro integrada de Office Word 2007, las nuevas acciones de macro reemplazarán a la macro integrada. Para ver una lista de las macros integradas, en la pestaña Desarrollador, en el grupo Código, haga clic en Macros. En la lista Macros en, haga clic en Comandos de Word.

  3. En el cuadro Guardar macro en, haga clic en la plantilla o documento donde quiera guardar la macro.

    Importante: Para que la macro esté disponible en todos los documentos, asegúrese de hacer clic en Normal.dotm.

  4. Escriba una descripción de la macro en el cuadro Descripción.

  5. Siga uno de los siguientes procedimientos:

    • Empezar a grabar    Para empezar a grabar la macro sin asignarla a un botón de la barra de herramientas de acceso rápido o a una tecla de método abreviado, haga clic en Aceptar.

    • Crear un botón    Para asignar la macro a un botón de la barra de herramientas de acceso rápido, siga este procedimiento:

      1. Haga clic en Botón.

      2. En Personalizar barra de herramientas de acceso rápido, seleccione el documento (o todos los documentos) en el que quiera agregar la macro a la barra de herramientas de acceso rápido.

        Importante: Para que la macro esté disponible en todos los documentos, asegúrese de hacer clic en Normal.dotm.

      3. En el cuadro de diálogo Comandos disponibles en, haga clic en la macro que esté grabando y, después, seleccione Agregar.

      4. Para personalizar el botón, haga clic Modificar.

      5. En Símbolo, haga clic en el símbolo que quiera usar para el botón.

      6. En el cuadro Nombre para mostrar, escriba el nombre de la macro que quiera mostrar.

      7. Haga clic en Aceptar dos veces para empezar a grabar la macro.

        El símbolo que seleccione se mostrará en la barra de herramientas de acceso rápido. El nombre que escriba se mostrará cuando señale el símbolo.

    • Asignar un método abreviado de teclado    Para asignar la macro a un método abreviado de teclado, siga este procedimiento:

      1. Haga clic en Teclado.

      2. En el cuadro Comandos, haga clic en la macro que esté grabando.

      3. En el cuadro Nueva tecla de método abreviado, escriba la secuencia de teclas que quiera usar y, después, haga clic en Asignar.

      4. Haga clic en Cerrar para empezar a grabar la macro.

  6. Realice las acciones que quiera incluir en la macro.

    Nota: Al grabar una macro, puede usar el mouse para hacer clic en Comandos y opciones, pero no podrá usarlos para seleccionar texto. Para seleccionar texto tiene que usar el teclado. Para obtener más información sobre cómo seleccionar texto con el teclado, vea Seleccionar texto.

  7. Para detener la grabación de las acciones, haga clic en Detener grabación en el grupo Código.

Cambiar el método abreviado de teclado de una macro

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office y, a continuación, en Opciones de Word.

  2. Haga clic en Personalizar.

  3. Junto a Métodos abreviados de teclado, haga clic en Personalizar.

  4. En la lista Categorías, haga clic en Macros.

  5. En la lista Macros, haga clic en la macro que quiera cambiar.

  6. En el cuadro Nueva tecla de método abreviado, escriba la combinación de teclas que quiera usar.

  7. Active la casilla Teclas activas para asegurarse de no asignar una combinación de teclas que ya use para realizar otra tarea.

  8. En la lista Guardar cambios en, haga clic en la opción que coincida con la ubicación donde quiera ejecutar la macro.

    Importante: Para que la macro esté disponible en todos los documentos, asegúrese de hacer clic en Normal.dotm.

  9. Haga clic en Cerrar.

  1. En el grupo Código de la ficha Programador, haga clic en Macros.

    Grupo Código en la pestaña Desarrollador

  2. En la lista que se encuentra en Nombre de la macro, haga clic en la macro que quiera ejecutar.

  3. Haga clic en Ejecutar.

  1. En el grupo Código de la ficha Programador, haga clic en Macros.

    Grupo Código en la pestaña Desarrollador

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Nota: Si asigna a una nueva macro el mismo nombre que una macro integrada de Office Word 2007, las nuevas acciones de macro reemplazarán a la macro integrada. Para ver una lista de las macros integradas, haga clic en Comandos de Word en la lista Macros en.

  3. En la lista Macros en, haga clic en la plantilla o documento donde quiera guardar la macro.

    Para que la macro esté disponible en todos los documentos, asegúrese de hacer clic en Normal.dotm.

  4. Haga clic en Crear para abrir el Editor de Visual Basic.

Después de abrir el Editor de Visual Basic, puede que quiera obtener más información sobre cómo trabajar con Visual Basic para Aplicaciones. Para obtener más información, haga clic en Ayuda de Microsoft Visual Basic en el menú Ayuda o presione F1.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×