Crear formularios e informes de Access a partir de una lista de SharePoint

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Puede crear formularios e informes de una lista de SharePoint y utilizarlas como vistas. Los usuarios del sitio de SharePoint que tienen instalado de Access 2007 pueden abrir estos formularios e informes mediante el menú Ver de la lista de SharePoint. Puede realizar un acceso a la vista predeterminada para una lista.

Las vistas que crea con Access 2007 se almacenan en un archivo de base de datos en el servidor Windows SharePoint Services. Cuando abre una vista de Access de una lista de SharePoint, inicie Access, y se muestra el formulario o informe. Dado que la base de datos se almacena en el sitio de SharePoint, se puede abrir la vista por otros usuarios del sitio. Un usuario no necesita conocer la ubicación en el sitio de SharePoint, del archivo de base de datos que contiene la vista de Access para poder usar la vista. Además, el usuario no es necesario saber cómo iniciar Access: se controla automáticamente por el sitio de SharePoint.

Nota: Para crear, utilizar o modificar una vista de Access en un sitio de SharePoint, el usuario debe tener instalado Access 2007 en su equipo.

¿Qué desea hacer?

Crear una vista de Access de una lista de SharePoint

Realizar un acceso a la vista predeterminada de la lista de SharePoint

Utilizar una vista de Access de una lista de SharePoint

Modificar una vista de Access de una lista de SharePoint

Crear una vista de Access de una lista de SharePoint

Al crear una vista de Access de una lista de SharePoint, Access se inicia de forma automática. En Access, es posible basar la vista en una serie de plantillas de formulario e informe y, a continuación, personalizar dicha vista. Al publicar la vista en el sitio de SharePoint, se pone a disposición de otros usuarios con facilidad.

Nota: Para crear una vista de una lista de SharePoint, debe contar con el permiso Administrar listas de Windows SharePoint Services, que está incluido de forma predeterminada en el nivel de permiso de diseño.

Para crear una vista de Access de una lista de SharePoint que está viendo en el explorador, utilice el siguiente procedimiento.

  1. En el sitio de SharePoint, en el menú Ver Menú desplegable , haga clic en Crear vista.

  2. En la página Crear vista, haga clic en Vista de Access.

    Access se inicia y solicita que se guarde una copia local de la base de datos que va a incluir la nueva vista.

  3. En el cuadro de diálogo Guardar una copia local, vaya a la ubicación del equipo en la que desea guardar la copia, escriba un nombre para la copia local en el cuadro Nombre de archivo y, a continuación, haga clic en Guardar.

    Access guarda y abre la copia local; a continuación, aparece el cuadro de diálogo Crear vista de Access.

  4. En el cuadro de diálogo Crear vista de Access, haga doble clic en el tipo de vista que desea crear.

    Access crea la nueva vista y la abre en la vista Presentación.

  5. Es posible personalizar la nueva vista en la vista Presentación o ir a la vista Diseño.

    En la vista Presentación es posible cambiar el tamaño de los controles de la vista (como etiquetas y campos) y reorganizarlos, aunque no se pueden agregar controles adicionales a la misma. La vista Presentación ofrece una vista previa de los datos que facilita la visualización del aspecto de los cambios en la vista finalizada.

    En la vista Diseño es posible cambiar el tamaño de los controles y reorganizarlos, así como agregar controles adicionales. Sin embargo, no ofrece una vista previa de los datos.

    Es posible alternar entre las vistas Diseño y Presentación tantas veces como se desee. Si utiliza la vista Diseño para agregar controles a la vista, a continuación puede ir a la vista Presentación para organizar esos controles mientras obtiene una vista previa de los datos.

  6. Una vez realizadas las personalizaciones, en la barra de mensajes, haga clic en Publicar en el sitio de SharePoint.

    barra de herramientas

    Aparece el cuadro de diálogo Publicar en servidor Web.

    Si la barra de mensajes no aparece, ábrala mediante el siguiente procedimiento:

    • En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

  7. De forma predeterminada, Access guarda la vista en un archivo de base de datos situado en la biblioteca de documentos compartidos del sitio de SharePoint (este sitio contiene la lista a partir de la que se ha creado la vista). En la mayoría de los casos, esto será lo que desee, aunque es posible cambiar la biblioteca de documentos en la que se almacena la base de datos si se selecciona una biblioteca distinta en el cuadro Guardar en del cuadro de diálogo Publicar en servidor Web. Puede hacer esto para controlar de una forma más específica quién tiene acceso a la vista y si los usuarios pueden abrirla en modo de sólo lectura o en modo de edición. El sitio de SharePoint también puede tener bibliotecas específicas configuradas para publicar vistas de Access, en cuyo caso es posible que deba cambiar la ubicación de Guardar en para seleccionar la biblioteca correcta.

    El administrador del sitio de SharePoint puede ayudarle a seleccionar la biblioteca adecuada.

  8. Access sugiere un nombre para la base de datos en el cuadro Nombre de archivo del cuadro de diálogo Publicar en servidor Web. Este nombre coincide con el de la base de datos guardada como copia local. Si lo desea, puede cambiar el nombre, aunque en la mayoría de los casos debería aceptar el sugerido (así resultará más sencillo recordar qué base de datos local se corresponde con la publicada en el sitio de SharePoint).

  9. Para guardar la base de datos en el sitio de SharePoint, haga clic en Publicar.

Principio de página

Realizar un acceso a la vista predeterminada de la lista de SharePoint

Cuando realiza un acceso a la vista predeterminada para una lista de SharePoint, la vista de Access se abre automáticamente cuando los usuarios abran la lista, si esos usuarios tengan Access instalado en sus equipos.

Importante: Si realiza una vista de acceso a la vista predeterminada, los visitantes de la lista que no tengan instalado de Access 2007 no podrá usar la lista.

  1. Con la lista de SharePoint abierta, en el menú configuración, haga clic en Configuración de la lista.

  2. En la página Configuración de la lista, en vistas, haga clic en el nombre de la vista de Access que desea que la vista predeterminada.

  3. En la página Editar vista, seleccione establecer como vista predeterminada y, a continuación, haga clic en Aceptar.

Principio de página

Utilizar una vista de Access de una lista de SharePoint

Para utilizar una vista de Access de una lista de SharePoint, seleccione la vista de Access en el menú Ver de la lista.

  • En el menú Ver Menú desplegable , haga clic en el nombre de la vista de Access. Este programa se inicia y, a continuación, muestra la vista en modo de sólo lectura.

    En el modo de sólo lectura, puede cambiar los datos de la vista e imprimir ésta, aunque no puede cambiar el diseño de la misma. Si desea cambiar el diseño de la vista, vea la siguiente sección de este artículo, Modificar una vista de Access de una lista de SharePoint.

Principio de página

Modificar una vista de Access de una lista de SharePoint

Para modificar el diseño de una vista de Access, guarde una copia local de la base de datos que contiene la vista de Access y, a continuación, realice los cambios. Entonces podrá utilizar la copia local de la vista o, si dispone de los permisos adecuados en el sitio de SharePoint, publicar la nueva vista.

Nota: Es posible modificar una copia local de una vista de Access independientemente del nivel de permiso de Windows SharePoint Services. No obstante, para publicar la vista modificada en el sitio de SharePoint, se necesita el permiso Administrar listas de Windows SharePoint Services, que está incluido de forma predeterminada en el nivel de permiso de diseño. Si ha creado la vista de Access, ya debe contar con el permiso Administrar listas. Si no está seguro, póngase en contacto con el administrador del sitio de SharePoint a fin de determinar si dispone de los permisos que necesita.

  1. Con la vista de Access abierta, en la barra de mensajes, haga clic en Guardar como.

    El botón Guardar como de la barra de mensajes

    Nota: Si la barra de mensajes no aparece, ábrala mediante el siguiente procedimiento:

    • En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

  2. Haga clic en cuando Access le pida que cierre la vista y todos los demás objetos abiertos.

    Aparece el cuadro de diálogo Guardar como.

  3. En el cuadro Guardar en, especifique la ubicación en la que desea guardar la copia local, escriba un nombre para la misma en el cuadro Nombre de archivo y, a continuación, haga clic en Guardar.

    Access guarda la copia local de la base de datos y, a continuación, la abre.

  4. Realice uno de los procedimientos siguientes:

    • Para cambiar la presentación de la vista sin agregar ningún control nuevo, en el panel de exploración, haga clic con el botón secundario del mouse (ratón) en la vista y, a continuación, haga clic en Vista Presentación en el menú contextual.

      En la vista Presentación es posible cambiar el tamaño de los controles de la vista (como etiquetas y campos) y reorganizarlos, aunque no se pueden agregar controles adicionales a la misma. La vista Presentación ofrece una vista previa de los datos que facilita la visualización del aspecto de los cambios en la vista finalizada.

    • Para agregar controles (como etiquetas o campos) a la vista o quitarlos, en el panel de exploración, haga clic con el botón secundario en la vista y, a continuación, haga clic en Vista Diseño en el menú contextual.

      En la vista Diseño es posible cambiar el tamaño de los controles y reorganizarlos, así como agregar controles adicionales. Sin embargo, no ofrece una vista previa de los datos.

      Nota: Si opta por modificar la vista en la vista Diseño y planea publicar la vista revisada en el sitio de SharePoint, no agregue a la vista ningún campo que no sea parte de la lista de SharePoint.

  5. Es posible alternar entre las vistas Diseño y Presentación tantas veces como se desee. Si utiliza la vista Diseño para agregar controles a la vista, a continuación puede ir a la vista Presentación para organizar esos controles en la vista mientras obtiene una vista previa de los datos.

Publicar la vista de Access modificada en el sitio de SharePoint

Una vez modificada la vista, si cuenta con el permiso Administrar listas en el sitio de SharePoint, puede publicar dicha vista modificada mediante el siguiente procedimiento.

Para obtener el permiso Administrar listas, póngase en contacto con el administrador del sitio de SharePoint.

  1. Guarde la vista en la copia local de la base de datos.

  2. En la barra de mensajes, haga clic en Publicar en el sitio de SharePoint.

    barra de herramientas

    Nota: Si no dispone del permiso Administrar listas, la barra de mensajes no muestra el botón Publicar en el sitio de SharePoint. Si la barra de mensajes no aparece, ábrala mediante el siguiente procedimiento:

    • En la ficha Herramientas de base de datos, en el grupo Mostrar u ocultar, haga clic en Barra de mensajes.

  3. En el cuadro de diálogo Publicar en servidor Web, haga clic en Publicar.

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×