Crear fórmulas condicionales para buscar datos o aplicar formato

Cuando las reglas de formato condicional integradas de Excel no respondan a sus necesidades, podrá usar una fórmula para obtener los resultados que desee. Por ejemplo, puede usar una fórmula condicional para buscar celdas en blanco y ponerlas en rojo para verlas más fácilmente.

  1. Seleccione las celdas a las que desee aplicar formato.

  2. Haga clic en Inicio > Formato condicional > Nueva regla.

  3. Haga clic en Utilizar una fórmula para determinar en qué celdas desea aplicar el formato.

  4. En Dar formato a los valores donde esta fórmula sea verdadera, especifique la fórmula.

  5. Haga clic en Formato.

  6. Use los controles de las pestañas Número, Fuente, Borde y Relleno para cambiar los datos o las celdas que están en torno a los datos.

Por ejemplo, puede poner valores negativos en negrita y rojo, agregar un relleno color amarillo claro para los fondos de celda o agregar un borde discontinuo.

Haga clic en Aceptar para cerrar todos los cuadros de diálogo abiertos.

Aquí tenemos un ejemplo:

  1. Seleccione todas las celdas de una hoja de cálculo. Para ello, haga clic en el selector situado encima de la fila 1 a la izquierda de la columna A.

  2. Repita los pasos 1 a 3 de los pasos anteriores.

  3. Cuando llegue al paso 4, especifique =RESIDUO(FILA(),2)=1.Puede copiar y pegar la fórmula, si así lo desea.

  4. Haga clic en Formato y después en la pestaña Relleno y seleccione un matiz de azul en la paleta de colores.

  5. Haga clic en Aceptar para completar la regla. Ahora, todas las demás filas de la hoja de cálculo estarán sombreadas con el color que ha elegido.

Es un ejemplo de lo que pueden hacer las fórmulas condicionales de una regla de formato.

Ejemplos de fórmulas condicionales

  • Para buscar celdas en blanco, primero seleccione el rango de celdas (una fila o columna) que contendrá los resultados y después repita los pasos de la primera sección para crear una regla de formato que use esta fórmula.

    =B2=""

    En la fórmula, no se olvide de reemplazar B2 por la primera celda que desee usar.

  • Para buscar valores duplicados en un rango de celdas, pruebe la siguiente fórmula: aplica formato a todos los valores que no son únicos.

    =CONTAR.SI($A$1:$D$11,D2)>1

  • Para calcular promedios, especifique:

    =A1>PROMEDIO(A1:A14)

Cuando se haya familiarizado con las fórmulas condicionales, pruébelas. Usan la lógica IF, AND y OR. Escríbalas en la barra de fórmulas de Excel (no las use en una regla), le ahorrarán tiempo y esfuerzos.

  • Buscar valores que cumplan dos condiciones: Excel muestra TRUE si el valor de la celda A2 es superior al valor de A3 y es también inferior al valor de A4. Pero si el valor de A2 no cumple ambas condiciones, verá FALSE.

    =Y(A2>A3,A2<A4)

  • Buscar valores que cumplan una condición: En este ejemplo, Excel solo muestra TRUE si el valor de A2 cumple una de las condiciones: es superior al valor de A3 o inferior al valor de A4.

    =O(A2>A3,A2<A4)

  • Usar fórmulas que no muestren TRUE o FALSE como resultado: Este ejemplo muestra "OK" si el valor de A2 no es igual a los valores de A3 y A4. De lo contrario, mostrará "NOT OK".

    Se muestra =SI(Y(A2<>A3,A2<>A4),"Correcto","Incorrecto").

  • Agregar letras de puntuación basadas en una puntuación numérica: Esta fórmula agrega una base de letras de puntuación a cualquier tipo de puntuación como por ejemplo resultados de pruebas o puntuaciones de productos.

    =SI(D2>=80,"A", SI(D2>=75, "B+", SI(D2>=70, "B", SI(D2>=70,"B", SI(D2>=65,"C+", SI(D2>=60, "C","D"))))))

  • Reemplazar las letras de puntuación con: "Correcto" e "Incorrecto" :

    =SI(D2>59,"Correcto","Incorrecto")

Más información sobre el formato condicional

Más información sobre el formato condicional

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×