Crear fórmulas condicionales

La comprobación de si las condiciones son verdaderas o falsas y la realización de comparaciones lógicas entre expresiones son elementos comunes de varias tareas. Para crear fórmulas condicionales, puede utilizar las funciones Y, O, NO y SI.

Por ejemplo, la función SI utiliza los siguientes argumentos.

fórmula con el concepto si función

Fórmula que usa la función SI

Imagen de botón prueba_lógica: la condición que se desea comprobar.

Imagen del botón valor_si_verdadero: el valor que se devolverá si la condición se cumple.

Imagen de botón  valor_si_falso: el valor que se devolverá si la condición no se cumple.

Para obtener más información sobre cómo crear fórmulas, vea Crear o eliminar una fórmula.

¿Qué desea hacer?

Crear una fórmula condicional que devuelva un valor lógico (VERDADERO O FALSO)

Crear una fórmula condicional que devuelva otro cálculo o valores distintos a VERDADERO o FALSO

Crear una fórmula condicional que devuelva un valor lógico (VERDADERO O FALSO)

Para realizar esta tarea, utilice las funciones Y, O y NO, así como los operadores tal y como se indica en el ejemplo siguiente.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo.

    Importante: No seleccione los encabezados de fila ni de columna.

    seleccionar un ejemplo de la ayuda de Excel 2013 para Windows

    Seleccionar un ejemplo de la Ayuda

  2. Presione CTRL+C.

  3. En Excel, cree un libro o una hoja de cálculo en blanco.

  4. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante: Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

1

".2"

3%

-4

'5

6%

7



8



9


10


11



12

A

B

Datos

15

9

8

Engranajes

Widgets

Fórmula

Descripción (resultado)

=Y(A2>A3, A2<A4)

Determina si el valor de la celda A2 es mayor que el valor de la celda A3 y a la vez menor que el valor de la celda A4. (FALSO)

=O(A2>A3, A2<A4)

Determina si el valor de la celda A2 es mayor que el valor de la celda A3 o si es menor que el valor de la celda A4. (VERDADERO)

=NO(A2+A3=24)

Determina si la suma de los valores de las celdas A2 y A3 no es igual a 24. (FALSO)

=NO(A5="Engranajes")

Determina si el valor de la celda A5 no es igual a "Engranajes". (FALSO)

=O(A5<>"Engranajes";A6 = "Widgets")

Determina si el valor de la celda A5 no es igual a "Engranajes" o si el valor de la celda A6 es igual a "Aparatos mecánicos" (VERDADERO)

Para obtener más información sobre el uso de estas funciones, vea los temas sobre las funciones Y, O y NO.

Principio de página

Crear una fórmula condicional que devuelva otro cálculo o valores distintos a VERDADERO o FALSO

Para realizar esta tarea, utilice las funciones SI, Y y O y operadores, tal y como se muestra en el ejemplo siguiente.

Ejemplo

Es más sencillo comprender el ejemplo si se copia en una hoja de cálculo en blanco.

¿Cómo se copia un ejemplo?

  1. Seleccione el ejemplo de este artículo.

Importante: No seleccione los encabezados de fila ni de columna.

seleccionar un ejemplo de la ayuda de Excel 2013 para Windows

Seleccionar un ejemplo de la Ayuda

  1. Presione CTRL+C.

  2. En Excel, cree un libro o una hoja de cálculo en blanco.

  3. En la hoja de cálculo, seleccione la celda A1 y presione CTRL+V.

Importante: Para que el ejemplo funcione correctamente, debe pegarlo en la celda A1 de la hoja de cálculo.

  1. Para cambiar entre ver los resultados y las fórmulas que devuelven los resultados, presione Alt+º (ordinal masculino) o bien, en la ficha Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón Mostrar fórmulas.

Después de copiar el ejemplo en una hoja de cálculo en blanco, puede adaptarlo a sus necesidades.

1

".2"

3%

-4

'5

6%

7


8



9



10



11




12



13



14




15



16

A

B

Datos

15

9

8

Engranajes

Widgets

Fórmula

Descripción (resultado)

=SI(A2=15, "Correcto", "Incorrecto")

Si el valor de la celda A2 es igual a 15, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Correcto)

=SI(A2<>15, "Correcto", "Incorrecto")

Si el valor de la celda A2 no es igual a 15, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Incorrecto)

=SI(NO(A2<=15), "Correcto", "Incorrecto")

Si el valor de la celda A2 no es menor o igual a 15, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Incorrecto)

=SI(A5<>"ENGRANAJES", "Correcto", "Incorrecto")

Si el valor de la celda A5 no es igual a "ENGRANAJES", devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Incorrecto)

=SI(Y(A2>A3, A2<A4); "Correcto", "Incorrecto")

Si el valor de la celda A2 es mayor que el valor de A3 y es menor que el valor de A4, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Incorrecto)

=SI(Y(A2<>A3, A2<>A4); "Correcto", "Incorrecto")

Si el valor de la celda A2 no es igual al de la celda A3 y tampoco es igual al de la celda A4, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Correcto)

=SI(O(A2>A3; A2<A4), "Correcto", "Incorrecto")

Si el valor de la celda A2 es mayor que el valor de A3 o es menor que el valor de A4, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Correcto)

=SI(O(A5<>"Engranajes", A6<>"Widgets"); "Correcto", "Incorrecto")

Si el valor de la celda A5 no es igual a "Engranajes" o el valor de la celda A6 no es igual a "Widgets", se devuelve "Correcto". De lo contrario, devuelve «Incorrecto». (No(Incorrecto)

=SI(O(A2<>A3, A2<>A4); "Correcto", "Incorrecto")

Si el valor de la celda A2 no es igual al valor de A3 o no es igual al valor de A4, devuelve "Correcto". De lo contrario, devuelve "Incorrecto". (Correcto)

Para obtener más información sobre el uso de estas funciones, vea los temas sobre las funciones SI, Y y O.

Principio de página

¿Le ha sido útil esta información?

De acuerdo. ¿Algún comentario más?

¿Cómo podemos mejorarlo?

¡Gracias por sus comentarios!

×