Crear, ejecutar, modificar o eliminar una macro

Para ahorrar tiempo en tareas que hace a menudo, puede grabar los pasos de esas tareas en forma de macro. Luego, cuando quiera llevar a cabo una de estas tareas grabadas, puede activar la macro para que los pasos se ejecuten automáticamente.

Word

En Word 2016 para Mac puede crear una macro que tiene un método abreviado de teclado, ejecutar una macro y eliminar una macro que ya no necesite.

  1. Haga clic en Vista > Macros > Grabar macro.

    En la pestaña Vista, haga clic en Macro y haga clic en Grabar Macro para empezar a crear una macro.
  2. Escriba un nombre para la macro o acepte el nombre predeterminado que proporciona Word.

    Escriba un nombre para su macro en Nombre de la macro o acepte el nombre genérico proporcionado por Word.
  3. Para usar esta macro en cualquier documento que cree, compruebe que la opción Todos los documentos (Normal) esté seleccionada en la lista Guardar macro en.

  4. Haga clic en Teclado para asignar una combinación de teclas a la macro.

    Word muestra el cuadro de diálogo Personalizar teclado.

  5. Escriba una combinación de teclas en el cuadro Presione el nuevo método abreviado de teclado.

    Word muestra el comando o la macro a los que ya se les ha asignado una combinación de teclas, si procede, después de que presione la combinación.

    Al presionar una combinación de teclas, Word muestra el comando o acción asignados a esa combinación de teclas, en caso de haber alguno.

  6. Si la combinación de teclas que ha elegido ya está asignada, elimínela del cuadro Presione el nuevo método abreviado de teclado y elija una nueva combinación de teclas.

    Vaya al siguiente paso cuando haya encontrado una combinación de teclas sin asignar.

    Word identifica cuando ha presionado una combinación de teclas que no se ha asignado todavía a un comando o a una macro.
  7. Para usar este método abreviado de teclado en cualquier documento nuevo, asegúrese de que Normal.dotm, la plantilla global, esté seleccionada en la lista Guardar cambios en.

    Seleccione Normal.dotm para hacer que una macro esté disponible para su uso en los documentos nuevos que cree.
  8. Haga clic en Asignar.

  9. Cuando esté listo para grabar la macro, haga clic en Aceptar.

  10. Haga clic en los comandos o presione las teclas para cada paso de la tarea.

    Word graba los clics y las pulsaciones de teclas, pero no graba el texto que seleccione con el ratón. Para seleccionar texto mientras graba una macro, use el teclado.

  11. Para detener la grabación, haga clic en Vista > Macros > Detener la grabación.

    Haga clic en Detener grabación en el menú Macros para detener la grabación de una macro.

Para ejecutar una macro, presione el método abreviado de teclado asignado o ejecute la macro desde la lista Macros.

  1. Haga clic en Vista > Macros > Ver macros.

    Haga clic en Ver macros para ver y editar las macros asociadas al documento actual.
  2. En la lista bajo Nombre de la macro, seleccione la macro que quiera ejecutar.

  3. Haga clic en Ejecutar.

    Después de seleccionar una macro en Nombre de macro, haga clic en Ejecutar para ejecutarla.

  1. Haga clic en Vista > Macros > Ver macros.

    Haga clic en Ver macros para ver y editar las macros asociadas al documento actual.
  2. Compruebe que la ubicación especificada por Macros en incluye la ubicación de la macro que quiere eliminar.

    Seleccione la ubicación de las macros que quiere ver en las Macros de la lista.

    La lista incluirá el documento que está abierto en la ventana actual, así como la plantilla global y los comandos de Word.

  3. En Nombre de la macro, seleccione la macro que quiere eliminar y haga clic en el signo menos situado debajo de la lista.

    Seleccione la macro que quiere eliminar y haga clic en el signo menos en la lista.
  4. Cuando Word le pida que confirme que quiere eliminar la macro, haga clic en .

Excel

En Excel 2016 para Mac puede crear una macro que tiene un método abreviado de teclado, ejecutar una macro y eliminar una macro que ya no necesite.

Cuando graba una macro, la grabadora de macros graba todos los pasos necesarios para completar las acciones que quiere que realice la macro. Entre estos pasos puede incluir escribir texto o números, hacer clic en celdas o comandos de la cinta o en los menús, dar formato, seleccionar celdas, filas o columnas, y arrastrar el ratón para seleccionar celdas en una hoja de cálculo.

Nota: Los comandos para grabar, crear y eliminar macros, así como otras funciones avanzadas, también están disponibles en la pestaña Desarrollador de la cinta. Para más información sobre el uso de la pestaña Desarrollador, vea Use the Developer tab to create or delete a macro in Excel 2016 for Mac (Usar la pestaña Desarrollador para crear o eliminar una macro en Excel 2016 para Mac).

  1. Seleccione Herramientas > Macro > Grabar nueva macro.

    Seleccione Herramientas, Macro y Grabar nueva macro

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Escriba un nombre de macro, una ubicación y una clave de acceso directo

  3. Para crear un método abreviado de teclado para la macro, escriba una letra en el cuadro Opción+Cmd.

  4. Seleccione una ubicación para la macro en la lista desplegable.

    Para guardar la macro

    Haga clic en

    En el documento donde vaya a crear la macro

    Este libro

    En todos los documentos abiertos

    Nuevo libro

    Para que esté disponible siempre que use Excel

    Libro de macros personal

  5. (Opcional) Agregue una descripción para la macro.

  6. Cuando esté listo para grabar, haga clic en Aceptar.

  7. Haga clic en los comandos o presione las teclas para cada paso de la tarea.

  8. Para detener la grabación, seleccione Herramientas > Macro > Detener grabación (este paso no se grabará en la macro).

    Seleccione Detener grabación

Para ejecutar una macro, presione el método abreviado de teclado asignado o ejecute la macro desde el cuadro de diálogo Macros.

  1. En la pestaña Vista, haga clic en Ver macros.

  2. Haga clic en Macros en el menú emergente y seleccione Este libro.

  3. Seleccione la macro en la lista y haga clic en Ejecutar.

    Cuadro de diálogo Macros de Excel para Mac

  1. Seleccione Herramientas > Macro > Macros.

    Seleccione Macro y, luego, seleccione Macros

  2. Seleccione la macro que quiere eliminar y presione el signo menos.

    Seleccione el nombre de la macro y, luego, seleccione el signo menos

  3. Aparecerá un mensaje de confirmación. Haga clic en para confirmar la eliminación.

    Confirmar eliminación

También puede eliminar una macro desde la pestaña Desarrollador.

  1. En la pestaña Programador, haga clic en Macros.

  2. En la lista, haga clic en la macro que desea eliminar y haga clic en el botón eliminar.

    Seleccione una macro y haga clic en el signo menos para eliminarla.

Word

Para automatizar una tarea repetitiva, puede crear rápidamente una macro en Word. También puede usar el Editor de Visual Basic en Microsoft Visual Basic para Aplicaciones para escribir un script de macro o para copiar toda o una parte de una macro en una nueva macro.

Al grabar una macro, se graban todos los pasos necesarios para completar las acciones que quiere que realice la macro. Pero la navegación a la pestaña para detener la grabación no se incluye en los pasos grabados.

  1. En la pestaña Programador, en Visual Basic, haga clic en Grabar.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

  3. En el menú emergente Guardar macro en, realice uno de los procedimientos siguientes:

    Para guardar la macro

    Haga clic en

    En el documento en el que está creando la macro

    [nombre del documento] (documento)

    En todos los documentos abiertos

    Todos los documentos (Normal)

  4. Haga clic en Aceptar y realice las acciones que desea grabar.

  5. En la pestaña Programador, en Visual Basic, haga clic en Detener.

Puede usar el Editor de Visual Basic integrado para crear una macro.

  1. En la pestaña Programador, en Visual Basic, haga clic en Editor.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. Si necesita insertar un módulo, en el Editor de Visual Basic, en el menú Insertar, haga clic en Módulo.

  3. En la ventana de código del módulo, escriba o pegue el código de la macro que desee usar.

  4. Cuando haya terminado, en el menú Word, haga clic en Cerrar y volver a Microsoft Word.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea ejecutar y, a continuación, en Ejecutar.

Para modificar una macro, use el Editor de Visual Basic.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea modificar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. Haga los cambios que desee.

  4. Cuando haya terminado, en el menú Word, haga clic en Cerrar y volver a Microsoft Word.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea copiar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. En la ventana de código del Editor de Visual Basic, seleccione las líneas de la macro que quiera copiar.

    Sugerencia: Para copiar toda la macro, asegúrese de incluir las líneas Sub y End Sub en la selección.

  4. En el menú Edición, elija Copiar.

  5. En el cuadro Proyecto de la ventana de código, haga clic en el módulo en el que desea colocar el código.

  6. En el menú Edición, elija Pegar.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Word, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea eliminar y, a continuación, en Eliminar.

PowerPoint

Para automatizar una tarea repetitiva, puede usar Visual Basic para Aplicaciones para crear una macro en PowerPoint.

Puede usar el Editor de Visual Basic integrado para crear una macro.

  1. En la pestaña Programador, en Visual Basic, haga clic en Editor.

    Pestaña Desarrollador de PowerPoint, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. Si necesita insertar un módulo, en el Editor de Visual Basic, en el menú Insertar, haga clic en Módulo.

  3. En la ventana de código del módulo, escriba o pegue el código de la macro que desee usar.

  4. Cuando haya terminado, en el menú PowerPoint, haga clic en Cerrar y volver a Microsoft PowerPoint.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de PowerPoint, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea ejecutar y, a continuación, en Ejecutar.

Para modificar una macro, use el Editor de Visual Basic.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de PowerPoint, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea modificar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. Haga los cambios que desee.

  4. Cuando haya terminado, en el menú PowerPoint, haga clic en Cerrar y volver a Microsoft PowerPoint.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de PowerPoint, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea copiar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. En la ventana de código del Editor de Visual Basic, seleccione las líneas de la macro que quiera copiar.

    Sugerencia: Para copiar toda la macro, asegúrese de incluir las líneas Sub y End Sub en la selección.

  4. En el menú Edición, elija Copiar.

  5. En el cuadro Proyecto de la ventana de código, haga clic en el módulo en el que desea colocar el código.

  6. En el menú Edición, elija Pegar.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de PowerPoint, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea eliminar y, a continuación, en Eliminar.

Excel

Para automatizar una tarea repetitiva, puede crear rápidamente una macro en Excel. También puede usar el Editor de Visual Basic en Microsoft Visual Basic para Aplicaciones para escribir un script de macro o para copiar toda o una parte de una macro en una nueva macro.

Se graban todos los pasos necesarios para completar las acciones que desea que realice la macro. Sin embargo, la navegación a la pestaña para detener la grabación no se incluye en los pasos grabados.

  1. En la pestaña Programador, en Visual Basic, haga clic en Grabar.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En el cuadro Nombre de la macro, escriba un nombre para la macro.

    Sugerencia: Para crear un método abreviado de teclado para la macro, escriba una letra en el cuadro Option+Cmd+.

  3. En el menú emergente Guardar macro en, realice uno de los procedimientos siguientes:

    Para guardar la macro

    Haga clic en

    En el documento en el que está creando la macro

    Este libro

    En todos los documentos abiertos

    Nuevo libro

    Para que esté disponible siempre que use Excel

    Libro de macros personal

    El libro de macros personal se encuentra en Usuarios/nombre de usuario/Biblioteca/Application Support/Microsoft/Office/Excel.

  4. Haga clic en Aceptar y realice las acciones que desea grabar.

  5. En la pestaña Programador, en Visual Basic, vuelva a hacer clic en Grabar.

Puede usar el Editor de Visual Basic integrado para crear una macro.

  1. En la pestaña Programador, en Visual Basic, haga clic en Editor.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. Si necesita insertar un módulo, en el Editor de Visual Basic, en el menú Insertar, haga clic en Módulo.

  3. En la ventana de código del módulo, escriba o pegue el código de la macro que desee usar.

  4. Cuando haya terminado, en el menú Excel, haga clic en Cerrar y volver a Microsoft Excel.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea ejecutar y, a continuación, en Ejecutar.

    Sugerencia: Para ejecutar una macro mediante un método abreviado de teclado, presione OPTION + COMANDO +la letra que escribió cuando creó el método abreviado de teclado.

Para modificar una macro, use el Editor de Visual Basic.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea modificar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. Haga los cambios que desee.

  4. Cuando haya terminado, en el menú Excel, haga clic en Cerrar y volver a Microsoft Excel.

Tras completar este procedimiento, la macro se ejecutará cada vez que se abra el libro que contiene la macro.

  1. En la pestaña Programador, en Visual Basic, haga clic en Grabar.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En el cuadro Nombre de macro, escriba Abrir_automáticamente.

  3. En el menú emergente Guardar macro en, realice uno de los procedimientos siguientes:

    Para guardar la macro

    Haga clic en

    En el documento en el que está creando la macro

    Este libro

    En todos los documentos abiertos

    Nuevo libro

    Para que esté disponible siempre que use Excel

    Libro de macros personal

  4. Haga clic en Aceptar y realice las acciones que desea grabar.

  5. En la pestaña Programador, en Visual Basic, vuelva a hacer clic en Grabar.

  6. En el menú Archivo, haga clic en Guardar como.

  7. En el menú emergente Formato, haga clic en Libro de Excel habilitado para macros (.xlsm) y luego haga clic en Guardar.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea copiar y, a continuación, en Editar.

    Se abre el Editor de Visual Basic.

  3. En la ventana de código del Editor de Visual Basic, seleccione las líneas de la macro que quiera copiar.

    Sugerencia: Para copiar toda la macro, asegúrese de incluir las líneas Sub y End Sub en la selección.

  4. En el menú Edición, elija Copiar.

  5. En el cuadro Proyecto de la ventana de código, haga clic en el módulo en el que desea colocar el código.

  6. En el menú Edición, elija Pegar.

  1. En la pestaña Programador, en Visual Basic, haga clic en Macros.

    Pestaña Desarrollador de Excel, grupo Visual Basic

    Si la pestaña Programador no está disponible

    1. En el lado derecho de la cinta de opciones, haga clic en Menú emergente Acción y, a continuación, haga clic en Preferencias de la cinta.

    2. En Personalizar, active la casilla Programador.

  2. En la lista, haga clic en la macro que desea eliminar y, a continuación, en Eliminar.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×