Office
Iniciar sesión

Corregir un error #N/A

El error #N/A suele indicar que una fórmula no encuentra lo que se le ha pedido que busque.

Solución principal

La causa más frecuente del error #N/A se deriva de las funciones BUSCARV, BUSCARH, BUSCAR o COINCIDIR si una fórmula no encuentra el valor al que se hace referencia. Por ejemplo, si el valor de búsqueda no existe en los datos de origen.

El valor de búsqueda no existe.  La fórmula de la celda E2 es =BUSCARV(D2;$D$6:$E$8;2;FALSO).  El valor Plátano no se encuentra, por lo que la fórmula devuelve un error #N/A.
No se encuentra el elemento en los datos de origen

En este caso, el valor “Plátano” no está presente en la tabla de búsqueda, por lo que BUSCARV devuelve un error #N/A.

Solución: compruebe que el valor de búsqueda existe en los datos de origen, o bien use un controlador de errores como SI.ERROR en la fórmula. Por ejemplo, =SI.ERROR(FORMULA();0), que dice lo siguiente:

  • =SI(su fórmula se evalúa como un error, se muestra 0; en caso contrario, se muestra el resultado de la fórmula)

Puede usar “” para no mostrar nada, o bien usar su propio texto: =SI.ERROR(FORMULA();”Escribir aquí el mensaje de error”)

Si no está seguro de lo que quiere hacer en este momento o del tipo de ayuda que necesita, puede buscar preguntas parecidas o publicar una pregunta en el foro de la comunidad de Excel.

Vínculo al foro de la comunidad de Excel

Si quiere avanzar, en la siguiente lista de comprobación encontrará pasos de solución de problemas para ayudarle a determinar los errores de las fórmulas.

El valor de búsqueda y los datos de origen contienen tipos de datos distintos. Por ejemplo, si intenta que BUSCARV haga referencia a un número, pero los datos de origen se almacenaron como texto.

Tipos de valores incorrectos.  En el ejemplo se muestra una fórmula BUSCARV que devuelve un error #N/A porque el elemento de búsqueda tiene formato de número, pero la tabla de búsqueda tiene formato de texto.
Error #N/A causado por diferentes tipos de datos

Solución: compruebe que los tipos de datos sean los mismos. Para comprobar los formatos de celdas, seleccione una celda o un rango de celdas y, después, haga clic con el botón derecho y seleccione Formato de celdas > Número (o presione Ctrl+1) y cambie el formato de número si es necesario.

Cuadro de diálogo Formato de celdas donde se muestra la pestaña Número y la opción Texto seleccionada

Sugerencia: Para cambiar el formato de toda una columna, primero aplique el formato que quiere usar y, después, use Datos > Texto en columnas > Finalizar.

Puede usar la función ESPACIOS para quitar espacios iniciales o finales. En el ejemplo siguiente se usa la función ESPACIOS anidada dentro de una función BUSCARV para eliminar los espacios iniciales de los nombres en el rango A2:A7 y devolver el nombre de departamento.

Uso de BUSCARV con ESPACIOS en una fórmula de matriz para eliminar los espacios iniciales y finales.  La fórmula de la celda E3 es {=BUSCARV(D2;ESPACIOS(A2:B7);2;FALSO)} y es necesario escribirla con CTRL+MAYÚS+ENTRAR.

{=BUSCARV(D2;ESPACIOS(A2:B7);2;FALSO)}

Nota: Esta es una fórmula de matriz y es necesario escribirla con Ctrl+Mayús+Entrar. Excel colocará automáticamente la fórmula entre llaves {}. Si intenta escribir las llaves de forma manual, Excel mostrará la fórmula como texto.

De forma predeterminada, las funciones que buscan información en tablas tienen que ordenarse en orden ascendente. Pero las funciones de hoja de cálculo BUSCARV y BUSCARH contienen el argumento ordenado, que indica a la función que busque una coincidencia exacta aunque la tabla no esté ordenada. Para encontrar una coincidencia exacta, establezca el argumento ordenado en FALSO. Tenga en cuenta que al usar VERDADERO se indica a la función que busque una coincidencia aproximada, lo que puede causar un error #N/A y devolver también resultados erróneos, tal y como se muestra en el ejemplo siguiente.

Un ejemplo donde se muestra que, si se usa BUSCARV con el argumento ordenado como VERDADERO, pueden producirse resultados erróneos.
BUSCARV produce errores si se usa el argumento de coincidencia aproximada en una tabla sin ordenar

En este ejemplo, no solo “Plátano” produce un error #N/A, sino que “Pera” devuelve el precio incorrecto. Esto es causado por el argumento VERDADERO, que le indica a BUSCARV que busque una coincidencia aproximada en lugar de una coincidencia exacta. No hay una coincidencia similar a “Plátano” y “Pera” aparece antes que “Melocotón” alfabéticamente. En este caso, si se usa BUSCARV con el argumento FALSO, devolvería el precio correcto de “Pera”, pero “Plátano” seguiría produciendo un error #N/A, ya que no hay ningún “Plátano” que se corresponda en la lista de búsqueda.

Si usa la función COINCIDIR, intente cambiar el valor del argumento tipo_de_coincidencia para especificar el criterio de ordenación de la tabla. Para buscar una coincidencia exacta, establezca el argumento tipo_de_coincidencia en 0 (cero).

Para corregir este error, asegúrese de que el rango al que hace referencia la fórmula de matriz tiene el mismo número de filas y columnas que el rango de celdas donde se ha escrito la fórmula de matriz. O bien, escriba esta fórmula en un número menor o mayor de celdas para que coincida con el rango al que hace referencia la fórmula.

En este ejemplo, la celda E2 hace referencia a rangos que no coinciden:

Ejemplo de fórmula de matriz con referencias de rango que no coinciden y causan un error #N/A.  La fórmula de la celda E2 es {=SUMA(SI(A2:A11=D2;B2:B5))} y es necesario escribirla con CTRL+MAYÚS+ENTRAR.

{=SUMA(SI(A2:A11=D2;B2:B5))}

Para que la fórmula realice el cálculo correctamente, es necesario cambiarla para que en los dos rangos se reflejen las filas 2-11.

{=SUMA(SI(A2:A11=D2;B2:B11))}

Nota: Esta es una fórmula de matriz y es necesario escribirla con Ctrl+Mayús+Entrar. Excel colocará automáticamente la fórmula entre llaves {}. Si intenta escribir las llaves de forma manual, Excel mostrará la fórmula como texto.

Ejemplo de #N/A en celdas que evita que se calcule correctamente una fórmula de SUMA.

En este caso, mayo y diciembre tienen valores #N/A, por lo que no se puede calcular el total y se devuelve un error #N/A en su lugar.

Para corregir esto, compruebe la sintaxis de la fórmula de la función que use y escriba todos los argumentos necesarios en la fórmula que devuelve el error. Puede que sea necesario usar el Editor de Visual Basic (VBE) para comprobar la función. Para tener acceso a VBE, vaya a la pestaña Desarrollador o presione ALT+F11.

Para corregir este error, compruebe que el libro que contiene la función definida por el usuario está abierto y que esta función funciona correctamente.

Para corregir este error, compruebe que los argumentos de la función son correctos y que se usan en la posición adecuada.

Para solucionar esto, presione Ctrl+Alt+F9 para actualizar la hoja

Puede usar el Asistente para funciones para obtener ayuda si no está seguro de los argumentos correctos. Seleccione la celda con la fórmula, vaya a la pestaña Fórmulas de la cinta y pulse Insertar función.

Botón Insertar función.

Excel abrirá automáticamente el asistente:

Ejemplo del diálogo Asistente para fórmulas.

A medida que haga clic en cada argumento, Excel proporcionará información adecuada para cada uno.

#N/A puede resultar útil Es frecuente usar #N/A al usar datos como en el ejemplo siguiente para gráficos, ya que los valores #N/A no se representarán en un gráfico. Estos son algunos ejemplos de la apariencia de un gráfico con valores de 0 o con valores #N/A.

Ejemplo de un gráfico de líneas donde se representan 0 valores.

En el ejemplo anterior, puede ver que los valores de 0 se representan y se muestran como una línea recta en la parte inferior del gráfico y, después, sube para mostrar el total. En el ejemplo siguiente, verá que los valores de 0 se reemplazan con #N/A.

Ejemplo de un gráfico de líneas donde no se representan valores #N/A.

Para más información sobre un error #N/A que aparece en una función específica, vea los temas siguientes:

Principio de página

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Convertir números almacenados como texto en números

Función BUSCARV

Función BUSCARH

Función BUSCAR

Función COINCIDIR

Información general sobre fórmulas en Excel

Evitar fórmulas erróneas

Detectar errores en las fórmulas con la comprobación de errores

Métodos abreviados de teclado de Excel para Windows

Métodos abreviados de teclado de Excel para Mac

Todas las funciones de Excel (orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×