Iniciar sesión

Corregir errores comunes en las fórmulas

Al igual que un corrector ortográfico, que comprueba si hay errores en los datos que se escriben en las celdas, se pueden implementar determinadas reglas para comprobar si hay errores en las fórmulas. Estas reglas no garantizan que la hoja de cálculo no tenga ningún error, pero ayudan en gran medida a encontrar errores comunes. Todas estas reglas se pueden activar y desactivar de forma individual.

Puede marcar y corregir los errores de dos maneras: de uno en uno (igual que un corrector ortográfico) o en el momento en que ocurre el error en la hoja de cálculo, a medida que escribe los datos. De cualquier manera, aparecerá un triángulo en la esquina superior derecha de la celda cuando se detecta un error.

Celda con un error de fórmula

Celda con un error de fórmula

Los errores que impiden devolver un resultado (por ejemplo, cuando se divide un número por cero) obligan a prestarles atención, y provocan que en la celda aparezca un valor de error (en este caso, #DIV/0!). Puede haber otros errores menos graves, por ejemplo cuando entre una fórmula y las fórmulas adyacentes parece haber una incoherencia. Aunque la fórmula devuelve un resultado correcto, el mensaje de error alerta sobre la conveniencia de examinar la fórmula.

Puede solucionar el error mediante las opciones que aparecen u omitirlo haciendo clic en Omitir error. Si omite une error en una celda en particular, ese error ya no volverá a aparecer en las comprobaciones de errores subsiguientes. Sin embargo, todos los errores que haya omitido se pueden restablecer para que vuelvan a mostrarse.

¿Qué quiere hacer?

Activar o desactivar reglas de comprobación de errores

Corregir errores de fórmula comunes de uno en uno

Marcar los errores de fórmula comunes en la hoja de cálculo y corregirlos directamente

Activar o desactivar reglas de revisión de errores

  1. Haga clic en el botón de Microsoft Office Imagen del botón de Microsoft Office, en Opciones de Excel y después, haga clic en la categoría Fórmulas.

  2. En Reglas de verificación de Excel, active o desactive las casillas de cualquiera de las siguientes reglas:

    • Las celdas contienen fórmulas que producen un error    La fórmula no usa la sintaxis, los argumentos o los tipos de datos esperados. Los valores de error son #¡DIV/0!, #N/A, #¿NOMBRE?, #¡NULO!, #¡NUM!, #¡REF! y #¡VALOR!. Cada uno de estos valores de error tienen causas diferentes y se resuelven de manera distinta.

      • Para más información sobre cómo solucionar estos errores, vea los vínculos en la lista Ver también.

        Nota: Si especifica un valor de error directamente en una celda, no se marcará como error.

    • Fórmula de columna calculada incoherente en las tablas    Una columna calculada puede incluir fórmulas que son diferentes de la fórmula de columna que crea una excepción. Las excepciones de columna calculada se crean al realizar las acciones siguientes:

      • Escribir datos que no son fórmulas en una celda de columna calculada.

      • Escribir una fórmula en una celda de columna calculada y después hacer clic en el botón Deshacer Imagen del botón de la Barra de herramientas de acceso rápido.

      • Escribir una nueva fórmula en una columna calculada que ya contiene una o varias excepciones.

      • Copiar datos en la columna calculada que no coinciden con la fórmula de columna calculada.

        Nota: Si los datos copiados contienen una fórmula, esta fórmula sobrescribe los datos en la columna calculada.

      • Mover o eliminar una celda de otra área de hoja de cálculo a la que hace referencia una de las filas de una columna calculada.

    • Celdas que contienen años representados con 2 dígitos    La celda contiene una fecha de texto en la que el siglo se puede interpretar de forma incorrecta si se usa en fórmulas. Por ejemplo, la fecha de la fórmula =AÑO("1/1/31") podría ser 1931 o 2031. Use esta regla para comprobar fechas de texto ambiguas.

    • Números con formato de texto o precedidos por un apóstrofo    La celda contiene números guardados como texto. Esto suele ocurrir cuando se importan datos de otros orígenes. Los números guardados como texto pueden causar resultados de ordenación inesperados y no se pueden calcular, por lo que se recomienda convertirlos a números.

    • Fórmulas incoherentes con otras fórmulas de la región    La fórmula no coincide con el patrón de las demás fórmulas cercanas. En muchos casos, las fórmulas que son adyacentes a otras fórmulas difieren sólo en las referencias que se usan. En el siguiente ejemplo de cuatro fórmulas adyacentes, Excel muestra un error junto a la fórmula =SUMA(A10:F10) ya que las fórmulas adyacentes incrementan en una fila y la fórmula =SUMA(A10:F10) incrementa de a filas 8 ; Excel espera la fórmula = SUMA(A3:F3).

  1. 1

  1. 2

  1. 3

  1. 4

  1. 5

  1. A

  1. Fórmulas

  1. =SUMA(A1:F1)

  1. =SUMA(A2:F2)

  1. =SUMA(A10:F10)

  1. =SUMA(A4:F4)

  • Si las referencias que se usan en una fórmula no son coherentes con las de las fórmulas adyacentes, Excel muestra un error.

  • Fórmulas que omiten celdas en una región    Una fórmula puede no incluir automáticamente referencias a los datos insertados entre el rango original de datos y la celda que contiene la fórmula. Esta regla compara la referencia en una fórmula en el intervalo real de celdas que es adyacente a la celda que contiene la fórmula. Si las celdas adyacentes contienen valores adicionales y no están en blanco, Excel muestra un error junto a la fórmula.

    • Por ejemplo, Excel inserta un error junto a la fórmula =SUMA(A2:A4) cuando se aplica esta regla, ya que las celdas A5, A6 y A7 son adyacentes a las celdas a las que se hace referencia en la fórmula y a la celda que contiene la fórmula (A8), y esas tres celdas contienen datos a los que la fórmula tendría que hacer referencia.

  1. 1

  1. 2

  1. 3

  1. 4

  1. 5

  1. 6

  1. 7

  1. 8

  1. A

  1. Factura

  1. 15.000

  1. 9.000

  1. 8.000

  1. 20.000

  1. 5.000

  1. 22.500

  1. =SUMA(A2:A4)

  • Celdas desbloqueadas que contengan fórmulas    La fórmula no está bloqueada para protección. De manera predeterminada, las celdas están bloqueadas para protección, por lo que la celda ha sido establecida por un usuario como sin protección. Cuando una fórmula está protegida, no se puede modificar sin antes desprotegerla. Asegúrese de que no quiere que la celda esté protegida. La protección de las celdas que contienen fórmulas impide que se modifiquen y puede ayudar a evitar futuros errores.

  • Fórmulas que hacen referencia a celdas vacías    La fórmula contiene una referencia a una celda vacía. Esto puede dar lugar a resultados no deseados, como se muestra en el ejemplo siguiente.

    • Imagine que quiere calcular el promedio de los números de la siguiente columna de celdas. Si la tercera celda está en blanco, no se incluye en el cálculo y el resultado es 22,75. Si la tercera celda contiene 0, la celda se incluye en el cálculo y el resultado es 18,2.

  1. 1

  1. 2

  1. 3

  1. 4

  1. 5

  1. 6

  1. 7

  1. A

  1. Datos

  1. 24

  1. 12

  1. 45 $

  1. 10

  1. =PROMEDIO(A2:A6)

  • Los datos de una tabla no son válidos    Error de validación en una tabla. Haga clic en Validación de datos en el grupo Herramientas de datos de la pestaña Datos para comprobar la configuración de validación de la celda.

Principio de página

Corregir los errores comunes de las fórmulas de uno en uno

Si previamente ha revisado si la hoja de cálculo contiene errores, los errores omitidos no aparecerán hasta que se restablezcan.

  1. Seleccione la hoja de cálculo cuyos errores desee revisar.

  2. Si la hoja de cálculo se calcula manualmente, presione F9 para actualizarla.

  3. En la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en el botón del grupo Comprobación de errores.

    Grupo Auditoría de fórmulas en la ficha Fórmulas

    Cuando se encuentra un error, aparece el cuadro de diálogo Comprobación de errores.

  4. Si previamente ha omitido errores, puede comprobar los errores de nuevo haciendo lo siguiente:

    1. Haga clic en Opciones.

    2. En la sección Comprobación de errores, haga clic en Restablecer errores omitidos.

    3. Haga clic en Aceptar.

    4. Haga clic en Reanudar.

      Nota: Al restablecer los errores omitidos se restablecerán todos los errores en todas las hojas del libro activo.

  5. Coloque el cuadro de diálogo Comprobación de errores justo debajo de barra de fórmulas.

    barra de fórmulas

  6. Haga clic en uno de los botones de acción en la parte derecha del cuadro de diálogo. Las acciones disponibles son diferentes para cada tipo de error.

    Nota: Si hace clic en Omitir error, se marcará el error para omitirlo en las revisiones subsiguientes.

  7. Haga clic en Siguiente.

  8. Continúe hasta finalizar la revisión de errores.

Principio de página

Marcar los errores comunes de las fórmulas en la hoja de cálculo y corregirlos directamente

  1. Haga clic en el botón de Microsoft Office Imagen del botón de Microsoft Office, en Opciones de Excel y después, haga clic en la categoría Fórmulas.

  2. En Comprobación de errores, asegúrese de que la casilla Habilitar comprobación de errores en segundo plano está seleccionada.

  3. Para cambiar el color del triángulo que marca dónde se produce un error, en el cuadro Indicar errores con el color, seleccione el color que desea.

  4. Seleccione una celda que tenga un triángulo en la esquina superior izquierda.

  5. Junto la celda, haga clic en el botón Comprobación de errores Imagen del botón que aparezca y, después, haga clic en la opción que prefiera. Los comandos disponibles son diferentes para cada tipo de error, y en la primera entrada se describe el error.
    Si hace clic en Ignorar error, el error se marcará para que se ignore en cada comprobación consecutiva.

  6. Repita los dos pasos anteriores.

Principio de página



¿Le ha sido útil esta información?

¿Cómo podemos mejorarlo?

¿Cómo podemos mejorarlo?

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!