Controlar su sitio Web mediante Visio

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Si se ocupa de administrar las operaciones cotidianas de un sitio Web, sabrá que es indispensable tener clara la estructura y el funcionamiento global del sitio, además de estar al tanto de los cambios en su desarrollo y supervisar y reparar los hipervínculos que dejen de funcionar. Todas estas tareas y más aún pueden realizarse con las herramientas de Mapa de sitio Web en Microsoft Office Visio Professional.

¿Qué desea hacer?

Asignar el contenido del sitio

Comprobar automáticamente los errores del sitio

Realizar un seguimiento de cambios en su sitio

Elaborar un mapa del contenido de su sitio Web

Lo primero es analizar el estado actual del sitio: elaborar el mapa, es decir, una representación gráfica actualizada de la estructura y el contenido del sitio.

Mapa de sitio Web que muestra la estructura jerárquica real de los vínculos del sitio

Cada forma del mapa de sitio representa un vínculo en el sitio Web e incluye información acerca del tipo de vínculo y su ubicación. Al hacer clic con el botón secundario en una forma, se obtiene acceso directamente desde ella a su ubicación en el Web.

  1. En Visio, en el menú Archivo, elija Nuevo, Software y base de datos y, a continuación, haga clic en Mapa de sitio Web.

  2. En el cuadro de diálogo Generar mapa de sitio, escriba la dirección de un sitio Web para uno de los casos siguientes:

    • Para un servidor HTTP, en el cuadro Dirección, escriba la dirección del sitio Web que desee asociar.

    • Para un servidor de red o un disco duro local, haga clic en Examinar, localice el archivo que será la raíz del mapa de sitio y, a continuación, haga clic en Abrir.

  3. En el cuadro de diálogo Generar mapa de sitio, haga clic en Configuración para revisar las opciones para el número máximo de niveles y el número de vínculos que deban detectarse.

  4. Para cambiar esta configuración, realice una de las siguientes acciones:

    • En la ficha Diseño, cambie el estilo del diseño del mapa de sitio Web; por ejemplo, el número de niveles que desea detectar o si el dibujo aparece como Árbol compacto o Diagrama de flujo.

    • En la ficha Extensiones, seleccione los tipos de archivo (como .doc, .jpg o .exe) que desee incluir en el mapa.

    • En la ficha Protocolos, seleccione los protocolos (como mailto, ftp o NNTP) que desee incluir en el mapa.

    • En la ficha Atributos, seleccione los atributos HTML (como HREF, SRC o CODE) en los que desee que se busquen vínculos.

    • En la ficha Avanzadas, seleccione opciones que definan todavía más sus criterios de búsqueda.

    • Haga clic en Aceptar.

  5. En el cuadro de diálogo Generar mapa de sitio, haga clic en Aceptar.

  6. Para guardar el mapa del sitio, en el menú Archivo, haga clic en Guardar.

Volver al principio

Comprobar los errores del sitio automáticamente

La tarea más crucial de la administración de un sitio Web radica en mantener los vínculos activos y sin errores.

Cuando se elabora el mapa del sitio, Visio sigue cada vínculo ciñéndose a los parámetros especificados e investiga cada error encontrado. Los vínculos con errores aparecen en el mapa del sitio, en la ventana Filtro y en la ventana Lista, como formas con X rojas. Si no están visibles estas ventanas, en el menú Mapa de sitio Web, elija Ventanas y haga clic en Ventana Filtro o en Ventana Lista. Podrá generar rápidamente una lista de los vínculos rotos junto con los errores asociados, y así efectuar un seguimiento del trabajo y realizar los ajustes necesarios.

Mapa de sitio Web que muestra la estructura de un sitio. Todas las formas con una X roja indican un vínculo roto.

Crear un informe de vínculos con errores en el sitio

  1. Abra el mapa de sitio a partir del que desee generar un informe de errores.

  2. En el menú Mapa de sitio Web, elija Informes, haga clic en Vínculos del mapa del sitio Web con errores y, por último, Ejecutar.

  3. Seleccione el tipo de archivo (como Excel o XML) en el que desee guardar la información y, a continuación, haga clic en Aceptar.

    Visio creará un informe con todos los hipervínculos con errores.

  4. Si el informe se abre en un programa ajeno a Visio, como es el caso de Microsoft Office Excel, deberá dar un nombre al informe y guardarlo.

Arreglar vínculos rotos

Ciertos vínculos rotos son consecuencia de errores de tiempo de espera. Para resolver este tipo de errores, haga clic con el botón secundario del mouse (ratón) en el vínculo y, después, haga clic en Actualizar o Actualizar origen de hipervínculo.

Otros vínculos rotos son resultado de los errores Sitio no encontrado, Acceso denegado o Se requiere contraseña, o bien se deben a nombres o ubicaciones de archivos incorrectos y archivos ausentes. Estas causas pueden producir el mensaje de error 404 o Archivo no encontrado. Todos estos errores deberán arreglarse en el propio sitio Web.

El el sitio Web y su mapa no se encuentran vinculados dinámicamente, es decir, un cambio en uno no implica automáticamente el mismo cambio en el otro. Tras arreglar un vínculo roto en el sitio Web, puede actualizar el mapa haciendo clic con el botón secundario en la forma que representa el vínculo en cuestión y haciendo clic en Actualizar hipervínculo. Desaparecerá la X roja.

Volver al principio

Mantenerse al tanto de los cambios en el sitio

Si varios programadores trabajan en el sitio, la supervisión de su trabajo puede llegar a ocupar la jornada completa. Mediante el informe de comparación del Mapa de sitio Web, puede comparar dos versiones del sitio con objeto de cuantificar los cambios realizados en un período de tiempo determinado. El informe compara ambas y genera una lista de las diferencias. No se limita a identificar los vínculos que aparecen en sólo uno de los mapas sino que, además, informa de los siguientes cambios en ambos mapas:

  • Estado del error

  • Título del archivo

  • Tamaño del archivo

  • Fecha de modificación del archivo

Por ejemplo, supongamos que desea cuantificar el trabajo realizado en el sitio cada semana. No tiene más que generar el mapa al comienzo de la semana y volver a hacerlo al final. Así, puede comparar ambos mapas y generar un informe de cambios. También puede cotejar el informe con una programación del trabajo planeado para la semana y ver si el proyecto de sitio Web lleva el ritmo adecuado.

Comparar mapas de sitio Web

  1. Abra el mapa más reciente del sitio Web.

  2. En el menú Mapa de sitio Web, haga clic en Comparar con el documento anterior.

  3. Localice el mapa de sitio Web con el que desee realizar la comparación, seleccione el archivo y haga clic en Abrir.

    Visio comparará ambos mapas y generará un informe HTML con una lista de las diferencias.

  4. Dé un nombre al informe y guárdelo.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×