Contar valores únicos entre duplicados

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Supongamos que desea averiguar cuántos valores numéricos en un rango o texto únicos. Por ejemplo, si tiene una columna de valores de texto Bradley, Doyle, Doyle, Doyle, hay dos valores únicos: Bradley y Doyle. Si el rango de los números 5, 6, 7, 6, los valores únicos son 5, 6 y 7.

Para contar solo valores únicos, use una combinación de las funciones siguientes, tal y como se muestra en la siguiente hoja de cálculo de ejemplo:

  • Use la función SI para asignar el valor 1 a cada condición que sea CIERTA.

  • Use la función SUMA para agregar todos los valores únicos.

  • Use la función FRECUENCIA para contar el número de valores únicos. Esta función pasa por alto el texto y los valores cero. Para la primera aparición de un valor específico, esta función devuelve un número igual al número de apariciones de dicho valor. Para cada aparición del mismo valor después de la primera, esta función devuelve un valor de 0.

  • Use la función COINCIDIR para devolver la posición de un valor de texto en un rango. La función FRECUENCIA usa el valor resultante para evaluar los valores de texto correspondientes.

  • Use la función LARGO para buscar celdas en blanco. Las celdas en blanco tienen una longitud (recuento de caracteres) de 0.

Ejemplo

Copie la tabla a la celda A1 en una hoja de cálculo en blanco de Excel para trabajar con estos ejemplos de fórmulas que utilizan funciones.

Datos

Datos

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Fórmula

Descripción (resultado)

=SUMA(SI(FRECUENCIA(A2:A10,A2:A10)>0,1))

Cuenta el número de valores numéricos únicos en las celdas A2:A10, pero no cuenta las celdas en blanco ni los valores de texto (4).

=SUMA(SI(FRECUENCIA(COINCIDIR(B2:B10,B2:B10,0),COINCIDIR(B2:B10,B2:B10,0))>0,1))

Cuenta la cantidad de valores de texto y numéricos únicos en las celdas B2:B10 (que no deben contener celdas en blanco) (7).

=SUMA(SI(FRECUENCIA(SI(LARGO(A2:A10)>0,COINCIDIR(A2:A10,A2:A10,0),""), SI(LARGO(A2:A10)>0,COINCIDIR(A2:A10,A2:A10,0),""))>0,1))

Cuenta la cantidad de valores de texto y numéricos únicos en las celdas A2:A10, pero no cuenta las celdas en blanco ni los valores de texto (6).

Notas: 

  • Las fórmulas de este ejemplo deben especificarse como fórmulas de matriz. Seleccione cada celda que contiene una fórmula, presione F2 y, a continuación, presione Ctrl + Mayús + Entrar.

  • Para ver cómo se evalúa una función paso a paso, seleccione la celda que contiene la fórmula y después en la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en Evaluar fórmula.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×