Office
Iniciar sesión

Contar valores únicos entre duplicados

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Supongamos que desea averiguar cuántos valores numéricos en un rango o texto únicos. Por ejemplo, si tiene una columna de valores de texto Bradley, Doyle, Doyle, Doyle, hay dos valores únicos: Bradley y Doyle. Si el rango de los números 5, 6, 7, 6, los valores únicos son 5, 6 y 7.

Para contar solo valores únicos, use una combinación de las funciones siguientes, tal y como se muestra en la siguiente hoja de cálculo de ejemplo:

  • Use la función si para asignar un valor de 1 a cada condición que sea verdadera.

  • Use la función suma para sumar todos los valores únicos.

  • Use la función frecuencia para contar el número de valores únicos. Esta función omite el texto y valores cero. La primera aparición de un valor específico, devuelve un número igual que el número de apariciones de dicho valor. Para cada aparición del mismo valor después del primero, esta función devuelve un valor de 0.

  • Use la función coincidir para devolver la posición de un valor de texto de un rango. La función frecuencia usa el valor resultante para evaluar los valores de texto correspondiente.

  • Use la función largo para buscar celdas en blanco. Celdas en blanco tienen una longitud (recuento de caracteres) de 0.

Ejemplo

Copie la tabla a la celda A1 en una hoja de cálculo en blanco de Excel para trabajar con estos ejemplos de fórmulas que utilizan funciones.

Datos

Datos

986

Bradley

Doyle

563

67

789

235

Bradley

Doyle

689

789

Doyle

143

56

237

67

235

Fórmula

Descripción (resultado)

=SUMA(SI(FRECUENCIA(A2:A10,A2:A10)>0,1))

Cuenta el número de valores numéricos únicos en las celdas A2:A10, pero no cuenta las celdas en blanco ni los valores de texto (4).

=SUMA(SI(FRECUENCIA(COINCIDIR(B2:B10,B2:B10,0),COINCIDIR(B2:B10,B2:B10,0))>0,1))

Cuenta la cantidad de valores de texto y numéricos únicos en las celdas B2:B10 (que no deben contener celdas en blanco) (7).

=SUMA(SI(FRECUENCIA(SI(LARGO(A2:A10)>0,COINCIDIR(A2:A10,A2:A10,0),""), SI(LARGO(A2:A10)>0,COINCIDIR(A2:A10,A2:A10,0),""))>0,1))

Cuenta la cantidad de valores de texto y numéricos únicos en las celdas A2:A10, pero no cuenta las celdas en blanco ni los valores de texto (6).

Notas: 

  • Las fórmulas de este ejemplo deben especificarse como fórmulas de matriz. Seleccione cada celda que contiene una fórmula, presione F2 y, a continuación, presione Ctrl + Mayús + Entrar.

  • Para ver cómo se evalúa una función paso a paso, seleccione la celda que contiene la fórmula y después en la pestaña Fórmulas, en el grupo Auditoría de fórmulas, haga clic en Evaluar fórmula.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×