Office
Iniciar sesión

Contar números o fechas a partir de una condición

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Para contar números o fechas que cumplan una única condición (tal como igual que, mayor que, menor que, mayor o igual que, o menor o igual que), utilice la función contar.Si . Para contar números o fechas que se encuentran dentro de un rango (por ejemplo, mayor que 9000 y al mismo tiempo menor 22500), puede usar la función contar.Si . Como alternativa, puede usar SUMAPRODUCTO demasiado.

Ejemplo

1

".2"

3%

-4

'5

6%

7

8%

9%

10

11

12

13

14

15

16

17

A

B

Vendedor

Factura

Buchanan

15.000

Buchanan

9.000

Suyama

8.000

Suyama

20.000

Buchanan

5.000

Dodsworth

22.500

Fórmula

Descripción (resultado)

=CONTAR.SI(B2:B7,">9000")

La función CONTAR.SI cuenta el número de celdas en el rango B2:B7 que contiene números mayores que 9.000 (4)

=CONTAR.SI(B2:B7,"<=9000")

La función CONTAR.SI cuenta el número de celdas en el rango B2:B7 que contiene números menores que 9.000 9000 (4)

=CONTAR.SI.CONJUNTO(B2:B7,">=9.000",B2:B7,"<=22.500")

La función CONTAR.SI.CONJUNTO (disponible en Excel 2007 y versiones posteriores) cuenta el el número de celdas en el rango B2:B7 mayores o iguales que 9.000 y menores o iguales que 22.500 (4)

=SUMAPRODUCTO((B2:B7>=9.000)*(B2:B7<=22.500))

La función SUMAPRODUCTO cuenta los números de celdas en el rango B2:B7 que contienen números mayores o iguales que 9.000 y menores o iguales que 22.500 (4). Puede usar esta función en Excel 2003 y en una versión anterior, en que CONTAR.SI.CONJUNTO no está disponible.

Fecha

3/11/2011

1/1/2010

12/31/2010

6/30/2010

Fórmula

Descripción (resultado)

=CONTAR.SI(B14:B17,">1/3/2010")

Cuenta el número de celdas en el rango B14:B17 con una fecha mayor que 1/3/2010 (3)

=CONTAR.SI(B14:B17,"31/12/2010")

Cuenta el número de celdas en el rango B14:B17 igual a 31/12/2010 (1). El signo igual no es necesario en el criterio, por lo que no se incluye aquí (la fórmula funcionará con un signo igual si lo incluye ("=31/12/2010").

=CONTAR.SI.CONJUNTO(B14:B17,">=1/1/2010",B14:B17,"<=31/12/2010")

Cuenta el número de celdas en el rango B14:B17 que está entre (ambos inclusive) 1/1/2010 y 31/12/2010 (3).

=SUMAPRODUCTO((B14:B17>=VALFECHA("1/1/2010"))*(B14:B17<=VALFECHA("31/12/2010")))

Cuenta el número de celdas en el rango B14:B17 que está entre (ambos inclusive) 1/1/2010 y 31/12/2010 (3). Este ejemplo sirve de sustituto de la función CONTAR.SI.CONJUNTO que se introdujo en Excel 2007. La función VALFECHA convierte las fechas en un valor número con el que puede trabajar la función SUMAPRODUCTO.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×