Contar la frecuencia de un valor

Hay varias funciones de la hoja de cálculo que pueden ayudarle a contar cuántas veces un texto o valor numérico en particular se produce en un rango de celdas. Por ejemplo, puede usar la función CONTAR.SIpara contar con qué frecuencia aparece un valor único, tal como se muestra en el siguiente ejemplo.

Ejemplo

Comercial

Factura

Benito

15.000

Benito

9.000

Solsona

8.000

Solsona

20.000

Benito

5.000

Navarro

22.500

Fórmula

Descripción

Resultado

=CONTAR.SI (A2:A7;"Benito")

Número de entradas de Benito (3)

3

=CONTAR.SI(A2:A7,A4)

Número de entradas de Solsona (2)

2

=CONTAR.SI(B2:B7,"< 20000")

Número de valores de facturas menores de 20.000 (4)

4

=CONTAR.SI(B2:B7,">="&B5)

Número de valores de facturas mayores o iguales a 20.000 (2)

2

Usar CONTAR.SI.CONJUNTO para contar valores basados en varios criterios

La función CONTAR.SI.CONJUNTO es similar a la función CONTAR.SI con una excepción importante: CONTAR.SI.CONJUNTO permite aplicar criterios a celdas en varios rangos y cuenta la cantidad de veces que se cumplen todos los criterios. Puede usar hasta 127 pares de rangos o de criterios con la función CONTAR.SI.CONJUNTO. La sintaxis de la función es similar a esta:

CONTAR.SI.CONJUNTO(rango_criterios1; criterios1, [rango_criterios2; criterios2];…)

Ejemplo

Id. de empleado

Número de región

Departamento

20552

2

Ventas

21268

2

Finanzas

23949

1

Administración

24522

4

Administración

28010

3

TI

29546

4

Ventas

31634

3

TI

32131

1

TI

35106

4

Finanzas

40499

1

RR. HH.

42051

1

Ventas

43068

2

RR. HH.

45382

2

Finanzas

47971

1

TI

Fórmula

Descripción

Resultado

'=CONTAR.SI.CONJUNTO(B2:B15,"2",C2:C15,"Finanzas")

Número de empleados en la región 2 y en el departamento de finanzas

2

El primer rango de criterios incluye todos los números de región y el segundo rango de criterios incluye todos los nombres de departamento. El criterio aplicado al primer rango de criterios es "2" y el criterio aplicado al segundo rango es "Finanzas". CONTAR.SI.CONJUNTO comprueba si se cumplen ambos criterios.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×