Contar con qué frecuencia aparece un valor en Excel

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Supongamos que desea averiguar cuántas veces aparece un valor de texto o numérico determinado en un rango de celdas. Por ejemplo:

  • Si un rango, como A2:D20, contiene los valores numéricos 5, 6, 7 y 6, el número 6 aparece dos veces.

  • Si una columna contiene "Tomás", "Navarro", "Navarro" y "Navarro", "Navarro" aparece tres veces.

Hay varias formas de contar con qué frecuencia aparece un valor.

¿Qué desea hacer?

Contar con qué frecuencia aparece un valor único empleando una función

Contar según varios criterios empleando la función CONTAR.SI.CONJUNTO

Contar según criterios empleando las funciones CONTAR y SI juntas

Contar con qué frecuencia aparecen varios valores de texto o numéricos empleando las funciones SUMA y SI juntas

Contar con qué frecuencia aparecen varios valores utilizando un informe de tabla dinámica

Contar con qué frecuencia aparece un valor único empleando una función

Use la función CONTAR.SI para realizar esta tarea.

Ejemplo

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Comercial

Factura

Benito

15.000

Benito

9.000

Solsona

8.000

Solsona

20.000

Benito

5.000

Navarro

22.500

Fórmula

Descripción

Resultado

=CONTAR.SI (A2:A7;"Benito")

Número de entradas de Benito (2)

=CONTAR.SI (A2:A7;"Benito")

=CONTAR.SI(A2:A7,A4)

Número de entradas de Solsona (3)

=CONTAR.SI(A2:A7,A4)

=CONTAR.SI(B2:B7,"< 20000")

Número de valores de facturas menores de 20.000 (4)

=CONTAR.SI(B2:B7,"< 20000")

=CONTAR.SI(B2:B7,">="&B5)

Número de valores de facturas mayores o iguales a 20.000 (2)

=CONTAR.SI(B2:B7,">="&B5)

Para más información sobre el uso de esta función, vea Función CONTAR.SI.

Volver al principio

Contar según varios criterios empleando la función CONTAR.SI.CONJUNTO

La función CONTAR.SI.CONJUNTO, que se introdujo en Excel 2007, es similar a la función CONTAR.SI con una excepción importante: CONTAR.SI.CONJUNTO permite aplicar criterios a celdas en varios rangos y cuenta la cantidad de veces que se cumplen todos los criterios. Puede usar hasta 127 pares de rango/criterios con la función CONTAR.SI.CONJUNTO. La sintaxis de la función es similar a esta:

CONTAR.SI.CONJUNTO(rango_criterios1; criterios1, [rango_criterios2; criterios2];…)

Ejemplo

Id. de empleado

N.º región

Departamento

20552

2

Ventas

21268

2

Finanzas

23949

1

Administración

24522

4

Administración

28010

3

TI

29546

4

Ventas

31634

3

TI

32131

1

TI

35106

4

Finanzas

40499

1

RR. HH.

42051

1

Ventas

43068

2

RR. HH.

45382

2

Finanzas

47971

1

TI

¿Cuántos empleados trabajan en la región 2 y en el departamento de finanzas?

'=CONTAR.SI.CONJUNTO(B2:B15,"2",C2:C15,"Finanzas")

'=CONTAR.SI.CONJUNTO(B2:B15,"2",C2:C15,"Finanzas")

El primer rango de criterios es el número de región y el segundo rango de criterios es el nombre de departamento. El criterio aplicado al primer rango de criterios es "2" y el criterio aplicado al segundo rango es "Finanzas". CONTAR.SI.CONJUNTO comprueba si se cumplen ambos criterios.

Para más información sobre el uso de esta función para contar con varios rangos y criterios, vea Función CONTAR.SI.CONJUNTO.

Volver al principio

Contar según criterios empleando las funciones CONTAR y SI juntas

Supongamos que tiene que determinar cuántos vendedores vendieron un artículo específico en una región determinada, o que desea saber cuántas ventas superiores a un determinado valor realizó un vendedor específico. Puede usar las funciones SI y CONTAR juntas; es decir, primero usa la función SI para probar una condición y luego, solo si el resultado de la función SI es Verdadero, usa la función CONTAR para contar celdas.

Ejemplos

Región

Comercial

Tipo

Ventas

Sur

Benito

Bebidas

3571

Oeste

Davolio

Lácteos

3338

Este

Solsona

Bebidas

5122

Norte

Solsona

Lácteos

6239

Sur

Navarro

Verdura

8677

Sur

Davolio

Carnes

450

Sur

Davolio

Carnes

7673

Este

Solsona

Verdura

664

Norte

Davolio

Verdura

1500

Sur

Navarro

Carnes

6596

Fórmula

Descripción

Resultado

=CONTAR(SI((A2:A11="Sur")*(C2:C11="Carnes"),D2:D11))

Número de ventas de carne en la región sur. (3)

=CONTAR(SI((A2:A11="Sur")*(C2:C11="Carnes"),D2:D11))

=CONTAR(SI((B2:B11="Solsona")*(D2:D11>=1000);D2:D11))

Número de ventas superiores a 1000 € realizadas por Solsona. (2)

=CONTAR(SI((B2:B11="Solsona")*(D2:D11>=1000);D2:D11))

Nota: 

  • Las fórmulas de este ejemplo se deben escribir como fórmulas de matriz. Si abrió este libro en el programa de escritorio de Excel y desea cambiar la fórmula o crear una fórmula similar, presione F2 y después presione Ctrl+Mayús+Entrar para que la fórmula devuelva los resultados esperados.

  • Para que estas fórmulas funcionen, el segundo argumento para la función SI debe ser un número.

La función CONTAR cuenta el número de celdas que contienen números y cuenta números dentro de su lista de argumentos. Si la función SI devuelve un valor si una condición especificada se evalúa como Verdadero y otro valor si se evalúa como Falso.

Para más información sobre estas funciones, vea Función CONTAR y Función SI.

Volver al principio

Contar con qué frecuencia aparecen varios valores de texto o numéricos empleando las funciones SUMA y SI juntas

En los ejemplos que siguen, usamos las funciones SI y SUMA juntas. La función SI primero prueba los valores en algunas celdas y luego, si el resultado de la prueba es Verdadero, SUMA calcula el total de los valores que pasan la prueba.

Ejemplos

Comercial

Factura

Benito

15000

Benito

9000

Solsona

8000

Solsona

20000

Benito

5000

Navarro

22500

Fórmula

Descripción

Resultado

=SUMA(SI((A2:A7="Benito")+(A2:A7="Navarro"),1,0))

Número de facturas de Benito o Navarro.

=SUMA(SI((A2:A7="Benito")+(A2:A7="Navarro"),1,0))

=SUMA(SI((B2:B7<9000)+(B2:B7>19000),1,0))

Número de facturas con valores inferiores a 9000 € o superiores a 19 000 €

=SUMA(SI((B2:B7<9000)+(B2:B7>19000),1,0))

=SUMA(SI(A2:A7="Benito",SI(B2:B7<9000,1,0)))

Número de facturas de Benito con un valor inferior a 9000 €.

=SUMA(SI(A2:A7="Benito",SI(B2:B7<9000,1,0)))

Nota: Las fórmulas de este ejemplo se deben escribir como fórmulas de matriz. Si abrió este libro en el programa de escritorio de Excel y desea cambiar la fórmula o crear una fórmula similar, presione F2 y después presione Ctrl+Mayús+Entrar para que la fórmula devuelva los resultados esperados.

Volver al principio

Contar con qué frecuencia aparecen varios valores utilizando un informe de tabla dinámica

Puede utilizar un informe de tabla dinámica para mostrar los totales y contar las apariciones de los valores únicos. Una tabla dinámica es una forma interactiva de resumir rápidamente grandes volúmenes de datos. Puede utilizar una tabla dinámica para expandir y contraer los niveles de datos para destacar los resultados y ver los detalles de los datos de resumen de las áreas de interés. Además, puede mover filas a columnas y columnas a filas ("pivotar") para ver diferentes resúmenes de los datos de origen.

Ejemplo de datos de origen e informe de tabla dinámica resultante

1   Datos de origen; en este caso, de una hoja de cálculo

2   Valores de origen del resumen Golf T3 del informe de tabla dinámica

3   Informe de tabla dinámica completo

4   Resumen de los valores de origen en C2 y C8 desde los datos de origen

Para crear un informe de tabla dinámica

  1. Seleccione la columna que contiene los datos.
    Asegúrese de que la columna tiene un encabezado.

  2. En la pestaña Insertar, en el grupo Tablas, haga clic en Tabla dinámica.
    Aparece el cuadro de diálogo Crear tabla dinámica.

  3. Haga clic en Seleccione una tabla o rango.

  4. Coloque el informe de tabla dinámica en una nueva hoja de cálculo comenzando por la celda A1 haciendo clic en Nueva hoja de cálculo.

  5. Haga clic en Aceptar.
    Se agregará un informe de tabla dinámica vacío a la ubicación que haya especificado en la lista de campos de tabla dinámica mostrada.

  6. En la sección del campo al principio de la lista de campos de tabla dinámica, haga clic y mantenga presionado el nombre del campo y, a continuación, arrastre el campo al cuadro Rótulos de fila en la sección de diseño de la parte inferior de la lista de campos de tabla dinámica.

  7. En la sección del campo al principio de la Lista de campos de tabla dinámica, haga clic y mantenga presionado el mismo nombre del campo y, a continuación, arrastre el campo de nuevo al cuadro Valores en la sección de diseño de la parte inferior de la Lista de campos de tabla dinámica.

Nota: Si los datos contienen números, el informe de tabla dinámica calcula el total de las entradas en lugar de contarlas. Para cambiar de la función de resumen Suma a la función de resumen Contar, seleccione una celda en dicha columna y, a continuación, en la pestaña Analizar, en el grupo Campo activo, haga clic en Configuración de campo, en la pestaña Resumir por, en Contar y, a continuación, en Aceptar.

Volver al principio

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×