Comparar dos tablas y buscar registros no coincidentes

Puede que, en ocasiones, necesite comparar dos tablas e identificar cuáles son los registros de una de ellas que no tienen un registro correspondiente en la otra. La manera más fácil de identificar esos registros es usar el Asistente para consultas de buscar no coincidentes. Una vez que el asistente haya creado la consulta, puede modificar su diseño para agregar o quitar campos. También puede agregar combinaciones entre las dos tablas (para indicar los campos cuyos valores deberían coincidir). También puede crear su propia consulta para buscar los registros no coincidentes sin usar el asistente.

En este artículo, se muestra cómo iniciar y ejecutar el Asistente para consultas de buscar no coincidentes, cómo modificar el resultado del asistente y cómo crear su propia consulta para buscar los registros no coincidentes.

Nota: El Asistente para consultas de buscar no coincidentes no es compatible con las aplicaciones web de Access ni con las bases de datos web.

En este artículo...

¿Cuándo debo buscar registros no coincidentes?

Usar el Asistente para consultas de buscar no coincidentes para comparar dos tablas

Crear y modificar una consulta de buscar no coincidentes para comparar usando más de un campo

Crear una consulta propia para buscar registros no coincidentes

¿Cuándo debo buscar registros no coincidentes?

Las siguientes son dos circunstancias comunes en las que puede querer comparar dos tablas y buscar registros no coincidentes. Dependiendo de en qué circunstancia se encuentre, la búsqueda de registros no coincidentes será o no el primero de varios pasos que deberá realizar. En este artículo, solo se trata la búsqueda de registros no coincidentes.

  • Usa una tabla para almacenar datos sobre algo específico (como un producto) y otra tabla para almacenar datos sobre las acciones relacionadas (como los pedidos).   

    Por ejemplo, en la plantilla de la base de datos Northwind, los datos sobre los productos se almacenan en la tabla Productos y los datos sobre qué productos se incluyen en cada pedido se almacenan en la tabla Detalles de pedidos. Dado que, de forma predeterminada, no hay datos sobre los pedidos en la tabla Productos, no es posible determinar qué productos no se han vendido nunca observando únicamente la tabla Productos. Esta información tampoco se puede determinar mirando únicamente la tabla Detalles de pedidos, ya que esta tabla incluye solo datos sobre los productos vendidos. Debe comparar las dos tablas para poder determinar qué productos no se vendieron nunca.

    Si desea revisar una lista de elementos de la primera tabla para los que no hay ninguna acción correspondiente en la segunda tabla, puede usar una consulta de buscar no coincidentes.

  • Tiene dos tablas con información superpuesta, redundante o contradictoria y desea consolidarlas en una sola tabla.   

    Por ejemplo, supongamos que tiene una tabla denominada Compradores y otra tabla denominada Clientes. Las tablas son casi idénticas, pero una de las tablas o ambas tablas contienen algunos registros que faltan en la otra tabla. Para consolidar las tablas, primero debe determinar qué registros son únicos en una tabla o la otra.

    Si este es su caso, los métodos descritos en este artículo pueden ayudarle, pero es probable que tenga que realizar algunos pasos más. Puede ejecutar el Asistente para consultas de buscar no coincidentes para identificar los registros no coincidentes, pero si desea recuperar el conjunto combinado de registros, deberá usar los resultados para crear una consulta de unión. Si domina el Lenguaje de consulta estructurado (SQL), quizás incluso prefiera no usar el Asistente para consultas de buscar no coincidentes y escribir manualmente la consulta de unión.

    A menudo, se puede abordar el problema de la información superpuesta, redundante o contradictoria buscando datos duplicados en dos o más tablas.

Para obtener más información acerca de las consultas de unión o sobre cómo buscar, ocultar o eliminar datos duplicados, haga clic en los vínculos de la sección Vea también.

Nota: En los ejemplos de este artículo se usa una base de datos creada con la plantilla de base de datos Northwind.

Mostrar cómo configurar Northwind

  1. En la pestaña Archivo, haga clic en Nuevo

  2. Según la versión de Access que tenga, podrá buscar Northwind en el cuadro de búsqueda o deberá hacer clic en Plantillas locales, en la opción Categorías de plantillas del panel izquierdo.

  3. En Plantillas locales, haga clic en Ejemplo de Northwind 2007 y, a continuación, haga clic en Crear.

  4. Siga las instrucciones que aparecen en la página Northwind Traders (en la pestaña de objeto Pantalla de inicio) para abrir la base de datos y, a continuación, cierre la ventana Cuadro de diálogo de inicio de sesión.

Usar el Asistente para consultas de buscar no coincidentes para comparar dos tablas

  1. En el grupo Consultas de la pestaña Crear, haga clic en Asistente para consultas. Nota: Si usa Access 2007, en el grupo Otros de la pestaña Crear, haga clic en Asistente para consultas.

    En el grupo Consultas de la cinta de opciones de Access, se incluyen dos opciones: Asistente para consultas y Diseño de consulta
  2. En el cuadro de diálogo Nueva consulta, haga doble clic en Asistente para consultas de buscar no coincidentes.

  3. En la primera página del asistente, seleccione la tabla que tiene registros no coincidentes y, a continuación, haga clic en Siguiente. Por ejemplo, si desea ver una lista de los productos de Northwind que nunca se vendieron, seleccione la tabla Productos.

    Seleccione una tabla o una consulta en el cuadro de diálogo Asistente para consultas de buscar no coincidentes.
  4. En la segunda página, seleccione la tabla relacionada y, a continuación, haga clic en Siguiente. Para seguir con el mismo ejemplo, seleccione la tabla Detalles de pedido.

    Seleccione una tabla o una consulta que contenga los registros relacionados en el cuadro de diálogo Asistente para consultas de buscar no coincidentes.
  5. En la tercera página, seleccione los campos que relacionan las dos tablas, haga clic en < = > y, a continuación, haga clic en Siguiente. Puede elegir solo un campo de cada tabla. Para seguir con el mismo ejemplo, seleccione ID de la tabla Productos e ID de producto de la tabla Detalles de pedido. Compruebe que se comparan los campos correctos revisando el texto en el cuadro Campos coincidentes.

    Seleccione los campos coincidentes de las tablas en el cuadro de diálogo Asistente para consultas de buscar no coincidentes.

    Observe que los campos ID e ID de producto ya pueden estar seleccionados debido a las relaciones existentes integradas en la plantilla.

  6. En la cuarta página, haga doble clic en los campos de la primera tabla que desee ver y, a continuación, haga clic en Siguiente. Para seguir con el mismo ejemplo, seleccione los campos Identificador y Nombre del producto.

    Seleccione los campos que desee ver en el resultado de la consulta en el cuadro de diálogo Asistente para consultas de buscar no coincidentes.
  7. En la quinta página, puede optar por ver los resultados o modificar el diseño de la consulta. En este ejemplo, haga clic en Ver los resultados. Acepte el nombre sugerido para la consulta y, a continuación, haga clic en Finalizar.

    Escriba un nombre para su consulta de no coincidentes en el cuadro de diálogo Asistente para consultas de buscar no coincidentes.

    Quizá desee modificar el diseño de la consulta para agregar otros criterios, cambiar el criterio de ordenación o agregar o quitar campos. Para obtener más información acerca de cómo modificar una consulta de buscar no coincidentes, lea la sección siguiente; si desea ver información más general acerca de cómo crear y modificar las consultas, visite los vínculos de la sección Vea también.

Crear y modificar una consulta de buscar no coincidentes para comparar usando más de un campo

  1. En el grupo Consultas de la pestaña Crear, haga clic en Asistente para consultas. Nota: Si usa Access 2007, en el grupo Otros de la pestaña Crear, haga clic en Asistente para consultas.

  2. En el cuadro de diálogo Nueva consulta, haga doble clic en Asistente para consultas de buscar no coincidentes.

  3. En la primera página del asistente, seleccione la tabla que tiene registros no coincidentes y, a continuación, haga clic en Siguiente. Por ejemplo, si desea ver una lista de los productos de Northwind que nunca se vendieron, seleccione la tabla Productos.

  4. En la segunda página, seleccione la tabla relacionada y, a continuación, haga clic en Siguiente. Para seguir con el mismo ejemplo, seleccione la tabla Detalles de pedido.

  5. En la tercera página, seleccione los campos que relacionan las tablas, haga clic en < = > y, a continuación, en Siguiente. Puede elegir solo un campo de cada tabla. Para seguir con el mismo ejemplo, seleccione ID de la tabla Productos e ID de producto de la tabla Detalles de pedidos. Compruebe que se comparan los campos correctos revisando el texto del cuadro Campos coincidentes. Podrá combinar los campos que queden una vez que haya completado el asistente.

    Observe que los campos ID e ID de producto ya pueden estar seleccionados debido a las relaciones existentes integradas en la plantilla.

  6. En la cuarta página, haga doble clic en los campos de la primera tabla que desee ver y, a continuación, haga clic en Siguiente. Para seguir con el mismo ejemplo, seleccione los campos Identificador y Nombre del producto.

  7. En la quinta página, haga clic en Modificar el diseño y, a continuación, haga clic en Finalizar.

    Se abrirá la consulta en la vista Diseño.

  8. En la cuadrícula de diseño de la consulta, observe que las dos tablas están combinadas por los campos especificados en la tercera página del asistente (en este ejemplo, ID e ID de producto). Cree una combinación para cada par de campos relacionados restante arrastrándolos desde la primera tabla (tabla con registros no coincidentes) hasta la segunda. Para este ejemplo, arrastre el campo Precio de venta de la tabla Productos hasta el campo Precio unitario de la tabla Detalles de pedidos.

  9. Haga doble clic en una combinación (la línea que conecta los campos) para que se muestre el cuadro de diálogo Propiedades de la combinación. Para cada combinación, elija la opción que incluya todos los registros de la tabla Productos y, a continuación, haga clic en Aceptar.

    En la cuadrícula de diseño de la consulta, observe que cada combinación tiene ahora una flecha en un extremo.

    El tipo de combinación viene indicado por el estilo de la línea.

    1. Al crear la combinación entre los campos Precio unitario y Precio de venta, se restringen los resultados de ambas tablas. En los resultados de la consulta se incluyen únicamente los registros con datos coincidentes en los campos de ambas tablas.

    2. Después de modificar las propiedades de la combinación, esta solo restringe la tabla a la que apunta la flecha. Todos los registros de la tabla desde la que apunta la flecha se incluyen en los resultados de la consulta.

    Nota: Asegúrese de que todas las flechas en las combinaciones apunten en la misma dirección.

  10. Para la tabla con los registros relacionados (en este ejemplo, la tabla Detalles de pedido), haga doble clic en cada campo combinado con la primera tabla, salvo en el campo elegido en la tercera página del asistente (en este caso, el campo ID de producto). Para cada uno de estos campos, desactive la casilla de la fila Mostrar y escriba Es Nulo en la fila Criterios.

  11. De manera opcional, agregue criterios a los otros campos de consulta o cree campos calculados que se basen en valores de la primera tabla.

  12. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

    La consulta devuelve los nombres de los productos que no forman parte de ningún pedido existente.

Crear una consulta propia para buscar registros no coincidentes

  1. En el grupo Consultas de la pestaña Crear, haga clic en Diseño de la consulta. Nota: Si usa Access 2007, en el grupo Otros de la pestaña Crear, haga clic en Diseño de la consulta.

  2. En el cuadro de diálogo Mostrar tabla, haga doble clic en la tabla con los registros no coincidentes y, a continuación, haga doble clic en la tabla con los registros relacionados.

  3. Cierre el cuadro de diálogo Mostrar tabla.

  4. En la cuadrícula de diseño de la consulta, las dos tablas deben tener líneas, denominadas combinaciones, que las conectan por sus campos relacionados. Si no hay combinaciones, créelas arrastrando cada campo relacionado de la primera tabla (la tabla con los registros no coincidentes) a la segunda tabla (la tabla con los registros relacionados).

  5. Haga doble clic en una combinación para que se abra el cuadro de diálogo Propiedades de la combinación. Para cada combinación, elija la opción 2 y, a continuación, haga clic en Aceptar.

    En la cuadrícula de diseño de la consulta, se muestran flechas en los extremos de las combinaciones.

    Nota: Asegúrese de que todas las combinaciones apuntan en la misma dirección. La consulta no se ejecutará si las combinaciones apuntan en diferentes direcciones y puede no ejecutarse si alguna combinación no es una flecha. Las combinaciones deben apuntar en dirección contraria a la tabla con los registros no coincidentes.

  6. En la tabla que tiene los registros no coincidentes, haga doble clic en los campos que desee que devuelva la consulta.

    Puede especificar criterios para cualquiera de estos campos o crear campos calculados.

  7. Para la tabla con los registros relacionados, haga doble clic en cada uno de los campos combinados con la primera tabla. Para cada uno de estos campos, desactive la casilla en la fila Mostrar y escriba Es Nulo en la fila Criterios.

  8. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

Vea también:

Crear una consulta de selección sencilla

Buscar registros duplicados con una consulta

Usar una consulta de unión para combinar varias consultas en un mismo resultado

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×