Cambiar a Access 2010

Información general

Cambiar a Access 2010 desde una versión anterior Si es un usuario experimentado de Access, este curso es ideal para usted. En este curso, se explica cómo cambiar a Access 2010 desde una versión anterior. Aprenderá a realizar tareas habituales en Access 2010, como usar bases de datos existentes, crear nuevas bases de datos, crear tablas y crear o editar formulario e informes..

Una vez finalizado este curso, sabrá realizar las siguientes tareas:

  • Usar la vista Backstage para abrir bases de datos existentes y crear nuevas bases de datos.

  • Guardar una base de datos existente como archivo de Access 2010.

  • Usar la cinta de opciones para iniciar la vista Diseño para tablas, formularios, informes y consultas.

  • Usar la vista Presentación para editar formularios e informes.

  • Usar la vista Presentación para agrupar datos en informes.

Este curso incluye:

  • Una lección autoguiada.

  • Una pequeña prueba al final de la lección. La prueba no será puntuada.

  • Una tarjeta de referencia rápida que puede imprimir al finalizar el curso.

Este curso supone que usted tiene al menos un nivel moderado de experiencia con Access; ha creado algunas bases de datos y comprende los conceptos básicos del diseño de bases de datos y de relación entre tablas. Si no tiene experiencia en el uso de Access, vea el tema sobre la introducción a Access 2010.

Versión sin conexión (123.5 MB)

Introducción a Access 2010

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Iniciar una acción con el panel de navegación

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Familiarizarse con la cinta de opciones

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Usar archivos de versiones anteriores de Access

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Introducción rápida a plantillas y bases de datos web

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Diseño instantáneo con la vista Presentación

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Pasos de práctica sugeridos

Si tiene algo de experiencia en el uso de Access 2003 o una versión anterior (un par de bases de datos pequeñas o más), este curso es ideal para usted. Aquí encontrará algunos modos sugeridos para practicar lo que aprendió en el curso.

Importante    Para seguir estos pasos, debe tener Access 2010 instalado en el equipo y debe estar conectado a Internet.

Crear una nueva base de datos en blanco

Para seguir estos pasos, puede usar uno de sus propios esquemas de bases de datos.

  1. Inicie Access 2010. Se abre automáticamente en la vista Backstage.

  2. Haga clic en la pestaña Nuevo. Ya está seleccionada la plantilla Base de datos en blanco.

  3. En el lado derecho de la ficha, en el cuadro Nombre de archivo, escriba un nombre para la nueva base de datos.

  4. También puede hacer clic en el icono de carpeta ubicado a la derecha del cuadro Nombre de archivo.

    Esta acción abre el cuadro de diálogo Archivo de nueva base de datos, y puede usarlo para seleccionar otra ubicación para la base de datos.

  5. Haga clic en Descargar.

    Se abre la base de datos y muestra una tabla en blanco en la vista Hoja de datos, lista para que agregue campos.

Agregar campos a una tabla

Access ofrece diversos modos de agregar campos a una tabla. A continuación, se mencionan los más frecuentes.

  1. Con la tabla abierta en la vista Hoja de datos, asegúrese de que está en la ficha Campos (si no lo está, haga clic en ella).

  2. En el grupo Agregar y eliminar, abra la lista Más campos.

  3. En la parte inferior de la lista, en Inicio rápido, haga clic en Nombre.
    Lista Más campos

  4. Haga clic en el encabezado del campo en blanco ubicado a la derecha de los nuevos campos (las palabras Haga clic para agregar) y, a continuación, repita el paso 4 para agregar los campos Dirección y Teléfono a la tabla.

  5. Haga clic con el botón secundario en el encabezado del campo en blanco (las palabras Haga clic para agregar) y, en la lista que aparece, seleccione Memo.

    Dicha acción establece el tipo de datos para el campo y hace que pueda escribirse en el encabezado.

  6. En el encabezado del campo, escriba Comentarios, luego haga clic fuera del encabezado para confirmar los cambios.

Navegar en el panel de navegación

Nota    Es preciso contar con una conexión a Internet para seguir estos pasos. Empiece descargando la base de datos de ejemplo de Northwind. Para ello, haga clic en la pestaña Nuevo y, a continuación, haga clic en Plantillas de ejemplo. Marque la base de datos como de confianza (en la barra de mensajes amarilla, haga clic en Habilitar contenido) e inicie sesión en la base de datos.

  1. El panel de navegación está cerrado en esta plantilla, por lo tanto, haga clic en la flecha doble para abrirlo.

    Botón de apertura/cierre del panel de navegación

  2. En el panel, haga clic en la barra Informes para expandir ese grupo.

    Observe que el grupo muestra un conjunto de accesos directos a los objetos de la base de datos. De ese modo, sabe que está viendo una categoría o un grupo personalizado.

  3. Haga clic en la barra ubicada en la parte superior del panel (dice Northwind Traders) y haga clic en Tipo de objeto. Ahora ve una lista de objetos en la base de datos.

  4. Haga clic en Formularios y, a continuación, haga clic con el botón secundario en el formulario Lista de clientes y en Vista Presentación.

  5. Haga clic en el grupo Tablas para expandirlo y, a continuación, haga doble clic en la tabla Clientes.

  6. Haga clic con el botón secundario en la parte superior del panel y haga clic en Barra de búsqueda.

    Para que la Barra de búsqueda esté visible, repita este paso.

  7. Cuando la Barra de búsqueda esté visible, expanda todos los grupos y, en el cuadro Búsqueda, escriba lentamente cliente. Observe cómo Access filtra la lista de objetos a medida que escribe.

Navegar por la cinta de opciones

Pruebe realizar estos pasos con una base de datos como Northwind.

  • Abra una tabla en la vista Hoja de datos y observe qué fichas contextuales aparecen; explore dichas fichas para ver los comandos que ofrecen.

  • Abra una consulta en la vista Diseño y observe qué fichas contextuales aparecen. Explore las fichas para ver los comandos que ofrecen.

  • Abra un formulario en la vista Presentación y observe qué fichas contextuales aparecen. Explore también estas fichas.

Pasos adicionales

  1. Con cualquier objeto de base de datos abierto y la ficha Inicio visible, presione la tecla ALT.

    Aparece una serie de Sugerencias clave.

    Sugerencias clave

    Access ofrece una sugerencia clave para cada pestaña de la cinta de opciones y una sugerencia clave para los comandos de cada ficha.

  2. Vuelva a presionar la tecla ALT y observe que las sugerencias clave desaparecen.

  3. Presione ALT+C para ir a la ficha Crear.

    Como navegó a la ficha Crear desde la ficha Inicio, Access muestra una serie de sugerencias clave para cada comando de la ficha Crear.

  4. Vuelva a presionar ALT y observe que las sugerencias clave desaparecen.

  5. Ahora, presione ALT+C y observe que las sugerencias clave para cada comando vuelven a aparecer.

    Si cierra las sugerencias clave para una ficha determinada por error, puede presionar ALT y la letra correspondiente a dicha ficha para volver a ver las sugerencias clave.

  6. Presione QD para iniciar el diseñador de consultas.

  7. Con el diseñador de consultas abierto, presione ALT+H para ir a la ficha Inicio.

    Observe cómo se deshabilitan también las sugerencias clave para comandos deshabilitados (gris).

Publicar una base de datos web

Empiece por descargar una de las plantillas de bases de datos web, como la plantilla Base de datos web de activos. Para ello, haga clic en la pestaña Nuevo y, a continuación, haga clic en Plantillas de ejemplo. Active la confianza para la base de datos (en la barra de mensajes amarilla, haga clic en Habilitar contenido) e inicie sesión en la base de datos.

  1. En la vista Backstage, haga clic en la pestaña Guardar y publicar.

  2. Haga clic en Publicar en Servicios de Access.

  3. Haga clic en Ejecutar Comprobador de compatibilidad.

  4. Haga clic en para cerrar los objetos abiertos y permitir la ejecución del Comprobador de compatibilidad.

    Si la comprobación de compatibilidad no detecta errores, o si sólo detecta advertencias, la base de datos está lista para ser publicada.

  5. Escriba la dirección URL del servidor y un nombre para el sitio. Puede solicitar la dirección URL al administrador del sistema.

  6. Haga clic en Publicar en Servicios de Access.

    Deberá esperar que finalice el proceso de publicación y que el servidor termine de procesar el nuevo sitio.

  7. Abra el explorador, vaya al sitio, abra el formulario Activos actuales y escriba algunos datos.

Cambiar una base de datos web y guardar los cambios en Web

  1. Abra la Base de datos web de activos en Access.

  2. Abra el formulario Principal en la vista Presentación.

  3. Haga clic con el botón secundario en la pestaña Introducción del formulario y en Eliminar; a continuación, presione CTRL+S para guardar los cambios.

  4. Haga clic en la pestaña Archivo para ir a la vista Backstage.

  5. En la ficha Información, haga clic en Sincronizar todo para escribir (guardar) los cambios en Web.

    Botón Sincronizar todo

Ponga a prueba sus conocimientos

Realice la siguiente prueba para asegurarse de que ha entendido todo el material. Sus respuestas serán privadas y los resultados de la prueba no se puntuarán.

Puede usar la vista Diseño para modificar los formularios y los informes en una base de datos web.

Verdadero.

Incorrecto. Sólo puede usar la vista Diseño para los formularios y los informes que no publicará en Servicios de Access. Para una base de datos web, use la vista Presentación para crear o modificar formularios e informes.

Falso.

Muy bien. Puede usar la vista Presentación para modificar los formularios y los informes en una base de datos web, pero no la vista Diseño.

Abre una base de datos de Access 97 en Access 2010. Escribe datos y realiza modificaciones de diseño.

Verdadero.

Inténtelo de nuevo. Sólo es posible leer datos cuando se abre una base de datos de Access 97 en Access 2010.

Falso.

Exactamente. Sólo puede leer los datos. Si desea realizar otras acciones, guarde el archivo en el formato de archivo de Access 2010.

Puede publicar una base de datos web en cualquier sitio web.

Verdadero.

No es cierto. Sólo puede publicar bases de datos web en un servidor de SharePoint que ejecute los Servicios de Access.

Falso.

Bien. El servidor de SharePoint 2010 debe ejecutar los Servicios de Access.

En el panel de navegación, se abre un formulario para entrada de datos del siguiente modo:

Debe hacer clic con el botón secundario en el formulario y hacer clic en la vista Diseño.

No es correcto. Si hiciera eso, abriría el formulario para realizar modificaciones de diseño, pero no para el uso habitual.

Debe hacer doble clic en el formulario.

Asígnese dos puntos. También puede hacer clic con el botón secundario sobre un objeto y hacer clic en Abrir.

No se usa el panel de navegación. Se usa el comando Abrir de la ficha Inicio de la cinta de opciones.

Inténtelo de nuevo. Desde ya que puede usar el panel de navegación para abrir objetos para su uso.

Cuando guarda un archivo MDB en el nuevo formato de archivo (como un archivo ACCDB), puede abrir ese nuevo archivo en Access 2003.

Verdadero.

Inténtelo de nuevo. No puede abrir archivos ACCDB en Access 2003.

Falso.

Bien. Sólo puede abrir archivos ACCDB en Access 2007 ó 2010. Además, recuerde que las características exclusivas de la versión 2010 no funcionan en la versión 2007.

Comentarios

Tarjeta de referencia rápida

Más cursos

Primero en una serie para principiantes.

Diseñar las tablas para una nueva base de datos

Vea también

Personalizar la Cinta

Libro de asignaciones de la cinta de Access

Mostrar u ocultar el panel de navegación

Cuadro de diálogo Opciones de navegación

Convertir una base de datos de Access 2010 a un formato de archivo de una versión anterior

Qué vista usar: vista Presentación o vista Diseño

Moverse por la vista Backstage

  • Access 2010 se abre en la vista Backstage. Vaya a la vista Backstage o desde ella a otra ubicación haciendo clic en la pestaña Archivo.

  • Puede abrir una base de datos haciendo clic en su nombre en Archivo o puede hacer clic en la pestaña Reciente.

  • En la ficha Nuevo, puede crear una base de datos nueva, incluso bases de datos y plantillas en blanco:

  • En la ficha Guardar y enviar, puede guardar una base de datos en otro formato de archivo, empaquetar y firmar una base de datos, compilarla en un archivo ejecutable y publicar una base de datos en un servidor de SharePoint 2010 que ejecute los Servicios de Access.

  • Haga clic en Opciones para iniciar el cuadro de diálogo Opciones de Access y definir las opciones para las bases de datos y para Access mismo.

Crear una nueva base de datos en blanco

  1. Haga doble clic en la plantilla que desea.

  2. Acepte el nombre predeterminado o escriba uno más adecuado.

  3. Haga clic en Crear.

Usar el panel de navegación

  • Haga doble clic en un objeto para abrirlo y usarlo.

  • Haga clic con el botón secundario para realizar cambios de diseño en el objeto, para exportarlo, cambiarle el nombre o abrir la hoja de propiedades para el archivo seleccionado.

Cambiar el modo en que el panel categoriza los objetos

  1. Haga clic en la barra ubicada en la parte superior del panel. Esta acción abre una lista de categorías y grupos.

  2. Seleccione una categoría de la mitad superior de la lista o un grupo de la mitad inferior.

Definir las opciones para el panel

  • Haga clic con el botón secundario en la barra ubicada en la parte superior del panel y haga clic en Opciones de navegación.

Buscar objetos

  1. Si la barra de búsqueda no está visible, haga clic con el botón secundario en la barra ubicada en la parte superior del panel de navegación y haga clic en Barra de búsqueda.

  2. Escriba parte del nombre del objeto o el nombre completo en el cuadro Buscar. El panel filtra la lista de objetos a medida que escribe.

Para evitar que los objetos de la base de datos se superpongan

  1. En la vista Backstage, haga clic en Opciones.

  2. Haga clic en Base de datos activa.

  3. Seleccione Documentos con fichas y Mostrar fichas de documento.

  4. Cierre la base de datos y vuelva a abrirla para ver los cambios.

Usar la cinta de opciones

  • La cinta de opciones no es estática; es decir, cambia en función del objeto en el que está centrada la atención o de la tarea que está realizando.

  • La cinta de opciones coloca los comandos en un conjunto de fichas y divide dichas fichas en grupos.

  • La ficha Inicio proporciona los comandos que usa con mayor frecuencia.

  • Asimismo, la barra de herramientas de acceso rápido que se encuentra en la esquina superior izquierda de la ventana de Access contiene los comandos usados con más frecuencia. La barra de herramientas de acceso rápido no se modifica, independientemente de la ficha de la cinta de opciones que use.

  • Puede personalizar la barra de herramientas de acceso rápido y la cinta de opciones.

Usar sugerencias clave

  • Presione la tecla ALT para mostrar las sugerencias clave para cada ficha de la cinta. Al presionar la tecla ALT más la letra asignada a la pestaña, va a esa ficha.

  • Cuando usa las sugerencias clave para ir a una ficha, también puede ver las sugerencias clave para cada comando de dicha ficha. Para usar un comando, simplemente presione el número, la letra (o letras). Si las sugerencias clave para los comandos de una ficha desaparecen, presione ALT más la letra correspondiente a la pestaña.

Personalizar la barra de herramientas de acceso rápido

  1. Haga clic en la flecha ubicada a la derecha de la barra de herramientas para abrir un menú de comandos.

  2. Seleccione el comando que desea agregar a la barra de herramientas.

  3. Si no puede ver el comando que desea, haga clic en Más comandos. Esta acción abre el cuadro de diálogo Opciones de Access.

  4. Agregue comandos del panel izquierdo en el panel derecho.

Personalizar la cinta

Cuando personaliza la cinta de opciones, los cambios se aplican a Access, no a una base de datos individual.

Importante    Cuando coloca un comando en una ficha o grupo de la cinta de opciones personalizada, rompe el vínculo entre ese comando y el tema de ayuda que se muestra al presionar F1.

  1. Haga clic en la pestaña Archivo para ir a la vista Backstage y, a continuación, haga clic en Opciones.

  2. Haga clic en Personalizar cinta de opciones.

  3. Debajo del panel izquierdo, haga clic en Nueva pestaña, Nuevo grupo o Cambiar nombre, en función de lo que desea hacer.

  4. En el panel izquierdo, escriba un nombre para la ficha o el grupo.

  5. Si está creando una nueva ficha o un nuevo grupo, seleccione el comando que desea del panel izquierdo y haga doble clic en el comando o haga clic en Agregar para mover el comando al panel derecho.

Reglas para usar archivos de versiones anteriores de Access

  • Las bases de datos creadas en Access 2000, Access 2002 y Access 2003 se ejecutarán en Access 2010, pero algunas características no funcionarán, incluidas la Ventana Base de datos y la replicación.

  • Los archivos de Access 97 pueden abrirse en Access 2010, pero sólo pueden verse objetos y agregar registros. No se pueden guardar los cambios de diseño, a menos que se convierta la base de datos al formato de archivo de Access 2010.

  • Una vez que guarda una base de datos de un formato anterior como archivo ACCDB, sólo puede usarla en Access 2007 ó 2010.

  • Si abre una base de datos de Access 2010 en Access 2007, todas las características exclusivas de Access 2010 no funcionarán.

Usar plantillas y bases de datos web

Access ofrece dos clases de plantillas: locales y en línea. Las plantillas locales se instalan en el equipo cuando se instala Access. Las plantillas en línea están disponibles si tiene una conexión a Internet.

Para usar plantillas en línea

  1. En la vista Backstage, en la ficha Nuevo, haga clic en Plantillas de ejemplo o haga doble clic en una de las categorías de plantillas en Plantillas de Office.com.

  2. Asigne un nombre a la nueva base de datos, elija una ubicación si es necesario y haga clic en Crear para descargar y abrir la plantilla.

  3. Habilite el contenido bloqueado y empiece a entrar datos o modifique la plantilla para adaptarla a sus necesidades.

Para publicar una base de datos web

  1. En la vista Backstage, haga clic en la pestaña Guardar y publicar si no está seleccionada y, a continuación, haga clic en Publicar en Servicios de Access.

  2. Haga clic en Ejecutar Comprobador de compatibilidad.

  3. Haga clic en para cerrar los objetos abiertos y permitir que se ejecute el Comprobador de compatibilidad.

  4. Si no se detectan problemas, la base de datos está lista para ser publicada.

  5. Escriba la dirección URL del servidor y un nombre para el sitio.

  6. Haga clic en Publicar en Servicios de Access.
    Una vez completado el proceso de publicación, las tablas de la base de datos se convierten en listas de SharePoint y los formularios se ven y se comportan como en Access.

Usar la vista Presentación

La vista Presentación es un diseñador visual para formularios e informes en Access 2010. Además, es el único diseñador para formularios e informes en una base de datos web.

Para usar la vista Presentación

  • En el panel de navegación, haga clic con el botón secundario en un formulario o un informe y, a continuación, haga clic en la vista Presentación.
    - o -
    Haga clic con el botón secundario en la ficha de documento de cualquier formulario o informe abierto y haga clic en la vista Presentación.

Algunos cambios rápidos que pueden hacerse en la vista Presentación

  • Seleccione un solo control o etiqueta y arrástrelo para modificar el tamaño de todos los controles o etiquetas de esa columna.

  • Seleccione una etiqueta, haga clic en la pestaña Formato y use los comandos que se encuentran en ella para cambiar la fuente, el color de fuente o la alineación del texto.

  • Presione CTRL, seleccione varias etiquetas y modifíqueles el formato.

  • Para realizar cambios globales en una presentación, haga clic en el selector de la presentación, la cruz ubicada en el extremo superior izquierdo de la presentación. Por ejemplo, seleccione toda la presentación. En la ficha Diseño, haga clic en Hoja de propiedades para abrir las propiedades del formulario, y configure los controles a una altura diferente.

Para mover o colocar controles agregando columnas o filas en blanco en una presentación

  1. En la ficha Diseño, haga clic en Agregar campos existentes.

  2. Arrastre los campos que desea usar a la presentación.

  3. Si es necesario, arrastre los controles por separado desde las etiquetas y suéltelos en la ubicación deseada. Una barra anaranjada indica el destino.

Para agrupar y ordenar los datos en los informes

  1. En la ficha Diseño, haga clic en Agrupar y ordenar.

  2. En el panel Agrupación, orden y total, haga clic en Agregar un grupo y, a continuación, haga clic en el campo en el cual desea agrupar los datos. El cambio aparece de inmediato.
    Puede agregar hasta siete niveles de agrupación.

Se aplica a: Access 2010



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma