Calcular la diferencia entre dos horas

Calcular la diferencia entre dos horas

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Suponga que desea averiguar cuánto tarda un empleado en finalizar una operación de cadena de montaje o un pedido de comida rápida en las horas de más actividad. Existen varias formas de calcular la diferencia entre dos horas.

Presentar el resultado en el formato de hora estándar

Existen dos enfoques que puede tomar para presentar los resultados en formato de hora estándar (horas: minutos: segundos). Use el operador de resta (-) para buscar la diferencia entre horas y, a continuación, siga uno de estos procedimientos:

Aplicar un código de formato personalizado a la celda haciendo lo siguiente:

  1. Seleccione la celda.

  2. En la pestaña Inicio, en el grupo Número, haga clic en la flecha situada junto al cuadro General y luego en Más formatos de número.

  3. En el cuadro de diálogo Formato de celdas, haga clic en Personalizada en la lista Categoría y, a continuación, seleccione un formato personalizado en el cuadro Tipo.

Usar la función texto para dar formato a las horas: Al usar los códigos de formato de hora, horas nunca superan 24 minutos no deben sobrepasar 60 y segundos no deben sobrepasar 60.

Tabla de ejemplo 1: Presentar el resultado en el formato de hora estándar

Copie la tabla siguiente en una hoja de cálculo en blanco y, a continuación, modifique si es necesario.

1

2

3


4


5


6

7


8


9

A

B

Hora de inicio

Hora de finalización

9/6/2007 10:35 a.m.

9/6/2007 3:30 p.m.

Fórmula

Descripción (resultado)

=B2-A2

Horas entre dos horas (4). Debe aplicar manualmente el formato personalizado "h" a la celda.

=B2-A2

Horas y minutos entre dos horas (4:55). Debe aplicar manualmente el formato personalizado "h:mm" a la celda.

=B2-A2

Horas, minutos y segundos entre dos horas (4:55:00). Debe aplicar manualmente el formato personalizado "h:mm:ss" a la celda.

=TEXTO(B2-A2;"h")

Horas entre dos horas con formato de celda "h" usando la función TEXTO (4).

=TEXTO(B2-A2;"h:mm")

Horas y minutos entre dos horas con formato de celda "h:mm" usando la función TEXTO (4:55).

=TEXTO(B2-A2;"h:mm:ss")

Horas, minutos y segundos entre dos horas en una celda con formato "h:mm:ss" usando la función TEXTO (4:55:00).

Nota: Si usa tanto un formato aplicado con la función TEXTO y como un formato de número en la celda, la función TEXTO tiene prioridad.

Para obtener más información sobre el uso de estas funciones, vea las funciones TEXTO y Mostrar números como fechas u horas.

Tabla de ejemplo 2: Presentar el resultado de una sola unidad de tiempo

Para realizar esta tarea, deberá usar la función INT o las funciones hora, minutoy segundo tal como se muestra en el ejemplo siguiente.

Copie el siguiente tableto una hoja de cálculo en blanco y, a continuación, modifique según sea necesario.

1

2

3


4


5


6

7


8


9

A

B

Hora de inicio

Hora de finalización

9/6/2007 10:35 a.m.

9/6/2007 3:30 p.m.

Fórmula

Descripción (resultado)

=ENTERO((B2-A2)*24)

Horas totales entre dos horas (4)

=(B2-A2)*1440

Minutos totales entre dos horas (295)

=(B2-A2)*86400

Segundos totales entre dos horas (17700)

=HORA(B2-A2)

La diferencia en la unidad de horas entre dos horas. Este valor no puede superar 24 (4).

=MINUTO(B2-A2)

La diferencia en la unidad de minutos entre dos horas. Este valor no puede superar 60 (55).

=SEGUNDO(B2-A2)

La diferencia en la unidad de segundos entre dos horas. Este valor no puede superar 60 (0).

Para obtener más información sobre el uso de estas funciones, vea los temas sobre las funciones ENTERO, HORA, MINUTO y SEGUNDO.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×