CONTAR.SI (función CONTAR.SI)

En este artículo, se describen la sintaxis de la fórmula y el uso de la funciónCONTAR.SI en Microsoft Excel.

Descripción

La función CONTAR.SI cuenta el número de celdas dentro de un rango que cumplen un solo criterio especificado por el usuario. Por ejemplo, puede contar todas las celdas que comienzan con cierta letra, o bien todas las celdas que contienen un número mayor o menor que un número especificado por el usuario. Por ejemplo, suponga que tiene una hoja de cálculo que contiene una lista de tareas en la columna A y el primer nombre de la persona asignada a cada tarea en la columna B. Puede usar la función CONTAR.SI para contar cuántas veces aparece el nombre de una persona en la columna B y, de esa forma, determinar cuántas tareas tiene asignadas. Por ejemplo:

=CONTAR.SI(B2:B25,"Nancy")

Nota   Para contar celdas basándose en varios criterios, vea la función CONTAR.SI.CONJUNTO.

Sintaxis

CONTAR.SI(rango;criterios)

La sintaxis de la función CONTAR.SI tiene los siguientes argumento:

  • rango    Obligatorio. Una o más celdas que se van a contar, incluidos números o nombres, matrices o referencias que contengan números. Los valores en blanco y los de texto no se tienen en cuenta.

  • criterios    Obligatorio. Número, expresión, referencia de celda o cadena de texto que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, ">32", B4, "manzanas" o "32".

    Nota   

    • En los criterios se puede usar los caracteres comodín  — signo de interrogación (?) y asterisco (*) —. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) delante del carácter que desea buscar.

    • Los criterios no distinguen entre mayúsculas y minúsculas; por ejemplo, la cadena "manzanas" y la cadena "MANZANAS" corresponden a las mismas celdas.

Observaciones

  • La función CONTAR.SI devuelve resultados incorrectos cuando se usa para comparar cadenas de más de 255 caracteres con la cadena #¡VALOR!.

Ejemplos

El libro de abajo muestra ejemplos de esta función. Inspecciónelos, cambie las fórmulas existentes o especifique sus propias fórmulas para saber cómo funciona la función.

Copie los datos de ejemplo en la tabla siguiente y cópielos en la celda A1 de una nueva hoja de cálculo de Excel. Para que las fórmulas muestren resultados, selecciónelas, presione F2 y después presione Entrar. Si lo necesita, puede ajustar los anchos de columna para ver todos los datos.

Datos

Datos

manzanas

3

naranjas

54

melocotones

75

manzanas

86

Fórmula

Descripción

Resultado

=CONTAR.SI(A2:A5;"manzanas")

Número de celdas con manzanas en las celdas A2 a A5.

2

=CONTAR.SI(A2:A5;A4)

Número de celdas con melocotones en las celdas A2 a A5.

1

=CONTAR.SI(A2:A5;A3)+CONTAR.SI(A2:A5;A2)

Número de celdas con naranjas y manzanas en las celdas A2 a A5.

3

=CONTAR.SI(B2:B5;">55")

Número de celdas con un valor superior a 55 en las celdas B2 a B5.

2

=CONTAR.SI(B2:B5;"<>"&B4)

Número de celdas con un valor no igual a 75 en las celdas B2 a B5.

3

=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85")

Número de celdas con un valor superior o igual a 32 e inferior o igual a 85 en las celdas B2 a A5.

3

Para trabajar más en profundidad con los datos de ejemplo en Excel, descargue el libro incrustado en el equipo y ábralo en Excel.

Ejemplo 2

Datos

manzanas

naranjas

No

melocotones

No

manzanas

Fórmula

Descripción

Resultado

=CONTAR.SI(A2:A7;"*es")

Número de celdas que acaban con las letras "es" en las celdas A2 a A7.

4

=CONTAR.SI(A2:A7;"?????es")

Número de celdas que acaban con las letras "es" y tienen exactamente 7 letras en las celdas A2 a A7.

2

=CONTAR.SI(A2:A7;"*")

Número de celdas que contienen cualquier texto en las celdas A2 a A7.

4

=CONTAR.SI(A2:A7;"<>"&"*")

Número de celdas que no contienen texto en las celdas A2 a A7.

2

=CONTAR.SI(B2:B7;"No") / FILAS(B2:B7)

Número promedio de votos negativos (incluidas las celdas vacías) de las celdas B2 a B7.

0,33333333

=CONTAR.SI(B2:B7;"Sí") / (FILAS(B2:B7) -CONTAR.SI(B2:B7; "<>"&"*"))

El número medio de votos afirmativos (excluidas las celdas vacías) de las celdas B2 a B7.

0,5

Se aplica a: Excel 2013, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma