CONTAR.SI (función CONTAR.SI)

CONTAR.SI (función CONTAR.SI)

Use CONTAR.SI, una de las funciones estadísticas, para contar el número de celdas que cumplen un criterio; por ejemplo, para contar el número de veces que una ciudad determinada aparece en una lista de clientes.

En su forma más sencilla, CONTAR.SI indica lo siguiente:

  • =CONTRAR.SI(¿Dónde quiere realizar la búsqueda y qué quiere buscar?)

Por ejemplo:

  • =CONTAR.SI(A2:A5,"Londres")

  • =CONTAR.SI(A2:A5;A4)

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Obtener más información sobre SUMAR.SI, CONTAR.SI y otras funciones relacionadas para analizar los datos rápidamente

Aumente sus conocimientos sobre SUMAR.SI, CONTAR.SI y otras funciones relacionadas con LinkedIn Learning. Aprenda a usar la función CONTAR.SI para analizar los datos rápidamente.

Ver la vista previa gratuita >

CONTAR.SI(rango;criterios)

Nombre del argumento

Descripción

Rango    (obligatorio)

El grupo de celdas que desea contar. Rango puede contener números, matrices, un rango con nombre o referencias que contengan números. Los valores en blanco y de texto se ignoran.

Obtenga información sobre cómo seleccionar rangos en una hoja.

Criterios    (obligatorio)

Número, expresión, referencia de celda o cadena de texto que determina las celdas que se van a contar.

Por ejemplo, puede usar un número como 32, una comparación como ">32", una celda como B4 o una palabra como "manzanas".

CONTAR.SI usa solo un criterio. Use CONTAR.SI.CONJUNTO si desea usar varios criterios.

Ejemplos

Para usar estos ejemplos de Excel, copie los datos de la tabla de abajo y péguelos en la celda A1 de una nueva hoja de cálculo.

Datos

Datos

manzanas

32

naranjas

54

melocotones

75

manzanas

86

Fórmula

Descripción

=CONTAR.SI(A2:A5;"manzanas")

Cuenta el número de celdas con manzanas entre las celdas A2 y A5. El resultado es 2.

=CONTAR.SI(A2:A5;A4)

Cuenta el número de celdas con melocotones, el valor de A4, entre las celdas A2 y A5. El resultado es 1.

=CONTAR.SI(A2:A5,A2)+CONTAR.SI(A2:A5,A3)

Cuenta el número de manzanas, el valor de A2, y de naranjas, el valor de A3, entre las celdas A2 y A5. El resultado es 3. Esta fórmula usa CONTAR.SI dos veces para especificar varios criterios, un criterio por expresión. También puede utilizar la función CONTAR.SI.CONJUNTO.

=CONTAR.SI(B2:B5;">55")

Cuenta el número de celdas con un valor superior a 55 entre las celdas B2 y B5. El resultado es 2.

=CONTAR.SI(B2:B5;"<>"&B4)

Cuenta el número de celdas con un valor distinto de 75 entre las celdas B2 y B5. El símbolo de la "y" (&) combina el operador de comparación "<>" (no es igual a) y el valor de B4 para leer =CONTAR.SI(B2:B5,"<>75"). El resultado es 3.

=CONTAR.SI(B2:B5;">=32")-CONTAR.SI(B2:B5;">85")

Cuenta el número de celdas con un valor superior o igual a 32 e inferior o igual a 85 entre las celdas B2 y A5. El resultado es 3.

=CONTAR.SI(A2:A5,"*")

Cuenta el número de celdas que contienen texto entre las celdas A2 y A5. El carácter comodín * se usa para reemplazar cualquier carácter. El resultado es 4.

=CONTAR.SI(A2:A5,"?????es")

Cuenta el número de celdas que tienen exactamente 7 caracteres y que terminan con las letras es entre las celdas A2 y A5. El carácter comodín ? se usa para reemplazar caracteres individuales. El resultado es 2.

Problemas comunes

Problema

Qué ha fallado

Se devolvió un valor incorrecto para cadenas largas.

La función CONTAR.SI devuelve resultados incorrectos cuando se usa para comparar cadenas de más de 255 caracteres.

Para comparar cadenas de más de 255 caracteres, use la función CONCATENAR o el operador concatenar &. Por ejemplo, =CONTAR.SI(A2:A5,"cadena larga"&"otra cadena larga").

No se devolvió ningún valor cuando se esperaba uno.

Asegúrese de encerrar el argumento de criterios entre comillas.

Si una fórmula CONTAR.SI hace referencia a otro libro, se recibe un error #VALOR!

Este error se produce cuando la fórmula que contiene la función hace referencia a celdas o a un rango de un libro cerrado y se calculan las celdas. Para que esta característica funcione, el otro libro debe estar abierto.

Prácticas recomendadas

Realice este procedimiento

¿Por qué?

Tenga en cuenta que CONTAR.SI pasa por alto mayúsculas y minúsculas en las cadenas de texto.

Los criterios no distinguen entre mayúsculas y minúsculas. En otras palabras, la cadena "manzanas" y la cadena "MANZANAS" darán como resultado la misma cantidad de celdas.

Use caracteres comodín.

Los caracteres comodín, que son el signo de interrogación (?) y el asterisco (*), pueden usarse en los criterios. El signo de interrogación corresponde a un solo carácter cualquiera, y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogación o un asterisco reales, escriba una tilde (~) detrás del carácter.

Por ejemplo, =CONTAR.SI(A2:A5,"manzana?") contará todas las instancias de "manzana" con una última letra que podrá variar.

Asegúrese de que los datos no contienen caracteres incorrectos.

Al contar valores de texto, asegúrese de que los datos no contienen espacios al principio ni al final, de que no haya un uso incoherente de las comillas rectas (' o ") ni tipográficas (‘ o “) y de que no haya caracteres no imprimibles. En estos casos, CONTAR.SI puede devolver un valor inesperado o incorrecto.

Intente usar la función LIMPIAR o la función ESPACIOS.

Para mayor comodidad, use rangos con nombre.

CONTAR.SI admite el uso de rangos con nombre en una fórmula (por ejemplo, =CONTAR.SI(fruta,">=32")-CONTAR.SI(fruta,">85"). El rango con nombre puede estar en la hoja de cálculo actual, en otra hoja de cálculo del mismo libro o en una hoja de cálculo de otro libro. Para hacer referencia a otro libro, ese libro también debe estar abierto.

Nota: La función CONTAR.SI no contará celdas según el color de la fuente o el fondo de la celda. Pero Excel es compatible con funciones definidas por el usuario (UDF) con las operaciones de Microsoft Visual Basic para Aplicaciones (VBA) en celdas basadas en el color de la fuente o el fondo. Este es un ejemplo de cómo puede contar el número de celdas con un color de celda específico con VBA.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Para contar las celdas que no estén en blanco, use la función CONTARA

Para contar las celdas con varios criterios, use la función CONTAR.SI.CONJUNTO

Vea un vídeo en el que se explica cómo usar la función CONTAR.SI.CONJUNTO

La función SUMAR.SI suma solamente los valores que cumplen un único criterio

La función SUMAR.SI.CONJUNTO suma solamente los valores que cumplen varios criterios

Función SI.CONJUNTO (Office 365, Excel 2016 y versiones posteriores)

Usar la función ESPACIOS para quitar los espacios iniciales y finales de las celdas

Usar la función LIMPIAR para quitar los caracteres no imprimibles de las celdas

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en las fórmulas con la comprobación de errores

Funciones estadísticas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Usar SUMAR.SI, CONTAR.SI y otras funciones relacionadas para analizar los datos rápidamente (vista previa gratuita)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×