Cómo evitar la ruptura de las fórmulas

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Cuando las fórmulas muestran errores o resultados no deseados y no sabemos qué hacer a continuación, puede resultar enormemente frustrante.

Son varias las cosas que pueden estar mal: paréntesis no coincidentes, errores de escritura, referencias a datos de rangos que no existen... Los procedimientos recomendados siguientes pueden ayudarle a evitar o resolver algunos errores comunes a la hora de compilar o corregir fórmulas.

Realice este procedimiento recomendado:

Para evitar este error común:

Iniciar todas las funciones con el signo igual (=)

Si no escribe un signo igual en primer lugar, no estará escribiendo una fórmula y por tanto no se realizará ningún cálculo (un error común fácil de solucionar).

Por ejemplo, si escribe algo como SUMA(A1:A10), Excel Online mostrará la cadena de texto SUMA(A1:A10) en lugar de un resultado de la fórmula. Si escribe 11/2, aparecerá una fecha (como 2-nov o 11/02/2009) en lugar de dividir 11 por 2.

Para evitar estos resultados inesperados, escriba siempre un signo igual en primer lugar. Por ejemplo, escriba: =SUMA(A1:A10) y =11/2.

Hacer coincidir todos los paréntesis de apertura y de cierre

Asegúrese de que todos los paréntesis corresponden a un par coincidente. Para que las funciones que se usan en las fórmulas funcionen correctamente, cada paréntesis de apertura necesita un paréntesis de cierre.

Por ejemplo, la fórmula =SI(B5<0),"No válido",B5*1,05) no funcionará porque hay un paréntesis de apertura y dos de cierre.

La fórmula correcta sería =SI(B5<0,"No válido",B5*1,05).

Escribir todos los argumentos necesarios

La mayoría de las funciones necesitan argumentos (valores que deben proporcionarse para que la función funcione correctamente). Solo algunas funciones (como HOY o PI) no los necesitan. Para asegurarse de escribir todos los argumentos necesarios (ni más ni menos), compruebe la sintaxis de la fórmula que aparece al comenzar a escribir un signo igual seguido de una función.

Por ejemplo, la función MAYUSC solo acepta una cadena de texto o una referencia de celda como argumento: =MAYUSC("hola") o =MAYUSC(C2).

Además, algunas funciones (como SUMA) solo precisan argumentos numéricos, mientras que otras (como REEMPLAZAR) requieren un valor de texto para, al menos, uno de sus argumentos. Si usa un tipo de datos incorrecto, algunas funciones pueden devolver resultados inesperados o mostrar el error #¡VALOR! .

Usar números sin formato en las fórmulas

No escriba en las fórmulas números con formato con signos de dólar ($) o separadores decimales con comas (,), ya que los signos de dólar indican referencias absolutas y las comas actúan como separadores de argumentos. Los números con formato no se usan en los cálculos de las fórmulas. En lugar de escribir en la fórmula 1,000 $, escriba 1000.

Si usa números con formato en los argumentos, obtendrá resultados inesperados en el cálculo y puede aparecer el error #¡NUM! . Por ejemplo, si escribe la fórmula =ABS(-2,134) para buscar el valor absoluto de -2134, Excel Online mostrará el error #¡NUM! porque la función ABS solo acepta un argumento.

Si, después de escribir la fórmula con números sin formato, desea aplicar formato al resultado obtenido con separadores decimales y símbolos de moneda, puede aplicar un formato de número.

Usar el tipo de datos de celda adecuado

Si el tipo de datos de una celda no puede usarse en los cálculos, la fórmula puede devolver resultados esperados.

Por ejemplo, si escribe una fórmula simple, como =2+3, en una celda con formato de texto, Excel Online no podrá calcular los datos que ha escrito. En la celda solo aparecerá =2+3.

Para corregir este problema, cambie el tipo de datos de la celda de Texto a General del modo siguiente:

  1. Seleccione la celda.

  2. Haga clic en Inicio y en la flecha Formato de número. Elija General.

  3. Presione F2 (para poner la celda en modo Edición) y Entrar (para aceptar la fórmula).

Si escribe una fecha en una celda con el tipo de datos Número, se mostrará como un valor de fecha numérico en lugar de como una fecha. Para mostrar este número como una fecha, elija el formato Fecha en la galería de Formato de número.

Usar el símbolo * para multiplicar números

Aunque tal vez quisiera usar x como operador de multiplicación en una fórmula, deberá usar el asterisco (*).

Si usa x en una fórmula, Excel Online no podrá calcular el resultado y, en su lugar, mostrará la fórmula en la celda, con un borde de puntos rojos alrededor de esta para indicar que hay un error de fórmula.

Usar comillas antes y después del texto de las fórmulas

Si crea un fórmula que incluye texto, escríbalo entre comillas.

Por ejemplo, la fórmula ="Hoy es " & TEXTO(HOY(),"dddd, mmmm dd") combina el texto "Hoy es " con el resultado de las funciones TEXTO y HOY para devolver Hoy es lunes, 30 de mayo en la celda.

En la fórmula, "Hoy es " incluye un espacio en blanco antes de las comillas de cierre para mantener este espacio entre las palabras Hoy es y lunes, 30 de mayo. Si no se usaran las comillas antes y después del texto, la fórmula indicaría el error #¿NOMBRE? .

Anidar un máximo de 64 funciones en una fórmula

Si lo desea, puede combinar (o anidar) hasta 64 niveles de funciones en una fórmula.

Por ejemplo, la fórmula =SI(RAIZ(PI())<2,"¡Menos de dos!","¡Más de dos!") tiene tres niveles de funciones: la función PI se encuentra anidada dentro de la función RAIZ que, a su vez, se encuentra anidada dentro de la función SI.

Evitar la división de valores numéricos por cero

Si divide una celda por otra que contiene cero (0) o ningún valor, aparecerá el error #¡DIV/0! .

Para evitar este error, anide la operación de división en la función SI.ERROR. Por ejemplo, escriba las dos fórmulas siguientes en celdas de una hoja de cálculo:

=SI.ERROR(3/0.0)

=SI.ERROR(3/7.0)

La primera fórmula devuelve 0 porque la función SI.ERROR reconoce que dividir por cero genera un error. La segunda fórmula devuelve el valor 3/7 (no se genera ningún error porque no se divide por cero).

Para que le resulte más fácil crear sus propias fórmulas, vea estos trucos y sugerencias sobre las fórmulas.

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×