Cómo corregir un error #¡VALOR! en las funciones PROMEDIO o SUMA

Si PROMEDIO o SUMA hacen referencia a celdas que contienen errores #¡VALOR!, las fórmulas proporcionarán un error #¡VALOR!.

Error #¡VALOR! en la función PROMEDIO

Para omitir los valores de error, crearemos una fórmula que ignora los errores en el rango de referencia mientras calcula el promedio con los valores "normales" restantes.

Para trabajar en este escenario, usamos una combinación de PROMEDIO junto con SI y ESERROR para determinar si existe un error en el rango especificado. Este escenario concreto necesita una fórmula de matriz:

=PROMEDIO(SI(ESERROR(B2:D2),"",B2:D2))

Nota: Esta es una fórmula de matriz y necesita escribirse con CTRL+MAYÚS+ENTRAR. Excel colocará automáticamente la fórmula entre llaves {}. Si intenta escribirlas de manera manual, Excel mostrará la fórmula como texto.

Función de matriz en PROMEDIO para resolver el error #¡VALOR!

Nota: La función anterior no solo funcionará para el error #¡VALOR!, sino también para #N/A, #NULL y #¡DIV/0! entre otros.

También puede usar SUMA de la misma manera:

=SUMA(SI(ESERROR(B2:D2),"",B2:D2))

¿Tiene alguna pregunta específica acerca de la función?

Publicar una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR!

Función PROMEDIO

Función SUMA

Información general sobre las fórmulas en Excel

Evitar fórmulas erróneas

Usar la comprobación de errores para detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×