Office
Iniciar sesión

Cómo corregir un error #¡VALOR! en las funciones INDICE/COINCIDIR

En este tema, se explican los escenarios comunes cuando detecta el error #¡VALOR! al usar las funciones INDICE y COINCIDIR juntas en una fórmula. Una de las razones más comunes para usar la combinación de INDICE y COINCIDIR es cuando quiere buscar un valor en un escenario donde la función BUSCARV no funcionará, como por ejemplo si el valor de búsqueda tiene más de 255 caracteres.

Problema: La fórmula no se ha escrito como una matriz

Si está usando INDICE como una fórmula de matriz junto con COINCIDIR para poder recuperar un valor, necesitará convertir la fórmula en una fórmula de matriz. De otro modo, verá un error #¡VALOR!.

Solución: INDICE y COINCIDIR deben usarse como una fórmula de matriz, lo que significa que necesita presionar CTRL+MAYÚS+ENTRAR. Así se colocará automáticamente la fórmula entre llaves {}. Si intenta escribirlas usted mismo, Excel mostrará la fórmula como texto.

Si está usando las funciones INDICE/COINCIDIR cuando tiene un valor de búsqueda superior a 255 caracteres necesitan escribirse como una fórmula de matriz.  La fórmula de la celda F3 es =INDICE(B2:B4,COINCIDIR(VERDADERO,A2:A4=F2,0),0), y se escribe presionando Ctrl+Mayús+Entrar
INDICE y COINCIDIR deben usarse como una fórmula de matriz

¿Tiene alguna pregunta específica acerca de la función?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR!

Función INDICE

Función COINCIDIR

Buscar valores con BUSCARV, INDICE o COINCIDIR

Información general sobre las fórmulas en Excel

Evitar fórmulas erróneas

Usar la comprobación de errores para detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×