Cómo corregir un error #¡VALOR! en la función CONTAR.SI/CONTAR.SI.CONJUNTO

En este tema, se enumeran las causas más comunes del error #¡VALOR! en las funciones CONTAR.SI y CONTAR.SI.CONJUNTO.

Problema: La fórmula hace referencia a celdas de un libro cerrado

Las funciones CONTAR.SI y CONTAR.SI.CONJUNTO que hacen referencia a una celda o a un rango de un libro cerrado provocarán un error #¡VALOR!.

Nota: Este es un problema conocido de varias funciones de Excel como SUMAR.SI, SUMAR.SI.CONJUNTO y CONTAR.BLANCO por nombrar algunas. Vea Las funciones SUMAR.SI, CONTAR.SI y CONTAR.BLANCO devuelven un error #¡VALOR! para obtener más información.

Solución: Abra el libro vinculado indicado en la fórmula y presione F9 para actualizar la fórmula.

También puede trabajar en este problema con las funciones SUMA y SI juntas en una fórmula de matriz. Vea Las funciones SUMAR.SI, CONTAR.SI y CONTAR.BLANCO devuelven un error #¡VALOR! para obtener más información.

Problema: La cadena tiene más de 255 caracteres

Solución: Acorte la cadena si es posible. Si no puede, use la función CONCATENAR o el operador de Y comercial (&) para desglosar el valor en varias cadenas. Por ejemplo,

  • =CONTAR.SI(B2:B12,"cadena larga"&"otra cadena larga")

¿Tiene alguna pregunta específica acerca de la función?

Publicar una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR!

Función CONTAR.SI

Función CONTAR.SI.CONJUNTO

Función SI: fórmulas anidadas y cómo evitar problemas

Ver un vídeo sobre las funciones SI avanzadas

Información general sobre las fórmulas en Excel

Evitar fórmulas erróneas

Usar la comprobación de errores para detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×