Cómo corregir un error #¡VALOR! en la función CONCATENAR

Importante: En Excel 2016, Excel Mobile y Excel Online, la función CONCATENAR se ha reemplazado por la función CONCAT. Aunque la función CONCATENAR sigue estando disponible para garantizar la compatibilidad con versiones anteriores, le recomendamos que use la función CONCAT ya que es una función más sólida.

Uno de los escenarios más comunes donde encontrará el error #¡VALOR! con la función CONCATENAR es cuando intenta crear una cadena que incluye una referencia de celda que tiene un error, como #¡VALOR!.

En el ejemplo siguiente, queremos concatenar D2, E2 y F2, donde E2 tiene un error #¡VALOR!.

Error #¡VALOR! en la función CONCATENAR

El error de E2 hace que la función muestre el error #¡VALOR!. Para que funcione correctamente, necesitará reemplazar el error por un valor que no sea el error. Puede crear una fórmula que compruebe si hay un error en la referencia de celda, y si lo hay, muestra la cadena de texto donde aparece un 0 en lugar del error (o puede sustituir su propio texto para 0, pero necesitará ajustar el texto entre comillas: "Su texto").

Funcionará una fórmula como esta:

=SI(ESERROR(E2),CONCATENAR(D2," ",0," ",F2))

Las funciones SI y ESERROR usadas como solución alternativa para concatenar una cadena con el error #¡VALOR!

¿Cómo funciona? La función SI usa la función SI.ERROR para determinar si existe un error en E2, y si lo hay, la función CONCATENAR combina los valores de D2, E2 y F2 (la función reemplaza el error por un 0), y muestra la cadena de texto resultante. Tenga en cuenta que la fórmula también usa espacios (" ") para ayudar a separar los valores.

Corregir el error #¡VALOR! con la función CONCATENAR en Excel 2003 y versiones anteriores

Si obtiene el error #¡VALOR! en Office Excel 2003 o en versiones anteriores, necesitará desactivar la opción Evaluación de fórmulas de transición (TFE) en Excel. Siga los pasos indicados en Error #¡VALOR! al concatenar las celdas para resolver el problema.

¿Tiene alguna pregunta específica acerca de la función?

Publicar una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR!

Función CONCATENAR

Función CONCAT

Información general sobre las fórmulas en Excel

Evitar fórmulas erróneas

Usar la comprobación de errores para detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Todas las funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×