Cómo corregir un error #¡REF!

Cómo corregir un error #¡REF!

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

La #REF! error muestra cuando una fórmula hace referencia a una celda que no es válida. Esto ocurre con mayor frecuencia cuando obtengan eliminadas o pegan celdas que se hace referencia en las fórmulas.

Ejemplo: el error #¡REF! se ha provocado al eliminar una columna

En el siguiente ejemplo se usa la fórmula =SUMA(B2,C2,D2) en la columna E.

Una fórmula que usa referencias de celda explícitas como =SUMA(B2,C2,D2) puede provocar un error #¡REF! si se elimina una columna.

Si desea eliminar la columna B, C y D crearía un #REF! error. En este caso, deberá eliminar la columna C (ventas 2007), y la fórmula debe indicar ahora =SUM(B2,#REF!,C2). Cuando usa referencias de celda explícitas así (cuando se hace referencia a cada celda individualmente, separados por punto y coma) y eliminar una referencia de fila o columna, Excel no puede resolver, por lo que devuelve el #REF! error. Esta es la razón principal, ¿por qué no se recomienda utilizar referencias de celda explícitas en las funciones.

Ejemplo del error #¡REF! que se ha provocado al eliminar una columna.

Solución

  • Si, por error, ha eliminado filas o columnas, puede hacer clic inmediatamente en el botón Deshacer de la Barra de herramientas de acceso rápido (o presionar CTRL+Z) para restaurarlas.

  • Ajustar la fórmula para que utilice una referencia de rango en lugar de celdas individuales, como =SUM(B2:D2). Ahora puede eliminar cualquier columna dentro del rango de suma y Excel ajustará automáticamente la fórmula. También puede utilizar =SUM(B2:B5) para una suma de filas.

Ejemplo: BUSCARV con referencias de rango incorrectas

En el siguiente ejemplo, =BUSCARV(A8,A2:D5,5,FALSO) devolverá un error #¡REF! porque está buscando un valor para devolver de la columna 5 pero el rango de referencia es A:D, que solo tiene 4 columnas.

Ejemplo de una fórmula BUSCARV con un rango incorrecto.  La fórmula es =BUSCARV(A8,A2:D5,5,FALSO).  No existe la quinta columna en el rango BUSCARV, por lo que 5 provoca un error #¡REF!.

Solución

Ajustar el intervalo para que sea más grande o reducir el valor de búsqueda de la columna para que coincida con el rango de referencia. =VLOOKUP(a8,a2:E5,5,False) sería un rango de referencia válida, como lo haría = VLOOKUP(A8,A2:D5,4,FALSE).

Ejemplo: INDICE con una referencia de columna o fila incorrecta

En este ejemplo, la fórmula =INDICE(B2:E5,5,5) devuelve un error #¡REF! porque el rango de INDICE es de 4 filas por 4 columnas, pero la fórmula solicita que se devuelva lo que está en la quinta fila y en la quinta columna.

Ejemplo de una fórmula INDICE con una referencia de rango no válida.  La fórmula es =INDICE(B2:E5,5,5) pero el rango solo tiene 4 filas y 4 columnas.

Solución

Ajustar las referencias de fila o columna para que estén dentro del rango de búsqueda de índice. =Index(B2:E5,4,4) devuelve un resultado válido.

Ejemplo: hacer referencia a un libro cerrado con INDIRECTO.

En el siguiente ejemplo, una función INDIRECTO está intentado hacer referencia a un libro que está cerrado, lo que provoca el error #¡REF!.

Ejemplo de un error #¡REF! que se ha provocado por INDIRECTO al hacer referencia a un libro cerrado.

Solución

Abrir el libro al que se hace referencia

Problemas OLE

Si ha usado un vínculo OLE (vinculación e incrustación de objetos ) que devuelve un error #¡REF!, inicie el programa al que está llamando el vínculo.

Nota: OLE es una tecnología que puede usar para compartir información entre programas.

Problemas DDE

Si ha utilizado un tema de intercambio dinámico de datos (DDE) que devuelve un #REF! error, primera comprobación para asegurarse de que haya que hace referencia el tema correcto. Si aún recibe un #REF! error, compruebe la Configuración del centro de confianza de contenido externo, como se describe en Bloquear o desbloquear contenido externo en documentos de Office.

Nota: Intercambio dinámico de datos (DDE)es un protocolo establecido para intercambiar datos entre programas de Microsoft Windows.

Problemas de macros

Si una macro introduce una función en la hoja de cálculo que hace referencia a una celda situada sobre la función y la celda que contiene la función está en la fila 1, la función devolverá #REF! porque no hay ninguna celda encima de la fila 1. Compruebe la función para ver si un argumento hace referencia a una celda o rango de celdas que no es válido. Esto puede requerir modificar la macro en el Editor de Visual Basic (VBE) para realizar esta situación en cuenta.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en las fórmulas con la comprobación de errores

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×