Cómo corregir un error #¡DIV/0!

Microsoft Excel muestra el error #DIV/0! cuando un número se divide por cero (0). Esto puede suceder al escribir una fórmula simple (como =5/0) o si una fórmula hace referencia a una celda con valor 0 o en blanco, tal como se muestra en esta imagen.

Ejemplos de fórmulas que provocan errores #¡DIV/0!.

Para corregir el error, siga uno de estos procedimientos:

  • Asegúrese de que el divisor de la función o fórmula no es cero ni está en blanco.

  • Cambie la referencia de celda de la fórmula a otra celda que no contenga un valor de cero (0) ni esté en blanco.

  • Escriba #N/A en la celda a la que se hace referencia como divisor de la fórmula. Así cambiará el resultado de la fórmula a #N/A para indicar que el valor del divisor no se encuentra disponible.

Muchas veces el error #¡DIV/0! no puede evitarse porque las fórmulas están esperando la entrada del usuario o de otra persona. En ese caso, no quiere que el mensaje de error se muestre por lo que existen algunos métodos de control de errores que puede usar para suprimir el error mientras espera la entrada.

Evaluar el denominador para 0 o ningún valor

La forma más sencilla de suprimir el error #¡DIV/0! es usar la función SI para evaluar la existencia del denominador. Si es 0 o ningún valor, entonces muestra 0 o ningún valor como resultado de la fórmula en lugar del valor de error #¡DIV/0!, de otro modo calcula la fórmula.

Por ejemplo, si la fórmula que genera el error es =A2/A3, use =SI(A3,A2/A3,0) para que se devuelva 0 o =SI(A3,A2/A3,””) para que se devuelva una cadena vacía. También puede mostrar un mensaje personalizado como este: =SI(A3,A2/A3,"Entrada necesaria"). Con la función COCIENTE del primer ejemplo usaría =SI(A3,COCIENTE(A2,A3),0). Esto indica a Excel SI(A3 existe, entonces devuelve el resultado de la fórmula, de otro modo lo ignora).

Ejemplos para solucionar errores #¡DIV/0!.

Usar SI.ERROR para suprimir el error #¡DIV/0!

También puede suprimir este error anidando su operación de división dentro de la función SI.ERROR. De nuevo, al usar A2/A3, puede usar =SI.ERROR(A2/A3,0). Esto indica a Excel si su fórmula se evalúa como un error, entonces devuelve 0, de otro modo devuelve el resultado de la fórmula.

Para las versiones de Excel anteriores a Excel 2007, puede usar el método SI(ESERROR()): =SI(ESERROR(A2/A3),0,A2/A3) (Vea Funciones ES).

Nota: los métodos SI.ERROR y SI (ESERROR()) son controladores de errores abiertos, suprimirán todos los errores, no solo los #¡DIV/0!. Necesita asegurarse de que su fórmula funciona correctamente antes de aplicar ningún control de errores, de otro modo puede que no note que su fórmula no está funcionando como espera.

Sugerencia:  Si se ha activado la comprobación de errores en Excel, haga clic Imagen del botón junto a la celda que muestra el error. Haga clic en Mostrar pasos de cálculo (si se encuentra disponible) y seleccione la resolución más adecuada para los datos específicos.

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Función SI

Función SI.ERROR

Funciones ES

Información general de fórmulas en Excel

Cómo evitar las fórmulas rotas

Usar la comprobación de errores para detectar errores en fórmulas

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×