Buscar valores con BUSCARV, INDICE o COINCIDIR

Importante:  Este artículo se ha traducido con traducción automática; vea la declinación de responsabilidades. Para su referencia, puede encontrar la versión en inglés de este artículo aquí.

Para encontrar un valor en una lista grande, puede usar una función de búsqueda. La función BUSCARV se utiliza ampliamente, pero también puede usar la función BUSCARH y las funciones ÍNDICE y COINCIDIR conjuntamente.

Aquí tiene el ámbito de BUSCARV y los argumentos que usa:

=BUSCARV(<valor de búsqueda>,<rango de búsqueda>,<columna>,<coincidencia aproximada>)

Por ejemplo: =BUSCARV(21500,C2:E7,3,FALSO)

  • El primer argumento (un elemento que la función necesita para funcionar) es el valor que desea buscar. Puede ser una referencia de celda como B2 o un valor como "martín" o 21500.

  • El segundo argumento es el rango de celdas que cree que contiene el valor que desea encontrar.

    Importante: Con BUSCARV, la columna que contiene el valor o la referencia de celda que busca debe ser la columna situada más a la izquierda del rango.

  • El tercer argumento es la columna del rango de búsqueda de celdas que contiene el valor que desea ver.

Aunque el cuarto argumento es opcional, la mayoría de las personas escriba Falso (o 0). ¿Por qué? Dado que esto obliga a la función para buscar una coincidencia exacta en la búsqueda. Puede no introducir ningún argumento o verdadero, pero si no encuentra una coincidencia exacta, la función devuelve la más cercanacoincidencia aproximada, y por lo general, la mayoría de las personas no quiere una coincidencia aproximada.

Para mostrar cómo una coincidencia aproximada puede ser un problema grave, supongamos que está buscando el precio de un elemento con el identificador 2345768, pero cambie dos números y escribir en la fórmula similar a esta: =VLOOKUP(2345678,A1:E7,5). la fórmula devuelve el precio del elemento incorrecto porque BUSCARV encontrar el número más cercano menor o igual que el número especificado (2345678). Podría acabar facturación a un cliente incorrecto debido a este error.

Si especifica FALSO ó 0 en el argumento Coincidencia aproximada y no hay una coincidencia exacta, la fórmula devuelve #N/A en la celda en lugar de un valor incorrecto: una solución mucho mejor. En este caso, #N/A no significa que haya introducido una fórmula incorrecta (excepto por el número mal escrito); significa que no se ha encontrado 2345678, y usted deseaba 2345768.

En este ejemplo se muestra el funcionamiento de la función. Cuando escribe un valor en la celda B2 (el primer argumento), BUSCARV busca en las celdas C2:E7 (el segundo argumento) y devuelve la coincidencia aproximada más cercana de la tercera columna del rango, la columna E (el tercer argumento).

Un uso típico de la función BUSCARV

En este ejemplo, como el cuarto argumento se dejó en blanco, la función devuelve una coincidencia aproximada.

Uso de la función BUSCARH

Una vez que esté familiarizado con BUSCARV, no le costará mucho usar la función BUSCARH. El usuario introduce los mismos argumentos, pero BUSCARH encuentra valores en filas en lugar de en columnas.

Uso conjunto de ÍNDICE y COINCIDIR

Si no desea estar limitado a buscar en la columna situada más a la izquierda, puede usar una combinación de las funciones INDICE y COINCIDIR. Una fórmula que usa estas funciones juntas es un poco más compleja que una fórmula con una función BUSCARV, pero puede ser más potente y hay usuarios que prefieren mucho más la combinación ÍNDICE/COINCIDIR antes que la función BUSCARV.

En este ejemplo se muestra una pequeña lista donde el valor que deseamos buscar, Chicago, no está en la columna situada más a la izquierda. Por lo tanto, no podemos usar BUSCARV. En su lugar, usaremos la función COINCIDIR para encontrar Chicago en el rango B1:B11. Se encuentra en la fila 4. A continuación, INDICE usa ese valor como el argumento de búsqueda, y encuentra la población de Chicago en la 4a columna (columna D). La fórmula usada se muestra en la celda A14.

Uso de ÍNDICE y COINCIDIR para buscar un valor

Más opciones de búsqueda

Principio de página

Nota: Declinación de responsabilidades de traducción automática: Este artículo se ha traducido con un sistema informático sin intervención humana. Microsoft ofrece estas traducciones automáticas para que los hablantes de otros idiomas distintos del inglés puedan disfrutar del contenido sobre los productos, los servicios y las tecnologías de Microsoft. Puesto que este artículo se ha traducido con traducción automática, es posible que contenga errores de vocabulario, sintaxis o gramática.

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×