Office
Iniciar sesión

Buscar valores con BUSCARV, INDICE o COINCIDIR

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Supongamos que tiene una lista de números de la ubicación de office y que debe saber qué empleados están en cada oficina. La hoja de cálculo es grande, por lo que se imagina es de difícil tarea. Es bastante sencillo con una función de búsqueda.

Las funciones BUSCARV y BUSCARH , junto con el índice y coincidir,son algunas de las funciones más útiles de Excel.

Nota: La característica de Asistente para búsquedas ya no está disponible en Excel.

Aquí es un ejemplo de cómo usar BUSCARV.

=BUSCARV(B2,C2:E7,3,VERDADERO)

En este ejemplo, B2 es el primer argumento, un elemento de datos que la función debe trabajar. BUSCARV, este primer argumento es el valor que desea buscar. Este argumento puede ser una referencia de celda o un valor fijo, como "Díaz" o 21.000. El segundo argumento es el rango de celdas, C2-:E7, en la que desea buscar el valor que desea buscar. El tercer argumento es la columna de ese rango de celdas que contiene el valor que busca.

El cuarto argumento es opcional. Escriba TRUE o FALSE. Si escribe Verdadero o deje en blanco el argumento, la función devuelve a una coincidencia aproximada del valor que especifique en el primer argumento. Si especifica FALSE, la función se coincide con el valor proporcionar por el primer argumento. En otras palabras, deje en blanco el cuarto argumento, o introduciendo verdadero: proporciona más flexibilidad.

Este ejemplo muestra cómo funciona la función. Cuando escribe un valor en la celda B2 (el primer argumento), BUSCARV busca las celdas del rango C2:E7 (2 º argumento) y devuelve la coincidencia aproximada más cercana de la tercera columna del rango, columna E (3ª argumento).

Un uso típico de la función BUSCARV

El cuarto argumento está vacío, la función devuelve una coincidencia aproximada. Si no, tendrá que especifique uno de los valores en las columnas C y D para obtener un resultado en absoluto.

Cuando se siente cómodo con BUSCARV, es igualmente fácil de usar la función BUSCARH. Introducir los mismos argumentos, pero busca en filas en lugar de columnas.'

Inténtelo

Si desea experimentar con las funciones de búsqueda antes de probarlo con sus propios datos, aquí tiene algunos datos de ejemplo. Algunos usuarios de Excel como con BUSCARV y BUSCARH; otros usuarios prefieren uso conjunto INDICE y coincidir. Pruebe cada método y ver cuáles que más le guste.

Ejemplo de BUSCARV en el trabajo

Copie los datos siguientes en una hoja de cálculo en blanco...

Sugerencia:    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A C en 250 píxeles y haga clic en Ajustar texto (fichaInicio, grupo Alineación ).

Densidad

Viscosidad

Temperatura

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Fórmula

Descripción

Resultado

=BUSCARV(1,A2:C10,2)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna B en la misma fila.

2,17

=BUSCARV(1,A2:C10,3,VERDADERO)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna c en la misma fila.

100

=BUSCARV(0.7,A2:C10,3,FALSO)

Usando una coincidencia aproximada, busca el valor 0,7 en la columna A. Como en la columna A no hay ninguna coincidencia exacta, devuelve un error.

#N/A

=BUSCARV(0.1,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 0,1 en la columna A. Como 0,1 es inferior al menor de los valores de la columna A, devuelve un error.

#N/A

=BUSCARV(2,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 2 en la columna A, busca el mayor de los valores que sea inferior o igual a 2 en la columna A, que es 1,29, y después devuelve el valor de la columna B en la misma fila.

1,71

Ejemplo de BUSCARH

Copie todas las celdas de esta tabla y péguelas en la celda A1 de una hoja de cálculo en blanco de Excel.

Sugerencia:    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A C en 250 píxeles y haga clic en Ajustar texto (fichaInicio, grupo Alineación ).

Ejes

Cojinetes

Pernos

4

4

9

5

7

10

6

8

11

Fórmula

Descripción

Resultado

=CONSULTAH("Ejes"; A1:C4; 2; VERDADERO)

Busca Ejes en la fila 1 y devuelve el valor de la fila 2 que está en la misma columna (columna A).

4

=CONSULTAH("Cojinetes"; A1:C4; 3; FALSO)

Busca Cojinetes en la fila 1 y devuelve el valor de la fila 3 que está en la misma columna (columna B).

7

=CONSULTAH("B"; A1:C4; 3; VERDADERO)

Busca B en la fila 1 y devuelve el valor de la fila 3 que está en la misma columna. Debido a que no se encuentra una coincidencia exacta para "B", se usa el siguiente valor menor que "B" en la fila 1: "Ejes". en la columna A.

5

=CONSULTAH("Pernos", A1:C4, 4)

Busca Pernos en la fila 1 y devuelve el valor de la fila 4 que está en la misma columna (columna C).

11

=CONSULTAH(3, {1,2,3;"a","b","c";"d","e","f"}, 2, VERDADERO)

Busca el número 3 en la constante matricial de tres filas y devuelve el valor de la fila 2 en la misma columna (en este caso, la tercera). Hay tres filas de valores en la constante matricial, cada una separada por punto y coma (;). Debido a que se encuentra "c" en la fila 2 y en la misma columna que 3, se devuelve "c".

c

INDICE y coincidir ejemplos

Este último ejemplo emplea las funciones INDICE y coincidir para devolver el número de factura más temprana y su fecha correspondiente para cada uno de los cinco ciudades. Dado que se devuelve la fecha como un número, usamos la función texto para darle formato como una fecha. La función INDICE realmente usa el resultado de la función coincidir como argumento. La combinación de las funciones INDICE y coincidir se usan dos veces en cada fórmula: en primer lugar, para devolver el número de factura y, a continuación, para devolver la fecha.

Copie todas las celdas de esta tabla y péguelas en la celda A1 de una hoja de cálculo en blanco de Excel.

Sugerencia:    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A D en 250 píxeles y haga clic en Ajustar texto (fichaInicio, grupo Alineación ).

Factura

Ciudad

Fecha de factura

Factura más temprana por ciudad, con fecha

3115

Atlanta

7/4/12

="Atlanta = "&INDICE($A$2:$C$33,COINCIDIR("Atlanta",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Atlanta",$B$2:$B$33,0),3),"d/m/aa")

3137

Atlanta

9/4/12

="Austin = "&INDICE($A$2:$C$33,COINCIDIR("Austin",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Austin",$B$2:$B$33,0),3),"d/m/aa")

3154

Atlanta

11/4/12

="Dallas = "&INDICE($A$2:$C$33,COINCIDIR("Dallas",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Dallas",$B$2:$B$33,0),3),"d/m/aa")

3191

Atlanta

21/4/12

="Nueva Orleans = "&INDICE($A$2:$C$33,COINCIDIR("Nueva Orleans",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Nueva Orleans",$B$2:$B$33,0),3),"d/m/aa")

3293

Atlanta

25/4/12

="Tampa = "&INDICE($A$2:$C$33,COINCIDIR("Tampa",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Tampa",$B$2:$B$33,0),3),"d/m/aa")

3331

Atlanta

27/4/12

3350

Atlanta

28/4/12

3390

Atlanta

1/5/12

3441

Atlanta

2/5/12

3517

Atlanta

8/5/12

3124

Austin

9/4/12

3155

Austin

11/4/12

3177

Austin

19/4/12

3357

Austin

28/4/12

3492

Austin

6/5/12

3316

Dallas

25/4/12

3346

Dallas

28/4/12

3372

Dallas

1/5/12

3414

Dallas

1/5/12

3451

Dallas

2/5/12

3467

Dallas

2/5/12

3474

Dallas

4/5/12

3490

Dallas

5/5/12

3503

Dallas

8/5/12

3151

Nueva Orleans

9/4/12

3438

Nueva Orleans

2/5/12

3471

Nueva Orleans

4/5/12

3160

Tampa

18/4/12

3328

Tampa

26/4/12

3368

Tampa

29/4/12

3420

Tampa

1/5/12

3501

Tampa

6/5/12

Obtenga más información sobre las funciones de búsqueda

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×