Buscar valores con BUSCARV, INDICE o COINCIDIR

Tiene una lista de números de oficina y necesita saber qué empleados están en cada oficina. Sin embargo, la hoja de cálculo es enorme, por tanto, ¿qué puede hacer? Use una función de búsqueda. Las funciones BUSCARV y BUSCARH son dos de las más útiles, como también lo son ÍNDICE y COINCIDIR.

Nota:  Si está tratando de encontrar el Asistente para búsquedas, dicha característica ya no forma parte de Excel.

Este es un rápido aviso de la manera de usar BUSCARV.

=BUSCARV(B2,C2:E7,3,VERDADERO)

El primer argumento —fragmentos de datos que la función tiene que trabajar— es el valor que desea encontrar. Puede ser una referencia de celda o un valor fuerte como "martín" o 21.000. El segundo argumento es el rango de celdas que cree que contiene el valor que desea encontrar. En este ejemplo, es C2-C7. El tercer argumento es la columna que desea ver en dicho rango de celdas que contiene el valor.

El cuarto argumento es opcional. Puede introducir Verdadero o Falso. Si introduce VERDADERO, o deja el argumento en blanco, la función devuelve una coincidencia aproximada del valor que especifica en el primer argumento. Si introduce FALSO, la función coincidirá con el valor proporcionado por el primer argumento. Es decir, dejando el argumento en blanco, o introduciendo VERDADERO, tendrá mayor flexibilidad.

En este ejemplo se muestra el funcionamiento de la función. Cuando introduce un valor en la celda B2 (el primer argumento), BUSCARV busca las celdas C2-E7 (el segundo argumento) y devuelve la coincidencia aproximada más cercana de la tercera columna del rango, la columna E (el tercer argumento).

Un uso típico de la función BUSCARV

El cuarto argumento está en blanco, por lo que la función devuelve una coincidencia aproximada. Si no la encuentra, tendría que introducir uno de los valores en las columnas C o D para obtener un resultado.

Una vez que esté cómodo con BUSCARV, la función BUSCARH no debería ser tan difícil de usar. El usuario introduce los mismos argumentos pero encuentra valores en filas en lugar de columnas.

Inténtelo

Si quiere practicar con las funciones de búsqueda antes de probarlas con sus propios datos, aquí se incluyen datos de ejemplo. A algunos usuarios les gusta usar BUSCARV y BUSCARH, otros prefieren usar conjuntamente ÍNDICE y COINCIDIR. Pruebe cada método y vea cuáles les gusta más.

BUSCARV en la oficina

Copie todas las celdas de esta tabla y péguelas en la celda A1 de una hoja de cálculo en blanco de Excel.

Sugerencia    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A a C en 250 píxeles y haga clic en Ajustar texto (pestaña Inicio, grupo Alineación).

Densidad

Viscosidad

Temperatura

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Fórmula

Descripción

Resultado

'=BUSCARV(1,A2:C10,2)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna B en la misma fila.

=BUSCARV(1,A2:C10,2)

'=BUSCARV(1,A2:C10,3,VERDADERO)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna c en la misma fila.

=BUSCARV(1,A2:C10,3,VERDADERO)

'=BUSCARV(0.7,A2:C10,3,FALSO)

Usando una coincidencia aproximada, busca el valor 0,7 en la columna A. Como en la columna A no hay ninguna coincidencia exacta, devuelve un error.

=BUSCARV(0.7,A2:C10,3,FALSO)

'=BUSCARV(0.1,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 0,1 en la columna A. Como 0,1 es inferior al menor de los valores de la columna A, devuelve un error.

=BUSCARV(0.1,A2:C10,2,VERDADERO)

'=BUSCARV(2,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 2 en la columna A, busca el mayor de los valores que sea inferior o igual a 2 en la columna A, que es 1,29, y después devuelve el valor de la columna B en la misma fila.

=BUSCARV(2,A2:C10,2,VERDADERO)

BUSCARH en la oficina

Copie todas las celdas de esta tabla y péguelas en la celda A1 de una hoja de cálculo en blanco de Excel.

Sugerencia    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A a C en 250 píxeles y haga clic en Ajustar texto (pestaña Inicio, grupo Alineación).

Ejes

Cojinetes

Pernos

4.

4.

9

5.

7.

10

6.

(8)

11

Fórmula

Descripción

Resultado

'=BUSCARH("Ejes", A1:C4, 2, VERDADERO)

Busca Ejes en la fila 1 y devuelve el valor de la fila 2 que está en la misma columna (columna A).

=BUSCARH("Ejes";A1:C4;2;VERDADERO)

'=BUSCARH("Cojinetes", A1:C4, 3, FALSO)

Busca Cojinetes en la fila 1 y devuelve el valor de la fila 3 que está en la misma columna (columna B).

=BUSCARH("Cojinetes";A1:C4;3;FALSO)

'=BUSCARH("B", A1:C4, 3, VERDADERO)

Busca B en la fila 1 y devuelve el valor de la fila 3 que está en la misma columna. Debido a que no se encuentra una coincidencia exacta para "B", se usa el siguiente valor menor que "B" en la fila 1: "Ejes". en la columna A.

=BUSCARH("B";A1:C4;3;VERDADERO)

'=BUSCARH("Pernos", A1:C4, 4)

Busca Pernos en la fila 1 y devuelve el valor de la fila 4 que está en la misma columna (columna C).

=BUSCARH("Pernos";A1:C4;4)

'=BUSCARH(3, {1,2,3;"a","b","c";"d","e","f"}, 2, VERDADERO)

Busca el número 3 en la constante matricial de tres filas y devuelve el valor de la fila 2 en la misma columna (en este caso, la tercera). Hay tres filas de valores en la constante matricial, cada una separada por punto y coma (;). Debido a que se encuentra "c" en la fila 2 y en la misma columna que 3, se devuelve "c".

=BUSCARH(3;{1;2;3\"a";"b";"c"\"d";"e";"f"};2;VERDADERO)

INDICE y COINCIDIR en acción

Este ejemplo usa conjuntamente las funciones INDICE y COINCIDIR para devolver el número de factura más temprana y su fecha correspondiente para cada una de las cinco ciudades. Puesto que la fecha se devuelve como número, usamos la función TEXTO para aplicarle formato como fecha. De hecho, la función INDICE usa el resultado de la función COINCIDIR como su argumento. La combinación de las funciones INDICE y COINCIDIR se usa dos veces en cada fórmula; primero, para devolver el número de factura y, después, para devolver la fecha.

Copie todas las celdas de esta tabla y péguelas en la celda A1 de una hoja de cálculo en blanco de Excel.

Sugerencia    Antes de pegar los datos en Excel, establezca los anchos de columna para las columnas A a D en 250 píxeles y haga clic en Ajustar texto (pestaña Inicio, grupo Alineación).

Factura

Ciudad

Fecha de la factura

Factura más temprana por ciudad, con fecha

3115

Atlanta

7/4/12

="Atlanta = "&INDICE($A$2:$C$33,COINCIDIR("Atlanta",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Atlanta",$B$2:$B$33,0),3),"d/m/aa")

3137

Atlanta

9/4/12

="Austin = "&INDICE($A$2:$C$33,COINCIDIR("Austin",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Austin",$B$2:$B$33,0),3),"d/m/aa")

3154

Atlanta

11/4/12

="Dallas = "&INDICE($A$2:$C$33,COINCIDIR("Dallas",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Dallas",$B$2:$B$33,0),3),"d/m/aa")

3191

Atlanta

21/4/12

="Nueva Orleans = "&INDICE($A$2:$C$33,COINCIDIR("Nueva Orleans",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Nueva Orleans",$B$2:$B$33,0),3),"d/m/aa")

3293

Atlanta

25/4/12

="Tampa = "&INDICE($A$2:$C$33,COINCIDIR("Tampa",$B$2:$B$33,0),1)& ", Fecha de factura: " & TEXTO(INDICE($A$2:$C$33,COINCIDIR("Tampa",$B$2:$B$33,0),3),"d/m/aa")

3331

Atlanta

27/4/12

3350

Atlanta

28/4/12

3390

Atlanta

1/5/12

3441

Atlanta

2/5/12

3517

Atlanta

8/5/12

3124

Austin

9/4/12

3155

Austin

11/4/12

3177

Austin

19/4/12

3357

Austin

28/4/12

3492

Austin

6/5/12

3316

Dallas

25/4/12

3346

Dallas

28/4/12

3372

Dallas

1/5/12

3414

Dallas

1/5/12

3451

Dallas

2/5/12

3467

Dallas

2/5/12

3474

Dallas

4/5/12

3490

Dallas

5/5/12

3503

Dallas

8/5/12

3151

Nueva Orleans

9/4/12

3438

Nueva Orleans

2/5/12

3471

Nueva Orleans

4/5/12

3160

Tampa

18/4/12

3328

Tampa

26/4/12

3368

Tampa

29/4/12

3420

Tampa

1/5/12

3501

Tampa

6/5/12

Más opciones de búsqueda

Principio de página

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×