BUSCARV (función BUSCARV)

Este artículo describe la sintaxis de la fórmula y el uso de la funciónBUSCARV en Microsoft Excel.

Descripción

Puede usar la función BUSCARV para buscar la primera columna de un intervalo de celdas y devolver un valor de cualquier celda de la misma fila del rango. Por ejemplo, si tiene una lista de empleados contenida en el rango A2:C10, los números de identificación de los empleados se almacenan en la primera columna del rango, como muestra la siguiente ilustración.

Un rango de celdas en una hoja de cálculo

Si conoce el número de identificación del empleado, puede usar la función BUSCARV para devolver el departamento o el nombre de dicho empleado. Para obtener el nombre del empleado número 38, puede usar la fórmula =BUSCARV(38, A2:C10, 3, FALSO). Esta fórmula busca el valor 38 en la primera columna del rango A2:C10 y después devuelve el valor contenido en la tercera columna del rango y en la misma fila que el valor buscado ("Juan Carlos Rivas").

La V de BUSCARV significa vertical. Use BUSCARV en lugar de BUSCARH si los valores de comparación se encuentran en una columna situada a la izquierda de los datos que desea buscar.

Sintaxis

BUSCARV(valor_buscado, matriz_buscar_en, indicador_columnas, [ordenado])

La sintaxis de la función BUSCARV tiene los siguientes argumento:

  • Valor_buscado    Obligatorio. Es el valor que se va a buscar en la primera columna de la tabla o rango. El argumento valor_buscado puede ser un valor o una referencia. Si el valor que proporcione para el argumento valor_buscado es inferior al menor valor de la primera columna del argumento matriz_buscar_en, BUSCARV devuelve al valor de error #N/A.

  • Matriz_buscar_en    Obligatorio. Es el rango de celdas que contiene los datos. Puede usar una referencia a un rango (por ejemplo, A2:D8) o un nombre de rango. Los valores de la primera columna de matriz_buscar_en son los valores que busca valor_buscado. Estos valores pueden ser texto, números o valores lógicos. Las mayúsculas y minúsculas del texto son equivalentes.

  • Indicador_columnas    Obligatorio. Es un número de columna del argumento matriz_buscar_en desde la cual debe devolverse el valor coincidente. Si el argumento indicador_columnas es igual a 1, la función devuelve el valor de la primera columna del argumento matriz_buscar_en; si el argumento indicador_columnas es igual a 2, devuelve el valor de la segunda columna de matriz_buscar_en y así sucesivamente.

    Si el argumento indicador_columnas es:

    • Inferior a 1, BUSCARV devuelve al valor de error #¡VALOR!.

    • Superior al número de columnas de matriz_buscar_en, BUSCARV devuelve el valor de error #¡REF!.

  • Ordenado    Opcional. Es un valor lógico que especifica si BUSCARV va a buscar una coincidencia exacta o aproximada:

    • Si omite ordenado o es VERDADERO, devolverá una coincidencia exacta o aproximada. Si no encuentra ninguna coincidencia exacta, devolverá el siguiente valor más alto inferior a valor_buscado.

      Importante   Si omite ordenado o es VERDADERO, los valores de la primera columna de matriz_buscar_en deben aparecer en orden ascendente; en caso contrario, es posible que BUSCARV no devuelva el valor correcto.

      Para más información, vea Ordenar datos en un rango o tabla.

      Si ordenado es FALSO, no es necesario ordenar los valores de la primera columna de matriz_buscar_en.

    • Si el argumento ordenado es FALSO, BUSCARV solo buscará una coincidencia exacta. Si hay dos o más valores en la primera columna de matriz_buscar_en que coinciden con el argumento valor_buscado, se usará el primer valor encontrado. Si no se encuentra una coincidencia exacta, se devolverá el valor de error #N/A.

Observaciones

  • Al buscar valores de texto en la primera columna de matriz_buscar_en, asegúrese de que los datos de la primera columna de matriz_buscar_en no tienen espacios al principio ni al final, de que no hay un uso incoherente de las comillas rectas ( ' o " ) ni tipográficas ( ‘ o “) y de que no hay caracteres no imprimibles. En estos casos, BUSCARV puede devolver un valor inesperado o incorrecto.

    Para más información, vea LIMPIAR (función LIMPIAR) y ESPACIOS (función ESPACIOS).

  • Al buscar valores de fechas o números, asegúrese de que los datos de la primera columna de matriz_buscar_en no se almacenen como valores de texto, ya que, en ese caso, BUSCARV puede devolver un valor incorrecto o inesperado.

  • Si ordenado es FALSO y valor_buscado es un valor de texto, puede usar los caracteres comodín de signo de interrogación (?) y asterisco (*) en el argumento valor_buscado. El signo de interrogación corresponde a un solo carácter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si lo que desea buscar es un signo de interrogación o un asterisco, escriba una tilde (~) antes del carácter.

Ejemplo

En el libro siguiente se muestran ejemplos de esta función. Revíselos, cambie las fórmulas existentes o escriba sus propias fórmulas para saber cómo funciona la función.

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de la nueva hoja de datos de Excel. Para que las fórmulas muestren resultados, selecciónelas, presione F2 y, después, presione Entrar. Si es necesario, puede ajustar los anchos de columna para ver todos los datos.

Densidad

Viscosidad

Temperatura

0,457

3,55

500

0,525

3,25

400

0,606

2,93

300

0,675

2,75

250

0,746

2,57

200

0,835

2,38

150

0,946

2,17

100

1,09

1,95

50

1,29

1,71

0

Fórmula

Descripción

Resultado

=BUSCARV(1,A2:C10,2)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna B en la misma fila.

2,17

=BUSCARV(1,A2:C10,3,VERDADERO)

Usando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0,946, y después devuelve el valor de la columna c en la misma fila.

100

=BUSCARV(0.7,A2:C10,3,FALSO)

Usando una coincidencia aproximada, busca el valor 0,7 en la columna A. Como en la columna A no hay ninguna coincidencia exacta, devuelve un error.

#N/A

=BUSCARV(0.1,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 0,1 en la columna A. Como 0,1 es inferior al menor de los valores de la columna A, devuelve un error.

#N/A

=BUSCARV(2,A2:C10,2,VERDADERO)

Usando una coincidencia aproximada, busca el valor 2 en la columna A, busca el mayor de los valores que sea inferior o igual a 2 en la columna A, que es 1,29, y después devuelve el valor de la columna B en la misma fila.

1,71

Para trabajar más en profundidad con los datos de ejemplo en Excel, descargue el libro insertado en el PC y ábralo en Excel.

Ejemplo 2

Id. de artículo

Artículo

Coste

Marcado

ST-340

Cochecito

145,67 $

30%

BI-567

Babero

3,56 $

40%

DI-328

Pañales

21,45 $

35%

WI-989

Toallitas

5,12 $

40%

AS-469

Aspirador

2,56 $

45%

Fórmula

Descripción

Resultado

= BUSCARV("DI-328", A2:D6, 3, FALSO) * (1 + BUSCARV("DI-328", A2:D6, 4, FALSO))

Calcula el precio minorista de los pañales agregando el porcentaje marcado al costo.

28,96 $

= (BUSCARV("WI-989", A2:D6, 3, FALSO) * (1 + BUSCARV("WI-989", A2:D6, 4, FALSO))) * (1 - 20%)

Calcula el precio de venta de las toallitas restando un descuento especificado al precio minorista.

5,73 $

= SI(CONSULTAV(A2, A2:D6, 3, FALSO) >= 20, "Marcado es " & 100 * CONSULTAV(A2, A2:D6, 4, FALSO) &"%", "Coste inferior a 20,00 $")

Si el coste de un artículo es mayor o igual a 20,00 $, se muestra la cadena "Marcado es nn%"; en caso contrario, se muestra la cadena "Coste inferior a 20,00 $"

Marcado es 30%

= SI(CONSULTAV(A3, A2:D6, 3, FALSO) >= 20, "Marcado es: " & 100 * CONSULTAV(A3, A2:D6, 4, FALSO) &"%", "El coste es $" & CONSULTAV(A3, A2:D6, 3, FALSO))

Si el coste de un artículo es mayor o igual a 20,00 $, se muestra la cadena "Marcado es nn%"; en caso contrario, se muestra la cadena "El coste es $n,nn"

El coste es 3,56 $

Ejemplo 3

Id.

Apellidos

Nombre

Cargo

Fecha de nacimiento

1

Cornejo

Sara

Repr. ventas

8/12/1968

2

López

Arturo

Vicepresidente de ventas

19/2/1952

3

Leal

Karina

Repr. de ventas

30/8/1963

4

Escolar

Jesús

Repr. de ventas

19/9/1958

5

Navarro

Tomás

Jefe de ventas

4/3/1955

6

Gil

Luis

Repr. de ventas

2/7/1963

Fórmula

Descripción

Resultado

=ENTERO(FRAC.AÑO(FECHA(2004,6,30), CONSULTAV(5,A2:E7,5, FALSO), 1))

Para el año fiscal 2004, busca la edad de un empleado cuya id. es 5. Usa la función FRAC.AÑO para restar la fecha de nacimiento de la fecha final del año fiscal y muestra el resultado como un entero usando la función ENTERO.

49

=SI(ESNOD(CONSULTAV(5;A2:E7;2;FALSO)) = VERDADERO; "Empleado no encontrado"; CONSULTAV(5;A2:E7;2;FALSO))

Si hay un empleado cuya id. es 5, muestra sus apellidos; en el caso contrario, muestra el mensaje "Empleado no encontrado".

La función ESNOD devuelve el valor VERDADERO si la función CONSULTAV devuelve el valor de error #N/A.

Navarro

=SI(ESNOD(CONSULTAV(15;A3:E8;2;FALSO)) = VERDADERO; "Empleado no encontrado"; CONSULTAV(15;A3:E8;2;FALSO))

Si hay un empleado cuyo id. es 5, muestra sus apellidos; en el caso contrario, muestra el mensaje "Empleado no encontrado".

La función ESNOD devuelve el valor VERDADERO si la función CONSULTAV devuelve el valor de error #N/A.

Empleado no encontrado

=CONSULTAV(4,A2:E7,3,FALSO) & " " & CONSULTAV(4,A2:E7,2,FALSO) & " es " & CONSULTAV(4,A2:E7,4,FALSO)

Para un empleado cuyo id. es 4, concatena (combina) los valores de tres celdas para formar una frase completa.

Jesús Escolar es representante de ventas.

Principio de página

Se aplica a: Excel 2013, Excel Online



¿Le ha sido útil esta información?

No

¿Cómo podemos mejorarlo?

255 caracteres restantes

Para proteger su privacidad, no incluya información de contacto en sus comentarios. Revisar política de privacidad.

¡Gracias por sus comentarios!

Recursos de soporte técnico

Cambiar idioma