Asignar elementos XML a las celdas de una asignación XML

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Para Importar y Exportar datos XML en Excel, una asignación XML que asocia elementos XML a datos en las celdas para obtener los resultados deseados será útil. Para crear uno, debe tener un archivo de esquema XML (.xsd) y un archivo de datos XML (.xml). Después de crear la asignación XML, puede asignar elementos XML a la forma que desee.

Sugerencia: Encontrará más información sobre el uso de XML con Excel en esta información general sobre XML en Excel.

Buscar o crear esquema XML y los archivos de datos XML

Usar el esquema XML de ejemplo y archivos de datos XML

Crear una asignación XML

Asignar elementos XML

Buscar o crear esquema XML y los archivos de datos XML

Si otra base de datos o aplicación crea un archivo de datos XML o esquema XML, puede que ya tenga su disposición. Por ejemplo, es posible que tenga una aplicación de línea de negocio que exporta datos a estos formatos de archivo XML, un sitio web comercial o un servicio web que proporciona estos archivos XML o una aplicación personalizada desarrollados por el departamento de TI que crea automáticamente estos XML archivos.

Si no tiene los archivos XML necesarios, puede crear guardando los datos que desea utilizar como un archivo de texto. A continuación, puede usar Access y Excel para convertir ese archivo de texto en los archivos XML que necesita. Le mostramos cómo:

Access

  1. Importe el archivo de texto que desea convertir y vincular a una nueva tabla.

    1. Haga clic en Archivo > Abrir.

    2. En el cuadro de diálogo Abrir, seleccione y abra la base de datos en la que desea crear una nueva tabla.

    3. Haga clic en Datos externos > Archivo de texto y siga las instrucciones de cada paso, asegurándose de vincular la tabla al archivo de texto.

      Access crea la nueva tabla y la muestra en el panel de navegación.

  2. Exporte los datos de la tabla vinculada a un archivo de datos XML y a un archivo de esquema XML.

    1. Haga clic en Datos externos > Archivo XML (en el grupo Exportar ).

    2. En el cuadro de diálogo Exportar - archivo XML, especifique el nombre de archivo y el formato y haga clic en Aceptar.

  3. Salga de Access.

Excel

  1. Crear una asignación XML basado en el archivo de esquema XML exportado desde Access.

    Si aparece el cuadro de diálogo Varias raíces, asegúrese de que elegir dataroot para que pueda crear una tabla XML.

  2. Crear una tabla XML asignando el elemento dataroot. Para obtener más información, vea elementos de la asignación XML .

  3. Importar el archivo XML que exportó desde Access.

Notas: 

  • Existen varios tipos de construcciones de elemento de esquema XML no es compatible con Excel. Las siguientes construcciones de elemento de esquema XML no se pueden importar en Excel:

  • <any>    Este elemento le permite incluir elementos no declarados por el esquema.

  • <anyAttribute>    Este elemento le permite incluir atributos no declarados por el esquema.

  • Estructuras recursivas    Un ejemplo común de una estructura recursiva es una jerarquía de empleados y administradores en la que son los mismos elementos XML anidados en varios niveles. Excel no admite estructuras recursivas con más de un nivel de profundidad.

  • Elementos abstractos    Estos elementos se han diseñado para declararse en el esquema, pero nunca para usarse como elementos. Los elementos abstractos dependen de otros elementos que se van a sustituir por el elemento abstracto.

  • Grupos de sustitución    Estos grupos permiten intercambiar un elemento siempre que se haga referencia a otro. Un elemento indica que es un miembro del grupo de sustitución de otro elemento mediante el atributo <substitutionGroup>.

  • Contenido mixto    Este contexto se declara mediante mixed="true" en una definición de tipo complejo. Excel no es compatible con el contenido sencillo del tipo complejo, pero sí lo es con las etiquetas secundarias y los atributos definidos en dicho tipo complejo.

Usar el esquema XML de ejemplo y archivos de datos XML

Los datos de ejemplo siguientes tienen elementos básicos de XML y estructuras que puede usar para probar la asignación XML si no tiene archivos XML o archivos de texto para crear los archivos XML. Esto es cómo puede guardar estos datos de ejemplo en los archivos del equipo:

  1. Seleccione el texto del archivo que desea copiar y presione CTRL+c.

  2. Inicie el Bloc de notas y presione CTRL+v para pegar el texto de muestra.

  3. Presione CTRL+s para guardar el archivo con el nombre de archivo y la extensión de los datos de ejemplo que ha copiado.

  4. Presione Ctrl + N en el Bloc de notas y repita el paso 1-3 para crear un archivo para el segundo texto de muestra.

  5. Salga del Bloc de notas.

Datos XML de muestra (Expenses.xml)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Root>
<EmployeeInfo>
<Name>Jane Winston</Name>
<Date>2001-01-01</Date>
<Code>0001</Code>
</EmployeeInfo>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Airfare</Description>
<Amount>500.34</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Hotel</Description>
<Amount>200</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Taxi Fare</Description>
<Amount>100.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Long Distance Phone Charges</Description>
<Amount>57.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-01</Date>
<Description>Food</Description>
<Amount>82.19</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Food</Description>
<Amount>17.89</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-02</Date>
<Description>Personal Items</Description>
<Amount>32.54</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Taxi Fare</Description>
<Amount>75.00</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>Food</Description>
<Amount>36.45</Amount>
</ExpenseItem>
<ExpenseItem>
<Date>2001-01-03</Date>
<Description>New Suit</Description>
<Amount>750.00</Amount>
</ExpenseItem>
</Root>

Esquema XML de muestra (Expenses.xsd)

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<xsd:element name="Root">
<xsd:complexType>
<xsd:sequence>
<xsd:element minOccurs="0" maxOccurs="1" name="EmployeeInfo">
<xsd:complexType>
<xsd:all>
<xsd:element minOccurs="0" maxOccurs="1" name="Name" />
<xsd:element minOccurs="0" maxOccurs="1" name="Date" />
<xsd:element minOccurs="0" maxOccurs="1" name="Code" />
</xsd:all>
</xsd:complexType>
</xsd:element>
<xsd:element minOccurs="0" maxOccurs="unbounded" name="ExpenseItem">
<xsd:complexType>
<xsd:sequence>
<xsd:element name="Date" type="xsd:date"/>
<xsd:element name="Description" type="xsd:string"/>
<xsd:element name="Amount" type="xsd:decimal" />
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:sequence>
</xsd:complexType>
</xsd:element>
</xsd:schema>

Crear una asignación XML

Crear una asignación XML al agregar un esquema XML a un libro. Puede copiar el esquema de un archivo de esquema XML (.xsd), o puede que Excel intenta deducir uno desde un archivo de datos XML (.xml).

  1. Haga clic en Programador > origen.

    Comandos XML en la pestaña Desarrollador

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el panel de tareas Origen XML, haga clic en Asignaciones XML y, a continuación, haga clic en Agregar.

  3. En la lista Buscar en, haga clic en la unidad, carpeta o ubicación de Internet que contenga el archivo que desee abrir.

  4. Haga clic en el archivo y en Abrir.

    • Para un archivo de esquema XML, XML creará una asignación XML que se basa en el esquema XML. Si aparece el cuadro de diálogo Varias raíces, elija uno de los nodos de raíz definidos en el archivo de esquema XML.

    • Para un archivo de datos XML, Excel intenta deducir el esquema XML de los datos XML y, a continuación, se crea una asignación XML.

  5. Haga clic en Aceptar.

    La asignación XML aparece en el panel de tareas Origen XML.

Asignar elementos XML

Los elementos XML se asignan a celdas de asignación única y a celdas de repetición en las tablas XML para que pueda crear una relación entre la celda y el elemento de datos XML en el esquema XML.

  1. Haga clic en Programador > origen.

    Comandos XML en la pestaña Desarrollador

    Si no se muestra la pestaña Programador, vea Mostrar la pestaña Programador.

  2. En el panel de tareas Origen XML , seleccione los elementos que desea asignar.

    Para seleccionar elementos no adyacentes, haga clic en un elemento, mantenga presionada la tecla Ctrl y haga clic en cada elemento que desee asignar.

  3. Para asignar los elementos, realice las siguientes acciones:

    1. Haga clic en los elementos seleccionados y haga clic en Asignar elemento.

    2. En el cuadro de diálogo de elementos XML de mapa, seleccione una celda y haga clic en Aceptar.

      Sugerencia: Asimismo, puede arrastrar los elementos seleccionados a la ubicación de la hoja de cálculo en la que desee que aparezcan.

      Cada elemento aparece en negrita en el panel de tareas Origen XML para indicar que se ha asignado el elemento.

  4. Decida cómo desea utilizar las etiquetas y los encabezados de columnas:

    • Al arrastrar un elemento XML no extensible a la hoja de cálculo para crear una celda de asignación única, aparece una etiqueta inteligente con tres comandos, que puede usar para controlar la colocación del encabezado o etiqueta:

      Los datos ya tienen un encabezado    Haga clic en esta opción para ignorar el encabezado del elemento XML, puesto que la celda ya tiene un encabezado (a la izquierda de los datos o sobre estos).

      Colocar encabezado XML a la izquierda    Haga clic en esta opción para usar el encabezado del elemento XML como etiqueta de la celda (a la izquierda de los datos).

      Colocar encabezado XML encima    Haga clic en esta opción para usar el encabezado del elemento XML como encabezado de la celda (sobre los datos).

    • Al arrastrar un elemento XML de repetición a la hoja de cálculo para crear celdas de repetición en una tabla XML, los nombres de los elementos XML se usan automáticamente como encabezados de las columnas en la tabla. No obstante, puede modificar los encabezados de las columnas por cualquier otro que desee mediante la edición de las celdas de los encabezados de las columnas.

      En el panel de tareas Origen XML, puede hacer clic en Opciones para controlar en mayor medida el comportamiento de la tabla XML:

      Combinar elementos automáticamente al asignar    Si esta casilla está activada, las tablas XML se expanden automáticamente al arrastrar un elemento a una celda adyacente a la tabla XML.

      Mis datos tienen título    Cuando esta casilla está activada, se pueden usar los datos existentes como títulos de las columnas al asignar elementos de repetición a la hoja de cálculo.

      Notas: 

      • Si todos los comandos XML aparecen atenuados y no se puede asignar elementos XML a las celdas, puede que el libro esté compartido. Haga clic en Revisar > Compartir libro para comprobar que y quitarlo compartidos use según sea necesario.

        Si desea asignar elementos XML en un libro que desea compartir, asignar los elementos XML a las celdas que desea, importa los datos XML, quita todas las asignaciones XML del y, a continuación, comparta el libro.

      • Si no puede copiar una tabla XML que contiene los datos a otro libro, la tabla XML que tenga una asignación XML asociada que define la estructura de datos. Esta asignación XML se almacenan en el libro, pero cuando copie la tabla XML a un libro nuevo, la asignación XML no se incluyen automáticamente. En lugar de copiar la tabla XML, Excel crea una tabla de Excel que contiene los mismos datos. Si desea que la nueva tabla como una tabla XML, haga lo siguiente:

        1. Agregar una asignación XML al libro nuevo usando el archivo .xml o .xsd que se usó para crear la asignación XML original. Debe guardar estos archivos si desea agregar asignaciones XML a otros libros.

        2. Asigne los elementos XML a la tabla para convertirla en una tabla XML.

      • Al asignar un elemento XML repetido a una celda combinada, Excel cancela la combinación de la celda. Este es el comportamiento esperado, elementos de repetición están diseñados para trabajar con celdas sin combinar solo.

        Puede asignar elementos XML sitúela solo a una celda combinada, pero no se permite la asignación de un elemento XML repetido (o un elemento que contiene un elemento de repetición) a una celda combinada. La celda se mostrará sin combinar y el elemento se asignará a la celda donde se encuentra el puntero.

Sugerencias: 

  • Puede eliminar la asignación de elementos XML que no desea usar, o para impedir que el contenido de celdas que se sobrescriba al importar datos XML. Por ejemplo, podría desasignar temporalmente un elemento XML a partir de una sola celda o repetición de las celdas que tienen las fórmulas que no desee sobrescribir al importar un archivo XML. Una vez completada la importación, puede asignar el elemento XML a las celdas de la fórmulas de nuevo, por lo que puede exportar los resultados de las fórmulas en el archivo de datos XML.

  • Para eliminar la asignación de elementos XML, haga clic en su nombre en el panel de tareas Origen XML y haga clic en Quitar elemento.

Mostrar la pestaña Programador

Si no aparece la pestaña Programador, realice las siguientes acciones para mostrarla:

  • En Excel 2010 y versiones posteriores:

    1. Haga clic en Archivo > Opciones.

    2. Haga clic en la categoría Personalizar cinta de opciones.

    3. En Pestañas principales, active la casilla Programador y haga clic en Aceptar.

  • En Excel 2007:

    1. Haga clic en el botón de Microsoft Office Imagen del botón de Microsoft Office > Opciones de Excel.

    2. Haga clic en la categoría Popular.

    3. En Opciones principales para trabajar con Excel, active la casilla Mostrar pestaña Programador en la cinta de opciones y haga clic en Aceptar.

Vea también

Anexar o sobrescribir los datos XML asignado

Información general sobre XML en Excel

Datos XML de importación

Datos de exportar XML

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×