Office
Iniciar sesión

Archivar datos de Access

Nota:  Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Una forma de ayudar a mantener los datos organizados es archivar periódicamente los registros antiguos o inactivos. Por ejemplo, suponga que utiliza Access para administrar una biblioteca de préstamos. Puede tener una tabla para hacer un seguimiento de las transacciones de préstamo, con un campo donde se almacenará la fecha en que se ha prestado el elemento y un campo para la fecha en que se devolvió. Una posible directiva de conservación de registros sería archivar los registros de transacciones de préstamo durante un año después de la devolución del elemento y destruir los registros después de dos años.

Puede archivar todas las tablas de una base de datos, tablas específicas, o sólo registros específicos, por ejemplo, los registros anteriores a una fecha determinada. En este tema se explica cómo archivar datos.

En este artículo

Información general

Mover periódicamente registros en una tabla de archivo

Reemplazar periódicamente una tabla

Reemplazar periódicamente todas las tablas

Información general

Archivar los datos es una posibilidad que debe considerar cuando haya datos que ya no vaya a utilizar, pero desea conservarlos a mano por si los necesitara. Puede guiar sus planes de archivado por alguna política, por ejemplo, una directiva de conservación de datos.

El almacenamiento (o archivado) de datos suele depender de una condición relacionada con una fecha, por ejemplo la proximidad del final de mes.

Métodos para archivar datos

En la siguiente tabla se indican distintas formas de archivar datos, cuándo se debe utilizar cada método y otras consideraciones.

Método

Descripción

Cuándo utilizarlo

Otras consideraciones

Mover periódicamente registros en una tabla de archivo

Periódicamente, se ejecuta una consulta que selecciona los datos que se archivarán y los anexa a una tabla de almacenamiento. A continuación, se ejecuta una consulta que selecciona los mismos datos (de la tabla original) y los elimina.

Cuando la condición que se utiliza para determinar qué registros se archivarán la cumplen algunos de los registros de la tabla.

EJEMPLO: cuando se desea archivar transacciones de biblioteca (préstamos) cuya fecha de devolución sea al menos hace un año.

  • Quizás tenga que resolver cuestiones de integridad referencial, especialmente si los registros que desea archivar están en el lado "uno" de una relación de uno a varios.

  • Si necesita usar parámetros en las consultas, debe crear un formulario para controlar los parámetros. En caso contrario, corre el riesgo de pérdida de datos.

Reemplazar periódicamente una tabla

De manera periódica, se realiza una copia de archivo de una tabla determinada y, a continuación, se reemplaza la tabla con una copia nueva y vacía.

Cuando la condición que se utiliza para determinar qué registros se archivarán la cumplen todos los registros de la tabla.

EJEMPLO: se tiene una tabla que almacena extremos de temperatura diarios. Cada año, se archiva la tabla y se empieza de cero con otra vacía.

  • Quizás tenga que resolver cuestiones de integridad referencial.

Reemplazar periódicamente todas las tablas

Se comienza con una base de datos dividida (base de datos que incluye un archivo de base de datos back-end que contiene todas las tablas y un archivo de base de datos front-end que contiene todos los demás objetos de la base de datos). Periódicamente, se realiza una copia de archivo de la base de datos back-end y se reemplaza ésta con una nueva base de datos vacía.

Cuando la condición que se utiliza para determinar qué registros se archivarán la cumplen todos los registros en la mayoría de las tablas.

EJEMPLO: la base de datos consta de varias tablas con diferentes tipos de datos meteorológicos. Cada año, se archivan todas las tablas.

  • Si dispone de tablas de búsqueda (tablas que se utilizan para almacenar valores para buscar, por ejemplo códigos postales o departamentos), tal vez tenga que importar los datos en la nueva base de datos back-end.

  • Con este método, no se puede usar una macro. Debe archivar la base de datos manualmente.

Resolver cuestiones de integridad referencial

Si los registros que desea archivar están relacionados con registros de otras tablas, es posible que haya que resolver cuestiones de integridad referencial. Si los registros que desea archivar son "secundarios" (pertenecen al lado "varios" de una relación relación de uno a varios), probablemente no haya ningún riesgo en archivarlos, y puede hacerlo sin ninguna preocupación. Si los registros que desea archivar son "principales" (pertenecen al lado "uno" de una relación relación de uno a varios), al archivarlos pueden darse dos casos en relación con los registros "secundarios" relacionados:

  • Que impidan la eliminación de los registros "principales". Esto puede causar problemas cuando ya se han anexado los registros "principales" a la tabla de almacenamiento.

    O bien

  • Que se conviertan en "huérfanos" (registros correspondientes a un registro "principal" que no existe). Esto puede causar problemas con la integridad de los datos y con diversas funciones de la base de datos que utilicen los registros "huérfanos".

Para mantener la integridad referencial, haga lo siguiente:

  1. Determine qué registros "secundarios" corresponden a los registros que desea archivar. Por ejemplo, si se trata de una biblioteca y desea archivar registros de bienes prestados, determine en primer lugar si hay alguna transacción abierta en relación con esos bienes, es decir, si han sido prestados pero no devueltos.

  2. Siga alguno de estos procedimientos:

    • Si el "secundario" registros siempre se pueden eliminar de forma segura, asegúrese de que la relación exige integridad referencial, con eliminaciones en cascada. Así se garantiza que se eliminarán todos los registros relacionados "secundarios".

    • Si los registros "secundarios" no siempre eliminarse, considere la posibilidad de archivado todas las tablas de la base de datos.

    • Crear una consulta que selecciona registros "padre" que no tengan registros "secundarios". A continuación, usar esa primera consulta para crear las consultas de archivo (consulte la sección mover periódicamente registros en una tabla de archivo), en lugar de usar la tabla "principal".

      Sugerencia: Puede usar al Asistente para consultas para buscar registros no coincidentes. Para obtener más información, vea el artículo comparar dos tablas y buscar registros no coincidentes.

Volver al principio

Mover periódicamente registros a una tabla de almacenamiento

En primer lugar, cree una copia vacía de la tabla que contiene los registros que desea archivar. Esta nueva tabla vacía será la tabla de almacenamiento. Luego, cree una consulta de datos anexados para copiar los registros de la tabla original a la tabla de almacenamiento. A continuación, cree una eliminar consulta para quitar de la tabla original los registros archivados. Por último, cree una macro que ejecute las dos consultas. Cuando desee archivar los registros, ejecute la macro.

Sugerencia: Puede adjuntar una macro a un botón de un formulario, de modo que se ejecute al hacer clic en el botón.

Paso 1: Crear una tabla de archivo

Paso 2: Crear una consulta que copie los datos a la tabla de archivo

Paso 3: Crear una consulta de eliminación que quita los mismos datos de la tabla original

Paso 4: Crear una macro que se ejecute ambas consultas

Paso 1: Crear una tabla de almacenamiento

Si desea mantener en una sola tabla todos los registros archivados, este paso solamente se realiza una vez. La tabla de almacenamiento que se crea en este paso contendrá todos los registros archivados.

Si desea destroy su tabla de archivo anterior cuando se crea uno nuevo, no es necesario realizar este paso. Puede usar un consulta de creación de tabla en lugar de una consulta de datos anexados para copiar los datos a la tabla de almacenamiento. Para ello, vaya directamente al paso 2.

Si cada vez que archive datos desea utilizar una nueva tabla de almacenamiento y mantener las tablas de almacenamiento anteriores, cambie el nombre de la tabla de almacenamiento anterior antes de crear una nueva. Si para archivar los datos se basa en fechas, considere la posibilidad de bautizar las tablas de almacenamiento anteriores según el intervalo de fechas que representan.

Nota: Si cada vez que archive datos creará una nueva tabla de almacenamiento y conservará la anterior, antes de ejecutar las consultas debe cambiar el nombre de la tabla de almacenamiento antigua.

  1. En el panel de navegación, seleccione la tabla que tiene los registros que archivará, presione CTRL+C y, a continuación, presione CTRL+V.

  2. En el cuadro de diálogo Pegar tabla como, dentro de Opciones de pegado, seleccione Estructura solamente.

  3. En el cuadro Nombre de la tabla, elimine las palabras Copia de anexar un carácter de subrayado y la palabra "archivo" en el nombre de tabla existente y, a continuación, haga clic en Aceptar. Por ejemplo, si la tabla original se denomina las transacciones de la tabla de archivo se denomina Transactions_archive.

    Pegar tabla como

Paso 2: Crear una consulta que copie los datos en la tabla de almacenamiento

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. Utilice el cuadro de diálogo Mostrar tabla para agregar la tabla que contiene los registros que desea archivar. Cierre el cuadro de diálogo Mostrar tabla.

  3. En la ventana de diseño de consulta, haga doble clic en el asterisco (*) en la tabla que acaba de agregar. El nombre de la tabla y un asterisco aparecerán en la primera columna de la cuadrícula de diseño de la consulta.

    Nota: El asterisco indica que la consulta incluirá en los resultados todos los campos de la tabla. Cuando se utiliza el asterisco, si se agregan o quitan campos de la tabla, el resultado de la consulta variará según corresponda.

  4. En la ventana de diseño de consulta, haga doble clic en el campo que desee utilizar para especificar la condición que deben cumplir los registros para ser archivados. Por ejemplo, si la tabla de transacciones tiene un campo denominado Fecha de devolución y desea archivar todos los registros cuya fecha sea hace más de un año, puede hacer doble clic en Fecha de devolución. El campo aparecerá en la siguiente columna vacía de la cuadrícula de diseño de la consulta.

    Cuadrícula de diseño de la consulta

    Repita este paso si desea usar algún criterio en otros campos.

  5. Use la fila criterios para especificar criterios para los campos que acaba de agregar. Por ejemplo, podría especificar que activada en fecha deben antes del 1 de enero de 2008 mediante la expresión < # #1/1/2008 en la fila criterios.

    Si los valores de criterios cambian cada vez que archiva, debe hacer que la consulta solicitar información. Para ello, use un parámetro en la fila criterios para que la consulta pide entrada. Para usar un parámetro, use una expresión como lo haría normalmente, pero en lugar de un valor especificado, use una pregunta breve entre corchetes. Por ejemplo, puede usar la expresión < [archivar transacciones completadas antes:], así:

    Expresión con parámetro

    Para obtener más información sobre el uso de parámetros, vea el artículo crear una consulta solicitar información.

    También puede utilizar la fila o para especificar condiciones alternativas. Para obtener más información sobre el uso de criterios, vea el artículo ejemplos de criterios de consulta.

    Sugerencia: Si está utilizando un campo de fecha para especificar criterios y desea archivar todos los registros que sean anteriores a la fecha actual, escriba < fecha() en la fila criterios del campo de fecha.

  6. Siga alguno de estos procedimientos:

    • Si ya ha creado la tabla de almacenamiento, para agregar a esa tabla los registros especificados necesitará una consulta de datos anexados.

      1. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Anexar.

      2. En el cuadro de diálogo Anexar, en el cuadro Nombre de tabla, seleccione el nombre de la tabla de almacenamiento y haga clic en Aceptar.

        Anexar a

        En la cuadrícula de diseño de consulta, aparecerá la fila Anexar a.

      3. Borre la fila Anexar a en todos los campos que haya usado para especificar criterios. (Solamente el asterisco debe tener un valor para Anexar a).

        Cuadrícula de diseño de consulta, fila Anexar a

    • Si no ha creado la tabla de almacenamiento, deberá crearla a partir de los registros especificados, usando una consulta de creación de tabla.

      1. En la ficha Diseño, en el grupo Tipo de consulta, haga clic en Crear tabla.

      2. En el cuadro de diálogo Crear tabla, en el cuadro Nombre de la tabla, escriba el nombre de la tabla de almacenamiento y haga clic en Aceptar.

  7. Presione CTRL+G para guardar la consulta.

Paso 3: Crear una consulta de eliminación que elimine los mismos datos de la tabla original

  1. En la ficha Crear, en el grupo Otros, haga clic en Diseño de la consulta.

  2. Utilice el cuadro de diálogo Mostrar tabla para agregar la tabla que contiene los registros que desea archivar. Cierre el cuadro de diálogo Mostrar tabla.

  3. En la ventana de diseño de consulta, haga doble clic en el asterisco (*) en la tabla que acaba de agregar. El nombre de la tabla y un asterisco aparecerán en la primera columna de la cuadrícula de diseño de la consulta.

  4. En la ventana de diseño de consulta, haga doble clic en los mismos campos que utilizó para especificar la condición en la consulta de datos anexados.

  5. Use la fila criterios para especificar criterios para los campos que acaba de agregar. Para obtener más información sobre el uso de criterios, vea el artículo ejemplos de criterios de consulta.

    Importante: Si la consulta de datos anexados o de creación de tabla, utiliza un parámetro, así que debe una consulta de eliminación. Además, debe asegurarse de que se especifica el mismo valor para ambas consultas. Si especifica distintos valores de parámetro, puede perder los datos. Para ayudar a evitar la pérdida de datos, considere la posibilidad de usar un formulario para recopilar los valores y sobre cómo hacer que las consultas pregunte en el formulario para los valores de entrada. Para obtener más información, vea el artículo crear una consulta solicitar información.

  6. En la ficha Diseño, en el grupoTipo de consulta, haga clic en Eliminar.

    En la cuadrícula de diseño de consulta, aparecerá la fila Eliminar.

    Cuadrícula de diseño de consulta, fila Eliminar

  7. Presione CTRL+G para guardar la consulta.

Paso 4: Crear una macro que ejecute las dos consultas

  1. En el grupo Otros de la pestaña Crear, haga clic en Macro. Si el comando no está disponible, haga clic en la flecha que aparece bajo el botón MóduloMódulo de clase y luego haga clic en Macro.

  2. En la primera fila de la cuadrícula de diseño de macro, en la columna Acción, seleccione AbrirConsulta.

    Acción de macro AbrirConsulta

  3. En la parte inferior de la cuadrícula, dentro de Argumentos de acción, en el cuadro Nombre de la consulta, seleccione en la lista desplegable la consulta (de datos anexados o de creación de tabla) que creó en el paso 2.

    Acción de macro AbrirConsulta, argumento Nombre de la consulta

  4. En la segunda fila de la cuadrícula de diseño de macro, en la columna Acción, seleccione AbrirConsulta.

  5. En la parte inferior de la cuadrícula, dentro de Argumentos de acción, en Nombre de la consulta, seleccione en la lista desplegable la consulta de eliminación.

    La macro debería verse así:

    Macro lista para guardar

  6. Presione CTRL+G para guardar la macro.

    Cuando desee archivar registros, ejecute la macro.

Volver al principio

Reemplazar periódicamente una tabla

Si desea archivar siempre todos los datos de una tabla, no necesita utilizar consultas ni macros; en cambio, puede reemplazar periódicamente la tabla con una copia vacía.

Importante: Si la tabla que archivar se relaciona con otras tablas, debe evitar la integridad referencial.

  1. En el panel de navegación, seleccione la tabla que desea archivar, presione CTRL+C y, a continuación, presione CTRL+V.

  2. En el cuadro de diálogo Pegar tabla como, dentro de Opciones de pegado, seleccione Estructura solamente y haga clic en Aceptar.

    Acceso de nombres de la copia de la copia original nombre de la tabla.

  3. En el panel de navegación, haga clic con el botón secundario en la tabla original y en el menú contextual que aparecerá haga clic en Cambiar nombre.

    Asigne a la tabla un nombre que indique su contenido, por ejemplo "ExtremosDeTemperaturasDiarias_archivo_2007".

  4. En el panel de navegación, haga clic con el botón secundario en la copia vacía y en el menú contextual que aparecerá haga clic en Cambiar nombre.

    Asigne a la copia vacía el nombre de la tabla original.

Volver al principio

Reemplazar periódicamente todas las tablas

Si utiliza una base de datos dividida, puede reemplazar periódicamente todas las tablas simplemente sustituyendo la base de datos back-end por una copia vacía.

En primer lugar, prepare la copia vacía. A menos que se modifique el diseño de la base de datos, puede volver a usar esta copia cada vez que archive datos. Luego, cuando desee archivar datos, cambie el nombre de la base de datos back-end actual, para indicar que se trata de un archivo, y a continuación, guarde la copia vacía como nueva base de datos back-end.

Preparar una copia vacía de una base de datos back-end

Importe las definiciones de todas las tablas de la base de datos back-end.

  1. Cree una nueva base de datos en blanco. Elimine la Tabla1.

  2. En la pestaña Datos externos, en el grupo Importar, haga clic en Access.

  3. En el cuadro de diálogo Obtener datos externos, seleccione Importar tablas, consultas, formularios, informes, macros y módulos en la base de datos actual y haga clic en Examinar.

  4. En el cuadro de diálogo Abrir archivo, seleccione la base de datos back-end. Haga clic en Abrir para cerrar el cuadro de diálogo Abrir archivo y luego haga clic en Aceptar.

  5. En el cuadro de diálogo Importar objetos, haga clic en Opciones.

  6. Dentro de Importar tablas, seleccione Sólo definición.

  7. En la ficha Tablas, haga clic en Seleccionar todo, haga clic en Aceptar y luego en Cerrar.

A continuación, agregue los datos necesarios a las tablas de búsqueda de la copia vacía. Para cada tabla de búsqueda, siga estos pasos:

  1. Establezca un vínculo con la tabla de búsqueda en la base de datos back-end existente.

  2. Cree una consulta de datos anexados que agregue todos los registros de la tabla original a la copia.

Reemplazar la base de datos back-end con una copia vacía

En primer lugar, cambie el nombre la base de datos back-end actual, para indicar que ahora es un archivo.

A continuación, abra la copia vacía y guárdela con el nombre de la base de datos back-end original.

  1. Haga clic en el Botón de Microsoft Office Imagen del botón de Office y, a continuación, elija Guardar como. Se abre el menú Guardar como.

  2. Bajo Guardar la base de datos en otro formato, haga clic en Base de datos de Access 2007.

Volver al principio

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×